Jump to content
  • 0

[Solved] KSP freezing while loading (x64)


FrontlineMist57
 Share

Question

Hey, so i have this issue, where my KSP keeps freezing while i try to load it (via steam) in KSP_x64 or 64bit model of the game. The 32 bit does not do this. I have gotten the 64bit version to load, and its much smoother, this is because i run a heavily modded version of the game (NO its IS NOT one of the mods causing it)

 

Here is the part it is loading when freezing

Obviously the "Rebuilding VAB..." is just a thing that KSP just says while loading for 'fun'

 

         -Thanks, the KSP community is great

                            Frontline

Edited by FrontlineMist57
Link to comment
Share on other sites

14 answers to this question

Recommended Posts

  • 0

The game is not freezing on that part. What's actually happening is that that is the last part to be loaded (to be technical it's an iva but that's irrelevant) and after the last part is loaded, a lot of plugins start doing stuff. I highly suspect a mod is broken. Please upload your logs (see link below for info on where they are)

http://forum.kerbalspaceprogram.com/index.php?/topic/83212-how-to-get-support-read-first/

Link to comment
Share on other sites

  • 0
5 hours ago, TheRagingIrishman said:

The game is not freezing on that part. What's actually happening is that that is the last part to be loaded (to be technical it's an iva but that's irrelevant) and after the last part is loaded, a lot of plugins start doing stuff. I highly suspect a mod is broken. Please upload your logs (see link below for info on where they are)

http://forum.kerbalspaceprogram.com/index.php?/topic/83212-how-to-get-support-read-first/

I can't upload logs, because the game isn't crashing, its just freezing up

Link to comment
Share on other sites

  • 0

okay, so i just got it to load again aft

6 hours ago, TheRagingIrishman said:

The game is not freezing on that part. What's actually happening is that that is the last part to be loaded (to be technical it's an iva but that's irrelevant) and after the last part is loaded, a lot of plugins start doing stuff. I highly suspect a mod is broken. Please upload your logs (see link below for info on where they are)

http://forum.kerbalspaceprogram.com/index.php?/topic/83212-how-to-get-support-read-first/

afer a half hour of trying!! it is not fixed yet, but it sometimes lets me in, for some reason, should i try to crash the game and have the game get the logs and find the issue while loading, or do the logs not go back that far?

Edited by FrontlineMist57
Link to comment
Share on other sites

  • 0
1 hour ago, FrontlineMist57 said:

should i try to crash the game

The game is not logging reatroactively after it crashed, it is beginning to write a log as soon as you start the game. So what is your problem right now, that you can't find a log or that you just assume that there is no log?

Link to comment
Share on other sites

  • 0
Just now, Harry Rhodan said:

The game is not logging reatroactively after it crashed, it is beginning to write a log as soon as you start the game. So what is your problem right now, that you can't find a log or that you just assume that there is no log?

if the game crashes, it does not include the startup in the log, right?

Link to comment
Share on other sites

  • 0
4 minutes ago, FrontlineMist57 said:

good point, so, i should try to crash the game, and upload the log?

Again: The game logs without having to be crashed. Are you actually looking if there's a log or are you still only assuming that there is none?

Link to comment
Share on other sites

  • 0
13 hours ago, FrontlineMist57 said:

(NO its IS NOT one of the mods causing it)

It's probably ALL of them.
How much RAM do you have? At least 99 out of 100 'failure to load' crashes are related to either incompatible/incorrectly installed mods or simply running out or RAM.

Link to comment
Share on other sites

  • 0
7 minutes ago, Tex_NL said:

It's probably ALL of them.
How much RAM do you have? At least 99 out of 100 'failure to load' crashes are related to either incompatible/incorrectly installed mods or simply running out or RAM.

I use a mod installer so it shouldn't be an installation error, and the program is designed to make sure you can only download compatible mod, or it will not even show them in your downloadable mods list. also, i have 16GB of ram

 

See Below More Computing Specs.

Spoiler

CPU: Intel Core I3-2100 3.10GHz - Four Core

Ram: 16GB

Graphics Card: Nvidia Gforce GTX750 Ti

Windows 10PRO (if this matters)

Ask more if needed

 

Edited by FrontlineMist57
Added Spoiler
Link to comment
Share on other sites

  • 0

I wouldn't expect much more help if you don't post your output log. The game does not need to crash for it to be produced. Read the "how to get support" thread that was posted earlier. Use Dropbox or Pastebin to upload the logs and share the link here. If you choose not to do that, its a guessing game, and nobody wants to waste their time with that. Your specs are not important at this point.

Edited by Galileo
Link to comment
Share on other sites

  • 0
46 minutes ago, Galileo said:

I wouldn't expect much more help if you don't post your output log. The game does not need to crash for it to be produced. Read the "how to get support" thread that was posted earlier. Use Dropbox or Pastebin to upload the logs and share the link here. If you choose not to do that, its a guessing game, and nobody wants to waste their time with that. Your specs are not important at this point.

i just checked, there seems to be no output log when this issue is happening, even after i close KSP

Link to comment
Share on other sites

  • 0
17 minutes ago, FrontlineMist57 said:

i just checked, there seems to be no output log when this issue is happening, even after i close KSP

That's not true. It's being generated (because it's always generated), you're just looking in the wrong place. The right place to look is explained in the support thread that you were given a link to earlier:

Good luck!

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...