HebaruSan

[1.6–1.7] SmartTank v0.3.0

Recommended Posts

SmartTank     CKAN-Indexed-green.svg

Demonstration animation

Automatically scale tanks from Procedural Parts to fit a specified TWR.

Dependencies:

Download:  https://github.com/HebaruSan/SmartTank/releases/latest

Where to report bugs:  https://github.com/HebaruSan/SmartTank/issues

Source and documentation:  https://github.com/HebaruSan/SmartTank

Localization:  https://github.com/HebaruSan/SmartTank/tree/master/assets/lang

License:  GPL v3

Credits and acknowledgements:

Language Translators
Spanish

Fitiales

Edited by HebaruSan

Share this post


Link to post
Share on other sites

Yeah. Procedurality (dunno if this word exists) to the border.

btw does it acknowledge the career limits of PP?

Edited by Gordon Dry

Share this post


Link to post
Share on other sites
12 hours ago, Nightside said:

That's really cool!

Thanks!

11 hours ago, drtedastro said:

This looks really good.

checking it out now.

many thanks.

cheers.

Thanks! Any feedback so far? There's more to it than shown here, but I wanted to keep the GIF short and simple.

5 hours ago, Gordon Dry said:

Yeah. Procedurality (dunno if this word exists) to the border.

Indeed.

5 hours ago, Gordon Dry said:

btw does it acknowledge the career limits of PP?

I don't know; I didn't test that or write any code specific to career mode. But based on the Procedural Parts code I've seen, if my code requests a size that's not allowed, it's possible that it might be rejected.

Share this post


Link to post
Share on other sites

I like the concept - but rarely do I build to the TWR.  More useful I think would be one that can scale to a specified d/v.  (Then you can check engines to see which has the TWR you need.)

Share this post


Link to post
Share on other sites

Dunno the culprit or the reason for this, but I freshly added this and "[x] Science!" and have to fight the kraken now:

This is the worst issue I had for two months, total unplayability.

To find out what's going on I have to start removing mods - which I hate :cool:

Edited by Gordon Dry

Share this post


Link to post
Share on other sites
4 hours ago, DStaal said:

I like the concept - but rarely do I build to the TWR.  More useful I think would be one that can scale to a specified d/v.  (Then you can check engines to see which has the TWR you need.)

Yeah, TWR and dV are both dependent variables on tank mass, so it should be possible to add that as an option. I'll look into it.

24 minutes ago, Gordon Dry said:

Dunno the culprit or the reason for this, but I freshly added this and "[x] Science!" and have to fight the kraken now:

This is the worst issue I had for two months, total unplayability.

To find out what's going on I have to start removing mods - which I hate :cool:

Doesn't look related, and you've got tons of exceptions from other mods, including at least one that indicates incompatibility with 1.3.0. I'm going to ask the mods to delete this to avoid setting a precedent for cluttering this thread with every random crash anyone encounters.

Share this post


Link to post
Share on other sites

This looks really cool. I've liked procedural tanks but have never liked the interface. Tools like this could propel proceduralness (a.k.a. procedurality) to the next level.

Share this post


Link to post
Share on other sites

I got problems.

I needed additional TAC-LS resources for an early career 72h manned mission.

The only unlocked part that could give me these resources is a Procedural Tank.

I toggled all "auto" features off and set it up manually.

But it always gets a negative mass and wakes up the kraken on the launchpad.

This happened with a "normal" fairing as well as with a PF.

sp3aTzd.png

Log:
https://www.dropbox.com/s/kenf4wgppb8ro09/2017-07-08-3 KSP.log.zip?dl=1

Share this post


Link to post
Share on other sites
8 minutes ago, Gordon Dry said:

I got problems.

I appreciate that you're frustrated with a problem you're having, but if you want to report issues here, please take at least basic steps to establish that it has something to do with this mod. For example, does this problem still happen if you uninstall SmartTank? This is not a general support thread for debugging modded installs.

Share this post


Link to post
Share on other sites
26 minutes ago, Gordon Dry said:

The only unlocked part that could give me these resources is a Procedural Tank.

I notice you've got two "Tank Type" fields, one of which is presumably from Procedural Parts (my guess is it's the one that says Structural).

jMUduF0.png

Any idea where the other one is from (the one that says "Default")? It's possible that other mods are trying to hide the one from PP when SmartTank re-enables it. I could confirm that if I knew which mod was doing it.

Share this post


Link to post
Share on other sites

I asked here, could be:

That adds a folder GameData\SETIrebalance\0ProceduralParts\
with several files

SETI-PartMod-PP-Battery.cfg
SETI-PartMod-PP-ConeLiquid.cfg
SETI-PartMod-PP-Heatshield.cfg
SETI-PartMod-PP-NoseCone.cfg
SETI-PartMod-PP-SRB.cfg
SETI-PartMod-PP-StackDecoupler.cfg
SETI-PartMod-PP-Structural.cfg
SETI-PartMod-PP-TankLifeSupport.cfg
SETI-PartMod-PP-TankLiquid.cfg
SETI-PartMod-PP-TankRCS.cfg
SETI-PartMod-PP-TankXenon.cfg
SETI-PP-HRB.cfg
SETI-PP-ProbeCore.cfg

Edit:

btw a day ago I posted about an issue over there

and just read the reply.

Edited by Gordon Dry

Share this post


Link to post
Share on other sites
1 hour ago, Gordon Dry said:

<snip>

That doesn't really tell me anything. Please read my replies and answer the questions I ask:

1 hour ago, HebaruSan said:

does this problem still happen if you uninstall SmartTank?

Share this post


Link to post
Share on other sites

Okay, I will test it without it.
I had to exit whatsoever, so the 15 minutes until ready will begin - now.

Share this post


Link to post
Share on other sites
46 minutes ago, Gordon Dry said:

I had to exit whatsoever, so the 15 minutes until ready will begin - now.

Annoying, isn't it? Now imagine having to do that multiple times because someone reported an issue that isn't even related* to your mod!

(*Speculatively, at this point.)

Note that you should always do this check before you post. If you suspect a mod might be causing an issue, uninstall it and test again. If the issue still happens, or if you haven't performed this check yet, you should not report it on the forum thread of that mod.

Share this post


Link to post
Share on other sites

@HebaruSan Hi , i just discovered this mod and installed it, and it seems to be working proper, but i had a question about how the PTanks are supposed to auto scale themselves. Now it scales just fine in diameter, but does nothing in length. i have tried different combinations of engines and heavier components and played with the TWR , but it has no effect on the length of the tank.  Any idea what im doing wrong. 

edit:  forgot to mention, i do have configurable containers mod,  is that a problem with this mod?

Edited by mechanicH

Share this post


Link to post
Share on other sites
3 hours ago, mechanicH said:

@HebaruSanedit:  forgot to mention, i do have configurable containers mod,  is that a problem with this mod?

Configurable Containers is reported by @Starwaster to be incompatible with Procedural Parts; it removes one of the needed PartModules. Given that, I would not expect it to work with SmartTank (which is essentially an automation layer on top of Procedural Parts).

https://github.com/allista/ConfigurableContainers/issues/10

Edited by HebaruSan

Share this post


Link to post
Share on other sites
1 hour ago, HebaruSan said:

incompatible with Procedural Parts

is there a way to fix this or make it compatible?

because i would really love to take advantage of this mod and the opportunities it presents. 

Edited by mechanicH

Share this post


Link to post
Share on other sites
6 minutes ago, mechanicH said:

is there a way to fix this or make it compatible?

because i would really love to take advantage of this mod and the opportunities it presents. 

You could try deleting GameData/ConfigurableContainers/Parts/ProceduralParts.cfg to turn off the change that corrupts PP's tanks, or you could uninstall ConfigurableContainers. Beyond that, it's out of my hands; CC is messing with another mod's run-time data structures, which is as inadvisable as it is surprising.

Share this post


Link to post
Share on other sites
1 minute ago, HebaruSan said:

You could try deleting GameData/ConfigurableContainers/Parts/ProceduralParts.cfg

I will try that , i just hope that does not break the dependencies to my other mods such as SSTU.  Thanks for the help and the info, , BTW i am very much enjoying Astrogator mod,  thank you for your hard work on these very nice mods. Cheers :) 

Share this post


Link to post
Share on other sites

Hope you don't mind me reporting this here.

[ERR 18:07:27.118] ADDON BINDER: Cannot resolve assembly: TestFlightCore, Culture=neutral, PublicKeyToken=null

[ERR 18:07:27.118] ADDON BINDER: Cannot resolve assembly: TestFlightCore, Culture=neutral, PublicKeyToken=null

[ERR 18:07:27.140] Module SmartTankPart threw during OnStart: System.NullReferenceException: Object reference not set to an instance of an object
  at SmartTank.SmartTank.gravAccel (.CelestialBody b) [0x00000] in <filename unknown>:0 
  at SmartTank.SmartTankPart.bodyChanged (.BaseField field, System.Object o) [0x00000] in <filename unknown>:0 
  at SmartTank.SmartTankPart.OnStart (StartState state) [0x00000] in <filename unknown>:0 
  at Part.ModulesOnStart () [0x00000] in <filename unknown>:0 

I get this whenever I add a procedural tank to a ship in my Galileo Planet Packs game. Unsurprisingly, the Smart Tank functionality is quite limited, only resizing the tank to match diameter. Seems that it fails to get a body to get TWR for.

Share this post


Link to post
Share on other sites
2 hours ago, Mipe said:

Hope you don't mind me reporting this here.

Not at all, please do, and thanks!

2 hours ago, Mipe said:

I get this whenever I add a procedural tank to a ship in my Galileo Planet Packs game. Unsurprisingly, the Smart Tank functionality is quite limited, only resizing the tank to match diameter. Seems that it fails to get a body to get TWR for.

Aha, that stack trace suggests that any mod that deletes Kerbin will have trouble. I'll look for a reliable way to get the current home world at startup.

In the meantime, you might be able to work around this by opening the settings window and picking Gael manually.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.