linuxgurugamer

[1.5.1+] Hangar Extender Extended

Recommended Posts

You are both probably missing the ToolbarController, which is separate from the Toolbar

Share this post


Link to post
Share on other sites
5 hours ago, secretly_asian said:

@linuxgurugamer

I seem to be having a similar problem here myself, where i have the dependencies installed and the latest version, however the mod doesnt seem to be active. I dont know if this is interference from other mods or what but here is the log.

https://www.dropbox.com/s/pujw9wnxi8rk3vf/KSP.log?dl=0

Your log shows that you do not have the Toolbarcontroller installed.

Also, please upload the output_log.txt file, the one you uploaded is not sufficient

Share this post


Link to post
Share on other sites
56 minutes ago, linuxgurugamer said:

Your log shows that you do not have the Toolbarcontroller installed.

Also, please upload the output_log.txt file, the one you uploaded is not sufficient

Thats strange i do have the toolbarcontroller installed. here's the other log you requested. 

https://www.dropbox.com/s/t9w3udgj71uutrr/output_log.txt?dl=0

Share this post


Link to post
Share on other sites
2 hours ago, secretly_asian said:

Thats strange i do have the toolbarcontroller installed. here's the other log you requested. 

https://www.dropbox.com/s/t9w3udgj71uutrr/output_log.txt?dl=0

Then you are sending me the wrong log file.  The log file you sent was for a 1.3 game

Assuming you are running a 1.4.x game, the file should be:

%USERPROFILE%\AppData\LocalLow\Squad\Kerbal Space Program\output_log.txt

 

Share this post


Link to post
Share on other sites
10 hours ago, linuxgurugamer said:

Then you are sending me the wrong log file.  The log file you sent was for a 1.3 game

Assuming you are running a 1.4.x game, the file should be:

%USERPROFILE%\AppData\LocalLow\Squad\Kerbal Space Program\output_log.txt

 

Ah okay. well i went ahead to wipe my mods out and reinstall them, and that didn't work. Then, i tried to delete my CKAN cache of mods and reinstall them and it worked. I think somewhere CKAN messed up the installation of one of the dependencies. 

Share this post


Link to post
Share on other sites

Just a heads up, I know this was already fixed in 2017, however in CKAN the mod is still named Hanger (and hence I spent an hour searching for it!).

 :)

Share this post


Link to post
Share on other sites

Thanks for the continuation of the original mod!
And why am I saying it like I made the original mod?
Like I say,
 

Quote

If a mod stops being worked on after some time, someone else will work on it for the original creator

 

Share this post


Link to post
Share on other sites

Since I'm obviously an idiot, how do I properly install this mod and its dependencies? I've tried everything and its brother to get it to work. Right now I have the fshangar file in the game data folder, and the CTB and TP files in the plugin folder, I am using a Mac running the most recent OS, and all the plugins/mods are the most recent version.

Share this post


Link to post
Share on other sites
4 hours ago, MjrLeeObvious said:

Right now I have the fshangar file in the game data folder, and the CTB and TP files in the plugin folder

Everything goes in the GameData folder; Plugins is a red herring, ignore it.

Share this post


Link to post
Share on other sites
On 11/30/2018 at 2:12 AM, JH4C said:

Everything goes in the GameData folder; Plugins is a red herring, ignore it.

Should it be the master file or just parts of it?

Share this post


Link to post
Share on other sites
1 hour ago, MjrLeeObvious said:

Should it be the master file or just parts of it?

 

On 11/30/2018 at 10:12 AM, JH4C said:

Everything

 

Share this post


Link to post
Share on other sites

Hello!

Dude, this mod is THE STUFF! A jewel, indeed!
First time I´ve tried it, an it works perfectly (win10 64bit - 1.5.1KSP).
Now, I can finally build some BIG SSTU-low-part-cost, to launch some BIG interplanetary vessels to carry some BIG ground bases.

Thank you for keeping it up!!!

  • Like 1

Share this post


Link to post
Share on other sites

*cough* 1.6.1x *cough*

Share this post


Link to post
Share on other sites
18 hours ago, ThePixeledFox said:

works fine in 1.6.1 :)

Not for me it doesn’t.

:sealed:Hide the pain Fraston, hide the pain.

Edited by Fraston

Share this post


Link to post
Share on other sites
15 minutes ago, Fraston said:

Not for me it doesn’t.

:sealed:Hide the pain Fraston, hide the pain.

You seem to be having issues with quite a few mods lately, that seem to work ok for other people in 1.6.x...
Have you ever thought, instead of posting not-really-helpful comments, that maybe its just an issue with your install of KSP?

Share this post


Link to post
Share on other sites

i need this mod like i need to breathe so i felt compelled to help , simple really make sure you have the latest toolbar controller and click through blocker and HEE v.3.5.3.3 go into all of their version .cfg files (open with wordpad if you need to) and edit all the ksp version numbers to : current 1.6.1  min = 1.6.0 max = 1.6.9 (or 99).

if the mod icon still isnt showing then you may need to make a fresh game and go to options and ckeck "use blizzy toolbar if availible"

i dont use ckan and always remove avc dlls just so you know i prefer to do my mods manually , hope this helps :)

Share this post


Link to post
Share on other sites
On 7/5/2017 at 10:03 PM, linuxgurugamer said:

Not difficult, but some of what I did was to remove the config file and add standard settings using the system setttings page.

I still need to get a hard-coded version out of one of the files.

I wish I could get the floating boxes and cars out of the scene when the buildings are being shown, but other than that, it's working nicely.

sorry for the noob question, but how can i replace the click through blocker files? What do i have to do?

Share this post


Link to post
Share on other sites
24 minutes ago, elamiramir said:

sorry for the noob question, but how can i replace the click through blocker files? What do i have to do?

what do you mean "replace"?

Share this post


Link to post
Share on other sites
8 minutes ago, linuxgurugamer said:

what do you mean "replace"?

i toke this test from the "readme" file into the clickthroughblocker directory:

The changes are very simple:

Replace all calls to GUILayout.Window with ClickThruBlocker.GUILayoutWindow, the parameters are identical
Replace all calls to GUI.Window with ClickThruBlocker.

Share this post


Link to post
Share on other sites
13 minutes ago, elamiramir said:

i toke this test from the "readme" file into the clickthroughblocker directory:

The changes are very simple:

Replace all calls to GUILayout.Window with ClickThruBlocker.GUILayoutWindow, the parameters are identical
Replace all calls to GUI.Window with ClickThruBlocker.

You need to be comfortable with compiling code.  If you arent, then dont try it, just use it as is

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now