Ser

[1.4.0-1.5.x] NavUtilities continued, ft. HSI & Instrument Landing System [v0.7.2] (2018 Apr, 1)

Recommended Posts

11 hours ago, kostor said:

well, it seems it just stuck the loading phase. I thought it had to do with NavUt, but it seems it didn't. I guess this isn't the thread to discuss it if that's the situation.

Anyhow, next weekend I'll update about my progress to get NavUt to work again.

It is suspicious that the AnalogHSI prop is shown on your screenshots. Certainly some mod adds it to the MK1 cockpit. I haven't tested that prop so it can probably cause troubles. So if I knew that mod I could check that myself and fix.

Share this post


Link to post
Share on other sites

Cheers everyone!

Is there a config file to include the new stock alternative runways, desert runway and whats-its-name (forgot how its called)?

Since they are now stock,  it would make sense perhaps to include them definitively in the mod config!

Great fan of the mod btw. Thanks @Ser for bringing it up to date with 1.4. 

Share this post


Link to post
Share on other sites
On 7/21/2018 at 7:42 PM, Daniel Prates said:

Cheers everyone!

Is there a config file to include the new stock alternative runways, desert runway and whats-its-name (forgot how its called)?

Since they are now stock,  it would make sense perhaps to include them definitively in the mod config!

Great fan of the mod btw. Thanks @Ser for bringing it up to date with 1.4. 

In this post the config with Dessert runway has been suggested:

 

Share this post


Link to post
Share on other sites

FYI everyone, there is a new KerbinSide for 1.4.x and I have simply pasted the old "customrunways" config file that was valid for ksp 1.3 into my new 1.4.5 game (with current kerbinside and current navutilities). Insofar I have only tested a few runways but it seems that it works fine with the more recent iterations of this mod and kerbinside. "Well duh!" you may think, but not quite: I read somewhere that the new kerbinside moved around the launch sites. If that is true,  the displacement was only slight or perhaps  it only changed a few of the sites. Can't say for sure. But anyway,  it seems to work fine!

Share this post


Link to post
Share on other sites

Hello @Ser, could you clarify something to me?

I am not exactly sure where the glideslope shows in the instrument. As far as real life goes, the glideslope mark walks towards the actual middle of the instrument, hence, "aligned" should be as the letter "A" I marked in the picture below. Is that the same in your mod? Or is middle or "aligned"  in the "B" marked in the picture, right between the round two balls or circle thinghys you drew in the instrument?

 

BACFkcf.png

 

Edited by Daniel Prates

Share this post


Link to post
Share on other sites
16 hours ago, Daniel Prates said:

Hello @Ser, could you clarify something to me?

I am not exactly sure where the glideslope shows in the instrument. As far as real life goes, the glideslope mark walks towards the actual middle of the instrument, hence, "aligned" should be as the letter "A" I marked in the picture below. Is that the same in your mod? Or is middle or "aligned"  in the "B" marked in the picture, right between the round two balls or circle thinghys you drew in the instrument?

The glide indicator center is at your B mark. I agree with you, it would be better to have it matched with the center of the gauge as it is in the most real life HSI's. The HSI wasn't designed by me, not even the original creator of the mod @kujuman as I understand, so I can only guess why they did it so. Perhaps, the reason was the free window space as its parts are crowded with indicators those aren't there IRL. I'll look what I can do with that, perhaps.

Share this post


Link to post
Share on other sites
2 hours ago, Ser said:

The glide indicator center is at your B mark. I agree with you, it would be better to have it matched with the center of the gauge as it is in the most real life HSI's. The HSI wasn't designed by me, not even the original creator of the mod @kujuman as I understand, so I can only guess why they did it so. Perhaps, the reason was the free window space as its parts are crowded with indicators those aren't there IRL. I'll look what I can do with that, perhaps.

Well,  either way, it works fine. Maybe just a little explanation in the OP is enough.

Share this post


Link to post
Share on other sites
On 1/6/2019 at 9:25 AM, Zapo147 said:

1.6 compatible?

Try it and let us know?

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, theonegalen said:

Try it and let us know?

Yep, seems to work fine! Checking RPM integration now too.

 

seems good too

Edited by Zapo147

Share this post


Link to post
Share on other sites

Hi Ser, I would like to use this mod with a specific version of KSP I am currently running, but your changelog lists version 0.7.1 as compatible with KSP 1.3.0.

Do you know if this version is compatible with KSP 1.3.1?

Share this post


Link to post
Share on other sites
Posted (edited)
11 hours ago, mountaineerman said:

Hi Ser, I would like to use this mod with a specific version of KSP I am currently running, but your changelog lists version 0.7.1 as compatible with KSP 1.3.0.

Do you know if this version is compatible with KSP 1.3.1?

Yes, v0.7.1 *is* compatable with 1.3.1. Somwheres back on page 1 or 2 of this thread, Ser confirms 0.7.1 is ok for 1.3.1.

There are few instances where plugins/mods break between minor versions of KSP. In the case of this specific mod, thats why there was no update specific for 1.3.1, and the next update only came for KSP 1.4.x

Edited by Stone Blue

Share this post


Link to post
Share on other sites
Posted (edited)
On 9/24/2018 at 6:54 AM, Daniel Prates said:

Well,  either way, it works fine. Maybe just a little explanation in the OP is enough.

I think I just wasn't thinking when I made the art. I think it would only require changing the background image (just move the GS markers up until they are in the middle) and changing the assignment in line 279 in GlobalV_DisplayData.cs; probably to y0 += 0.5f.

@Ser Let me know if I should make and test those changes and then put in a pull request.

Edited by kujuman

Share this post


Link to post
Share on other sites
 
 
 
2
On 3/16/2019 at 12:30 AM, Stone Blue said:

Yes, v0.7.1 *is* compatable with 1.3.1. Somwheres back on page 1 or 2 of this thread, Ser confirms 0.7.1 is ok for 1.3.1.

Is it possible for the CKAN info be adjusted to reflect this?

Share this post


Link to post
Share on other sites

How do you bring up the GUI for runway creation?

Share this post


Link to post
Share on other sites

Note that in my setup, I have NavUtilities in the Blizzy toolbar.

Hold ALT and left-click on the NavUtilities icon.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.