Jump to content

Imgur albums broken ... again?!


Recommended Posts

I've found the best way to do it is to ignore the links available in the right panel and to actually copy the address in the url navigation bar and paste it. Now granted, the last time I did it was last week...

Link to post
Share on other sites
1 minute ago, adsii1970 said:

I've found the best way to do it is to ignore the links available in the right panel and to actually copy the address in the url navigation bar and paste it. Now granted, the last time I did it was last week...

That's what I was doing as well. It worked a few days ago.

Edited by Azimech
Link to post
Share on other sites

OK, we've implemented a new button in the editor to allow imgur embeds. Click the black square with the "i" on it, enter the 5 character album code in the text box that appears, and click OK. A link will appear in the post that will be replaced by the album when the post is submitted. This is a bit clunky but appears to work fine. This is not thoroughly tested, please report any issues or errors in this thread. If you enter an invalid imgur album code, the forum will appear to hang when saving the post. Refreshing the page will make your post appear.

Album Ng1I9 will appear when post is submitted

Hopefully this workaround will suffice for now, until @ManeTI can dig a bit deeper and maybe get the Invision and Imgur people on the same page.

Link to post
Share on other sites
28 minutes ago, Red Iron Crown said:

OK, we've implemented a new button in the editor to allow imgur embeds. Click the black square with the "i" on it, enter the 5 character album code in the text box that appears, and click OK. A link will appear in the post that will be replaced by the album when the post is submitted. This is a bit clunky but appears to work fine. This is not thoroughly tested, please report any issues or errors in this thread. If you enter an invalid imgur album code, the forum will appear to hang when saving the post. Refreshing the page will make your post appear.

Hopefully this workaround will suffice for now, until @ManeTI can dig a bit deeper and maybe get the Invision and Imgur people on the same page.

Wow, you guys are quick! Thanks!

Link to post
Share on other sites
56 minutes ago, Dr. Jet said:

Maybe it works with new posts, but it doesn't work with starting post edit/update.

 

Worked fine editing an album in, tested in my previous post in this thread. Can you give more detail on your browser/OS, and how exactly you used the button?

Link to post
Share on other sites

Win7x64, Opera 46.0 (Chrome Engine)

Pressed the button, typed "egLdt" (https://imgur.com/a/egLdt) then pressed "Edit Topic" button to save the post. String stayed as "Album egLdt will appear when post is submitted". No album is visible, link does not connect to Imgur album.

"a/egLdt" doesn't work either. Though it properly links to imgur album on mouse click.

BTW, is there any way to display good old BBCODE instead of that crappy WYSIWYG editor? 

Edited by Dr. Jet
Link to post
Share on other sites
1 hour ago, Dr. Jet said:

Win7x64, Opera 46.0 (Chrome Engine)

Pressed the button, typed "egLdt" (https://imgur.com/a/egLdt) then pressed "Edit Topic" button to save the post. String stayed as "Album egLdt will appear when post is submitted". No album is visible, link does not connect to Imgur album.

Can you link to the post in question? I don't see it in the OP of the thread you linked, if you'd mark where you want the album added I'll put it there for you. Not an ideal solution but at least the images will be visible. Edit: hang on, I just missed it in your post. Edit2: Got it embedded for you.

Quote

BTW, is there any way to display good old BBCODE instead of that crappy WYSIWYG editor? 

No, sadly.

1 hour ago, Physics Student said:

I just checked on a few of my posts. All Images are gone, some of the posts are just a few days old.

Individual images or albums? Can you link the posts in question?

Edited by Red Iron Crown
Link to post
Share on other sites
8 minutes ago, Red Iron Crown said:

Individual images or albums? Can you link the posts in question?

Both. E.g an album is missing here:

And pictures here. 

Every Imgur thing is missing. I'm checking older posts right now.

 

Edit: Older posts too. This one is pretty important. All the pictures in spoilers are missing.

 

Edited by Physics Student
Link to post
Share on other sites
2 hours ago, Alewx said:

@Red Iron Crown

Could you tell how you edited the embeds in @Dr. Jet thread, because I got just the very same problem but using IE11.
Better tell us how to do it than making it youself, so we can deal with it.

I had to do it by editing the HTML source directly, which is only available to admins for security reasons. Link any post you need fixed either here or in PM and I'll fix it when I'm at my computer again. 

Link to post
Share on other sites

 

5 minutes ago, Red Iron Crown said:

Should look OK now, please let me know if it doesn't.

It's not perfect, but it does show up. The text for each image is cut off. I'm not sure if that's their problem or yours.

Edited by Error_Sophius
Link to post
Share on other sites

Here's how it looks on FF/Win10 from here:

sOuyzWE.png

AFAIK this is how it should look, are you seeing different?

Edit: That's a screenie of the album, for anyone wondering why clicking it doesn't work. :P

Edited by Red Iron Crown
Link to post
Share on other sites
2 minutes ago, Red Iron Crown said:

AFAIK this is how it should look, are you seeing different?

"the stuff that was under that fairing, ..." should be followed by several more sentences, rather than being truncated with a Read More link (compare to the text on the other side of the link). Again, I'm not sure if that's something you can control -- but the point of embedding an album to me is to not have to go off-site to view stuff.

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...