micha

[1.3.x - 1.7.x] Corvus CF - a Size-1 Command Pod for 2 Kerbals (V1.3.4)

Recommended Posts

On 8/27/2018 at 9:30 PM, Daniel Prates said:

The result was the same as with Corvus: Deadly Reentry has gotten so badass in its latest iteration, that it is nearly impossible to return anything from anywhere. The poor vostok-like capsule was eaten alive  before even reaching 50km, the parachute exploding much earlier.  The stock mk1 capsule survived the rougher patch, but the ablator material was entirely consumed and exploded, whereas the parachute nearly snuffed it too as it came close to 90% or so of it's max temperature. So IMHO there is no tweaking necessary regarding CORVUS, if the same thing happens with a wide array of other parts!

 

If you were using the stock heat shields, there is a bug (typo) in the DRE config for it.

And I see the same problem in the config for the Corvus heat shield

 

You need to change the following in the Corvus_DRE.cfg patch:

pyrolysisLossFactor = 600

to

pyrolysisLossFactor = 6000

 

Share this post


Link to post
Share on other sites
1 minute ago, linuxgurugamer said:

If you were using the stock heat shields, there is a bug (typo) in the DRE config for it.

And I see the same problem in the config for the Corvus heat shield

 

You need to change the following in the Corvus_DRE.cfg patch:


pyrolysisLossFactor = 600

to


pyrolysisLossFactor = 6000

 

 

Well @micha there you go! 

Share this post


Link to post
Share on other sites
8 minutes ago, Daniel Prates said:

 

Well @micha there you go! 

Heh, I actually changed it from 6000 to 600 based on the DRE configs just the other day....  guess that'll be needing reverting then!

11 minutes ago, linuxgurugamer said:

If you were using the stock heat shields, there is a bug (typo) in the DRE config for it.

And I see the same problem in the config for the Corvus heat shield

Thanks! See above..

Share this post


Link to post
Share on other sites

Huh, the Corvus nosecone seems to create a very high amount of drag that flips just about every rocket over.

https://imgur.com/a/uxUohqm

I'm not using FAR or anything like that in this (new) 1.5.1 install. Currently hand-selecting a few mods and this came up.

Edit: I hacked it by removing the drag_cube line in the config, no more flipping. So it's probably something in there.

Edited by Zah

Share this post


Link to post
Share on other sites
On 12/11/2018 at 10:57 PM, Zah said:

Huh, the Corvus nosecone seems to create a very high amount of drag that flips just about every rocket over.

https://imgur.com/a/uxUohqm

I'm not using FAR or anything like that in this (new) 1.5.1 install. Currently hand-selecting a few mods and this came up.

Edit: I hacked it by removing the drag_cube line in the config, no more flipping. So it's probably something in there.

Can confirm

Share this post


Link to post
Share on other sites
On 12/11/2018 at 11:57 PM, Zah said:

Huh, the Corvus nosecone seems to create a very high amount of drag that flips just about every rocket over.

https://imgur.com/a/uxUohqm

I'm not using FAR or anything like that in this (new) 1.5.1 install. Currently hand-selecting a few mods and this came up.

Edit: I hacked it by removing the drag_cube line in the config, no more flipping. So it's probably something in there.

Hi, sorry for the late reply.

 

And I'm sorry, but I cannot repro in stock KSP 1.6.1.  Using a basic rocket stack, no fins.

 

First-stage : LV-T45 with 2x FL-T800 tanks and 2x "Thumper" boosters.

Second stage : LV-909 with FL-T400 tank

Third stage : "standard" Corvus stack + a KEES payload module.

Launch profile: "Thumpers" at 61% thrust-limit to give ~1.5 TWR at launch; full-throttle, standard gravity-turn launch (~45deg attitude by 10km altitude)


I did notice there was an aerodynamics issue with KSP1.5, but I think that was fixed with 1.5.1 which you said you were using?
So unless your flight profile exposes the rocket to a very high angle of attack, which should cause flipping anyway, I'm not sure what could be causing your issues.  

Share this post


Link to post
Share on other sites

In lieu of finding any issues (@Zah and @ssd21345's reports notwithstanding) I've marked Corvus as compatible with 1.6.x and 1.7.

Any reproducible issues please do let me know, also, if there needs to be a balance pass over any of the parts (I don't play very much at the moment) please tell me what should be changed and why.

Cheers, and fly safe!

Share this post


Link to post
Share on other sites
On 4/11/2019 at 11:31 PM, micha said:

In lieu of finding any issues (@Zah and @ssd21345's reports notwithstanding) I've marked Corvus as compatible with 1.6.x and 1.7.

Any reproducible issues please do let me know, also, if there needs to be a balance pass over any of the parts (I don't play very much at the moment) please tell me what should be changed and why.

Cheers, and fly safe!

it was 1.5.1 I don't have far,(unlike him) and the speed stuck at speed of sound because the drag of the nosecone it seemed. 

Share this post


Link to post
Share on other sites
Posted (edited)

Just discovered the same issue as the posts above with the nosecone. Extreme drag levels with the nosecone that no gimbal could counter. Take the nosecone off, the rocket flies completely normal. This is in 1.7.

Edited by amo28

Share this post


Link to post
Share on other sites
Posted (edited)
1 hour ago, amo28 said:

Just discovered the same issue as the posts above with the nosecone. Extreme drag levels with the nosecone that no gimbal could counter. Take the nosecone off, the rocket flies completely normal. This is in 1.7.

I'm really sorry, but I haven't been able to repro this issue.  Either I build and fly rockets totally differently to you or there's magic happening on my PC.  Perhaps if someone can send me their savefile which demos the issue as well as detailed instructions on how to repro using their specific rocket?

Alternatively I'm happy to remove the drag cube config from the nose cone (or generally from all non-hollow parts in the mod) since they don't appear to be required anyway so not sure why OrionKermin put them in.  Have just been reluctant to make any unnecessary changes to avoid changing the aim of the original mod too much.

 

EDIT: actually, how are people who have removed the drag-cube config from the nosecone doing at parachute reentries; does that still work?  I think the drag-cube is necessary on the nose-cone to make the parachutes work..

Edited by micha

Share this post


Link to post
Share on other sites
Posted (edited)
5 hours ago, micha said:

I'm really sorry, but I haven't been able to repro this issue.  Either I build and fly rockets totally differently to you or there's magic happening on my PC.  Perhaps if someone can send me their savefile which demos the issue as well as detailed instructions on how to repro using their specific rocket?

Alternatively I'm happy to remove the drag cube config from the nose cone (or generally from all non-hollow parts in the mod) since they don't appear to be required anyway so not sure why OrionKermin put them in.  Have just been reluctant to make any unnecessary changes to avoid changing the aim of the original mod too much.

 

EDIT: actually, how are people who have removed the drag-cube config from the nosecone doing at parachute reentries; does that still work?  I think the drag-cube is necessary on the nose-cone to make the parachutes work..

One of the possibly "Magic thing" is PartDatabase.cfg. Tell them to delete it and try again

Just tried no drag bug in 1.7

and I think just delete PACKED line the parachute still works?

Edited by ssd21345

Share this post


Link to post
Share on other sites
On 5/8/2019 at 5:38 PM, ssd21345 said:

One of the possibly "Magic thing" is PartDatabase.cfg. Tell them to delete it and try again

How about it, any of you guys with problems tried to delete this file (it's in the root directory of your KSP install) and restarted the game and tried again?

Last night I tried again with some more extreme launches. Rocket consisted of a Corvus Nosecone/Capsule/heatshield/decoupler stack placed on an overpowered rocket (couple of LT800 tanks and a S3 KS-25 or RK-7, no fins or anything else). Full throttle and launch! I was easily able to break the speed of sound as well as enter a 700kmx-100km sub-orbital flight, no flipping, starting to turn almost immediately after launch.  Flying does depend on never tilting the rocket outside the yellow circle on the navball while in the atmosphere though!

Share this post


Link to post
Share on other sites
On 5/10/2019 at 8:22 AM, micha said:

How about it, any of you guys with problems tried to delete this file (it's in the root directory of your KSP install) and restarted the game and tried again?

Last night I tried again with some more extreme launches. Rocket consisted of a Corvus Nosecone/Capsule/heatshield/decoupler stack placed on an overpowered rocket (couple of LT800 tanks and a S3 KS-25 or RK-7, no fins or anything else). Full throttle and launch! I was easily able to break the speed of sound as well as enter a 700kmx-100km sub-orbital flight, no flipping, starting to turn almost immediately after launch.  Flying does depend on never tilting the rocket outside the yellow circle on the navball while in the atmosphere though!

if you try to surface attach things to Corvus long fuel tank, the part goes very far...

Share this post


Link to post
Share on other sites

Love this mod! But does anyone have issues with the corvus heatshield not being able to shield the parachute/RCS piece during reentry?

Share this post


Link to post
Share on other sites
18 minutes ago, subyng said:

Love this mod! But does anyone have issues with the corvus heatshield not being able to shield the parachute/RCS piece during reentry?

Haven't tried in 1.7.1 yet (sorry, RL is really busy right now) but didn't see this issue before.  What's your atmospheric entry approach speed and angle?

Share this post


Link to post
Share on other sites
On 6/8/2019 at 1:58 AM, micha said:

Haven't tried in 1.7.1 yet (sorry, RL is really busy right now) but didn't see this issue before.  What's your atmospheric entry approach speed and angle?

Well, even reentry from a 70-80km orbit, lowering the PE to about 50km, the nosecone will explode unless I constantly wiggle the craft. I am using DRE though, but  I'm not sure if that changes how much of a "shadow" the heat shields cast. 

Share this post


Link to post
Share on other sites
20 minutes ago, subyng said:

Well, even reentry from a 70-80km orbit, lowering the PE to about 50km, the nosecone will explode unless I constantly wiggle the craft. I am using DRE though, but  I'm not sure if that changes how much of a "shadow" the heat shields cast. 

Well, that's a bit of a game-changer :P

I don't use DRE.  There were some issues with it some other users had a while back which was due to a bad config (typo in a config file which I then copied) but that was reverted.  It -should- work, but I really don't know DRE very well. @Daniel Prates seemed happy with the way it works, maybe something changed in DRE since then.

Does Corvus get protected by stock heat shield?

Do other capsules survive fine with DRE and similar reentry profile?

Do other capsules survive fine with Corvus heatshield?

Share this post


Link to post
Share on other sites

Let me do some checking and I'll report my findings. Back then I think I was constantly overheating because of mod soup. But let us all chill, it's only 3,6 roentgens - not great, not terrible!

Share this post


Link to post
Share on other sites
Posted (edited)

Ok, done it. 

To be fair, I always use the stock 1.5 heat shield (out of habit, nothing more), and I didn't know anymore what the Corvus shield was able to withstand. 

As far as I remember, the issue I pointed out months ago had to do with mod soup, that is, I use some 200 mods (more or less, not even I know anymore) and one of them, 'deadly reentry' I think, was making reentry INDEED DEADLY. I have since stopped using it and had no more problems. 

Anyway, to the matter at hand. Without deadly reentry, here is how the Corvus shield behaves in a reentry from 80k, with periapsis set to 30k more or less. Obviously, nothing wrong with the mod! Observe temperature readings, on the top left of the screen (thanks to Kerbal Engineer!) and the ablator data, taken directly from the part's gizmo:

 

3490VmL.pngJM8qoiY.pngUAH2ith.pngBUA6DxW.pngrss4pV8.png3QnebK5.pngKYUuy55.pngPgJRLAP.png

So, pretty surviveable. My heat settings in the difficulty are set to standard (no tweaking). For sure the reported issue has to do with some other mod messing around with things.

Edited by Daniel Prates

Share this post


Link to post
Share on other sites
2 hours ago, Daniel Prates said:

Ok, done it. 

...

Without deadly reentry, here is how the Corvus shield behaves 

Thank you very much @Daniel PratesPrates. Much appreciated!

I had already done the stock tests myself and found no issues (apart from forgetting decouplers the first flight.)

But the other guy is having issues specifically with DRE with which I have no experience. Well I'll wait for him to reply with more information.

Share this post


Link to post
Share on other sites
10 minutes ago, micha said:

Thank you very much @Daniel PratesPrates. Much appreciated!

I had already done the stock tests myself and found no issues (apart from forgetting decouplers the first flight.)

But the other guy is having issues specifically with DRE with which I have no experience. Well I'll wait for him to reply with more information.

I have given up altogether with deadly reentry after the experience we talked about in the past. I am sure it is different now, but to keep CPU use a bit lower, there are some mods I have simply deprecated. 

Not Corvus though! It remains my solid go-to ferry for all my early and mid career games. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.