• 1
Toontoonizer

Constant Access Violation Crashes x64 v1.2.2

Question

Posted (edited)

Hi All,

I am constantly getting access violation crashes in my Kerbal install. I am using the steam version of the game. I know that an access violation crash is caused by memory issues, however the error logs show that only 65ish% of my overall memory is being utilised (i have 16gb RAM). 

EDIT 2: See post below

I have uploaded logs to the following location: https://1drv.ms/f/s!AsRiF1eWiROUimz8z18N94NK2ln_ EDIT: added the latest crash log and output log for that crash. Crashed 5 times about 15ish minutes into playing each time.

My specs are as follows:

  • Win 10 Home
  • Intel 3770k
  • 16GB RAM
  • 256GB Samsung 830
  • 256GB Samsung 850 EVO
  • EVGA 680GTX 2GB

Mods Installed:

Quote

KSP: 1.2.2 (Win64) - Unity: 5.4.0p4 - OS: Windows 10  (10.0.0) 64bit
000_AT_Utils - 1.4.2
Toolbar - 1.7.13
Advanced Jet Engine - 2.8
B9 Animation Modules - 1.0.5
B9 Part Switch - 1.7.1
B9 Aerospace - 6.3.1
B9 Aerospace - 6.3.1
B9 Aerospace Procedural Parts - 0.40.11
BD Animation Modules - 0.6.4.4
BOSSContinued - 3.0.3
Community Resource Pack - 0.6.6
CommunityTechTree - 3.0.3
Connected Living Space - 1.2.4.2
Contract Configurator - 1.22.2
CustomBarnKit - 1.1.12
Deadly Reentry - 7.6.0.1
DistantObjectEnhancement - 1.8.1
DMagic Orbital Science - 1.3.0.8
Ferram Aerospace Research - 0.15.8.1
Firespitter - 7.5.1
RasterPropMonitor - 0.28
Kerbal Construction Time - 1.3.9
Kerbal Engineer Redux - 1.1.2.8
Kerbal Joint Reinforcement - 3.3.2
KSP-AVC Plugin - 1.1.6.2
XT Landertron - 1.0
MagiCore - 1.2.5
Infernal Robots - 2.0.10
ModularFlightIntegrator - 1.2.4
PlanetShine - 0.2.5.2
Procedural Parts - 1.2.11
QuizTechAeroPackContinued - 1.3.9
RCS Build Aid - 0.9.1
RealChute - 1.4.3
RealismOverhaul - 11.5.1
RealSolarSystem - 12.0
RemoteTech - 1.8.6
RetractableLiftingSurface - 0.1.3
SolverEngines - 3.1
SXTContinued - 0.3.12.1
ThrottleControlledAvionics - 3.4.1
TAC Life Support - 0.13
TweakScale - 2.3.4
Universal Storage - 1.3.0.1
VenStockRevamp - 1.9.5
[x] Science! - 5.6

I've tried to make sure everything i've installed is 1.2.2 compatible (i know installing mods for 1.3 can cause issues). But i am honestly at a loss as to what is causing the issues. I have ran memtest86 and passed all tests, no other games/software exhibit memory issues or access violation issues.

Another weird thing i have noted is that if i verify the integrity of game cache through steam it always identifies a single file that fails verification and needs to be redownloaded. Even if i run the verification back to back after it has redownloaded the file, it identifies a single file that fails verification. Additionally, CKAN identifies my current install as not valid but continues to work with it.

I have been experiencing crashes for a while and prior to this i had completely uninstalled kerbal and redownloaded through steam but the same issues persist.

Any and all help would be very much appreciated!

Edited by Toontoonizer

Share this post


Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 1
Posted (edited)

I've solved the issue. Removed, cleaned and reinserted my RAM sticks into the empty RAM slots. (2x8GB DDR3 Dual Channel) 

EDIT: I thought this solved the issue but see newest post below.

Given I passed memtest with 0 issues I was pretty sure it wasn't a RAM issue. But turned out it was. After checking the logs, the same memory address was being referenced in the access violation (ffffffb1 if anyone is interested but the number of 'f's might not be accurate). This made me inclined to think it was a hardware issue.

Hope this helps anyone else having similar issues. 

Edited by Toontoonizer

Share this post


Link to post
Share on other sites
  • 0

EDIT 2: I decided to do a fresh install and install mods in groups to identify any problematic cases potentially. TL;DR: Last night kerbal (1.2.2 x64) ran for an hour and a half with no crashes (most of the time in the SPH/VAB and switching back and forth between flying and building) with a majority of the mods listed below installed. The only ones i didnt install were RP-0 and RSSVE. Graphic memory monitor indicates ~10gb being used by the game across RAM and VRAM (with VRAM being the minor component)

The steps I took were as follows:

  1. Uninstalled game through steam and removed any remnants 
  2. Redownloaded through steam (v1.3)
  3. Started v1.3 and played for ~1 hour
  4. Set steam to download v1.2.2
  5. Installed Realism Overhaul only with dependencies and recommended mods through CKAN (no suggested mods)
  6. Played this version ~1 hour with no issues
  7. Installed DMagic Orbital Science, FASA, KW Rocketry Redux, RealEngines, SXT Continued, Firespitter, Retractable Lifting Surface through CKAN
  8. Played this version for ~1 hour with no issues. I then left the game on the VAB screen at around 1pm. When i came back at around 6pm the game had crashed with an access violation error. (haven't checked the log for when it crashed. but it may have been around 
  9. Ran Memtest86 and passed
  10. Installed further mods (as at this point i thought what the heck) including, KER, TCA, TweakScale, AGX, B9 Aerospace, Better Burn Time, BOSS, Dr Jets Chop Shop, Dangit, Forgotten Real Engines, Hullcam VDS, Procedural part textures, RSS (8096x4096)
  11. Ran the game again and enjoyed a crash free experience.

I have no idea whats going on - Would anyone have any further suggestions to understand what might be causing it? I think i'll try RSSVE to see if it starts crashing - will help rule it out.

Share this post


Link to post
Share on other sites
  • 0

So...re-seating the RAM has not caused the issue to go. Instead the time between crashes is now a lot longer ~1-2 hours but will still crash. The error log references the same memory access violation at address fffffffffb1.

Anyone have any ideas? Is this just a unity 64bit bug?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now