• 0
TjoMas_A

[CRASH][MODDED] Game crashes on startup 64 bit only

Question

EDIT

The comment below by TaggedYa provides a fix for this issue, so if you are having a problem, follow their instructions.

 

Hope this helps anyone who has this issue.

Original post below

I recently decided to have another go at trying RP-0, and downloaded a fresh install of KSP 1.2.2 from Steam. I then used CKAN to install, first, Realism Overhaul and its dependencies and recommended mods. After which, I installed RP-0, and its dependencies and recommended mods.

Once all installed, I tried launching from CKAN, and the game immediately crashed. 

The crash log is contained within the following link

https://pastebin.com/VqYRau7B

I then tried the same with the 32 bit exe. Instead of it crashing immediately, it instead crashed when it ran out of memory (I tracked how much RAM it used with Task Manager, it crashes when it reaches about 3.3-3.5GB)

There appear to be no other solutions that I can find for this error, and was wondering if anyone else has been experiencing this error, and if there were any fixes.

The mod list as exported by CKAN

https://pastebin.com/vC7d6UvD

These are the most up to date versions of the mod CKAN allows for 1.2.2

DxDiag - I have seen this be requested a few times in relation to similar crashes from other games, so will provide it.

https://pastebin.com/MAwJXNVP

Thank you for any help.

Edited by TjoMas_A
Issue was fixed, making the fix visible at the top of the original post.

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Try removing RN_US_Rockets with CKAN and reload.

I was having this issue and removing it let my game load.  I am still trying to figure out the problem but I can run with it uninstalled.

 

TaggedYa

Ok: CKAN is updating a US Rockets dependancy to a non 1.2.2 compatable version.

get the current dependancy versions here: https://www.dropbox.com/s/paqjbizbmxfhdqc/RN_Dependencies_KSP_v1.2.x.zip?dl=0

Overwrite the existing with these.

Edited by TaggedYa
Found the problem

Share this post


Link to post
Share on other sites
  • 0
On 24/07/2017 at 3:56 AM, TjoMas_A said:
d3d9.dll caused an Access Violation (0xc0000005)

  in module d3d9.dll at 0033:f734fd0c.

I'm not much good with Windows logs these days, but crashing in d3d9.dll doesn't sound like a mod issue to me.
Do you have anything running that hooks the graphics stack? Overlays, FPS counters, GPU overclocking utilities, shader injectors?
Rivatuner is the most common culprit, but anything that mucks about in there can cause the game to crash.

If it is a mod causing this, we need output_log.txt. See here for location.
 

5 hours ago, TaggedYa said:

CKAN is updating a US Rockets dependancy to a non 1.2.2 compatable version.

CKAN does that a lot. Be very careful using it for 1.2.2, and check that the mods it's trying to install are actually compatible.

Edited by steve_v

Share this post


Link to post
Share on other sites
  • 0

I have the exact same problem. After a while, I realized that RN_US_Rockets was the problem. I uninstalled and KSP is working fine. Unfortunately though, no US rockets.

Edited by AlienFromTrappist-1

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, AlienFromTrappist-1 said:

I have the exact same problem. After a while, I realized that RN_US_Rockets was the problem. I uninstalled and KSP is working fine. Unfortunately though, no US rockets.

Go ahead and reinstall US Rockets then use the dependancys I linked above (provided by RaiderNick) to overwrite the ones that CKAN put in.  Everything will then work fine.

Share this post


Link to post
Share on other sites
  • 0

Just to confirm what has been said above, using the dependencies provided in the quoted comment

15 hours ago, TaggedYa said:

Try removing RN_US_Rockets with CKAN and reload.

I was having this issue and removing it let my game load.  I am still trying to figure out the problem but I can run with it uninstalled.

 

TaggedYa

Ok: CKAN is updating a US Rockets dependancy to a non 1.2.2 compatable version.

get the current dependancy versions here: https://www.dropbox.com/s/paqjbizbmxfhdqc/RN_Dependencies_KSP_v1.2.x.zip?dl=0

Overwrite the existing with these.

helped fix the issue. I would like to thank you all for your help, especially TaggedYa for providing a fix.

I will leave this up, and edit the original post with the comment for anyone else who needs this fix.

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.