linuxgurugamer

[1.5.1, 1.6.1] NASA CountDown Clock Updated

Recommended Posts

4 hours ago, immi said:

@linuxgurugamer

I managed to get the mod working again on 1.4.3 (and 1.4.4). I sent you a pull request on github :)

I saw, will release it this evening.

Thanks

Share this post


Link to post
Share on other sites

New release, 1.3.6.5, the Immi release:

  • Thanks to github user immi101 (forum user @immi) for these fixes
    • fix control flow
    • don't repeatedly check GravityTurn availability
    • fix NullRef
    • fix path for loading textures
  • Like 2

Share this post


Link to post
Share on other sites

New release, 1.3.6.6:

  • Fixed null refs at startup/initialization
  • Like 1

Share this post


Link to post
Share on other sites

I cant figure out how to get this to trigger GT.

Can someone please explain how to get Gravity Turn to fire when the count reaches zero, thanks.

Share this post


Link to post
Share on other sites
2 hours ago, Cruesoe said:

I cant figure out how to get this to trigger GT.

Can someone please explain how to get Gravity Turn to fire when the count reaches zero, thanks.

I noticed this as well-- the radio button to switch to GT appears to have gone away.  That might be linked to the fix recently implemented for the repeatedly-checking-GT-availability, at a guess.

Share this post


Link to post
Share on other sites

@MaxwellsDemon

yup, it is indeed

@linuxgurugamer

if you look at my change to NASA_CountDown/States/SequenceState.cs:

The check should be against 'GravityTurnAPI.GTAvailable', not GravityTurnAPI.GravityTurnActive

sry, I mixed those up ;)

Share this post


Link to post
Share on other sites
1 hour ago, immi said:

@MaxwellsDemon

yup, it is indeed

@linuxgurugamer

if you look at my change to NASA_CountDown/States/SequenceState.cs:

The check should be against 'GravityTurnAPI.GTAvailable', not GravityTurnAPI.GravityTurnActive

 sry, I mixed those up ;)

Looking for a GTAVailable, it's not public

I'll get it all fixed

New release, 1.3.6.7:

  • Fixed missing Gravity Turn toggle
Edited by linuxgurugamer
  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, linuxgurugamer said:

Looking for a GTAVailable, it's not public

I'll get it all fixed

New release, 1.3.6.7:

  • Fixed missing Gravity Turn toggle

Now that's good service!

Thank you!

Share this post


Link to post
Share on other sites

Hi, since a few days when I click on the mod it does not appear, I can not find a solution ...

Edited by sumghai
Revert to standard forum post font

Share this post


Link to post
Share on other sites

New release, 1.3.7:

  • Fixed hang after doing a launch with GT, on the next launch
  • Swapped names of ToggleOff and ToggleOn methods to properly reflect the functionality
  • Fixed saving of launch sequence
  • Changed id from guid to vessel name for Sequences
  • Now properly saves settings for each vessel, using the craftName before any modifications are made by other mods
  • Added optional (but highly recommended) MM patch to support this.  If MM not installed, then it uses the craftname on the pad
  • Like 1

Share this post


Link to post
Share on other sites

New release, 1.3.7.1:

  • Fixed bug where launch sequence item #10 was not being saved
  • Fixed the enableSAS not being obeyed (was always being turned on)
  • Renamed EngineControl to LaunchSequenceControl
  • Made change so if LaunchSequenceControl is false, no stages will be activated and GravityTurn will not be called.
  • Added the following to the per-vessel info:
    • LaunchSequenceControl
    • Initial throttle
    • Final throttle
    • Enable SAS at launch

The per-vessel info additions were not released yet, sorry

Edited by linuxgurugamer
  • Like 1

Share this post


Link to post
Share on other sites

new release, 1.3.7.2:

  • Added the following to the per-vessel info:
    • LaunchSequenceControl
    • Initial throttle
    • Final throttle
    • Enable SAS at launch
  • Like 1

Share this post


Link to post
Share on other sites

:-(

And of course, right after I release, I found another bug.

Probably best to wait a day for me to fix this.

It seems to fail when a new vessel is launched.

  • Like 1

Share this post


Link to post
Share on other sites

straight to 10000 likes hm?

thanks 4 all ur work

ksp would be very different game without some mods

Share this post


Link to post
Share on other sites

New release, 1.3.7.3

  • Fixed loading window positions
  • Like 2

Share this post


Link to post
Share on other sites
AssemblyLoader: Exception loading 'NASA_CountDown': System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

Additional information about this exception:

 System.TypeLoadException: Could not load type 'NASA_CountDown.CountDownMain' from assembly 'NASA_CountDown, Version=1.3.7.3, Culture=neutral, PublicKeyToken=null'.

Doesn't work. On Kerbal Space Program 1.4.5 64bit

Share this post


Link to post
Share on other sites
11 hours ago, PyjackMeat said:

AssemblyLoader: Exception loading 'NASA_CountDown': System.Reflection.ReflectionTypeLoadException: The classes in the module cannot be loaded.
  at (wrapper managed-to-native) System.Reflection.Assembly:GetTypes (bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <filename unknown>:0 
  at AssemblyLoader.LoadAssemblies () [0x00000] in <filename unknown>:0 

Additional information about this exception:

 System.TypeLoadException: Could not load type 'NASA_CountDown.CountDownMain' from assembly 'NASA_CountDown, Version=1.3.7.3, Culture=neutral, PublicKeyToken=null'.

Doesn't work. On Kerbal Space Program 1.4.5 64bit

First, a complete log file is needed.

Second, do you have the dependencies installed?

 

I just installed it on a fresh 1.4.5 install using CKAN, it works fine.

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

Okay, this is weird but suddenly this and the other plugins giving me trouble are suddenly working again.

Share this post


Link to post
Share on other sites
On 8/4/2018 at 4:22 PM, PyjackMeat said:

Okay, this is weird but suddenly this and the other plugins giving me trouble are suddenly working again.

Not weird at all.  I released an update to the ToolbarController which had a problem,  Fixed and released the fix last night

  • Like 1

Share this post


Link to post
Share on other sites

Hi @linuxgurugamer, I'm putting together a Soyuz sound pack for this mod. On the records I have there is ~110 or so seconds of post-launch countdown (like: "10 [seconds in flight], flight progressing normally... 20, vessel stabilized... 30, pitch, yaw, roll nominal..."). I'm actually torn on whether to include it in the liftoff event or not - especially since the actual "Liftoff contact, check!" is almost drowned out by the sound of the rocket lifting off on each record I've found so far. What do you think?

For now it sounds like this:

https://drive.google.com/file/d/1gtoHzGrHgR94ocxpoUWj3wo0aMBOr-HE/view?usp=sharing

Edited by TK-313

Share this post


Link to post
Share on other sites

Hello @linuxgurugamer

Absolutely love your mods! Is there anyway with the NASA Countdown Clock to allow longer than 60 seconds. For example if I want to do a 5 minute countdown (300 seconds) that it can be done? I have tried sequentially naming the files from 300 to 0 and have found when I start the clock it shows the second as blank but does not set the minutes.

Also, one other request I would like to have. Can you please add an event that can be toggled on and off for polling. For example if turned on play sound file called "poll.ogg" or "polling.ogg" when you click "Launch". After the sound file plays pick up the count with the timer sound files? Thanks in advance!

Edited by RushHour2k5

Share this post


Link to post
Share on other sites
On 1/12/2019 at 6:36 PM, RushHour2k5 said:

Hello @linuxgurugamer

Absolutely love your mods! Is there anyway with the NASA Countdown Clock to allow longer than 60 seconds. For example if I want to do a 5 minute countdown (300 seconds) that it can be done? I have tried sequentially naming the files from 300 to 0 and have found when I start the clock it shows the second as blank but does not set the minutes.

Also, one other request I would like to have. Can you please add an event that can be toggled on and off for polling. For example if turned on play sound file called "poll.ogg" or "polling.ogg" when you click "Launch". After the sound file plays pick up the count with the timer sound files? Thanks in advance!

Sorry to say, not really.  It's a mod I support, but not intending to make any changes to it in the near future.  I do know of at least one other countdown mod here which might be able to do what you want:

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now