Jump to content

[1.11.1] Knes 1.9.4 "Back In Time"


Recommended Posts

Ok, a couple of quick tests carried out with an MRK returning from the Mun...

Using KER to monitor thermal loads on the spacecraft. At 75km altitude, critical part switches from heatshield to MRK temperature (limit 2200K)

Test 1: Periapsis 65km... MRK critical skin temperature limit 2130/2200K... survived its journey through the upper atmosphere but carried on through into a highly elliptical Kerbin orbit

Test 2: Periapsis 62.5km... MRK critical skin temperature reached 2200K... craft burnt up.

Test 3: Periapsis 85km... Used all fuel in the service module at periapsis to reduce apoapsis from Munar altitude to 5000km, then used monoprop at apoapsis to reduce peri to 60km and jettisoned the service module. MRK skin temperature maxed out at 2160K at 60km altitude. Craft survived and skipped out of the atmosphere with an apoapsis of 3500km.

It looks like the MRK won't survive a deorbit reentry from much above Low Kerbin Orbit due to the 2200K limit on the part.

 

Link to post
Share on other sites
22 minutes ago, facmanpob said:

Ok, a couple of quick tests carried out with an MRK returning from the Mun...

Using KER to monitor thermal loads on the spacecraft. At 75km altitude, critical part switches from heatshield to MRK temperature (limit 2200K)

Test 1: Periapsis 65km... MRK critical skin temperature limit 2130/2200K... survived its journey through the upper atmosphere but carried on through into a highly elliptical Kerbin orbit

Test 2: Periapsis 62.5km... MRK critical skin temperature reached 2200K... craft burnt up.

Test 3: Periapsis 85km... Used all fuel in the service module at periapsis to reduce apoapsis from Munar altitude to 5000km, then used monoprop at apoapsis to reduce peri to 60km and jettisoned the service module. MRK skin temperature maxed out at 2160K at 60km altitude. Craft survived and skipped out of the atmosphere with an apoapsis of 3500km.

It looks like the MRK won't survive a deorbit reentry from much above Low Kerbin Orbit due to the 2200K limit on the part.

 

ok thanks for this review, i'm going to add more max temp on those parts... still strange they explode, behind the heatshield, they are not supposed to burn, like i've said they probably take heat by the side or by the skin. Many thanks for this precise review. Did you have an idea what max temp could be nice for those parts ? i don't want to add too much resistance.

Also can you said what part explode at first ?

Link to post
Share on other sites
2 minutes ago, Well said:

ok thanks for this review, i'm going to add more max temp on those parts... still strange they explode, behind the heatshield, they are not supposed to burn, like i've said they probably take heat by the side or by the skin. Many thanks for this precise review. Did you have an idea what max temp could be nice for those parts ? i don't want to add too much resistance.

Also can you said what part explode at first ?

Glad to be of service :)

About to have dinner now with the family, but I’ll be back online later this evening. Planning to run a few more tests with different retrograde alignments (surface vs orbit) as the temperature dropped significantly when the craft rolled. I think you might be correct that heat is bleeding round the side of the shield. I’ll also try out the same reentry profile with the stock 3-kerbal pod just to see what happens as the maxTemp is a little bit higher for that pod iirc. I’ll make notes of the parts that fail and let you know in detail what I find. :D 

Link to post
Share on other sites

So I feel like a complete idiot! :D

Tested again from Munar orbit reentry, with a 45km periapsis, but this time aligning with the surface retrograde marker instead of the orbital marker, and had absolutely no problems. Heat was fine, and still had a little bit of ablator left over. So its all working fine and no alterations to the configs necessary!

In my defence I haven't played KSP for over a year, and its been at least 3 years since I had RSS or any other mods that changed the size of the plantes/orbits etc, so I'm a bit rusty! ;)

Anyway, hopefully this can be used as a Public Service Announcement for people who need help with deorbiting: align with the surface marker, NOT the orbital marker, lol!

 

As an aside, this is my current small space station, using KNES parts and parts from Universal Storage (one of my other favourite mods). Station parts launched using Ariane 1 and Viking launched on a Bacchus. It was at this point that I realised that carrying out Science was going to need a lot more power!

ymr7q1t.png

 

Link to post
Share on other sites
6 hours ago, facmanpob said:

So I feel like a complete idiot! :D

Tested again from Munar orbit reentry, with a 45km periapsis, but this time aligning with the surface retrograde marker instead of the orbital marker, and had absolutely no problems. Heat was fine, and still had a little bit of ablator left over. So its all working fine and no alterations to the configs necessary!

In my defence I haven't played KSP for over a year, and its been at least 3 years since I had RSS or any other mods that changed the size of the plantes/orbits etc, so I'm a bit rusty! ;)

Anyway, hopefully this can be used as a Public Service Announcement for people who need help with deorbiting: align with the surface marker, NOT the orbital marker, lol!

 

As an aside, this is my current small space station, using KNES parts and parts from Universal Storage (one of my other favourite mods). Station parts launched using Ariane 1 and Viking launched on a Bacchus. It was at this point that I realised that carrying out Science was going to need a lot more power!

ymr7q1t.png

 

Ok great, still going to up a little the MRK max temp, people could love to explore also other planet.

Awesome little space station! Exactly how i like them, so cute at this scale.

Link to post
Share on other sites
On 1/10/2021 at 10:41 AM, Starhelperdude said:

is knes jnsq-size optimised?

KNES is overpowered like stock parts so it is optimized for a 2.5-system. So yes, it works well with JNSQ.

Edited by Cheesecake
Link to post
Share on other sites
2 hours ago, Well said:

Ok great, still going to up a little the MRK max temp, people could love to explore also other planet.

Awesome little space station! Exactly how i like them, so cute at this scale.

Thanks. I checked the stock 3-kerbal pod and it’s maxTemp is 2400, so just a little higher than the MRK

1 hour ago, Starhelperdude said:

is knes jnsq-size optimised?

Yes, the Ariane in particular is perfect for JNSQ. The Ariane 44L and MRK work seamlessly at that scale.

Link to post
Share on other sites

A little busy irl, but i've recently made a solar panel to match the irl concept a little more.

Erd4ovRW8AEHRn0?format=jpg&name=large

Erd4ovRWMAAl-Uu?format=jpg&name=large

Erd4ovWW8AQnHv4?format=jpg&name=large

Even if i personnaly feel the best way is to use fuel cell

Link to post
Share on other sites

I launched a ship with a lander pre-docked. But when I decouple the nodes in orbit they won't actually detach, the bumpers seem stuck on each other. Nothing I do will let them separate. I tried extending the bumpers on both vessels but they're just locked together. Used RCS to reverse on ship and it just catches on the port and won't move. Any advice?

Link to post
Share on other sites
2 minutes ago, viveleroi said:

I launched a ship with a lander pre-docked. But when I decouple the nodes in orbit they won't actually detach, the bumpers seem stuck on each other. Nothing I do will let them separate. I tried extending the bumpers on both vessels but they're just locked together. Used RCS to reverse on ship and it just catches on the port and won't move. Any advice?

I've also encountered this problem with BDB, I think this is an issue with 1.11 and not specifially from mods

Link to post
Share on other sites
24 minutes ago, Starhelperdude said:

I've also encountered this problem with BDB, I think this is an issue with 1.11 and not specifially from mods

I guess it could be, the stock ones don't have this issue but they don't have extra bits. Unfortunately I need to problem solve, got a mission to minmus I can't undock. May need to abort and use them LEM to push the whole ship home.

30 minutes ago, Starhelperdude said:

I've also encountered this problem with BDB, I think this is an issue with 1.11 and not specifially from mods

Ok well moving the ship around and starting my time-warp to my maneuver node was enough I guess. the ships finally came apart, although they shook enough it looked like things could go kraken any time.

Link to post
Share on other sites
15 hours ago, viveleroi said:

I guess it could be, the stock ones don't have this issue but they don't have extra bits. Unfortunately I need to problem solve, got a mission to minmus I can't undock. May need to abort and use them LEM to push the whole ship home.

Ok well moving the ship around and starting my time-warp to my maneuver node was enough I guess. the ships finally came apart, although they shook enough it looked like things could go kraken any time.

i've see something like that in 1.11, i will investigate, but not sure i could fix this. will see. Timewarp could be an answer for now.

Edited by Well
Link to post
Share on other sites

Knes 1.9.3 is online  Github

Knes 1.9.3 [2021-01-19]
-------------------------------

	- Tweakscale Patch update to include New Hermes Parts by @Lisias
	- Add a patch for Waterfall Support
	- Move Hermes payload Parts to Utility category.
	- Reduce Mass of Veronique & Vesta Parts
	- Augmented Thrust on Veronique Engine
	- Remove shadow on European Flag
	- New little animation for the Catpod
	- New Canopy for Viking chute 0.625
	- New Canopy for Vesta / Catpod parachute 0.3125
	- New radial Main chute
	- New 1.25 / 0.625 endcap
	- New Solar Panel for Callisto Shuttle
	- Solar Panel Power generation review
	- TechTree Review
	- Cost Review
	- Fix some physicalSignificance configs
	- Fix Wrong texture endcap on 1.25 station module
	- Fix inline parachute 0.625 max temp
	- Fix MRK Max temp
	- New EndCap for EPS engine
	- New EndCap for EAP nose cones
	- New Endcap for HERA Robotic Arm
	- New Knes Flag
	- LH2 patch is now automatic when CryoTank installed
	- Kerbal in MRK IVA are no without helmet
	- New Overlay Mask for MRK IVA
	- Metal StarWatcher Variant deprecated
	- Vulcain engine Emissive change
	- Add Control point on MRK and Hermes Part

 

Link to post
Share on other sites

I really like this mod! I have a thing for small lifting body vehicles and shuttle-like vehicles like the X-35B.

 

Did I install the mod wrong, though? The two smaller vessels say they need crew to operate but don't have any seats. I've been clipping a probe core into them.

Link to post
Share on other sites
1 hour ago, Mimos said:

Did I install the mod wrong, though? The two smaller vessels say they need crew to operate but don't have any seats. I've been clipping a probe core into them.

Something is probably wrong on your install, but to be sure please tell me what is the name of the parts concerned, or a picture.

Link to post
Share on other sites
On 1/20/2021 at 9:27 AM, Well said:

Something is probably wrong on your install, but to be sure please tell me what is the name of the parts concerned, or a picture.

The Hermes and Callisto shuttles won't accept crew, and are required to operate, and the K-CEV/IXV say they require crews and don't have a probe control point.

 

https://imgur.com/MFC0zkG

https://imgur.com/WPCYHNOhttps://imgur.com/WPCYHNO

https://imgur.com/Kq1hkSw

https://imgur.com/G3UKIdv

Link to post
Share on other sites
12 minutes ago, Mimos said:

The Hermes and Callisto shuttles won't accept crew, and are required to operate, and the K-CEV/IXV say they require crews and don't have a probe control point.

 

https://imgur.com/MFC0zkG

https://imgur.com/WPCYHNOhttps://imgur.com/WPCYHNO

https://imgur.com/Kq1hkSw

https://imgur.com/G3UKIdv

There should be something wrong with you installation. They are working for me. Also it is intended that a crewed pod has no control point because it needs a crew. It`s the same like the stock ones. You cannot start dem without a crew or a separate probe core.

To help you we need more informations like the log. Did you tried a new installation?

Link to post
Share on other sites
1 hour ago, Mimos said:

The Hermes and Callisto shuttles won't accept crew

You need to install the mod again, something is wrong on your install. Knes is not the problem here

Link to post
Share on other sites

Despite all my work, Veronique and Vesta Rocket are still really low in thrust and Dv on KSP 1.11, wich i've discovered that caused by a KSP issue.

In fact, in KSP 1.11.0 all part under 30 Kg can't exist really in game. KSP will increase the mass in the flight scene whithout calculate the mass or Dv wich is an enormous issue for small rocket / parts

Sorry for the inconvenience, i hope the Game could be update a fix this soon.

 

My other Luciole Mod is completely broken by this new change.

Link to post
Share on other sites
41 minutes ago, Well said:

 KSP will increase the mass in the flight scene whithout calculate the mass or Dv wich is an enormous issue for small rocket / parts

Is this the reason for Orbits massively changing when going on eva with Kerbals?

Link to post
Share on other sites
45 minutes ago, KawaiiLucy said:

Is this the reason for Orbits massively changing when going on eva with Kerbals?

I think this is an other bug, actually the KSP issue tracker is full.... so .... :confused:

Link to post
Share on other sites
2 hours ago, Well said:

Sorry for the inconvenience, i hope the Game could be update a fix this soon.

Same thing was discovered about some SRMs from BDB, you're not alone.

There is an edit you can do to the KSP physics file to reduce the cutoff weight that KSP uses for this bug: partRBMassMin. It's currently shipped with 0.3 but 0.03 will fix tons of parts ... whatever other affect it might have, IDK! I'm sticking with 1.10.1 until they update.

Link to post
Share on other sites

Hi there,

while checking some other errors, I found the following in my logs:

[LOG 14:19:23.218] Load(Model): Knes/Resources/Plumes/FX_Cora_Engine_1
[ERR 14:19:23.225] File error:
Value cannot be null.
Parameter name: shader
  at (wrapper managed-to-native) UnityEngine.Material.CreateWithShader(UnityEngine.Material,UnityEngine.Shader)
  at UnityEngine.Material..ctor (UnityEngine.Shader shader) [0x00007] in <5aeafee3fea24f37abd1315553f2cfa6>:0 
  at PartReader.ReadMaterial4 (System.IO.BinaryReader br) [0x0001f] in <55ba45dc3a43403382024deac8dcd0be>:0 
  at PartReader.ReadChild (System.IO.BinaryReader br, UnityEngine.Transform parent) [0x005ca] in <55ba45dc3a43403382024deac8dcd0be>:0 
  at PartReader.Read (UrlDir+UrlFile file) [0x000c1] in <55ba45dc3a43403382024deac8dcd0be>:0 

[WRN 14:19:23.225] Model load error in 'C:\Program Files (x86)\GOG Galaxy\Games\Kerbal Space Program\GameData\Knes\Resources\Plumes\FX_Cora_Engine_1.mu'

Not sure if this is relevant, but thought I post it. Playing on 1.9.1 with Knes 1.9.3

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...