Question

Posted (edited)

Just upgraded to 1.3.

Mods:

Latest versions of: B9PartSwitch

Bluedog Design Buerau

Community Resource Pack

DMagicScienceAnimate

XenonHallThrusters

Near Future Propulsion

Near Future Launch Vehicles

Module Manager 2.8.1

Near Future Solar

DecayingRTGs

NearFuture Electrical

DynamicBatteryStorage

Near Future Construction

OrbitalLFOEngines

NearFutureProps

Near Future Spacecraft

DMagicOrbitalScience (game gets stuck loading some "US" experiment from this mod)

SCANsat

RealPlume

RealPlume-Stock

Smokescreen

Firespitter

BahaSP

TextureReplacer

Tantares

TantaresLV

Hotrockets

SpaceY-Lifters

SpaceY-Expanded

HabTech

StationPartsExpansion

CTN

FuelTanksPlus

Mechjeb2

I don't know how to get a log file, except for copy-pasting. Please help!

(srsly, this issue has almost made me depressed)

Edited by thekspbegginer
us not uss

Share this post


Link to post
Share on other sites

24 answers to this question

Recommended Posts

  • 1

BuranButt loads right before CA_delta which will cause the problem when something is wrong with your firespitter.

Share this post


Link to post
Share on other sites
  • 1
5 minutes ago, thekspbegginer said:

I don't know how to get a log file, except for copy-pasting.

Everything you need to know is here:

 

Share this post


Link to post
Share on other sites
  • 1
6 minutes ago, thekspbegginer said:

How do i get the log in my post?

Save the ksp.log file into Dropbox. Then share the Dropbox link. The moderators will like you better after that rather than just posting the entire log.

Share this post


Link to post
Share on other sites
  • 1
Just now, thekspbegginer said:

but what i i don't want to use dropbox

then use Google Drive or some other file sharing site

Share this post


Link to post
Share on other sites
  • 1

Now the link works! :)

KSP.log is very poor in information, unfortunately. Show us output_log.txt, as indicated here:

On 23/08/2014 at 4:27 AM, NathanKell said:

Windows: KSP_win\KSP_Data\output_log.txt (32bit) or KSP_win64\KSP_x64_Data\output_log.txt (64bit) or %USERPROFILE%\AppData\LocalLow\Squad\Kerbal Space Program\output_log.txt

(you don't need to try to run the game again, just find the file that's already there and upload it)

 

Share this post


Link to post
Share on other sites
  • 1

I don't have a Mac, but he link that Gaarst posted right in the beginning of this thread should point you to the right folder :)

Share this post


Link to post
Share on other sites
  • 1
Posted (edited)

"Receiving unhandled NULL exception". That's... surprisingly unhelpful :( (not you, the log!)

 

The only thing I can think of right now is that the last thing to load when the game crashed was a Cormorant Aeoronology part. Looking at the OP in the thread, there's this:

On 02/09/2015 at 2:40 AM, Pak said:

File structure has changed, delete old version if updating from 1.2.1

Have you upgraded it from a previous version? In any case, try removing all of your Cormorant files, and install them again.

Edited by monstah

Share this post


Link to post
Share on other sites
  • 1
1 minute ago, thekspbegginer said:

It went unresponsive, not crashing.

Oh, so that's why there's no "CRASH!" in the logs...

In that case... how long have you waited for it to load? Depending on how many mods I have installed, my game might take 10 or more minutes to load (tho usually it's around 5).

Share this post


Link to post
Share on other sites
  • 1

Unresponsive... how? If it's loading, there's nothing for it to respond to. You just wait while it loads.

Share this post


Link to post
Share on other sites
  • 1
41 minutes ago, thekspbegginer said:

As I said, the cursor turned into the Spinny Wheel of Death.

Doesn't matter, that happens sometimes. Try waiting at least 5 min and see if anything happens.

Share this post


Link to post
Share on other sites
  • 1

The only crash cases I've seen moving to 1.3 is having extra versions of firespitter will cause a crash now. Make sure you're using the most recent version of CA, then if you're using the firespitter dll make sure it's up to date and there aren't any others hiding out someplace.

If you're using the firespitter folder, rename it to 000Firespitter. This forces it to load first with MM. You're likely seeing a problem on the CA_delta wing because it's usually the first part that tries to load firespitter.

Share this post


Link to post
Share on other sites
  • 0

Nope, no other files.  It went unresponsive, not crashing.

#spinnywheelofdeath

Share this post


Link to post
Share on other sites
  • 0
Posted (edited)

about 30 seconds after it goes unresponsive.

Edited by thekspbegginer
im so impatient

Share this post


Link to post
Share on other sites
  • 0

As I said, the cursor turned into the Spinny Wheel of Death.

Share this post


Link to post
Share on other sites
  • 0

ok

no, i'm having trouble with a part named "BuranButt"

not working, need more help.

 

 

Share this post


Link to post
Share on other sites
  • 0

That helped. Thanks! Can a moderator now close this?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now