Jump to content

[1.4.2] Before Kerbin - 2 Billion Years before Kerbol


Recommended Posts

On 8/19/2017 at 3:09 PM, Mrcarrot said:

I'd like to try this out, but I have 3 GB of RAM. Old computer.

I'm getting a RAM upgrade to 6GB- looking forward to trying it out!

On 9/10/2017 at 10:05 AM, Milhafre1981 said:

All planets have science biomes like "Serpent Pole"?

And the kerbals get 2 stars on the 1rst moon (serpent). I think is to soon.

Not really to me. Kerbals get 1 star for LKO in stock.

Link to post
Share on other sites
  • 2 weeks later...

After a lot of fighting, I got Before Kerbin working on Linux (OpenGL).

I had to rename all _Normal and _normal files to _NRM (adjusting the cfg files appropriately), and drop the .dds extension from the texture entries in the materials for scaled space.

I still have a problem with Atlas' southern hemisphere not working with scatterer(?), but otherwise, BK looks really nice.

Three things though, 1) a lot of science reports say "an Eden" (drop the "an"), and 2) why does Eden not have any mountain biomes? 3) The mismatch between internal name and display name makes debugging tricky (Borea/Kamar).

 

[edit]I'm not 100% certain the rename on the normal files was required, but the dropping of the extension definitely was.

Edited by taniwha
Link to post
Share on other sites
2 hours ago, taniwha said:

Three things though, 1) a lot of science reports say "an Eden" (drop the "an"), and 2) why does Eden not have any mountain biomes? 3) The mismatch between internal name and display name makes debugging tricky (Borea/Kamar).

Great that you've got it working on Linux! (I thought it already worked on Linux, eek.)

1. I think I've got a way to fix this

2. Eden does have mountains biomes from what I remember. Should be the grey bits on the biome map.

3. I'll rename Borea to Kamar in the files next update

Thank you :)

Link to post
Share on other sites

According to [x]Science, there are no mountain biomes, only highlands (as the "highest"). I just had a look in the cfg file and there is no mountains biome. I also took a look at the biome map (had fun finding that :P): the gray areas seem to be highlands. I do see some white specs (#CECFCE) in the middle of some of the gray areas that were possibly intended to be mountains, though they are rather tiny. Perhaps a language issue? (I consider highlands and mountains to be different).

Biome
{
    name = Cool Seas
    value = 1
    color = #121A28
}
Biome
{
    name = Sandy Shores
    value = 1
    color = #898470
}
Biome
{
    name = Grassy Lowlands
    value = 1
    color = #4C563C
}
Biome
{
    name = Grassy Uplands
    value = 1
    color = #3C452B
}
Biome
{
    name = Rocky Highlands
    value = 1
    color = #898989
}
Biome
{
    name = Polar Regions
    value = 1
    color = #BFE9FF
}
Biome
{
    name = KSC Island
    value = 1
    color = #45602E

I do like the descriptive titles (grassy lowlands, etc).

 

Link to post
Share on other sites
3 hours ago, taniwha said:

According to [x]Science, there are no mountain biomes, only highlands (as the "highest"). I just had a look in the cfg file and there is no mountains biome. I also took a look at the biome map (had fun finding that :P): the gray areas seem to be highlands. I do see some white specs (#CECFCE) in the middle of some of the gray areas that were possibly intended to be mountains, though they are rather tiny. Perhaps a language issue? (I consider highlands and mountains to be different).

Biome
{
    name = Cool Seas
    value = 1
    color = #121A28
}
Biome
{
    name = Sandy Shores
    value = 1
    color = #898470
}
Biome
{
    name = Grassy Lowlands
    value = 1
    color = #4C563C
}
Biome
{
    name = Grassy Uplands
    value = 1
    color = #3C452B
}
Biome
{
    name = Rocky Highlands
    value = 1
    color = #898989
}
Biome
{
    name = Polar Regions
    value = 1
    color = #BFE9FF
}
Biome
{
    name = KSC Island
    value = 1
    color = #45602E

I do like the descriptive titles (grassy lowlands, etc).

 

Ah gotcha. Highlands are what I considered the same as mountains. I'll go over the biome map and raise the highland threshold and lower the peaks/mountains altitude. I'll go over the CFG also.

Cheers. I'll also be updating Kopernicus to the next version 

Link to post
Share on other sites
2 hours ago, taniwha said:

If it is just a language issue, I'm fine with it, really. However, those tiny whitish spots will cause holes in the biome map until another biome is added, or they are removed (I prefer having another biome).

If the white spots don't have any entry in the config, it is likely because I forgot or missed it out by accident. Fixed for next update.

Link to post
Share on other sites

All of the grass textures have stripes and when I look at planets in the tracking station there's a weird yellow grid like some sort of texture is missing.  Tried installing a couple different ways (both putting in eve/scatterer first and just using the versions in the download provided) and get the same thing either way.

Link to post
Share on other sites
48 minutes ago, Requia said:

All of the grass textures have stripes and when I look at planets in the tracking station there's a weird yellow grid like some sort of texture is missing.  Tried installing a couple different ways (both putting in eve/scatterer first and just using the versions in the download provided) and get the same thing either way.

Must be using 32 bit. Please use 64 bit KSP.

You might be using Mac / Linux, which also apparently have this bug (with no obvious fix from what I can tell)

@taniwha has been providing some info into this issue with Linux. Side note: "of an Eden" is not a typo from myself. It's Kopernicus. I think if I use displayName I can resolve this issue.

A quick fix for you: On the main menu, go to the options page, then graphical. Adjust your 'texture quality' to anything. Hit apply and it will be fixed until you restart the game.

Make sure to use 64 bit KSP by launching Ksp_x64.exe

Edited by Gameslinx
Link to post
Share on other sites
15 minutes ago, Gameslinx said:

Must be using 32 bit. Please use 64 bit KSP.

You might be using Mac / Linux, which also apparently have this bug (with no obvious fix from what I can tell)

@taniwha has been providing some info into this issue with Linux. Side note: "of an Eden" is not a typo from myself. It's Kopernicus. I think if I use displayName I can resolve this issue.

A quick fix for you: On the main menu, go to the options page, then graphical. Adjust your 'texture quality' to anything. Hit apply and it will be fixed until you restart the game.

Make sure to use 64 bit KSP by launching Ksp_x64.exe

Linux yes, it seems very strange that that should be the case since I have no problems running EVE/Scatterer (with the AVP configs) in the stock system.

 

19 hours ago, taniwha said:

After a lot of fighting, I got Before Kerbin working on Linux (OpenGL).

I had to rename all _Normal and _normal files to _NRM (adjusting the cfg files appropriately), and drop the .dds extension from the texture entries in the materials for scaled space.

I still have a problem with Atlas' southern hemisphere not working with scatterer(?), but otherwise, BK looks really nice.

Three things though, 1) a lot of science reports say "an Eden" (drop the "an"), and 2) why does Eden not have any mountain biomes? 3) The mismatch between internal name and display name makes debugging tricky (Borea/Kamar).

 

[edit]I'm not 100% certain the rename on the normal files was required, but the dropping of the extension definitely was.

I'm not 100% sure which textures to rename, can you be more specific, or just upload the modified directories?

Link to post
Share on other sites

The yellow "stripes" are fixed using the methods I mentioned here:

21 hours ago, taniwha said:

I had to rename all _Normal and _normal files to _NRM (adjusting the cfg files appropriately), and drop the .dds extension from the texture entries in the materials for scaled space.

though I'm not 100% certain the normal->nrm renaming was necessary. This is for the textures in Material (and sometimes EmmisiveOverlay) blocks in ScaledVersion blocks.

[edit] sorry, just noticed the rest of message: I plan on compiling a patch.

Edited by taniwha
Link to post
Share on other sites

patch threw a fit because apparently it doesn't treat Windows and UNIX EOLs the same (who am I supposed to be mad at that we have 3 different EOL standards anyway?), and Gameslinx's files all use the windows EOL. I had to change the patch file to use windows EOL characters and then run it as

patch --binary -p1 < beforekerbin.diff

 

Link to post
Share on other sites

Yeah, sorry about that. If I had left the file alone (I passed it through dos2unix before uploading), it would have had mixed line endings, which I find worse.

[edit]Perhaps I should have used unix2dos instead. Again, sorry.

Edited by taniwha
Link to post
Share on other sites
39 minutes ago, taniwha said:

Yeah, sorry about that. If I had left the file alone (I passed it through dos2unix before uploading), it would have had mixed line endings, which I find worse.

[edit]Perhaps I should have used unix2dos instead. Again, sorry.

Unfortunately I don't have a Linux PC to actually test this on, so I'm severely limited to what I can do.

I'll rename the normals and update the configs with the new paths but I'm not sure it would do much.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...