Jump to content

[KSP 1.5.*] Outer Planets Mod[2.2.1] [25 April 2018]


Galileo
 Share

Recommended Posts

2 hours ago, flekota said:

I'm giving the last load logs and mods

Hi @flekota,

I'm sorry, but we've had to remove your link due to copyright violation.  I know you mean well and you're just trying to help diagnose the problem, but you're not allowed to upload the content of your GameData folder to the Internet.  You're definitely violating Squad's copyright (because you're taking a big chunk of the game, which costs money and isn't free, and uploading it to the Internet where anyone can freely download it, which is a big no-no).  You're also highly probably violating the license of one or more mods (depends on each mod's license; some mods don't allow people to redistribute them).

Accordingly, please remove your share from the Internet.  I'm sorry for the inconvenience, it's just one of those unfortunate realities of life.

In the future, if you want to show people "here's what my GameData folder looks like" in a "safe" way that's not going to violate any licenses or copyright, probably the easiest thing to do is to just post a screenshot of your GameData folder.

One thing that you can post is your log file (do it on a 3rd-party sharing site like OneDrive or whatever, please-- don't paste a giant log file into the forum).  Not only is it not copyrighted (meaning that it's okay to share), but also it will often contain useful diagnostic information that may help people to see what your problem is.

Thanks,
Snark

Link to comment
Share on other sites

18 hours ago, Snark said:

Redundancy, mainly.  Let's say someone had OPM installed, let's consider the various combinations of comm setup:

  • Stock DSN, no JX2Antenna:  doesn't work, comms don't reach outer planets, nearly unplayable, so obviously this is out.
  • Add level 4 DSN, no JX2Antenna:  Works fine.  Can reach outer planets.  Don't need JX2Antenna.
  • Stock DSN, with JX2Antenna:  Works fine.  Can reach outer planets.  Don't need JX2Antenna.
  • Add level 4 DSN, with JX2Antenna:  Massive overkill.  Antenna range goes far beyond outer planets.  Don't really need JX2Antenna at all because an RA-100 can talk directly to Kerbin with no JX2 antenna in the chain.

Basically... there's simply no point in even having JX2Antenna if the comm network is upgraded to such power.  With the level-4 boost to DSN, the player doesn't need JX2Antenna.  And if they've got JX2Antenna, they don't need the DSN boost.

So it's basically a play-balance thing.  It's a choice beween "need lots of money to upgrade DSN to talk to outer planets" and "need lots of science to unlock powerful antenna to talk to outer planets".  OPM is perfectly playable without JX2Antenna, because it picks the former option.  JX2Antenna is a mod for folks who would like to try the latter.

It is in fact a nice choice option when you are also running a Warp drive  (+CTT which makes warp drives veeeery expansive to put on a ship). You better have some mobile labs frming science to research your JX2 antennae so you can actually buy a warp drive to explore the Outer planets, at least for the first warp ships you take there. Afterrwards, you'll have gained enough money from first milestones with a proper warpship to make the tier 4 DNS upgrade and go explore further if you have a Grannus star around. Witch such star system to eplore next to Kerbol, your JX2 antennae provide a nice relay network that you can set up around Plock orbit to be able to reach Grannus system at which ever position it is on its orbit.  So it is not completely useless, it is only for the one who don't go explore other stars just yet.  So I'll stick to the previous OPM version as of now I guess so I can use your antennae with OPM (just launched a probe to Sarnus, my first OPM exploraroty mission ever, and I hope I won't unlock warp tech before then but thanks to that damn OP MPL that I shouldn't have used in science mode, I'll have explored the entirety of OPs before that probe even reach Sarnus...

Edited by Quoniam Kerman
Link to comment
Share on other sites

5 minutes ago, Quoniam Kerman said:

So I'll stick to the previous OPM version as of now I guess so I can use your antennae with OPM

Well, if for your own gameplay you want to have both the tier 4 DSN and JX2Antenna, that's easy to do-- just delete the file GameData/JX2Antenna/Patches/jx2_OPM.cfg, and it will get rid of the "compatibility patch" that restores the tracking station to stock behavior.

So you can run the most recent OPM, no problem.

Link to comment
Share on other sites

4 hours ago, OhioBob said:

I see one problem, OPM_FinalFrontier is installed incorrectly.  Drill down further into the folder and you'll see another folder titled Nereid.  It is the Nereid that should go in GameData.

 

Thanks sorry about the up load. didn't mean to upload all that. thanks for removing the link. Being dyslexic does not help me solving these problems. I reinstalled the Nereid folder. 

Link to comment
Share on other sites

4 hours ago, Galileo said:

You have a few mods installed incorrectly. Also, please remove your link. You are not allowed to upload mods the way you did. All I need is a screenshot of your gamedata folder. 

 

Sorry about that . IS this what you needed https://1drv.ms/u/s!AneT8Vt1fAkat2Hx9LJZGqocdQhf 

4 hours ago, Galileo said:

You have a few mods installed incorrectly. Also, please remove your link. You are not allowed to upload mods the way you did. All I need is a screenshot of your gamedata folder. 

 

sorry about that is this what you need I redid the Nereid folder what other ones do I need to redo.https://1drv.ms/u/s!AneT8Vt1fAkat2Hx9LJZGqocdQhf.

This is from onedrive but they are just screenshot

Link to comment
Share on other sites

Did you go into the tracking station to check if the planets were there?

If you also use the mod to discover planets one at a time, you won't see them until you have researched them, so open a new sandbox game and check the tracking station.

Also check if you have installed all the dependancies, Kpernicus, Custom Barn kit, etc...

Edited by Quoniam Kerman
Link to comment
Share on other sites

18 hours ago, flekota said:

Sorry about that . IS this what you needed https://1drv.ms/u/s!AneT8Vt1fAkat2Hx9LJZGqocdQhf 

sorry about that is this what you need I redid the Nereid folder what other ones do I need to redo.https://1drv.ms/u/s!AneT8Vt1fAkat2Hx9LJZGqocdQhf.

This is from onedrive but they are just screenshot

Active Texture Manager has been long dead since 1.0.5 and doesn’t do anything, as it is now in the stock game

I doubt planet cerillian is compatible with OPM

and you have a “source” folder, which probably means you have whatever that mod is downloaded and installed incorrectly.

Link to comment
Share on other sites

22 minutes ago, Galileo said:

Active Texture Manager has been long dead since 1.0.5 and doesn’t do anything, as it is now in the stock game

I doubt planet cerillian is compatible with OPM

and you have a “source” folder, which probably means you have whatever that mod is downloaded and installed incorrectly.

Yes I seen the sorce folder and removed it last night I'll try the other And let you know.  I'll check out your site if you have one. again thank you.   I have just loaded everything it looks good and working fine so far. Again thank you Now if I can oly get E.V.E to work lol

 

Edited by flekota
Link to comment
Share on other sites

5 hours ago, Quoniam Kerman said:

Did you go into the tracking station to check if the planets were there?

If you also use the mod to discover planets one at a time, you won't see them until you have researched them, so open a new sandbox game and check the tracking station.

Also check if you have installed all the dependancies, Kpernicus, Custom Barn kit, etc...

I went to the tracking station in sandbox and do see them (before i wasnt sure if i would be able to or not)

I have Kopernicus, and barn kit (along with some others i like)

 

Any other thoughts on what i could check, because it seems i dont have it installed correctly somehow.

Link to comment
Share on other sites

1 hour ago, Wright1331 said:

Any other thoughts on what i could check, because it seems i dont have it installed correctly somehow.

Probably the best first step is to post a screenshot of your GameData folder.  That might enable us to spot installation errors.

Link to comment
Share on other sites

9 minutes ago, Wright1331 said:

https://imgur.com/1wJy60s

there is a link to the gamedata folder ss

There's nothing I can spot as an obvious cause.  Maybe you should try a fresh installation with just the essential stuff to see if that works.

  • CTTP
  • Kopernicus
  • ModularFlightIntegrator
  • OPM
  • Squad
  • ModuleManager

 

Link to comment
Share on other sites

4 hours ago, Gidreess said:

Very good mod, but... Well, I dont want stock replacements like Eeloo I want it to be on its stock place

Removing Eeloo.cfg from OPM\KopernicusConfigs\SarnusMoons should do the trick.

Link to comment
Share on other sites

New Release

Outer Planets Mod v2.2.1 - Link

Changelog

v2.2.1

  • Fixed errors in Slate and Wal's normal map paths causing them not to use OnDemand loading effectively.

Previous changelogs can be found on the GitHub repository or the original forum thread: https://forum.kerbalspaceprogram.com/index.php?/topic/93999-1

 

Edited by Poodmund
Link to comment
Share on other sites

1 hour ago, DracoSilverpath said:

Having a curious problem with a fresh KSP install that i'm testing mods on.

All the planets show up in the tracking station, but none of them have textures! They all appear as something akin to a black hole for some reason. Any idea what would cause this?

An incorrect install

Link to comment
Share on other sites

10 minutes ago, Galileo said:

An incorrect install

I've been doing some fiddling, and for some reason or another, it seems to be stemming from having Extrasolar installed. Its labelled as compatible, but once added in, OPM planets seem to all lose their inflight map/tracking station textures, but flying low over them shows a textured planet.

Link to comment
Share on other sites

Just to say it, I got ExtraSolar textures together with OPM (and clouds) - but yeah, it's not really compatible now.
The issues differ from player to player somehow.

In an unpredictable way it could happen that ModularFlightIntegrator is triggered to throw exceptions, but the root is hard to pinpoint for me:
https://forum.kerbalspaceprogram.com/index.php?/topic/130656-142-extrasolar-v171-4918/&do=findComment&comment=3354803

 

Link to comment
Share on other sites

12 minutes ago, Gordon Dry said:

Just to say it, I got ExtraSolar textures together with OPM (and clouds) - but yeah, it's not really compatible now.
The issues differ from player to player somehow.

In an unpredictable way it could happen that ModularFlightIntegrator is triggered to throw exceptions, but the root is hard to pinpoint for me:
https://forum.kerbalspaceprogram.com/index.php?/topic/130656-142-extrasolar-v171-4918/&do=findComment&comment=3354803

 

1 hour ago, Poodmund said:

We don't list Extrasolar as a compatible mod... sorry, you'd have to take up this issue with the Extrasolar mod developer.

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...