Galileo

[KSP 1.5.*] Outer Planets Mod[2.2.1] [25 April 2018]

Recommended Posts

PSA TO ALL OPM USERS

OPM requires Kopernicus as a dependency and as such will not work on KSP 1.5+ at this time. Please retain your KSP 1.4.5 (or earlier) installs with the corresponding version of Kopernicus that matches your KSP version (1.4.x-*). Kopernicus will not function if you try to run a version that is not designed to work with KSP 1.5 at this time and will corrupt your saves if attempted.

Please be patient and continue with your current OPM games; an update will be released in due course (if necessary) when OPM's dependencies update to KSP 1.5.

Share this post


Link to post
Share on other sites

Kopernicus is updated now. Do you need to also update OPM?

Haven't downloaded 1.5.0 yet anyway. Haven't even touched 1.4.5 either as I was was busy on my old separate 1.3.1 for the time being.

Share this post


Link to post
Share on other sites
16 minutes ago, Quoniam Kerman said:

Kopernicus is updated now. Do you need to also update OPM?

I see no reason why the current OPM shouldn't work with the new KSP, but you'll get a "Unsupported KSP Version" warning.  The warning just means that your KSP version is newer than last version for which OPM was updated.  It doesn't necessarily mean it won't work.  Just click close and continue.  You'll have your answer when you see whether or not the OPM planets load.

That being said, it's my understanding that an OPM update is forthcoming.

Share this post


Link to post
Share on other sites

When Outer Planets is installed I get a few second freeze when I press the map button. Any ideas on how to fix this?

Share this post


Link to post
Share on other sites
17 hours ago, Arte said:

When Outer Planets is installed I get a few second freeze when I press the map button. Any ideas on how to fix this?

I've seen reports elsewhere of this happening. It's very likely another significant KSP 1.5 bug.

Share this post


Link to post
Share on other sites
17 hours ago, Arte said:

When Outer Planets is installed I get a few second freeze when I press the map button. Any ideas on how to fix this?

It's not just OPM.  The problem seems to occur with any planet pack installed.

Share this post


Link to post
Share on other sites
10 minutes ago, sslaptnhablhat said:

This hasn't really been made clear, so I just want some clarification. Do OPM planets support Scatterer and/or EVE?

The Outer Planets Mod does not contain any support for Scatterer or EVE itself, however, visual mods exist that give Scatterer and EVE effects to the OPM bodies such as SVE and OPM-VO.

Share this post


Link to post
Share on other sites
45 minutes ago, Poodmund said:

The Outer Planets Mod does not contain any support for Scatterer or EVE itself, however, visual mods exist that give Scatterer and EVE effects to the OPM bodies such as SVE and OPM-VO.

Is there a mod that gives just Scatterer effects to OPM's planets?

Share this post


Link to post
Share on other sites
44 minutes ago, sslaptnhablhat said:

Is there a mod that gives just Scatterer effects to OPM's planets?

If you want just the scatterer effects (i.e. no EVE effects), then just install scatterer and none of the other visual mods.

Share this post


Link to post
Share on other sites

New Release - KSP 1.5.* Compatibility!

Outer Planets Mod v2.2.2 - Link

Changelog

v2.2.2

  • Converted all biome maps to Palette 4bpp/8bpp .dds formats to improve loading time and OD functionality.
  • Removed Custom Asteroids integration in favor of using Kopernicus' Asteroids module.
  • Included configs for "Classic Stock" resource system if present.

Previous changelogs can be found on the GitHub repository or the original forum thread: https://forum.kerbalspaceprogram.com/index.php?/topic/93999-1

Please Note: Custom Barn Kit also seems to work just fine on KSP 1.5.1 so feel free to install it to enhance OPM's gameplay. It is currently marked down as being compatible with KSP 1.4.1 max. and thus, will not appear on CKAN for KSP 1.5.* and will have to be force installed or installed manually.

Finally, the CKAN entry will be auto-listed in due course, its all set up, please give CKAN time to re-index the new release.

Edited by Poodmund

Share this post


Link to post
Share on other sites

Is there any specific reason Sarnus starats the game fully researched no matter what the RB settings are? 

Is it OK to edit the RB config file in OPM, remove it from the IGNORE section, and make the last entry for Sarnus as "false" in order to make RB allow you to discover and research it?

Or will that break something?

What I'm looking for is a game where I have Sun, Kerbin, Mun, Minmus, and that's it for starting 100% researched. OPM kind of jacks this up by defaulting Sarnus to fully researched under all conditions, so, if there's not a programmatic or error related reason, I'd just as soon undo it via a simple edit or 2 to the OPM RB Config.

Edited by Murdabenne

Share this post


Link to post
Share on other sites
11 minutes ago, Murdabenne said:

Is there any specific reason Sarnus starats the game fully researched no matter what the RB settings are? 

Is it OK to edit the RB config file in OPM, remove it from the IGNORE section, and make the last entry for Sarnus as "false" in order to make RB allow you to discover and research it?

Or will that break something?

What I'm looking for is a game where I have Sun, Kerbin, Mun, Minmus, and that's it for starting 100% researched. OPM kind of jacks this up by defaulting Sarnus to fully researched under all conditions, so, if there's not a programmatic or error related reason, I'd just as soon undo it via a simple edit or 2 to the OPM RB Config.

edit it all you want.

The reason it’s visible is because of our own history. Before we ever peered through a telescope, we knew the gas giants existed. Granted, humans thought they were gods, but we knew they were there. If the outer planets existed in the Kerbal universe, we can only speculate that their ancestors would have already annotated their existence far before the Kerbal Space Program was ever concieved.

Edited by Galileo

Share this post


Link to post
Share on other sites

Thanks!  I am imagining my kerbals are rather dim, given they haven't discovered the giant mint ice-cream moon Minmus right there next to them :D... 

So I'll give them that one and make them look for Sarnus instead.:cool:

Thanks for the fast reply!

 

Share this post


Link to post
Share on other sites

Is there a way to remove the procedural craters added to Eeloo? I figure that it is renewing its surface enough that the craters wouldn't last long. I tried the guide to doing this on page 13 of the thread but that just completely breaks OPM.

Edited by nsgallup

Share this post


Link to post
Share on other sites
5 hours ago, nsgallup said:

I tried the guide to doing this on page 13 of the thread but that just completely breaks OPM.

How's it breaking it?  I don't see why anything suggested on page 13 would completely break OPM.

Share this post


Link to post
Share on other sites

Idk, I had to actually completely remove and reinstall kopernicus and OPM after that to get it to work again so it might have been unrelated. I'll try again next time I boot up the game.

Share this post


Link to post
Share on other sites

So, a mod that I really, really miss pretty badly is the old "Clouds for Outer Planets" mod, especially since, back in the day, I would commonly load up Astronomer's Pack Interstellar, OPM, and then the cloud config for OPM and Astronomer's. Well, see the below screenshots; it's not perfect, but it seems like a good start...

 

EDIT: The below screenshots were taken from a 1.5 install running the most recent Outer Planets mod, Astronomer's Pack, a post processing mod that's recently popular, and a config from the old "Clouds for Outer Planets" mod that I partially converted to the newer EVE format.

 

v9caAf5.png

 

DapQpPH.png

Edited by Raven.

Share this post


Link to post
Share on other sites

EVE has configs for OPM, but it doesn't seem to work on the gas giants themselves, OPM-VO works on the gas giants but not the moons.. and they won't both work together lol

 

Share this post


Link to post
Share on other sites
1 minute ago, nsgallup said:

EVE has configs for OPM, but it doesn't seem to work on the gas giants themselves, OPM-VO works on the gas giants but not the moons.. and they won't both work together lol

 

On 1.3.1 I used OPM-VO, it was ok, but not my personal preference. 

Share this post


Link to post
Share on other sites

Well if you get clouds working on all OPM bodies, let me know! I want in on that!

Share this post


Link to post
Share on other sites
22 minutes ago, nsgallup said:

Well if you get clouds working on all OPM bodies, let me know! I want in on that!

I might have a test config file in the next day or so, depends on how far I get tonight and much my day job holds me down tomorrow. 

On another note, don't I remember that Slate may have had a cloud config, either by astronomer's or another mod? I know someone way back in 2014 did one for a lot of moons in KSP (such as where there was this one cool mod that gave Moho a dust layer).

Share this post


Link to post
Share on other sites

Slate would probably not have this since it has pretty high surface gravity, but there was a mod that gave minmus dust, and moho a visible EM field interacting with solar radiation.

Share this post


Link to post
Share on other sites

Hello there!

  I have been trying to install the Outer Planets pack since about 3 days and I can't find a way to make it work! The mod never loads. It's like it is not even there and only the dependencies of the mod are installed. Can someone help me? Im running on KSP 1.3.1

I can upload the Logs if necessary.

Edited by Pedro_Commander

Share this post


Link to post
Share on other sites
1 hour ago, Pedro_Commander said:

Hello there!

  I have been trying to install the Outer Planets pack since about 3 days and I can't find a way to make it work! The mod never loads. It's like it is not even there and only the dependencies of the mod are installed. Can someone help me? Im running on KSP 1.3.1

I can upload the Logs if necessary.

Logs is a huge help to anyone attempting to help. Also, may I ask what folder did you drop the OPM files in?

 

22 hours ago, nsgallup said:

EVE has configs for OPM, but it doesn't seem to work on the gas giants themselves, OPM-VO works on the gas giants but not the moons.. and they won't both work together lol

 

Out of curiousity, what version of EVE are you running?

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.