linuxgurugamer

[1.3.1] Docking Camera KURS Style

Recommended Posts

@DennyTX has come back and resumed development and control of this mod.

Please move all discussion to the original thread here:

 

 

Reviving a mod written by @DennyTX, which hasn't been updated for almost a year.  Original thread is here: https://forum.kerbalspaceprogram.com/index.php?/topic/124475-122-docking-camera-kurs-18may17/

Once upon a time there was LAZOR mod from famous Romfarer, which included a useful docking camera, that displays the videostream a small window in the main flight scene. However, it has not been updated for a long time, and refused to work in recent versions of the game (or I could not start it). Nevertheless, I like it output style of information and I was bored without this service. That in turn has led me to attempt to revive the aforementioned docking camera. And YES, i know about Docking Port Alignment Indicator, HullCamVDS, cameras for RasterPropMonitor etc. But i do not know about any working cameras in window.

Availablity

Download: https://spacedock.info/mod/1542/

Source Code: https://github.com/linuxgurugamer/DockingCameraKURS

License:  CC-BY_NC_SA-4.0

 

New shaders example:

 



 

 

So, what we have here. Docking-camera itself, which can be integrated to any part (MM patch enclosed for the docking port modules). It looks ahead by the vertical axis of the vessel's and displays a minimum of necessary info for the docking maneuver - namely, range, speed, angle, alignment and when the correct trajectory occured - time prior to docking with the mark that such trajectory will lead our vessel to dock without additional actions (small lamp will become green and will show time to docking). camera window has three size presets. It also has three viewing modes: color, Black and white and infrared. Powered zoom function. Also, there is a button to remove flight data from the screen. Furthermore, effect of television interference can be added. The range of the camera,parameters of night vision (RSMA) and presence of noise - can be configured through CFG. Camera requires a target to operate.

In addition the ugly external camera enclosed. It can show videostream only and also has three modes of vision and is able to rotate on two axes. For cameras, installed under the belly of the aircraft (which gets inverted upside down) there is the mode of rotation of the image. In the CFG of the partcamera some meshes could be configured for use with other camera model.

All cameras have a title with its number, and also can work a few pieces at a time. Docking camera reporting its target on its window title.

There is an experiment on part camera - a try to reproduce a surveilance (spy) activity. You need to be at a distance less than 1000 m near any targetable thingie, catch it on camera's screen and targeted. press "⦿" button. A ray will be shoot. If all requirements have met and there are no obstacle on ray's path - you'll should get experiment results, if something wrong - you just spend one bullet.  Experiments is limited by bullets (4 yellow balls around cam, dissapearing one by one each time). I thought it will be interesting if contracts.

Camera has 3 presets of shaders (noisy TV 1960th style, TV 1980th style  and standart (color, b/w and nightvision). available via button, appearing when blizzy toolbar is installed. 

Also, by toolbar button you could find info about nearby cameras installed on other vessels in transmission range. If camera has been activated on some vessel, but you drive other one - a new window from distant camera will appear when distance from first one will become less than 2500 (or 10k (customizable)). 

If you want you can use "look at me" mode by activating it on distant camera. "Targetcam"  and "follow me" modes on your active vessel (set camera position using scrollers).

The cameras can transmit the videostream to nearby vessels, but only at a distance of up to 2 500 meters. You can change this unload range via toolbar button.

 

Configuring examples

Spoiler

Docking Camera

    MODULE
    {
        name = DockingCameraModule
        allowedDistance = 1000
        targetCrossColor = 0.9,0.0,0.0,1.0
        targetCrossColorOLDD = 0.0,0.0,0.9,1.0
        noise = true
    }

 

Part Camera

MODULE

{

name = CameraModule

windowSize = 300 // initial camera window size

cameraName = CamExt

rotatorZ = Case

rotatorY = Tube

zoommer = Lenz

cap = Cap

bulletName = Sphere // name of consumables (expected that names in model will be finished by 00X)

stepper = 1000 // using for zooming visualization. for another camera model

distance = 1000 // allowed distance for scanning experiment

resource = ElectricCharge.50 // resourseName/resourceUsage

}

MODULE

{

name = ModuleSpyExperiment

experimentID = TargetScanning

experimentActionName = Scan Target

resetActionName = Delete Data

useStaging = False

useActionGroups = True

hideUIwhenUnavailable = False

xmitDataScalar = 0.8

dataIsCollectable = True

collectActionName = Take Data

interactionRange = 1.2

rerunnable = True

usageReqMaskInternal = 1

usageReqMaskExternal = 8

}
 

 

Edited by linuxgurugamer
  • Like 5

Share this post


Link to post
Share on other sites

@linuxgurugamer just pinging you so when you get the time to look at this error,

using the stock "Slim shuttle" i get this when placed on the launch pad/starting rocket

everything runs good,and no problems so far (but then again what do i know about coding :D ) hope it;s nothing difficult.

Spoiler

[ERR 01:47:11.989] Exception handling event onPartDestroyed in class CameraDestroyer:System.NullReferenceException: Object reference not set to an instance of an object
  at OLDD_camera.Modules.DockingCameraModule.Deactivate () [0x00000] in <filename unknown>:0
  at OLDD_camera.CameraDestroyer.PartCameraDeactivate (.Part part) [0x00000] in <filename unknown>:0
  at EventData`1[Part].Fire (.Part data) [0x00000] in <filename unknown>:0

[EXC 01:47:11.991] NullReferenceException: Object reference not set to an instance of an object
    OLDD_camera.Modules.DockingCameraModule.Deactivate ()
    OLDD_camera.CameraDestroyer.PartCameraDeactivate (.Part part)
    EventData`1[Part].Fire (.Part data)
    UnityEngine.Debug:LogException(Exception)
    EventData`1:Fire(Part)
    Part:OnDestroy()

 

Edited by dtoxic

Share this post


Link to post
Share on other sites

What were you doing, and, of course, a complete log file helps

Share this post


Link to post
Share on other sites
21 minutes ago, linuxgurugamer said:

What were you doing, and, of course, a complete log file helps

From the Main scene selected the Slim shuttle for the launch pad, that was it, nothing else, thou i do have a lot of mod's installed this is an old bug i think from when DanyTX was working on it, i posted there also (will see if i can dig up the post)

https://www.dropbox.com/s/jzqx0h275nl4uaj/KSP.rar?dl=0

Line 25389

Share this post


Link to post
Share on other sites

I just tried this on a totally clean install, the only thing installed was this and MM.

It did not happen.

however, I did find a place in the code where it might conceivably happen, so I'll fix that for now.

If I'm right, this can be ignored (although I am fixing it), it will happen one time occasionally when instantiating a vessel, but not after

 

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

cool, i didn't know if it was game breaking or not (still not playing the game just testing mod's) so i did not know if it was game breaking or not, better safe then sorry i guess :)

Share this post


Link to post
Share on other sites

New release, 1.3.1.3:

  • Fixed nullref when instantiating vessel
  • Like 1

Share this post


Link to post
Share on other sites

New release, 1.3.2:

  • Added ability to rotate the docking camera
  • Added zoom to docking camera

Share this post


Link to post
Share on other sites

Dear @linuxgurugamer

I have a little problem with this mod. The 'image' is being shown 'outside the camera window. I've tried everything and I don't know what is wrong. Are there any other mods needed for it to work? Or is it conflict with another modification? Thanks for your answer!

hTnGZ5w.jpg

Edited by strozyk85

Share this post


Link to post
Share on other sites

If you could post the output_log.txt, it looks like you posted the KSP.log file

Also, the craft file

Edited by linuxgurugamer
  • Like 1

Share this post


Link to post
Share on other sites
7 minutes ago, strozyk85 said:

@linuxgurugamer The problem seems to disappear when I start the game without -force-d3d11 startup parameter.

Here you have the rest of the files.

output_log (64bit).txt
output_log.txt
RVR_1_0-001.craft

Regards!

Oh, yuck.

I'm not sure I can do anything about that

  • Like 1

Share this post


Link to post
Share on other sites
On 27.11.2017 at 10:32 PM, linuxgurugamer said:

Oh, yuck.

I'm not sure I can do anything about that

So your mod unplayable in dx11?

Share this post


Link to post
Share on other sites
5 minutes ago, Battou said:

So your mod unplayable in dx11?

  Looks that way, doesn't it?

Share this post


Link to post
Share on other sites

Hello ,

I confirm I have exactly the same problem. This mod is currently incompatible with DX11. But nothing can resist @linuxgurugamer !:)

Share this post


Link to post
Share on other sites
4 hours ago, doudou said:

Hello ,

I confirm I have exactly the same problem. This mod is currently incompatible with DX11. But nothing can resist @linuxgurugamer !:)

Nope, not this time.

I'm not touching that, if someone else wants to, that would be great.  I'd love a PR 

Share this post


Link to post
Share on other sites

i know the cause. Fixed. it was simple with DX11. but I want to re-release my version of the mod, if  @linuxgurugamer does not mind. need few hours for testing.

Edited by DennyTX
  • Like 2

Share this post


Link to post
Share on other sites
53 minutes ago, DennyTX said:

i know the cause. Fixed. it was simple with DX11. but I want to re-release my version of the mod, if  @linuxgurugamer does not mind. need few hours for testing.

I don't mind, but please  look at mine for some changes I made.  Would be good for people if they moved forward for consistency.  Also, you never uploaded the last version of the mod to github, I had to reverse-engineer it.and I did message you about it multiple times.

Share this post


Link to post
Share on other sites

@DennyTX has come back and resumed development and control of this mod.

Please move all discussion to the original thread here:

 

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.