Jump to content
  • 1

Kopernicus problem



Hi there. I'm trying to modify default planets to look a bit more realistic, so I've tried to install Kopernicus with Stock Visual Terrain or RSS mod. While EVE & SVE that including Kopernicus as dependence works fine, Kopernicus with SVT or RSS won't work and all I get is striped yellow planets without any texture. I've tried both 1.3 and 1.2.2 version.

Like this:




What do I know: texture packs are detected and used by game because with them game loads incredibly slow (+ ~10 mins). I have Windows 8.1 installed with latest Nvidia drivers. Tried to force either DX9 nor DX11, also ran in x64 and with admin privileges, still didn't got to work.

I'm confused because with the same problems were encountered unix users only, I've tried to google the solution already. Seems like everyone got working Windows version except of me.

You can see my logs here: https://pastebin.com/1M46c9ck

Can somebody help me?


Edited by umeeo
shortening question
Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

You're not trying to use both SVT and RSS at the same time, are you? "Nolas" isn't a stock world.

I'd review the SVT instructions again. The steps I've been following are:

  1. Start with a clean KSP install, no mods.
  2. Install Kopernicus by itself and test. Kerbin should be rotated in the main menu screen compared to stock.
  3. Add SVT and an SVT texture pack according to SVT's instructions, which I think are to add SVT first, then the texture pack.
  4. Start KSP and test.

That should be enough. After this works, you can add SVE and other visual add-ons.

I've read somewhere that running the game in Direct3D 11 mode might cause the funny line patterns, but haven't tried that myself.

Also, on Windows 8 and later you don't need to run KSP as an admin or force D3D9 or D3D11. The logged-on user just needs Modify permissions in the KSP folder. SVT would benefit more running in 64-bit with ksp_x64.exe though, so you can use the higher resolution texture pack.

Edited by Gordon Fecyk
Not Windows 10
Link to comment
Share on other sites

  • 0

An additional step should be added between 1 and 2 in Gordon's list: Run KSP once without any mods.  Just getting to the space center screen should be enough, but I usually will hit all the buildings as well, just to make sure.  What this does is give KSP the chance to create settings and such needed for the mods to have something to work with.  It's one of the first steps for installing Kopernicus with Galileo's Planet Pack (which eliminates the entire stock system and adds a new one).

Anyway, that might or might not help, but it's something to try, and only takes a few minutes since you'll have no mods installed as yet.

Link to comment
Share on other sites

  • 0

Bumping because I'm having a very similar problem. The problem in my case seems to be SVE. I also am using Windows and have a fairly old (not *that* old, though) Intel graphics driver.

I am working on my own planet pack, and some of the planets have this same problem while others are just fine. 

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...