linuxgurugamer

[1.5.1] Probe Control Room Recontrolled

Recommended Posts

Feel free to make the paty/IVA

I am only keeping this going, I am not doing any active development on this.

Share this post


Link to post
Share on other sites
12 minutes ago, Errol said:

I realize the point of this mod is to make it look like you are controlling a probe from far away, that is not what we were discussing here though. 

What I am talking about is how to handle the situation in which you are controlling the probe with a signal processor from another vessel from a Remote command point.

I also understand that if the IVA's don't match, it would seem inconsistent, hence my proposal of creating a new part, to house the IVA for vessels that are controlling probes locally. It could be a copy of a stock my 1 passenger fuselage with a computer station on the wall inside. The IVA would still be on the probe itself, it's just that if the controlling vessel has the signal processor part this alternat IVA is used. Part of my thinking with timing it to a part is that if you want to be able to see your probe from the perspective of the controlling craft there are two ways it could be done. By somehow having control of the probe while the IVA is in the controlling vessel, which I'm going to guess is not actually possible in the game. This would allow you to simply look out the window....but then we start getting into the miss match IVA problems too.

So make it a camera instead. I mean the part. You have to attach a small part to your controlling craft, along with the signal processor, which either looks like a window or a camera, but regardless acts like a camera in that it feeds a POV to a screen in an IVA that either looks like a monitor on the wall of some craft, or looks like a window on the wall of some craft. The if you are controlled from the signal processor instead of the ground, you see the ship control point IVA instead. 

I don't know if having a camera on a vessel that is not focused is problematic. Just trying to brainstorm here. 

Brainstorm is good that's how things come about

Share this post


Link to post
Share on other sites

Loving this mod - using it with "Through the eyes" for an immersive experience. One problem, though - my RCS translation controls (IJKL) are not working - or responding at all. Can't get translation to work in docking mode either. Anyone else experienced this problem (I realise it may not be this mod causing the issue).

Share this post


Link to post
Share on other sites

I thought this had gone outdated! Big ups. I love this - it's more stable, too (for me anyway).

Curious: If I am using IVA-"only" on say-- a shuttle coming in for landing; if I'm not wrong, you cannot switch from cockpitIVA to missioncontrolIVA? Either I missed a config, or the mission control is IVA and you can't use two IVA instances at the same time like that. Any answers from anyone would be cool ! :sticktongue:

Edited by ElonsMusk

Share this post


Link to post
Share on other sites
26 minutes ago, ElonsMusk said:

I thought this had gone outdated! Big ups. I love this - it's more stable, too (for me anyway).

Curious: If I am using IVA-"only" on say-- a shuttle coming in for landing; if I'm not wrong, you cannot switch from cockpitIVA to missioncontrolIVA? Either I missed a config, or the mission control is IVA and you can't use two IVA instances at the same time like that. Any answers from anyone would be cool ! :sticktongue:

You can't use Mission Control on man missions but you can on probe's

Share this post


Link to post
Share on other sites

Have the "loss of connection" and "screens go blank if energy is empty"-features (cfgs) been included?
Sry i cant test it because i cant Update Kerbal to 1.3.1 because of Kerbalism.

Thx for keeping this Mod alive!

Share this post


Link to post
Share on other sites
10 hours ago, Euer_Hochwuergen said:

Have the "loss of connection" and "screens go blank if energy is empty"-features (cfgs) been included?
Sry i cant test it because i cant Update Kerbal to 1.3.1 because of Kerbalism.

Thx for keeping this Mod alive!

No idea, I don't really use this right now.

Are those cfg files? and if so,do you know the names of them?

Share this post


Link to post
Share on other sites
On 16.12.2017 at 4:11 AM, linuxgurugamer said:

No idea, I don't really use this right now.

Are those cfg files? and if so,do you know the names of them?

I also dont really know but i suppose yes. I read a couple of months ago, when the mod wasnt really maintained by anyone sepcific, but lots of people did their own stuff on it, that there was allegedly a cfg file for the screens going black thing, but maybe it was outdated already to that time. I try to backtrace on it and will post if i find.

Share this post


Link to post
Share on other sites

Hello,

Back IG and so glad to see this mos is updated. Thanks for your time !

 

Finally, i may try this. I've always kept that in archive thinking "i'll use it later".

Any suggestion for mods for a new game, apart RasterProp and ASET ?

Edited by brienne

Share this post


Link to post
Share on other sites

I do my entire space program IVA from time to time, and this mod was sorely missed. Thank you once again for your enthusiasm for helping orphans.

Share this post


Link to post
Share on other sites

So, the latest version of this doesnt seem to work for me.
KSP 1.3.1 fresh install... just a few other mods installed (all checked for latest updates):

https://imgur.com/a/BV9xI
Your 1.2.28 recompile seems to work fine when I switch it with 1.2.29, into this same install.

Bunch of relevant logs...
The last two sets of KSPDev logs are with 1.2.28 and then 1.2.29 installed...

https://drive.google.com/open?id=1zDHXgKOFIToFiiWUskcpkYQfTeadAvrV
With 1.2.29 installed, nothing happens when clicking the PCR icon on the toolbar.
I first had problems when I had Toolbar installed also... I was getting constantly running log spam related to PCR and Toolbar, right from the start of game loading, right thru to inflight play...
So I uninstalled Toolbar first, but still having the above issues with just PCR installed.
Edited by Stone Blue

Share this post


Link to post
Share on other sites

Did you update ModuleManager at the same time?  

Looks like  you are loading an existing save, I'm seeing a partModule indexing mismatch in one of the files

If you don't have the toolbar loaded, delete the file:  ProbeControlroomToolbar.dll, if it's there

Oh, and a complete list of mods.

Would also help if you just installed PCR in stock and see if it works, if it does, then add the mods back a few at a time

Share this post


Link to post
Share on other sites
29 minutes ago, linuxgurugamer said:

Did you update ModuleManager at the same time? 

no... been using 3.0.1since it came out
 

29 minutes ago, linuxgurugamer said:

Looks like  you are loading an existing save, I'm seeing a partModule indexing mismatch in one of the files

thats cuz I deleted the default save folder, to make sure nothing carried over after removing/switching mods...
starting a new "default" save that way, it still asks if you want to overwrite it... vOv
 

29 minutes ago, linuxgurugamer said:

Oh, and a complete list of mods.

contents of GameData in the imgur link... ASET contained only Avionics, Props, and ALCOR

OK... pulled everything out except PCR and KSP Dev Logger
New logs:
https://drive.google.com/open?id=1zDHXgKOFIToFiiWUskcpkYQfTeadAvrV

(didnt try removing the PCRToolbar dll yet)... trying that next

EDIT: yeah, removing the PCRToolbar dll didnt seem to change anything... clicking PCR stock app button still does nothing :(

 

 

Edited by Stone Blue

Share this post


Link to post
Share on other sites

One more, can you try the old MM, 2.8.1?  I don't think it will do it, but would like confirmation

 

Share this post


Link to post
Share on other sites

Hmmm... I thot i HAD switched them... would have been in some of the older KSPDev logs... but yup, will do it nao

Share this post


Link to post
Share on other sites
17 minutes ago, linuxgurugamer said:

One more, can you try the old MM, 2.8.1?  I don't think it will do it, but would like confirmation

 

'K... still nothing... this is with only JSI(RPM), KSPDev, MM 2.8.1, PCR installed (PCR Toolbar dll removed)...fresh save

https://drive.google.com/open?id=1zDHXgKOFIToFiiWUskcpkYQfTeadAvrV

Edited by Stone Blue

Share this post


Link to post
Share on other sites
1 minute ago, Stone Blue said:

'K... still nothing... this is with only JSI(RPM), KSPDev, MM 2.8.1, PCR installed (PCR Toolbar dll removed)...fresh save

https://drive.google.com/open?id=1zDHXgKOFIToFiiWUskcpkYQfTeadAvrV

Ok, thanks for testing.

I'll set up a clean install to test this.

Did you install by hand or via CKAN?

Share this post


Link to post
Share on other sites

hmmm... finally looking thru the logs, I see this, which i assume is the issue? vOv :

" [ERROR] [InternalProp.AddModule] Cannot find an InternalModule of typename 'RasterPropMonitorComputer'"

I'm now gonna try downgrading RPM a version or two...

hmmm... finally looking thru the logs, I see this, which i assume is the issue? vOv :

" [ERROR] [InternalProp.AddModule] Cannot find an InternalModule of typename 'RasterPropMonitorComputer'"

I'm now gonna try downgrading RPM a version or two...

5 minutes ago, linuxgurugamer said:

Did you install by hand or via CKAN?

All manual install.. i dont CKAN

Also, when this all started, I had 1.7.16.5 of Toolbar installed... and THAT was not showing up at all either for me... Downgraded to 1.7.15 and it (Toolbar itself), was working fine...
So, I know its a completley seperate thing, but if yer gonna do a clean test with PCR, and it was throwing specific PCRToolbar.dll errs with 1.7.15, maybe test the newer localiztion beta for Toolbar, afterwards... vOv

 

Share this post


Link to post
Share on other sites

No rush... I was looking into updating/making a whole new control room, but I have another project I'm still in the middle of... :wink:

Share this post


Link to post
Share on other sites

Hi Linuxgurugamer and Stone Blue.
I was happy to see this mod alive,

But that's the same for me here.
I've try to keep just PCR RPM and ASET,
manual install,
with MM in 2.8  or tried MM with 3.0.1 too,
On a fresh save,

and nothing appear. No trace of PCR.


In the Player.log i found " Cannot find an InternalModule of typename 'RasterPropMonitorComputer'".... :(
 

 

Share this post


Link to post
Share on other sites
2 hours ago, Stig73 said:

Hi Linuxgurugamer and Stone Blue.
I was happy to see this mod alive,

But that's the same for me here.
I've try to keep just PCR RPM and ASET,
manual install,
with MM in 2.8  or tried MM with 3.0.1 too,
On a fresh save,

and nothing appear. No trace of PCR.


In the Player.log i found " Cannot find an InternalModule of typename 'RasterPropMonitorComputer'".... :(
 

 

I assume you are on Linux (or a Mac)?  Please post a link to the entire log file.

I don't see anything wrong in the cfg files, but we really need the entire log.

One thing, do you have RPM installed?  and if so, where and how?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.