• 0
techgamer16

MechJeb Not working with KSP 1.3.1

Question

So I recently updated my KSP to 1.3.1 and I wanted to reinstall all my mods anyway, but the only mods that aren't currently working now with the latest patch are MechJeb and the mod that allows having the MechJeb functionality on all parts.

Because I'm lazy, I like to let MechJeb do all the maneuvers for me, including ascent guidance and performing nodes, but I can't do this now as it wont work.

Please can someone guide me as to what version to use, if any for the new update. Thanks.

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

Hey guy,

I use MechJeb2 v2.6.1 from 9 June. I didn't notice any problems. Some users report trouble with auto land and auto ascent staging. I use MJ for the data readouts and maneuver node planning; I fly my ascent somewhat manually (command SmartASS to set a certain attitude) and I never use auto land.

Share this post


Link to post
Share on other sites
  • 0

yes auto land is broken.. it lands you on the blue marker not the red one.. so essentially you end up on the opposite side of the planet/moon

Share this post


Link to post
Share on other sites
  • 0

There's a link on the first page of the main thread that takes you to the latest dev releases.

Here's the link for that dev page:

https://ksp.sarbian.com/jenkins/job/MechJeb2-Dev/

If you download and install the latest stable release it should work okay.

I'm using it with 1.3.1 and everything's running fine. Like aaronsta1 said, there have been reported issues with autoland, though I personally haven't had any problems with ascent autostaging.

I'm sorry if this is somewhat prudish, but it probably would've been better if you posted this question in the main Mechjeb thread. You would've gotten a quicker response and better support.

Good luck with everything. I hope it helps you out.

Share this post


Link to post
Share on other sites
  • 0
On 28.10.2017 at 12:49 AM, oversoul said:

Hey guy,

I use MechJeb2 v2.6.1 from 9 June. I didn't notice any problems. Some users report trouble with auto land and auto ascent staging. I use MJ for the data readouts and maneuver node planning; I fly my ascent somewhat manually (command SmartASS to set a certain attitude) and I never use auto land.

Hi guys, for the start - sorry for my english, if something, it's not my native language)

I also thought that autoland mode is not working correctly but! It realy does land at oposite side just for a single reason, the orbit is 2 low. Here is my advise, 2 execute autoland maneuver at moon, just set your Periapsis high atleast 20K metres. 

Hope that info was usefull.

Share this post


Link to post
Share on other sites
  • 0

Hoping I can figure out what I messed up.

1.3.1, latest mechjeb (MechJeb2-2.6.1.0-768) and RPM (RasterPropMonitor.0.29.2) integration.

Hitting the auto section of my monitors I get the dreaded SmartASS/MJ Control mechjeb autopilot not found, but ... it is there, I have the tab I can go on, and the module installed on the spacecraft.

I used to have these working, but now it's gone from every spacecraft, even my SSTU ones which include mechjeb into the module.

 

Thanks beforehand.

 

 

Share this post


Link to post
Share on other sites
  • 0

Im Currently using the latest Build of KSP (1.3.1) And I thought this mod Would work great because i am very bad at Launching satellites, and ships, But, i used the Jenkins Link, And the Latest Release, But the Mod never Loads on KSP. It loads in ModuleManager, But never shoes up In game. Help Please! 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now