• 1
a_space_oddity

SAS won’t hold

Question

I don’t know if this is a known problem or not, but SAS won’t hold. It just randomly drifts of vector. It’s like it thinks the vector it’s supposed to hold is on the other side of the navball. It makes docking nearly impossible. Does anyone else have this problem? I am using 1.3.1

Share this post


Link to post
Share on other sites

12 answers to this question

Recommended Posts

  • 1

Do you have a gamepad/joystick plugged in but not in use? Maybe it's turning your ship for you.

Share this post


Link to post
Share on other sites
  • 1

Pics will help a lot here. 3 obvious thoughts:

  1. Is this in atmosphere? You're discussing docking so I seriously doubt it but aerodynamics generally beats SAS if your ship is moving through the air.
  2. Are your engines above or near your center of mass? Sometimes they get confused and gimbal the wrong way when they're not at the back. Please let's stop and pour one out for my very first Moho mining operation, so many years ago now.
  3. Are your RCS ports not balanced? If you're trying to translate, and all your RCS ports are at the front or back, you will rotate.

Share this post


Link to post
Share on other sites
  • 0

check if you have electricity or enough reaction wheels to actually be able to turn and stay put.  Sometimes with big ships you have reaction wheels, but when you turn you don't stop turning, so you drift around a lot.

Share this post


Link to post
Share on other sites
  • 0
3 minutes ago, TwinKerbal said:

check if you have electricity or enough reaction wheels to actually be able to turn and stay put.  Sometimes with big ships you have reaction wheels, but when you turn you don't stop turning, so you drift around a lot.

I don’t think that’s the problem. I had a small craft, and RCS didn’t help. I would get the craft aligned for a burn, and all at once it would start yawing to the right or left. Also, when you select one of the hold options, it will start to turn to the assigned vector, but it won’t stop. It just does circles. 

Share this post


Link to post
Share on other sites
  • 0

I thought of 1 more: Do you have a lot of struts? Like, a LOT of struts? It's been years but I had a ship that the struts somehow created this odd torque on my craft whenever I thrust. Removing some of the struts caused the issue to go away.

Share this post


Link to post
Share on other sites
  • 0

I was running through the docking tutorial so I assume Squad balanced the RCS thrusters on the craft for that tutorial. It couldn’t be gimbal problems because the engine was off. As for pics, I don’t have 45 minutes right now to spend coaxing my pc to open KSP and get some pics. 

Edit: I had no struts. 

Edited by a_space_oddity

Share this post


Link to post
Share on other sites
  • 0

You can right click, and click "control from here" on docking ports and command pods, and probes.  It will re-orient the NAV-ball to that part.  There is also an option in settings to keep that persistent when entering IVA.

You can also click the green text on the navball to switch from target/orbit/surface mode.  The tutorial says to "click the velocimeter".  I can see how that could be confusing.

Edited by MrChumley

Share this post


Link to post
Share on other sites
  • 0
10 minutes ago, MrChumley said:

You can right click, and click "control from here" on docking ports and command pods, and probes.  It will re-orient the NAV-ball to that part.  There is also an option in settings to keep that persistent when entering IVA.

I know, I use that feature for docking. 

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, 5thHorseman said:

Do you have a gamepad/joystick plugged in but not in use? Maybe it's turning your ship for you.

Good point, I am using a joystick, I’ll test that when I get a chance. 

Share this post


Link to post
Share on other sites
  • 0

I just ran through the tutorial to see if there was anything weird.  Aside from setting it up so that Rendezvous, and docking occurred on the night side with no lights (At least for me) everything seemed to work ok.  There was a point were it switched the navball out of target mode, and made me click it back to complete the step.

Spoiler

zeCtJEw.png

bNopMuW.png

I was able to get it though... :wink:

Share this post


Link to post
Share on other sites
  • 0

I got through, but only after several hours of frustration. I first noticed it in 1.3. This is one of the reasons I updated. I will hopefully have time to open KSP tonight and see if my joystick is the problem. 

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.