Jump to content

[1.9.x] Action Groups ReExtended: 250 Action Groups, in-flight editing.


Recommended Posts

Thanks for the infos :)

@linuxgurugamer I think the "problem" comes from the fact that my VAB in career is only lvl 2 (so I have only access to basic AGs) ... I just tested your mod in sandbox and it works perfectly well (same installation with all of my other mods). What I didn't understant is the fact that I'm able to define custom1 to custom0 with the stock AGs system as you can see in my previous post and that does not reflect in AGX ... but it is probably another mod that allows to do that, and AGX is only taking in account the fact that only basic actions are allowed ;)

So "problem" solved.

LKS

Link to post
Share on other sites
4 hours ago, LukeStrike said:

Thanks for the infos :)

@linuxgurugamer I think the "problem" comes from the fact that my VAB in career is only lvl 2 (so I have only access to basic AGs) ... I just tested your mod in sandbox and it works perfectly well (same installation with all of my other mods). What I didn't understant is the fact that I'm able to define custom1 to custom0 with the stock AGs system as you can see in my previous post and that does not reflect in AGX ... but it is probably another mod that allows to do that, and AGX is only taking in account the fact that only basic actions are allowed ;)

So "problem" solved.

LKS

Hi LKS, if i remember correctly, there is a option in KSP which allowed you to unlock the access to AG (stock and mod) when in carreer mode. It may help.

Link to post
Share on other sites
22 hours ago, LukeStrike said:

Hi @linuxgurugamer

This mod doesn't work for me ... lot of UI elements such as choosing your group, naming it etc just don't appear as you can see here: https://imgur.com/a/ItJHvyT

I'm in KSP 1.8.1 and not using other "actions groups" mods ...

LKS

 

Hi, the AGX dialogs in the screenshot you posted looks like what I would expect to see when you've unlocked "basic" action groups (first VAB upgrade) but haven't yet unlocked "custom" action groups (second VAB upgrade). The Abort group shown in the picture has fewer editable options than the numbered custom groups.

What does look wrong in the picture (and when I did a quick test myself) is that the stock action groups panel is showing custom groups available when they shouldn't be.

I normally don't see this since I enable the "Always allow action groups" option on the difficulty settings advanced whenever I start a new career save.

Link to post
Share on other sites
  • 4 weeks later...

Hey Linux loved your mods and what you do for the community. Quick question, I am trying to lower my mod usage (I am a mod junky) and was wondering what the performance hit, if any was on on this mod?

 

Thanks!

Link to post
Share on other sites
20 hours ago, KIMCHI said:

Hey Linux loved your mods and what you do for the community. Quick question, I am trying to lower my mod usage (I am a mod junky) and was wondering what the performance hit, if any was on on this mod

No idea, sorry.  I don't use it

Link to post
Share on other sites
On 6/15/2020 at 8:38 PM, KIMCHI said:

Hey Linux loved your mods and what you do for the community. Quick question, I am trying to lower my mod usage (I am a mod junky) and was wondering what the performance hit, if any was on on this mod?

 

I use this mod quite a bit, and see very little performance hit.  I see bigger hits from many of the science mods.

Az

Link to post
Share on other sites
  • 2 months later...
10 minutes ago, ss8913 said:

is this mod still being actively maintained?  It "works" in 1.10.1 but has a few issues, wondering if it's still slated to be updated or if I should find a new action group mod?

Other than not supporting the new Axis groups, what issues  are you having?

On 6/19/2020 at 8:13 PM, Jesusthebird said:

Is there a big different in this and the AGM renewed mod(aside the adding 250 action groups)??

No

Link to post
Share on other sites
2 hours ago, linuxgurugamer said:

Other than not supporting the new Axis groups, what issues  are you having?

No

every action group that I press, double actuates it.  ie if i have 0 bound to cabin lights, pressing 0 will turn them on and immediately back off.  pushing a button to 'increase flap deflection' will go from 0 to 2, instead of 0 to 1, etc.  this is new behavior with 1.10.x, worked fine in 1.9.1.

Link to post
Share on other sites
3 hours ago, ss8913 said:

every action group that I press, double actuates it.  ie if i have 0 bound to cabin lights, pressing 0 will turn them on and immediately back off.  pushing a button to 'increase flap deflection' will go from 0 to 2, instead of 0 to 1, etc.  this is new behavior with 1.10.x, worked fine in 1.9.1.

First I've heard of this.  Not sure when  I can look at it, but it's on my list.  For now, try Action Group Manager, that's the only other mod which controls action groups that I know of

Link to post
Share on other sites
3 hours ago, ss8913 said:

every action group that I press, double actuates it.  ie if i have 0 bound to cabin lights, pressing 0 will turn them on and immediately back off.  pushing a button to 'increase flap deflection' will go from 0 to 2, instead of 0 to 1, etc.  this is new behavior with 1.10.x, worked fine in 1.9.1.

Sounds like it is acting on both the keydown and key up, I'll take a look tomorrow

Link to post
Share on other sites
  • 3 weeks later...

I love this mod!  So grateful that you picked it up @linuxgurugamer.  I've always had a problem though and I suspect it's either user error or the nature of the beast.  I lose my names on the actions after docking with another vessel that has named AGX actions defined.  As an example, I have a space plane with 9 actions defined with names and a detachable probe attached to it that has 1 action defined.  I put the plane's actions in 1-9 and the probe's action in 20 (it was designed and saved in VAB, then merged to the spaceplane).  On launch, all the actions show up correctly.  After attaining orbit if I undock the probe and redock it then all of the action names on the space plane are blank.  This is just one example.  I have the same issue with, for another example, a rover lander and rover which have separate actions defined with names that get lost after docking.

I hope I explained the issue clearly.  I was wondering... is there is a method I could use for defining the actions that won't cause this issue, or is this perhaps just a limitation of the way things work?

Edited by DoubleUU
Link to post
Share on other sites
3 hours ago, DoubleUU said:

I love this mod!  So grateful that you picked it up @linuxgurugamer.  I've always had a problem though and I suspect it's either user error or the nature of the beast.  I lose my names on the actions after docking with another vessel that has named AGX actions defined.  As an example, I have a space plane with 9 actions defined with names and a detachable probe attached to it that has 1 action defined.  I put the plane's actions in 1-9 and the probe's action in 20 (it was designed and saved in VAB, then merged to the spaceplane).  On launch, all the actions show up correctly.  After attaining orbit if I undock the probe and redock it then all of the action names on the space plane are blank.  This is just one example.  I have the same issue with, for another example, a rover lander and rover which have separate actions defined with names that get lost after docking.

I hope I explained the issue clearly.  I was wondering... is there is a method I could use for defining the actions that won't cause this issue, or is this perhaps just a limitation of the way things work?

Nature of the beast, would be a lot of work to fix, and I'm only maintaining it

Sorry

Link to post
Share on other sites
1 minute ago, linuxgurugamer said:

Nature of the beast, would be a lot of work to fix, and I'm only maintaining it

Sorry

No worries at all.  Never thought to ask about it before since I rarely created craft that triggered the issue.  Been doing that more lately so I figured I'd see if I was just doing something stupid.  Thanks for getting back to me so fast.

Link to post
Share on other sites
  • 1 month later...

I am experiencing the same double-press weirdness as ss8913. I "solved" it via the keybinding setting, though I don't understand how it works- in the keys menu (showing the full list) there are two blocks labeled "None" in the top left (next to "Clear Key") If you click either of these you'll get a little (1) or (2) next to the displayed keybinding, which appears to stop the doublepressing. Again, I don't understand why it works, but it works.

It does seem to revert after any "change of control" of the vessel, be that quicksave or EVA, but is repeatably fixed upon selecting the "None" button

Link to post
Share on other sites
  • 3 months later...

I also had the double-press weirdness, and solved it the same way as WindupHero7, above. 

I'd also like to add my vote for (some) of the functionality this mod offers. But it is showing it's age. LGG, maybe it is now more work to maintain than to start a new mod?

Like myself, seems most ppl just really like having a configurable, named button on screen for their action groups, one that can be made to change colour if toggled. While the 250 action groups and being able to assign any key is nice (I guess) its not really needed. And the rest of the mods functionality I neither understand or use and I suspect most of it no longer works either it's just no-one uses that stuff so it's not being reported.

If it in anyway counts, my vote is for a sleek new mod that simply puts a movable button on the screen that I can label, make it's colour togglable (on/off, raised/lowered, staged/not staged, etc) and, of course, it activates an action group, even if it's just one of the  built-in 10 (or 50 with new axis groups).

Or else maybe an update to AGM to include these features? AGM with labelled buttons in flight?

I would write the mod myself except that I don't know any C#, Unity or the KSP API, and for now using this mod, despite it's quirks, is less effort than learning all that other stuff.

 

BTW LGG, just started watching your steam on occasion and really enjoying it. Though seeing you in person ruined changed the imagined version of you. You kinda look ordinary vs the heroic image I had based solely on your KSP mod work. Just saying.....

For anyone else interested in seeing the real LGG...

https://www.twitch.tv/linuxgurugamer

 

Link to post
Share on other sites

Nothing too specific, just kind of a nebulous concept that kinda looks like a multi-limbed "Bond" aged Sean Connery or maybe a Dr Strange Cumberbatch, floating in the void, surrounded by computer monitors, simultaneously typing on two keyboards while studying a third screen and, somehow, also drinking coffee and reading a tech manual. Oh, and of course has the 3d printer going in the background.

Occasionally, he will look down, smile patiently, and deliver sage words of wisdom and advice to those who are trying to get their heavily modded KSP to work without crashing.

I'm sure I'm not alone in this.....am I?

TBH, didn't really think about it too much, was just surprised and a little disappointed that you looked so much like me.

Edited by Coyote21
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...