Shadowmage

[1.7.x] Textures Unlimited - PBR-Shader, Texture Set, and Model Loading API

Recommended Posts

5 minutes ago, Gordon Dry said:

What could this be?

 

IDK -- seems pretty well explained from the bit that TU sent to the log:

ERROR: KSPShaderLoader - Texture could not be located for name: TexturesUnlimited_NSS/Textures/silver for texture slot: _MetallicGlossMap while loading textures for material:

means that you tried to reference a texture that doesn't exist.  Fix your texture reference, and the error will go away.

Share this post


Link to post
Share on other sites
4 minutes ago, Gordon Dry said:

It's not "my texture reference" ... :D@linuxgurugamer

Then why are you bugging me?  I don't offer support to random people for configs.  If a mod author has an issue, let him bring it up.

Trying to get yourself involved is likely to only cause problems.

Share this post


Link to post
Share on other sites
1 minute ago, Shadowmage said:

Then why are you bugging me?  I don't offer support to random people for configs.  If a mod author has an issue, let him bring it up.

Trying to get yourself involved is likely to only cause problems.

@ShadowmageSorry about that, too. Just was trying to fix my mod install! :D

Edited by Moofrog

Share this post


Link to post
Share on other sites

So I have Unofficial Patch, TURD  and TU installed. For some reason the metallic shinyness/glossyness from the probe cores are missing.

Am I missing something? Sorry to bother again.

Share this post


Link to post
Share on other sites
13 minutes ago, Moofrog said:

So I have Unofficial Patch, TURD  and TU installed. For some reason the metallic shinyness/glossyness from the probe cores are missing.

Am I missing something? Sorry to bother again.

TURD has not been updated for the new models/textures yet, so you'll have to remove those parts from the TURD configs.

Edited by Electrocutor

Share this post


Link to post
Share on other sites

Nevermind. Thats stock behaviour. The shinyness was only ever a small glint.

50 minutes ago, Electrocutor said:

TURD has not been updated for the new models/textures yet, so you'll have to remove those parts from the TURD configs.

Also noticed when I installed Near Future Spacecraft with Patches to convert Stock Parts to look conforming that the Cupola Module looks messed up as well. Cheers. :)

Share this post


Link to post
Share on other sites
2 minutes ago, Moofrog said:

Nevermind. Thats stock behaviour. The shinyness was only ever a small glint.

Also noticed when I installed Near Future Spacecraft with Patches to convert Stock Parts to look conforming that the Cupola Module looks messed up as well. Cheers. :)

He has an MM patch for that if you read his forum thread. This thread is for TU itself.

Share this post


Link to post
Share on other sites
1 minute ago, Electrocutor said:

He has an MM patch for that if you read his forum thread. This thread is for TU itself.

Sorry must have missed it as I only installed it via ckan. My bad.

Share this post


Link to post
Share on other sites

@Electrocutor So how would I go about adding TU/TURD configs to mods? What do I have to do? Is there some kind of documentation/tutorial? I saw you make one for ProceduralFairings ;)

Share this post


Link to post
Share on other sites
Just now, Moofrog said:

@Electrocutor So how would I go about adding TU/TURD configs to mods? What do I have to do? Is there some kind of documentation/tutorial? I saw you make one for ProceduralFairings ;)

You can look at this thread and the wiki on the TU github. There's many ways to accomplish it: the easiest is if the author wants to implement it since they have the original uvmaps though.

If you hit a spot, just post what you have and what is not working.

Share this post


Link to post
Share on other sites
7 minutes ago, skyhawkmlt said:

is this working with the newest version? I seem to be having trouble getting it to work

this plugin which is the core of it yes. But you also need configs and some are outdated. But it works nevertheless on more than half the parts I use. I am talking about recolour Depot and waiting for sstu update also.

Share this post


Link to post
Share on other sites
Just now, Agustin said:

this plugin which is the core of it yes. But you also need configs and some are outdated. But it works nevertheless on more than half the parts I use. I am talking about recolour Depot and waiting for sstu update also.

what about stock parts config?

Share this post


Link to post
Share on other sites

tht is the recolour depot itself. It just doesn't work for the new parts that were introduced in 1.5
I am using it nonetheless

Share this post


Link to post
Share on other sites

So... Ever since the last Windows Update, -force-opengl and -force-glcore have been crashing on me regularly; so I'm going to have to downgrade -force-glcore from the most stable to unstable.

Share this post


Link to post
Share on other sites
On 11/16/2018 at 6:30 PM, Electrocutor said:

So... Ever since the last Windows Update, -force-opengl and -force-glcore have been crashing on me regularly; so I'm going to have to downgrade -force-glcore from the most stable to unstable.

Interesting...  it started crashing on startup for me here and there as well recently -- right when trying to load a save game from the main menu; but not 100% of the time either.  Wonder if there is a graphics driver that needs updated as well, or something KSP or mod specific?  I didn't really investigate much.

DX11 seems to work fine though; I'm not seeing any of the issues that used to be present in older KSP versions.  Will likely make the move to have it be the recommended version in the OP (for Windows anyhow).

Share this post


Link to post
Share on other sites
31 minutes ago, Shadowmage said:

Interesting...  it started crashing on startup for me here and there as well recently -- right when trying to load a save game from the main menu; but not 100% of the time either.  Wonder if there is a graphics driver that needs updated as well, or something KSP or mod specific?  I didn't really investigate much.

DX11 seems to work fine though; I'm not seeing any of the issues that used to be present in older KSP versions.  Will likely make the move to have it be the recommended version in the OP (for Windows anyhow).

It's not mod related. It happens even on a completely fresh/clean stock install. I've also had OpenGL crashing in other programs now too, so it's not specific to KSP.

I tried installing the newest NVidia driver, but that didn't help.

For reflections, dx11 is preferable anyway if you could fix those two sides so they look right. Oddly enough, I do not have that issue with my skybox with reflection probe: it works across all 4 rendering APIs the same, so not sure what is causing it for you.

----

As a matter of note: I'm working on creating a normal-generator in-game, so that at scene load if any Part, Terrain, or Scenery texture does not have a bump, it auto-creates a fake one. It's not ideal, but DRAMATICALLY makes everything look better except for a few places where the diffuse RGB average is not suitable for defining height.

Edited by Electrocutor

Share this post


Link to post
Share on other sites
9 minutes ago, alexus said:

Shadowmage, hello.

Can you make light reflection like at pic?

l-Heco-IUJMVQ.jpg

I'm guessing you are referring to how the light is reflecting off of the top of the craft, highlighting the multiple lights used in the scene.  If you model the hangar, and the aircraft, and texture it all properly, then yes, TU's shaders should give nearly identical results to what you see in that image.  Caveat:  It will be a ton of work to do that modeling/texturing.

TLDR:  ^^^ is exactly what TU's shaders doIf you use them properly, which almost nobody has so far; the one exception I can think of, where someone is actually using the PBR shaders to their fullest, is @vossiewulf's Fintech mod --

 

 

Share this post


Link to post
Share on other sites

Would it be possible to apply a PBR a shader to, let's say, the moon? (i'm speaking of the ground texture)

And  by PBR, i only mean a decent normal, color and maybe bump map. The vanilla textures, and even the modded ones lack that and it really looks bad. I am no modder and tbh i don't know much about texturing.. Just being curious.

 

Just realized that while waching a Simple Rockets 2 video: https://imgur.com/a/ZJbJBV0

Share this post


Link to post
Share on other sites
On 12/5/2018 at 1:36 AM, Cementruck said:

Would it be possible to apply a PBR a shader to, let's say, the moon? (i'm speaking of the ground texture)

And  by PBR, i only mean a decent normal, color and maybe bump map. The vanilla textures, and even the modded ones lack that and it really looks bad. I am no modder and tbh i don't know much about texturing.. Just being curious.

 

Just realized that while waching a Simple Rockets 2 video: https://imgur.com/a/ZJbJBV0

Its an interesting question.  Really, I'm not sure if it would work or not;  the shaders themselves are capable, but I'm not sure if the stock terrain shaders do anything special (and don't have source access to those), so I couldn't guarantee 100% compatibility.

I've certainly messed with the physics materials on the terrain without issue (for KSPWheel functions), but I've never attempted adjusting the regular MeshRenderer materials or swapping shaders.  For someone with coding experience and access to the TU source code, should only take a few minutes to investigate if it would be viable.

However, even if the shaders do work for the stock terrain -- it still won't solve the problem of the terrible textures  -- someone would still need to create the new textures, and then find the proper way to replace them for the various planets/terrain types.

Share this post


Link to post
Share on other sites

@Shadowmage out of curiosity: Is there anything noteworthy that happened to the atmospheric scattering since you last mentioned it?

Share this post


Link to post
Share on other sites
29 minutes ago, Delay said:

@Shadowmage out of curiosity: Is there anything noteworthy that happened to the atmospheric scattering since you last mentioned it?

Life has been happening :)  (keeping me busy / busier than I would like)

I actually did quite a bit of work on getting the Bruneton's Improved Atmosphere working as a general post-process effect.  Was working fairly well when I last played with it (at least in the Unity editor); next steps would be to do some testing on setting it up and using it from within KSP.  Next would be allowing for parameter specification, and then adapting it to properly handle all of the edge-cases that KSP would present.

Currently I would say the status is 'on hold', pending seeing how much Blackrack cleans up Scatterer itself.  If Scatterer can be made to stop messing with the rendering routines and screwing up cubemap/reflection captures, I'de much prefer to just use it rather than making something new with the same features.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.