Jump to content

[1.9.x] Textures Unlimited - PBR-Shader, Texture Set, and Model Loading API


Shadowmage
 Share

Recommended Posts

[AddonLoader]: Instantiating addon 'TexturesUnlimitedDebug' from assembly 'TexturesUnlimited'
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Uploading Crash Report
NullReferenceException: Object reference not set to an instance of an object
  at KSP.UI.Screens.ApplicationLauncher.RemoveModApplication (KSP.UI.Screens.ApplicationLauncherButton button) [0x00029] in <cd473063d3a2482f8d93d388d0c95035>:0
  at KSPShaderTools.Addon.TexturesUnlimitedDebug.Awake () [0x000b9] in <d05d146f0f32458d9a30cf17e61f35a8>:0
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)
UnityEngine.GameObject:Internal_AddComponentWithType(Type)
UnityEngine.GameObject:AddComponent(Type)
AddonLoader:StartAddon(LoadedAssembly, Type, KSPAddon, Startup)
AddonLoader:StartAddons(Startup)
AddonLoader:OnLevelLoaded(GameScenes)
AddonLoader:OnSceneLoaded(Scene, LoadSceneMode)
UnityEngine.SceneManagement.SceneManager:Internal_SceneLoaded(Scene, LoadSceneMode)

Textures unlimited throws this up in the log file when I place the "LV-T91 Cheetah" engine"

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...
On 12/9/2021 at 5:37 AM, Grunf911 said:

Hi,

I have the following issue with James Webb.

When i build it in VAB, all looks good, however when i take it out the mirror and all else is black. Here is what it looks like:

 

 

You could have reflections turned off in the game settings or you may need planetshine to make it look how you think it should.

Link to comment
Share on other sites

  • 2 months later...
On 8/1/2021 at 7:58 AM, Bob’sCousin said:

So I installed this mod and Procedural Parts, and I encountered a problem, the paint will work in the VAB/Hanger however when you launch it disappears 

  Hide contents

KmYIPxI.png

  Hide contents

vNmGZru.png

 

Did you find a workaround? This one is frustrating to track down and I'm not having much luck. 

Link to comment
Share on other sites

  • 2 months later...

Sorry if this has been asked time and time again, i'm newly back to KSP heavy modding and its hard to keep track of which mods / addons are updated and which are 3 years old and shouldnt even be attempted :D

I'm of course running Textures Unlimited, and this Recolor mod.
Now, i'm looking for where i can find compatible recolors for the NearFutureTech mods (liquid hydrogen/methane engines, the other parts), as well as some fuel tanks that i *think* are stock but arent supported in this recolor (the fuel adapters and the mid-sized tanks).

I'm running these versions;
TexturesUnlimited-1.5.10.25
TU_Stock Recolour_v0_3_10
TU_pWingsB9_v0_1_0

I'm looking for recolor mods for these;
NearFuture (all packs)
FarFutureTechnologies_1_2_0
SCANsat-v20.4
Pathfinder-1.38.0
KerbalAtomics_1_3_3
DMagic_Orbital_Science-1.4.3

Do those exist or is it just a case of, nobody has put in the work on making those mods compatible yet (understandable given the amount)?
Thanks, sorry for just splashing a big list, ive searched in google but found very sporadic extremely old / incomplete packs. 

Link to comment
Share on other sites

  • 1 month later...
  • 3 weeks later...

h i there ,

i have a little visual problem with the control surfaces when its shape is set to "rounded". see picture https://1drv.ms/u/s!Am0PDmGqv17_hKpdF2TZHArDG0HCdw?e=vTQLhv

and i can't even recolor it.

any idea how to fix that?

my latest  logs are available here => https://1drv.ms/u/s!Am0PDmGqv17_hKpOqPRyuaODwZc86w?e=nYPNsn

greets

Link to comment
Share on other sites

I noticed that with this mod installed, the stock "silver" fairing texture looks broken; it looks like dull plain steel instead of shiny silver.

Link to comment
Share on other sites

  • 3 weeks later...
  • 3 weeks later...

I've been trying to figure out why this is happening but whenever I have this mod installed, all of my stock command pods and cockpits windows become opaque in IVA, which makes IVA much less playable than I'd like. I've been able to definitively isolate it to TexturesUnlimited but I'm not willing to just remove the mod, I'd like to, if possible, figure out how to fix the windows but keep TU installed. Thanks in advance for anyone who knows what steps I should start to take. Here's an example image to describe what I'm experiencing, this is the Cupola module facing upwards on the launchpad at midday.

Link to comment
Share on other sites

10 hours ago, devoured.by.incandescence said:

I've been trying to figure out why this is happening but whenever I have this mod installed, all of my stock command pods and cockpits windows become opaque in IVA, which makes IVA much less playable than I'd like. I've been able to definitively isolate it to TexturesUnlimited but I'm not willing to just remove the mod, I'd like to, if possible, figure out how to fix the windows but keep TU installed. Thanks in advance for anyone who knows what steps I should start to take. Here's an example image to describe what I'm experiencing, this is the Cupola module facing upwards on the launchpad at midday.

Can you post your modlist please? It's probably a problem with another mod.

Link to comment
Share on other sites

10 hours ago, devoured.by.incandescence said:

I've been trying to figure out why this is happening but whenever I have this mod installed, all of my stock command pods and cockpits windows become opaque in IVA, which makes IVA much less playable than I'd like. I've been able to definitively isolate it to TexturesUnlimited but I'm not willing to just remove the mod, I'd like to, if possible, figure out how to fix the windows but keep TU installed. Thanks in advance for anyone who knows what steps I should start to take. Here's an example image to describe what I'm experiencing, this is the Cupola module facing upwards on the launchpad at midday.

Check you TU cfg/s and comment the entries that have "internal" or "spaces" in them, for example

// model = Squad/Spaces/Mk2CrewCabinInternal/MK2_CrewCab_Int

Hope this helps

Link to comment
Share on other sites

  • 2 months later...

I used to have the shiny textures.

now, it doesn't work.

I also never had the option to change the colors of items.

I deleted all my mods awhile back since i had so many that I didn't use. I then, redownloaded TU and it doesn't work anymore.. I've tried uninstalling and reinstalling and still hasn't worked in months. 

 

 

could someone help.. PLEASE :(

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...