Jump to content
  • 1

Fun with subassemblies


Starchaser
 Share

Question

I admit to being mystified by subassemblies and how they work. I barely use them because it seems like every time I think "I'm going to use this combination a lot" the game won't let me save it.

Case in point.

iz0M4WB.jpg

My science probe. There's an octo2 in there, a couple oscar tanks, a spark, batteries, panels, antennae and 2 scanners and 3 or 4 other sciency parts.

For 2 contracts I just received, I need to replicate this 4 times.Sounds perfect for a subassembly....but....

FWV0z4H.jpg

 

It says it's not attachable.

However, note in my subassembly list "Biome Probe"....

qz5pPyo.jpg

It's the same basic concept with less parts. WTH?

 

Link to comment
Share on other sites

5 answers to this question

Recommended Posts

  • 4

Main rule is: the subassembly needs to be 'attachable' according to the game rules. Iow, the root part of the subassembly needs to be either surface attachable, or has to have an open stack node.

  • Contrary to what @Magzimum says, this can in fact include the root part too, the entire craft you build, as long as the above applies.
  • Another interesting detail: due to the above rule, one can create a subassembly with a root part that would normally not be accepted as a root part (ie. that cannot be placed as the very first part, like most surface attachable parts). The game only cares about it being attachable somehow.

Quick test to prove the above: place an octo probe core, attach any other part(s) to it - but leave either the top or bottom node of the core open. Now grab the probe core and you'll see that the entire craft can be dropped as a subassembly. However, if you use both the top and bottom stack nodes for other parts, and grab the probe core now... no dice, no subassembly allowed.

If you have a set of parts that you wish to save as subassembly, and somehow it won't save, it can usually be solved by using the re-root gizmo, and picking as root any other part of the set that still has either an open stack node or is surface attachable. Of course this may not attach as logical/pretty as one would wish, which is why you should always build a subassembly with the main rule in mind.

Edited by swjr-swis
simple is better
Link to comment
Share on other sites

  • 0

A ship has a "Root" part. That root part cannot be part of the subassembly. So, in other words, you can only save a subassembly of the ship, not the whole ship - even if you plan to make that a sub-part of a future ship.

 

The solution is that you attach 1 extra part, and make that the root. I typically take a fuel tank. Then press "4" to change the Root part of the ship, and make that tank the root part. Now, you can disconnect that entire subassembly from the tank, and save it as a subassembly.

NOTE: Your subassembly can now only be attached to the new ship at the point where it was attached to that tank. So, in your case, if you want to attach it by the engine, then put the new tank (the new root part) on the engine. If you want to attach it by the top, then attach the tank to the top.

Link to comment
Share on other sites

  • 0

Make good use of root tool (which works for inactive part tree as well), and shift click (which can tear apart inactive part tree). Anything that inactive parts can't attach - you go with the previous two methods.

Subassembly is a management nightmare. Subassembly itself is stored per-save, but the categorization is stored globally (for each game). Every time you want to move stuff across game installs, or you move around the sandbox/career save for whatever reason, something is going to screwed up. So I use Merge craft exclusively, with the two methods above. Works just how it should work for me.

Link to comment
Share on other sites

  • 0

I am unfamiliar with the merge craft function....

The root part explains why the biome probe was able to be saved. I made that little probe to piggyback on top of a mun lander, so I already had a pad in place, and built the probe from the engine up, so the game must have made the engine the root part. Anyway I had solved my issue by taking some of the biome probe off and adding what I needed to have it be like my science probe and then resaving it under a new name. But thanks for showing me what I was doing wrong

Link to comment
Share on other sites

  • 0

I think it all boils down to what was the first part used when designing the whole thing. If you start your design with a conical nose,  and then start adding things below it,  you wont be able to select that nose (and all below it) and save it as a sub assembly - simply because that nose can't be attached 'under' anything. Not if it does not have a free attachment node.

Well, thats what everyody said above,  I know.

My idea on how to circumvent the problem is this:  whenever you start building anything that is meant to be a subassembly,  make the first part a decoupler,  separator,  structural node or, for that matter,  anything that can attach to parts both BELOW and ABOVE it,  and then develop your subassembly BELOW it. Then save it as a subassembly. When you select it,  it will be a valid subassembly,  since it will have a valid and free attachment node above it.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...