Jump to content
  • 1

Docking ports problem


oglommi
 Share

Question

So I recently started a new kerbal game after a lengthy pause from playing KSP.

Getting the docking ports to grab each other seems to horrible difficult now. Manual docking of mechjeb docking don't seem to matter. The docking ports are kissing each other but don't want to connect. Changing to another docking port and other forms of trickery don't help.

Is there an issue with ksp 1.31 and docking or is it just my game?

Link to comment
Share on other sites

10 answers to this question

Recommended Posts

  • 2
4 hours ago, Rocket In My Pocket said:

Perhaps this is a silly question, but both the docking ports are facing the right way yeah?

Yes and it is a problem with multiple ships

 

4 hours ago, swjr-swis said:

Mods can change 'stock' parts to behave radically different from stock even when they still look the same, and sometimes add unintended side-effects or bugs of their own, so a bit more information about your mod list might be crucial to finding out what's happening.

Do you happen to have a mod loaded that patches docking ports to only engage when they are at specific rotation angles relative to each other (eg. 0, 90, 180, 270 degrees), or that makes docking ports gendered, such that some ports are 'male' and others 'female' and only mixed-gender couplings work? These are relatively recent features added to the stock docking port code, that are normally not enabled in stock, but can be enabled by module manager patches. Some realism-enhancing mods add that sort of patches; also part mods sometimes make the stock ports behave like the modded ports they add. You could test if this is the issue by trying to get your crafts rotated such that the docking ports are aligned.

 

 

Thank you for answering. I think it is a tweakscale issue as the docking ports where attached straight onto fueltanks that were tweakscaled up. Seems to be working fine when im not using spaceship with tweakscaled parts.

Link to comment
Share on other sites

  • 0

Sounds like a stuck port to me. Have you undocked (one of) the ports previously? In that case they de-activate in oder to not immediately grab the port they've just been undocked from. They're supposed to become ready again once their previous dockee has been moved sufficiently far away (a few meters), but sometimes this doesn't happen.

In the old days, one had to edit the savegame in order to fix this, but I think there's now a mod for that.

Link to comment
Share on other sites

  • 0
26 minutes ago, oglommi said:

So I recently started a new kerbal game after a lengthy pause from playing KSP.

Getting the docking ports to grab each other seems to horrible difficult now. Manual docking of mechjeb docking don't seem to matter. The docking ports are kissing each other but don't want to connect. Changing to another docking port and other forms of trickery don't help.

Is there an issue with ksp 1.31 and docking or is it just my game?

I've had no problems using the (stock) docking ports in 1.3.1. So there must be something causing your troubles. Make sure the docking port size matches; you can't mix port sizes.

You give very little information to help diagnose the issue though. You mention KSP 1.3.1. What OS do you run it on? Are you using mods? Can you explain a bit how you are trying to dock? Do you notice the magnetic attraction when the ports come close together, or is that absent too? Do you have pics of the crafts you are trying to dock together, or (better) a download of the craft/save files so we can try reproduce it too?

Link to comment
Share on other sites

  • 0

Is SAS activated on any of the craft, both? Sometimes the reaction control will fix the attitude into one direction that the docking port magnets are unable to overcome. The magnetic mechanism needs to attract a docking port and get both ends to attach flat bottom to bottom. To much SAS can fix the angle of both docking ports with only a few degrees, and it will stay there unable to dock unless you do something to correct it.

So if SAS is turned on, disengage it and try again.
Something can also clip through the docking port on any of both vessels. This may also prevent docking.  
 

Link to comment
Share on other sites

  • 0
1 hour ago, swjr-swis said:

I've had no problems using the (stock) docking ports in 1.3.1. So there must be something causing your troubles. Make sure the docking port size matches; you can't mix port sizes.

You give very little information to help diagnose the issue though. You mention KSP 1.3.1. What OS do you run it on? Are you using mods? Can you explain a bit how you are trying to dock? Do you notice the magnetic attraction when the ports come close together, or is that absent too? Do you have pics of the crafts you are trying to dock together, or (better) a download of the craft/save files so we can try reproduce it too?

Yes the docking ports are the same size.  I've docked a million times before on earlier ksp versions. But for some reasons they don't want to connect now. I'm using win 7. I got loads of mods but the docking ports are stock.

Anyway thank you for answering.

19 minutes ago, Helmetman said:

Is SAS activated on any of the craft, both? Sometimes the reaction control will fix the attitude into one direction that the docking port magnets are unable to overcome. The magnetic mechanism needs to attract a docking port and get both ends to attach flat bottom to bottom. To much SAS can fix the angle of both docking ports with only a few degrees, and it will stay there unable to dock unless you do something to correct it.

So if SAS is turned on, disengage it and try again.
Something can also clip through the docking port on any of both vessels. This may also prevent docking.  
 

When i dock manually i turn on SAS, when mechjeb does it I don't think the SAS is on. Maybe there is a weight issue since there is small ships docking to huge refuelers.

Thank you for answering.

Link to comment
Share on other sites

  • 0
23 minutes ago, oglommi said:

I got loads of mods but the docking ports are stock.

Mods can change 'stock' parts to behave radically different from stock even when they still look the same, and sometimes add unintended side-effects or bugs of their own, so a bit more information about your mod list might be crucial to finding out what's happening.

Do you happen to have a mod loaded that patches docking ports to only engage when they are at specific rotation angles relative to each other (eg. 0, 90, 180, 270 degrees), or that makes docking ports gendered, such that some ports are 'male' and others 'female' and only mixed-gender couplings work? These are relatively recent features added to the stock docking port code, that are normally not enabled in stock, but can be enabled by module manager patches. Some realism-enhancing mods add that sort of patches; also part mods sometimes make the stock ports behave like the modded ports they add. You could test if this is the issue by trying to get your crafts rotated such that the docking ports are aligned.

 

Link to comment
Share on other sites

  • 0
3 hours ago, oglommi said:

Thank you for answering. I think it is a tweakscale issue as the docking ports where attached straight onto fueltanks that were tweakscaled up. Seems to be working fine when im not using spaceship with tweakscaled parts.

Good to see you found a workaround. Now that you have found the possible source of the issue, you might want to report it in the Tweakscale thread.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...