linuxgurugamer

[1.4.4] Now in BETA - Interstellar Flight Inc. Life Support - Full release

Recommended Posts

On 1/18/2018 at 2:32 PM, linuxgurugamer said:

If you just added the CTT after you started the game, you might be out of luck.  I'm not sure, but I think there is an issue when you do that.

Also, I need to see your log file.

OK Hydroponics only includes the Garden in a Can Greenhouse and the Greenhouse: Expand-O-Matic. Seems like I'll have to start a new game. 

Thanks for the help!

Edited by breakthesystem
Forgot to be polite.

Share this post


Link to post
Share on other sites

I believe there is an issue when you time warp to fast. The Organic Slurry doesn't get properly processed when above x 1000.

I just time warped a save at different speed and under x 1000 there was no Slurry left, at x 10 000, 0.64 Slurry was left. The only thing difference was the time warp speed.

Share this post


Link to post
Share on other sites
2 hours ago, Keldion said:

I believe there is an issue when you time warp to fast. The Organic Slurry doesn't get properly processed when above x 1000.

I just time warped a save at different speed and under x 1000 there was no Slurry left, at x 10 000, 0.64 Slurry was left. The only thing difference was the time warp speed.

The sounds like a floating point error.

Share this post


Link to post
Share on other sites
4 hours ago, linuxgurugamer said:

The sounds like a floating point error.

Krak-en response. :)

I'll see myself out.

Share this post


Link to post
Share on other sites

Something else :-\ It doesn't look like things are calculated properly in the other vessels when I time warp. If I timewarp at x 1000 everything seems fine in the current vessel, but for the others vessels, it looks like the organic slurry is just throw out the windows and my life support is melting... :-\

I always though that the life support in my station was doing down too fast and didn't undertood why the sludge wasn't accumulating (it supposed to since the aquatic greenhouse isn't currently working). Now I believe that regular greenhouse don't work at all while timewarping away from the vessel. You can time warp in the tracking station and see that 1 life support is being consume per kerbal per day even if the vessel got working greenhouses.

Share this post


Link to post
Share on other sites

I've found the problem with the background processing of the convertors.

This is a test  build, I would appreciate any feedback:

(deleted, working on a new beta)

Assuming no problems, I'll release this on Sunday.

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

New test build, fixed a small bug where the foreground processing wasn't working:

(deleted, new beta released below)

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites

Seems i posted my last reply in a wrong thread, so here goes again:

 

Hi everyone

 

I have a small problem with the mod, just want to check if anyone has seen this before.

I installed the mod yesterday, and my kerbals have lifesupport available and are using it away happily.

However, im missing the parts that comes with the mod?

They dont show up in sandbox parts list, and in career i can unlock them, but they dont show up in the parts list here either?

What gives? Everything else seems to be working?

 

I tried both with a modded and fresh install of KSP x64.

Edited by Conzolax

Share this post


Link to post
Share on other sites
On 2/16/2018 at 4:37 AM, Conzolax said:

Seems i posted my last reply in a wrong thread, so here goes again:

 

Hi everyone

 

I have a small problem with the mod, just want to check if anyone has seen this before.

I installed the mod yesterday, and my kerbals have lifesupport available and are using it away happily.

However, im missing the parts that comes with the mod?

They dont show up in sandbox parts list, and in career i can unlock them, but they dont show up in the parts list here either?

What gives? Everything else seems to be working?

 

I tried both with a modded and fresh install of KSP x64.

How are you installing it?  It requires the following:

  • Community Resource Pack
  • Community Category Kit
  • Module Manager

 

Share this post


Link to post
Share on other sites

I think i got it working.

I believe i had the wrong version, since several seems to be floating around in several threads.

Anyway, thanks.

Share this post


Link to post
Share on other sites

I'm confused by the science experiments.  

The Garden in a Can GreenHouse says "Plant Respiration Study" must be completed in the biome before use.   OK, so there are two experiments unlocked.  

The Biosphere Containment Unit has an experiment called "Observe Plant Life" 

The BSS-G has an experiment called "Perform Experiments" but the description specifically says this will need to be done to use the MicroBiome, BioReactor and Aquatic Greenhouse. 

 

I went back and checked the OP, and it says this.  

Quote
  • The greenhouses need to have the experiment: BSS-1 (Biological Systems Study-1) to be run
  • The AlgaeHouse and BioReactor need the experiment BSS-G (Biological Systems Study-Goo)
  • The BioReactor needs the Biosphere Containment Study experiment run

 

Which doesn't really help that much, maybe I just need more parts unlocked. 

Share this post


Link to post
Share on other sites

I've been doing some tests on my mod install and there seems to be a pretty big overhead that is worse with a vessel with more parts.  With a 200 part ship I get about 55 FPS in the stock game, adding the mod gives me a steady 40FPS.   With a small vessel I don't notice a performance impact. 

Share this post


Link to post
Share on other sites

Im working on an update which should fix this, maybe a week or so

Share this post


Link to post
Share on other sites
On 2/19/2018 at 8:07 PM, eberkain said:

I've been doing some tests on my mod install and there seems to be a pretty big overhead that is worse with a vessel with more parts.  With a 200 part ship I get about 55 FPS in the stock game, adding the mod gives me a steady 40FPS.   With a small vessel I don't notice a performance impact. 

Is it the number of parts, or the number of parts that can contain crew?

And, how are you measuring the FPS?

Could you send me the ship so I can test with it?

 

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites
24 minutes ago, linuxgurugamer said:

Is it the number of parts, or the number of parts that can contain crew?

And, how are you measuring the FPS?

Could you send me the ship so I can test with it?

 

I've been using the kerbo katz utilites to watch FPS and Sim Speed.  The vessel was just several stock craft all docked together in the editor and cheated into orbit, I dont still have the save I was testing with.  I've sense swapped over to a different install and reevaluated my mod list again.  I did not test the difference between crew parts and just parts.  I don't think my test craft had more than a few crew parts.  I will see if I can reproduce easily and set something up to send you. 

Share this post


Link to post
Share on other sites
5 minutes ago, eberkain said:

I've been using the kerbo katz utilites to watch FPS and Sim Speed.  The vessel was just several stock craft all docked together in the editor and cheated into orbit, I dont still have the save I was testing with.  I've sense swapped over to a different install and reevaluated my mod list again.  I did not test the difference between crew parts and just parts.  I don't think my test craft had more than a few crew parts.  I will see if I can reproduce easily and set something up to send you. 

That would be  helpful, but please see the PM I just sent you first

Share this post


Link to post
Share on other sites

Any compatibility with SSPRx, station parts expansion reduX? Lovely mod btw, currently gonna be my main ls mod

Share this post


Link to post
Share on other sites
13 hours ago, The-Doctor said:

Any compatibility with SSPRx, station parts expansion reduX? Lovely mod btw, currently gonna be my main ls mod

Wait a bit, Im working on some bugs

Share this post


Link to post
Share on other sites

Thanks for your work. This mod looks really interesting.

In the original mod thread it says this mod kills the kerbals when the vessel runs out of life support. Is there a way to configure it so kerbals just become tourist until the receive more life support?

Thanks for your answer.

Edit: Just took a look. I see you can choose if they die or not. Thanks

Edited by Elkram

Share this post


Link to post
Share on other sites

@linuxgurugamer thank you for keeping this great mod alive, it has always been my favorite LS mod. You are a true hero of the KSP modding community, is there a way I can donate to your coffee/beer fund? 

Share this post


Link to post
Share on other sites
10 hours ago, nebuchadnezzar said:

@linuxgurugamer thank you for keeping this great mod alive, it has always been my favorite LS mod. You are a true hero of the KSP modding community, is there a way I can donate to your coffee/beer fund? 

Patreon is best:  https://www.patreon.com/linuxgurugamer

 

Share this post


Link to post
Share on other sites

@linuxgurugamer, do you have any new beta of this mod, I've noticed the tanks (LS, sludge and slurry) all seem to store life support...

Although I've downloaded 1.4.2, I'm still playing KSP 1.3.1... :wink:

Share this post


Link to post
Share on other sites
53 minutes ago, jlcarneiro said:

@linuxgurugamer, do you have any new beta of this mod, I've noticed the tanks (LS, sludge and slurry) all seem to store life support...

Although I've downloaded 1.4.2, I'm still playing KSP 1.3.1... :wink:

No updates, and this is going to be one of the last, since there are some bugs I need to fix

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.