BigNose

[1.3.1] Aviation Lights v3.14 [use MOARdV's version instead!]

Recommended Posts

22 minutes ago, Stone Blue said:

Its becuase you ended up with a /GameData/GameData/AviationLights/ folder, instead of ust /GameData/AviationLights/

All the parts .cfgs use the new mesh MODULE, EXCEPT the Red Beacon, which for some reason got missed, and still uses the old mesh = def.

Meaning the new model def is dependent on folder URL/structure.... the OLD mesh def is NOT...

From your log:


(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

AssemblyLoader: Loading assembly at D:\GOG Games\Kerbal Space Program\GameData\GameData\AviationLights\Plugins\AviationLights.dll
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

AssemblyLoader: Loading assemblies
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Non platform assembly: D:\GOG Games\Kerbal Space Program\GameData\GameData\AviationLights\Plugins\AviationLights.dll (this message is harmless)
VesselModules: Found VesselModule of type CommNetVessel with order 999

 

Ok cool it works! Thank you all for your help!

Share this post


Link to post
Share on other sites

@BigNose @MOARdV I've made some time ago a mod that (among others things) turn lights on/off when the sun rise/fall. I like your mod to be compatible with it, the problem is that all your method in "ModuleNavLight" toggle the light, I need a way to turn light on/off not inverse the current state.

I've made a pull request on your github for that. It should be completely transparent on your hand.

The mod in question is Crew Light, the discussion about support for Aviation Lights begin here.

Share this post


Link to post
Share on other sites

@BigNose @MOARdV I've rewrote the way I use PartModule from other mod, I now use reflection instead of the Unity method "SendMessage" so the change I requested earlier is no longer needed.

Please check the new version of CrewLight, beacon light turning on when engine start are really cool :)

 

Share this post


Link to post
Share on other sites

Sweet little mod! Thank you! Although I don't use these lights as designed:) For example, I have red blinking "hazard lights" when my drills are enabled or blinking green along ladders. Pretty neat.

Share this post


Link to post
Share on other sites

I just installed it the first time and while in SPH I wanted to toggle the default function of single lights and each attempt throws an exception.

It seems that "it doesn't matter" because the lights work as I set them up but I wanted to mention it anyway:

NullReferenceException: Object reference not set to an instance of an object
  at AviationLights.ModuleNavLight.LightDoubleFlashEvent () [0x00000] in <filename unknown>:0 
  at BaseEvent.Invoke () [0x00000] in <filename unknown>:0 
  at UIPartActionButton.OnClick () [0x00000] in <filename unknown>:0 
  at UnityEngine.Events.InvokableCall.Invoke (System.Object[] args) [0x00000] in <filename unknown>:0 
  at UnityEngine.Events.InvokableCallList.Invoke (System.Object[] parameters) [0x00000] in <filename unknown>:0 
  at UnityEngine.Events.UnityEventBase.Invoke (System.Object[] parameters) [0x00000] in <filename unknown>:0 
  at UnityEngine.Events.UnityEvent.Invoke () [0x00000] in <filename unknown>:0 
  at UnityEngine.UI.Button.Press () [0x00000] in <filename unknown>:0 
  at UnityEngine.UI.Button.OnPointerClick (UnityEngine.EventSystems.PointerEventData eventData) [0x00000] in <filename unknown>:0 
  at UnityEngine.EventSystems.ExecuteEvents.Execute (IPointerClickHandler handler, UnityEngine.EventSystems.BaseEventData eventData) [0x00000] in <filename unknown>:0 
  at UnityEngine.EventSystems.ExecuteEvents.Execute[IPointerClickHandler] (UnityEngine.GameObject target, UnityEngine.EventSystems.BaseEventData eventData, UnityEngine.EventSystems.EventFunction`1 functor) [0x00000] in <filename unknown>:0 
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
UnityEngine.Logger:LogException(Exception, Object)
UnityEngine.Debug:LogException(Exception)
UnityEngine.EventSystems.ExecuteEvents:Execute(GameObject, BaseEventData, EventFunction`1)
UnityEngine.EventSystems.StandaloneInputModule:ProcessMousePress(MouseButtonEventData)
UnityEngine.EventSystems.StandaloneInputModule:ProcessMouseEvent(Int32)
UnityEngine.EventSystems.StandaloneInputModule:ProcessMouseEvent()
UnityEngine.EventSystems.StandaloneInputModule:Process()
UnityEngine.EventSystems.EventSystem:Update()

 

Share this post


Link to post
Share on other sites
18 hours ago, MOARdV said:

For the 2 or 3 other people still using this mod :) I've updated to KSP 1.3.0, on GitHub.

Thank you so VERY much for the update! this is one of the first after update mods i install. 

Share this post


Link to post
Share on other sites
1 hour ago, Gordon Dry said:

I just installed it the first time and while in SPH I wanted to toggle the default function of single lights and each attempt throws an exception.

It seems that "it doesn't matter" because the lights work as I set them up but I wanted to mention it anyway:

 

So it does.  I'll get that fixed soon.

... And, fixed.  v3.14 fixes the NRE I introduced back in October when setting flash mode to Flash, Double Flash, or Interval in the VAB/SPH.

Edited by MOARdV

Share this post


Link to post
Share on other sites
On 26.5.2017 at 3:30 AM, MOARdV said:

For the 2 or 3 other people still using this mod :) I've updated to KSP 1.3.0, on GitHub.

Thanks a lot @MOARdV ! Loosing a frequently used part mod during a long career game is bad news. So thank you for caring for so many mods to stay alive! =)

 

btw: Although CKAN offers V3.13 currently for KSP 1.2.2, I rolled back to V3.12, as the game kept crashing reliably after I upgraded. Easy to work around, but could be hard to find. =)

 

Cheers!

SchrottBot

Edited by SchrottBot
Well, turning off german spellchecking on an english text would have been better ... =8)

Share this post


Link to post
Share on other sites
1 hour ago, SchrottBot said:

btw: Although CKAN offers V3.13 currently for KSP 1.2.2, I rolled back to V3.12, as the game kept crashing reliably after I upgraded. Easy to work around, but could be hard to find. =)

 

Whoever put it on CKAN marked it incorrectly, then (it wasn't I).  GitHub clearly says v3.13 (and v3.14) is for KSP 1.3.0,

Share this post


Link to post
Share on other sites

Yea, I thought that it came this way. There were quite some mod versions recently installed via CKAN that shouldn't. Maybe I go back to do it all manually. All in all it's less work. =) 

Share this post


Link to post
Share on other sites
On 5/26/2017 at 3:30 AM, MOARdV said:

For the 2 or 3 other people still using this mod :) I've updated to KSP 1.3.0, on GitHub.

A lot more than 2/3 of us still use this mod man, and we appreciate you keeping it alive!

Share this post


Link to post
Share on other sites

I need help figuring out why this mod is crashing my game while it's loading. The game runs fine without this mod but crashes with it installed. Any suggestions or ideas? 

Update: error log says "Read from location 00000010 caused an access violation." Hope the added info helps!

Edited by Kerbal3258
To provide clearer information

Share this post


Link to post
Share on other sites
1 hour ago, Kerbal3258 said:

I need help figuring out why this mod is crashing my game while it's loading. The game runs fine without this mod but crashes with it installed. Any suggestions or ideas? 

Update: error log says "Read from location 00000010 caused an access violation." Hope the added info helps!

How much memory do you have available, and how much are your mods using? Are you playing on 64 bit?

It's possible you're on the limit of your RAM, and this mod is the last straw.

Share this post


Link to post
Share on other sites

It's not a RAM limit.

 

I was having crashes as well. Fresh install, couldn't get the game to fully load with a lot of mods installed. Uninstalled and started adding mods 1 by 1. As soon as I got to Aviation lights(3rd mod) the game would no longer finish loading.

 

Note: I'm running 1.2.2, and the mod is listed as working with 1.3 in CKAN, even when filtered by compatible. I went and downloaded the 1.2.x version and it loads up fine. So the one on CKAN isn't compatible with 1.2.2. If you're trying to use this, go grab an older version.

Share this post


Link to post
Share on other sites

My friend recommended this mod to me and I'm already in love. Thank you for making this!

 

Share this post


Link to post
Share on other sites

@MOARdV I downloaded the latest version from github for ksp 1.3 and i got a little issue with it...

When i am building my rocket and use these lights, i can't switch them on or change the texture.... Only when i am in orbit, the lights do turn on or off...

Everything is installed correctly, so do i seem to be missing something here? What may be the problem?

Edited by renejant

Share this post


Link to post
Share on other sites
1 hour ago, renejant said:

@MOARdV I downloaded the latest version from github for ksp 1.3 and i got a little issue with it...

When i am building my rocket and use these lights, i can't switch them on or change the texture.... Only when i am in orbit, the lights do turn on or off...

Everything is installed correctly, so do i seem to be missing something here? What may be the problem?

How are you trying to switch them on?  Since there are multiple modes available for the lights, they are not added to the Lights action group automatically.  You have to configure them in the VAB before launch.

Share this post


Link to post
Share on other sites
10 hours ago, MOARdV said:

How are you trying to switch them on?  Since there are multiple modes available for the lights, they are not added to the Lights action group automatically.  You have to configure them in the VAB before launch.

In the VAB, i just select the part and right click on them to turn them on, but they won't lit up... While other lights from other mods do work in the VAB... I know i have to set them in the action group and that works well in orbit... but they just won't turn on in the VAB itself... Maybe the mod is missing some line of code?

Share this post


Link to post
Share on other sites
16 hours ago, renejant said:

In the VAB, i just select the part and right click on them to turn them on, but they won't lit up... While other lights from other mods do work in the VAB... I know i have to set them in the action group and that works well in orbit... but they just won't turn on in the VAB itself... Maybe the mod is missing some line of code?

No line of code is missing.  These lights do not light up in the VAB.  You may select modes in the VAB, but the lights do not glow until flight.

Share this post


Link to post
Share on other sites
On 6-7-2017 at 4:46 PM, MOARdV said:

No line of code is missing.  These lights do not light up in the VAB.  You may select modes in the VAB, but the lights do not glow until flight.

hmm i see, but i swear, these lights did work before in the vab... of course it may be a few patches earlier because i haven't been playing this game for quite some time... 

Share this post


Link to post
Share on other sites
1 hour ago, renejant said:

but i swear, these lights did work before in the vab

Nope, these never worked in the VAB I've been using them since they first came out

Share this post


Link to post
Share on other sites
On 10/06/2017 at 5:44 PM, Dortmunder said:

It's not a RAM limit.

 

I was having crashes as well. Fresh install, couldn't get the game to fully load with a lot of mods installed. Uninstalled and started adding mods 1 by 1. As soon as I got to Aviation lights(3rd mod) the game would no longer finish loading.

 

Note: I'm running 1.2.2, and the mod is listed as working with 1.3 in CKAN, even when filtered by compatible. I went and downloaded the 1.2.x version and it loads up fine. So the one on CKAN isn't compatible with 1.2.2. If you're trying to use this, go grab an older version.

 

On 30/05/2017 at 10:51 PM, MOARdV said:

Whoever put it on CKAN marked it incorrectly, then (it wasn't I).  GitHub clearly says v3.13 (and v3.14) is for KSP 1.3.0,

I added an issue for this on CKAN's github - hoping they can fix the metadata: https://github.com/KSP-CKAN/NetKAN/issues/5680

Share this post


Link to post
Share on other sites

Hello! I have downloaded the 3.12 version of Aviation lights. I have also a bunch of other mods. The problem is when I try to set a light mode in the editor, it doesn't show the available modes. When I right click on a light in the editor, nothing happens. Did you have the same problem?

Share this post


Link to post
Share on other sites

This is one of those mods that I always, always install. :D

I do have one (admittedly very minor!) complaint, and that is that, while the lights do emit light (duh), the textures of the lights don't become emissive, so they don't actually look like light sources. :)

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.