Dagger

[1.4.2] Luna multiplayer (LMP) - Beta

Recommended Posts

Posted (edited)

So my buddy and I tested this mod on 1.4.1, and found the newest version to work pretty good. We wanted to use a 1.3.1 compatible version since 1.3.1 has all the mods currently, but the version your website says to use (0.3.28) isn't working, even on just a vanilla 1.3.1 build. KSP says the mods are incompatible with 1.3.1 and Unity 5.4.0p4.

Edited by HalfdeadKiller
More accurate text.

Share this post


Link to post
Share on other sites
19 hours ago, HalfdeadKiller said:

So my buddy and I tested this mod on 1.4.1, and found the newest version to work pretty good. We wanted to use a 1.3.1 compatible version since 1.3.1 has all the mods currently, but the version your website says to use (0.3.28) isn't working, even on just a vanilla 1.3.1 build. KSP says the mods are incompatible with 1.3.1 and Unity 5.4.0p4.

The version that the website says is wrong. The latest 131 compatible version is 0.2.22. Still, I don't recommend you to use it as many bugs were fixed in the last iteration.

@SupperRobin6394

Share this post


Link to post
Share on other sites
1 hour ago, Dagger said:

The version that the website says is wrong. The latest 131 compatible version is 0.2.22. Still, I don't recommend you to use it as many bugs were fixed in the last iteration.

@SupperRobin6394

I have been summoned!

 

Apologies, you should have version is 0.2.22 and I have corrected this mistake on the website.

 

Here's a download link btw: http://lunamultiplayer.com/redirect?p=download&v=0.2.22

 

Share this post


Link to post
Share on other sites
Posted (edited)

Thanks for the help! I will admit the new version does work great, however I'm kinda stuck between using KSP 1.4.0 and 1.3.1. I get most of my enjoyment out of mods, and unfortunately there are a lot of 1.3.1 mods that aren't there for 1.4.1. We've been using LMP 0.2.22 and Syncrio, its janky but it kinda works for coop campaign. Also mods like MKS, Dang It!, Distant Object Enhancement aren't for 1.4.1 explicitly. I'll keep an eye on this mod though as things update!

 

Edit: If you can somehow get it so that career syncs like Syncrio does, then this mod would be like, top tier. I'd look at it myself but C# is a bit of an animal to me still.

Edited by HalfdeadKiller

Share this post


Link to post
Share on other sites
Posted (edited)
10 hours ago, HalfdeadKiller said:

Thanks for the help! I will admit the new version does work great, however I'm kinda stuck between using KSP 1.4.0 and 1.3.1. I get most of my enjoyment out of mods, and unfortunately there are a lot of 1.3.1 mods that aren't there for 1.4.1. We've been using LMP 0.2.22 and Syncrio, its janky but it kinda works for coop campaign. Also mods like MKS, Dang It!, Distant Object Enhancement aren't for 1.4.1 explicitly. I'll keep an eye on this mod though as things update!

 

Edit: If you can somehow get it so that career syncs like Syncrio does, then this mod would be like, top tier. I'd look at it myself but C# is a bit of an animal to me still.

Another developer is implementing career mode into LMP so we might have it soon :wink: At the moment I'm more focused on having it stable and without bugs

Edited by Dagger

Share this post


Link to post
Share on other sites

Hello @ all,

I´m new in this Forum. I have installed the newest Version from LMP. The Server is running in Science Mode. The Client Version is the 1.4.1 with the Making History DLC. Now I have a Problem.

I have build a big Vessel and if I start it, i have big Problems with the Stages.

If I sperate the first Stage my Vessel explode.

I have tested the Vessel in the normal Game Science Mode from the Game and it gives no Problems with the seperation from the Stages.

Can you help me please?

Sorry for my bad English.

Best Regards

Maik alias f!r3fOx_

Share this post


Link to post
Share on other sites
On 22/3/2018 at 10:04 AM, f!r3fOx_ said:

Hello @ all,

I´m new in this Forum. I have installed the newest Version from LMP. The Server is running in Science Mode. The Client Version is the 1.4.1 with the Making History DLC. Now I have a Problem.

I have build a big Vessel and if I start it, i have big Problems with the Stages.

If I sperate the first Stage my Vessel explode.

I have tested the Vessel in the normal Game Science Mode from the Game and it gives no Problems with the seperation from the Stages.

Can you help me please?

Sorry for my bad English.

Best Regards

Maik alias f!r3fOx_

I just released a new version so it might help you on that.

Anyway, career and science mode are still not supported although another developer is actively working on that

You can either downlaod them in the lunamultiplayer website or directly in the github repo

Share this post


Link to post
Share on other sites

Thank you, I have tested it, and it will do, how in the normal game. Very nice Work :)

Thank you very much.

Share this post


Link to post
Share on other sites

Hello! Will there be any backport of the latest versions to 1.3.1? I and my friend are playing RSS RO (and it won't transfer to 1.4.1 any time soon). P.S. Amazing job!!!

Share this post


Link to post
Share on other sites
Posted (edited)
On 25/3/2018 at 10:51 PM, panzerwaffe044 said:

Hello! Will there be any backport of the latest versions to 1.3.1? I and my friend are playing RSS RO (and it won't transfer to 1.4.1 any time soon). P.S. Amazing job!!!

The code changed quite a lot between 1.3.1 and 1.4.1 and the developers team is very small and must focus our time in other stuff atm. Still, feel free to get the code and compile it against the old dll's if you want

Edited by Dagger

Share this post


Link to post
Share on other sites

Just pushed a new release. Main update is that we support career and science modes thanks to MalteJanz!

Share this post


Link to post
Share on other sites

I just downloaded LMP and windows defender flagged LMPServer/Server.exe as a virus (Win32/Fuery.A!cl).

Anyone else see this issue?

Share this post


Link to post
Share on other sites
12 hours ago, PrestonF said:

I just downloaded LMP and windows defender flagged LMPServer/Server.exe as a virus (Win32/Fuery.A!cl).

Anyone else see this issue?

False positive. You can check the source code in the github repo if you want to be sure about it

Share this post


Link to post
Share on other sites
12 hours ago, Warsoul said:

 

Well, warp subspaces in my opinion are the best trade off for multiplayer also, you can set the "warp master" mode in LMP so a designated player is the warp master or just a no-warp game.

Your idea would mean a total rework of how LMP works and that would mean syncing a ton of stuff between players in the same ship. Although possible, it would involve massive work

Share this post


Link to post
Share on other sites
Posted (edited)

why some servers require certain terrain quality? because i play on low to my game use less ram memory and every server needs high terrain quality.

Edited by Hunony

Share this post


Link to post
Share on other sites
7 hours ago, Hunony said:

why some servers require certain terrain quality? because i play on low to my game use less ram memory and every server needs high terrain quality.

If a player has low and another player has high there's > 1m height difference between them and ground positioning doesn't work (vessels clip inside terrain or fly)

Share this post


Link to post
Share on other sites
50 minutes ago, Dagger said:

If a player has low and another player has high there's > 1m height difference between them and ground positioning doesn't work (vessels clip inside terrain or fly)

ugh

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now