Dagger

[1.5.1] Luna multiplayer (LMP) - Beta

Recommended Posts

Take it easy guys, we're all here to help each other out. No need to get personal about it. Having said that, @x_men, since LMP doesn't support mods, it is unlikely the developers will be willing to help you right now. The best thing you can do is eliminate the mods in batches or one at a time until you find out which mod is causing the problem, then at least you can find out where to start looking for a fix.

I hope that helps, at least a little! 

 

Share this post


Link to post
Share on other sites
Posted (edited)
11 hours ago, Deddly said:

Take it easy guys, we're all here to help each other out. No need to get personal about it. Having said that, @x_men, since LMP doesn't support mods, it is unlikely the developers will be willing to help you right now. The best thing you can do is eliminate the mods in batches or one at a time until you find out which mod is causing the problem, then at least you can find out where to start looking for a fix.

I hope that helps, at least a little! 

 

My apologies [snip] 

Anyways. I don't expect great enthusiasm or any obligation to support from the devs, it is free software after all. The fine line they draw is not to support mod and I understand, however the LMP server config has LMPModControl.xml, as well as a tool to generate that file, so while they say they don't support mods, I'm hoping it might just be a case of politically correct/official statement rather than actual practice.

Also, I'm looking for anyone else having similar issue, not just from devs themselves, maybe someone already figured it out, or do some other troubleshooting that I may rule out on my own. Let's put our heads together and figure it out kind of thing. [snip] 

Edited by Deddly

Share this post


Link to post
Share on other sites

Not sure why, but when I joined the "Luna Server" the "server" said some random things in the chat then banned me with no reason whatsoever. Has anyone got an explanation? Am I not supposed to join this server?

Share this post


Link to post
Share on other sites

Some posts have been removed from this thread. There's no need to attack each other over this stuff, guys. 

  • Like 1

Share this post


Link to post
Share on other sites

I'm trying to play LMP with my brother, who is on the same network as me; I'm hosting the server and he keeps getting disconnected a few minutes after joining, because his connection has timed out. Is there any way to make this happen less often, or not at all? 

Share this post


Link to post
Share on other sites

Hi guys, I just wanted to remind you that this mod is made on my spare time, at this moment we are only 2 developers and it's not an easy task to make something designed for single player available to several players, the mod is still in beta, it's not in the addons release forum as it's not stable. If there's some bug/improvement and you want it solved ASAP, feel free to fix it and do a push request as other developers have done.

Besides this, let me remind you of the wiki page (https://github.com/LunaMultiplayer/LunaMultiplayer/wiki) most of the issues I've seen are explained there

  • Like 2

Share this post


Link to post
Share on other sites

I have a server setup for me and 1 other player. Sometimes we seem to have issues after warping and it messes everything up. It's usually when he loads into a ship to fly a lot of the orbits get messed up and they magically start orbiting other planets for heading into space somewhere.

Anyone know what the solution to this is?

 

Thanks,

Share this post


Link to post
Share on other sites
Posted (edited)

read the wiki people read the wiki! It is your friend. Its free and doesn't cost you nothing but a little time. Test things out. Try different things. See what works and what does not work. Trial and error,experiment with it, and in doing so you will learn alot! https://github.com/LunaMultiplayer/LunaMultiplayer/wiki

.-.. -- .--. / .. ... / .. -. / -... . - .- .-.-.- / - .... .. ... / -- . .- -. ... / .. - / .. ... / -. --- - / ..-. .. -. .. ... .... . -.. / -.-- . -  ;)

Edited by Redneck
  • Like 1

Share this post


Link to post
Share on other sites
On 7/10/2018 at 6:17 PM, Redneck said:

read the wiki people read the wiki! It is your friend. Its free and doesn't cost you nothing but a little time. Test things out. Try different things. See what works and what does not work. Trial and error,experiment with it, and in doing so you will learn alot! https://github.com/LunaMultiplayer/LunaMultiplayer/wiki

.-.. -- .--. / .. ... / .. -. / -... . - .- .-.-.- / - .... .. ... / -- . .- -. ... / .. - / .. ... / -. --- - / ..-. .. -. .. ... .... . -.. / -.-- . -  ;)

 No, it's not finished. ;)

Share this post


Link to post
Share on other sites

Loving LMP, you guys are doing a fantastic job and I've yet to see a Multiplayer mod to have such stable flight with other players. Great work and thank you.

  • Like 1

Share this post


Link to post
Share on other sites
3 hours ago, Sleepy068 said:

Loving LMP, you guys are doing a fantastic job and I've yet to see a Multiplayer mod to have such stable flight with other players. Great work and thank you.

I did a lot of improvements in nightly so the next one will be even smoother ;)
I just need to find a nice way of syncing part modules....

  • Like 2

Share this post


Link to post
Share on other sites

First of all, thank you and congrats for the effort. I've been trying to find the best place to ask a question to the team but I guess this was the best I could find. Apologies if the purpose of this thread was not to ask questions. My questions are:

1. The game seems to allow F5 to quick save, but it says it doesn't allow load F9. Is that correct, is it the intended design?

2. I was playing with a friend, the server was on his side. He went for dinner and I kept playing on his server. I launched a couple of ships, all working fine. At some point the friend tried to connect and he was not able to. So he killed the server and restarted it. When we logged the ships were no longer there. A) If there was something wrong with the server, shouldn't it have given me an error? It used to give an error in DMP when the server disconnected. B) If the server was still working, why did it not save my ships when we restarted it? It's not like the server was restarted 1 minute after I launched the ships... At least 10m to 15m had gone since the ships were in orbit. Shouldn't they have been saved?

Thanks and Regards

Share this post


Link to post
Share on other sites
12 hours ago, Vdrela said:

First of all, thank you and congrats for the effort. I've been trying to find the best place to ask a question to the team but I guess this was the best I could find. Apologies if the purpose of this thread was not to ask questions. My questions are:

1. The game seems to allow F5 to quick save, but it says it doesn't allow load F9. Is that correct, is it the intended design?

2. I was playing with a friend, the server was on his side. He went for dinner and I kept playing on his server. I launched a couple of ships, all working fine. At some point the friend tried to connect and he was not able to. So he killed the server and restarted it. When we logged the ships were no longer there. A) If there was something wrong with the server, shouldn't it have given me an error? It used to give an error in DMP when the server disconnected. B) If the server was still working, why did it not save my ships when we restarted it? It's not like the server was restarted 1 minute after I launched the ships... At least 10m to 15m had gone since the ships were in orbit. Shouldn't they have been saved?

Thanks and Regards

1) There's actually a message from LMP that says that so it's the expected behaviour. Loading a savegame creates paradoxes as you are going back in time and that's not allowed, also it doesn't make any sense in a multiplayer game

2) Probably a bug, I'm working on the new version and the code has changed a lot so I don't know if it's reproduceable in the lastest nightly. Hopefully not :)

Edited by Dagger
  • Like 1

Share this post


Link to post
Share on other sites
On 9/15/2018 at 12:01 PM, Dagger said:

I did a lot of improvements in nightly so the next one will be even smoother ;)
 I just need to find a nice way of syncing part modules....

Is the syncing problem a frequency/bandwidth problem or a "get the data" problem? I might have some ideas for the former, but not for the latter.

On a related note, I wonder if KIS/KAS could be made to work over network.

Share this post


Link to post
Share on other sites
19 hours ago, Thygrrr said:

Is the syncing problem a frequency/bandwidth problem or a "get the data" problem? I might have some ideas for the former, but not for the latter.

On a related note, I wonder if KIS/KAS could be made to work over network.

The problem is getting/relaying the data basically.

Example:

The deployable solar panels inherit from "ModuleDeployableSolarPanel" When you extend a panel you must replicate that action to the other players.

For the players that are within load distance (< 20km) of that vessel they must call the same function (Extend()) over the same part module and on the same part of the original player.

For the players that are far away, they must update the protovessel (the vessel serialized as it appears in the save files) with the new part module value (extended = true) on that same part.

It's not an easy job, specially since every part module is different and nobody designed them with multiplayer in mind, therefore the only solution is to make a XML for every part module.

Share this post


Link to post
Share on other sites

What does ModuleDeployableSolarPanel inherit from? Is there a Deployable base class at least SOMEWHERE? :D

That said, wouldn't a network message that contains the action and the module suffice, rather than building and sending across XML data?

(as protovessels themselves get synced, I guess that problem is somewhat solved?)

 

Anyway, as a long time game developer I am AMAZED at how the DMP "hack" already worked to make a convincing multiplay experience, and LMP one-ups that with decent interpolation and more vessel stability ("immortality", though I had some vessels that should have died but wouldn't; will try to get a repro next time)

Share this post


Link to post
Share on other sites
On 9/27/2018 at 11:58 PM, Thygrrr said:

What does ModuleDeployableSolarPanel inherit from? Is there a Deployable base class at least SOMEWHERE? :D

That said, wouldn't a network message that contains the action and the module suffice, rather than building and sending across XML data?

(as protovessels themselves get synced, I guess that problem is somewhat solved?)

 

Anyway, as a long time game developer I am AMAZED at how the DMP "hack" already worked to make a convincing multiplay experience, and LMP one-ups that with decent interpolation and more vessel stability ("immortality", though I had some vessels that should have died but wouldn't; will try to get a repro next time)

All the PartModules inherit from a "PartModule" base class, but they implement different fields on the child classes so that doesn't help much as the parent class is too "flexible"

If you only relay the protovessel you will not see the panels extending/retracting and you will have to reload the vessel. That's what DMP does, it reloads the vessel every 30 seconds but unfortunately the reloading process s very CPU/memory intensive and that's why you see stuttering on DMP.

The only way to do that is to call the same method on the part sync and also send the protovessel field to the other players that are far away from that vessel so when they laod it they have the latest data

  • Like 1

Share this post


Link to post
Share on other sites

Hello there, I am loving the mod so far, but I am curious if there is anyway to disable 'modcontrol'?

At the moment, my friend and I are having trouble spawning in aircraft with modded parts. Is there any way to allow modded parts without manually inputting the names of all the parts in the LMPmodcontrol file?

I am completely aware mods are not completely supported yet

:) 

Share this post


Link to post
Share on other sites
11 hours ago, HolidayTheLeek said:

Hello there, I am loving the mod so far, but I am curious if there is anyway to disable 'modcontrol'?

At the moment, my friend and I are having trouble spawning in aircraft with modded parts. Is there any way to allow modded parts without manually inputting the names of all the parts in the LMPmodcontrol file?

I am completely aware mods are not completely supported yet

:) 

Nope there's no way of doing that because of how KSP works. But you can install the mods and then generate the mod file from KSP so you have the part names already inserted

Share this post


Link to post
Share on other sites

Thank you very much for your awesome work on this mod.

Question on the career mode - from what I can see money, reputation, science, Kerbals, etc. are all shared with every player in the server. Is that correct? Is there a plan to make the resources dedicated to each player?

From memory DMP had dedicated resources per player, rather than the common resources for the whole server.

Share this post


Link to post
Share on other sites
12 hours ago, rosokan said:

Thank you very much for your awesome work on this mod.

Question on the career mode - from what I can see money, reputation, science, Kerbals, etc. are all shared with every player in the server. Is that correct? Is there a plan to make the resources dedicated to each player?

From memory DMP had dedicated resources per player, rather than the common resources for the whole server.

Yep LMP career is shared. There are no plans to change this at the moment, too much work and bugs are first in the priority

  • Like 1

Share this post


Link to post
Share on other sites

I found out about this mod from a comment in the 1.5 update on steam. I'd like to know how does this mod compare to darkmultiplayer? Is it more stable, is timewarp usable, and can other players' kerbonauts be in one rocket?

  • Like 1

Share this post


Link to post
Share on other sites

it is more stable timwarp is usable no kerbonauts can not be in one rocket

 

But simply see for yourself!

Edited by Nightmare

Share this post


Link to post
Share on other sites

Hello everyone and hello Dagger , first thing ,thanks you for the good work for the multiplayer.  Its cool and SQUAD have to paid you to buy your code (I hope it will come for you) But its not the point here.

I have found a bug and maybe someone can help me.

The bug in question : When i try to dock any vessel between them ,they literally duplicate himself while i connect the docking port ,and they struggle and, booooom explosion everywhere. I have tried many thing to fix it , like playing in debug version , like playing with no modded game , in space , on the ground , same result , explosion.  How i can fix it ? Is it my fault ? Or its a LunaMultiplayer bug ? 

 

Thanks and fly safe :D

(apologise for my english translation ,its hard) 

 

 

Edited by Rangetonbang

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now