Dagger

[1.7.3] Luna multiplayer (LMP) - Beta

Recommended Posts

Is there a known bug in regards to asteroids spawning? It's set to the default 10 right now and apparently there are now well over 100 untracked objects around. If this isn't known, I'll get on putting this into a proper bug report later today, hopefully.

Share this post


Link to post
Share on other sites

I have a question, is it possible for me and a friend to have a space race in science mode where we try to unlock x technology first or travel to planet y before the other person can? It would be great if you could respond.

Share this post


Link to post
Share on other sites
18 hours ago, NotConor said:

I have a question, is it possible for me and a friend to have a space race in science mode where we try to unlock x technology first or travel to planet y before the other person can? It would be great if you could respond.

All science gain is shared. You could still do a race to reach Eve, etc but unlocking the parts would be collaborative.

If you're looking for a competition but still want a challenge you can start a science mode with ~2500-3000 science for your initial parts unlock and set the science gain multiplier down to 0.01. You won't be able to research new parts and will have to make do with mid-tier equipment.

Share this post


Link to post
Share on other sites

I have another question; can me and a friend build a craft at the same time?

Share this post


Link to post
Share on other sites
38 minutes ago, NotConor said:

I have another question; can me and a friend build a craft at the same time?

There is a Library available to save your craft builds to share them. You could start a craft and save it in the Library and let your friend add to it then he/she could save it and you add to it and so on....

Edited by Castille7

Share this post


Link to post
Share on other sites

Do mods sync between people on a server? A friend and I are wondering if we have to do that another way or we can get LMP to do it for us. Thanks.

Share this post


Link to post
Share on other sites

This mod has got me back playing KSP like I was back in the alpha days! THANK YOU SO MUCH! Alas, I have come across a game breaking issue that I hope may be remedied with a settings adjustment. Now, when I launch my craft from the space center or from the VAB it will explode before loading and I find my probe hurtling toward the sun. It only happened occasionally when the universe was new, now it's every time and, especially when I'm logging in remote from the server.  We only have a few vessel out. It seems exacerbated when loading a rocket with a lot of parts. Initially, I was able to stop it from halting the program (when the game locks up it seems to trigger the explosion) by accelerating very slowly, which I think helped by creating fewer particle effects and putting less demand on memory and processing. Is this something that can be helped by increasing or decreasing the MTU or by changing the vessel sync interval or some other server side setting? Any ideas? Please let me know. 

Thanks again.

Share this post


Link to post
Share on other sites

I really wanna make a LMP server with mods, but i don't know how. Can anyone tell me how to add mods to a server?

Share this post


Link to post
Share on other sites
On 11/27/2018 at 11:30 AM, Dagger said:

Latest version (0.17.0) should fix most of those issues I can't guarantee that is 100% stable but it contains a fix for a nasty bug that existed on LMP since the beginning and may have caused that behaviour

Cant believe i missed this. Thanks for replying i'll check it out. ☺

Share this post


Link to post
Share on other sites

Is there any way to stop debris from being removed, or increase the time it takes for it to be removed to something like an hour?

Share this post


Link to post
Share on other sites

We just tried the latest version of LMP with KSP 1.7.1 to see how well it worked. For the most part things work pretty well considering! But let me report some weirdness for posterity:

EVA. With each player launching and rendezvousing two separate ships piloted by 1 kerbal, everything went more or less smoothly. But then we tried to do an EVA to swap ships. It couldn't be done. When you EVA any kerbals from your ship, a representation of the EVA kerbal does appear for the other player, but no kerbals are removed from the ship on the other players computer. This means other plays are not able to board your empty ship. If you manage to return to your ship things work normally. But if for some reason you don't, this half empty / half full ship can't be boarded. If you attempt to switch to the half empty ship you will see a half missing kerbal portait! Also during the EVA the kerbal roster in astronaut complex begins to show the kerbal as available as well as assigned.

Ladders are quite fickle, moving or not. A kerbal doing fine on a ladder on one machine may be clipping through and applying excessive forces to the craft on the other machine. Grabbing a ladder at all with atmosphere was not accepted, F bounces you away.

Parachute graphics don't show for other players, but fortunately the parachute forces do apply to the ship.

The safety bubble. Other players can't spectate your ship from the tracking station when your craft begins on the launch pad or on the runway, but if you move slightly then they can, even before leaving the safety bubble. Would be convenient to spectate any time.

 

Share this post


Link to post
Share on other sites

Hi there.

My friend and I love this game and are really excited about the concept of playing it together and flying side by side, doing missions etc.

However, whenever we play either I can see him in real time and he can't see me at all or he can see me and he is appearing 5 minutes in the past doing all the stuff he was doing then but he can see me no problem in real time.

We both end up chasing his past self (even though he can't see himself)

I would really like a fix for this so we can play together in real time.

Hope someone can help 

Share this post


Link to post
Share on other sites
On 3/14/2019 at 5:02 PM, CreepinJesus said:

This mod has got me back playing KSP like I was back in the alpha days! THANK YOU SO MUCH! Alas, I have come across a game breaking issue that I hope may be remedied with a settings adjustment. Now, when I launch my craft from the space center or from the VAB it will explode before loading and I find my probe hurtling toward the sun. It only happened occasionally when the universe was new, now it's every time and, especially when I'm logging in remote from the server.  We only have a few vessel out. It seems exacerbated when loading a rocket with a lot of parts. Initially, I was able to stop it from halting the program (when the game locks up it seems to trigger the explosion) by accelerating very slowly, which I think helped by creating fewer particle effects and putting less demand on memory and processing. Is this something that can be helped by increasing or decreasing the MTU or by changing the vessel sync interval or some other server side setting? Any ideas? Please let me know. 

Thanks again.

 Having this exact same problem. Did you manage to find a fix for it? (Edit) FIxed it for medium sized ship by turning on "auto increase MTU" Larger vessels still freezing up and exploding.

Edited by Talavar

Share this post


Link to post
Share on other sites

The "accelerating" behaviour happens when your computer can't handle the graphics and then LMP forces the game to run at a higher speed. Next version has a part limit count setting on the server. This will avoid players from spawning vessels with million part count and then getting very low FPS.

Bear in mind that KSP is not prepared for multiplayer and this mod is just a proof of concept. To really make it multiplayer the physiscs should be handled server-side but that would be way too much work

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.