Jump to content

[1.9.x] Filter Extensions (No localization)


Recommended Posts

2 hours ago, KuboS0S said:

I've tried installing Filter Extensions - Default Configuration from CKAN. For whatever reason, multiple parts including Hydraulic Cylinders and the KAL were not responding to user input properly when I had it installed.

I have no clue why, I don't even know if this specific mod caused it, but removing the mod always fixed the issue.

I don't have any log files, as this didn't cause any crashes.

Here's a pastebin with my mods from CKAN.

Log files conain information which is essential to tracking down most issues.  In fact, a crash is about the only time a log file is sometimes not needed

Link to post
Share on other sites
10 hours ago, KuboS0S said:

I've tried installing Filter Extensions - Default Configuration from CKAN. For whatever reason, multiple parts including Hydraulic Cylinders and the KAL were not responding to user input properly when I had it installed.

I have no clue why, I don't even know if this specific mod caused it, but removing the mod always fixed the issue.

I don't have any log files, as this didn't cause any crashes.

Here's a pastebin with my mods from CKAN.

Welcome to the forums.

Log files are always created, regardless, and they contain information that may help identify problems with your install that, in turn, are causing your issue.  So, please provide them.

To determine where to find them and what to do once you have, read the thread below.

Also, consider that uninstalling Filter Extensions may remove a conflict with another mod which is actually the problem.

Link to post
Share on other sites
  • 2 weeks later...

Hello! I have Breaking Ground DLC installed and when i installed Filter extensions the "Robotics" category was gone. How do I fix this problem?

Edited by Gleb
Incorrect marks
Link to post
Share on other sites
5 hours ago, Gleb said:

Hello! I have Breaking Ground DLC installed and when i installed Filter extensions the "Robotics" category was gone. How do I fix this problem?

I would recommend you get into the habit of reading the last couple of pages of a topic before posting.  You may find solutions or a similar situations to yours.  In this case, the post immediately above yours contains a reference to how best report bugs and problems, and there are several posts indicating problems that may be the same as yours.  Many mod authors would like/want to have log information and it shows your willingness to participate in the solution effort.  It can go a long way to helping other forum members assist you.

Other basic info that would help (some of which would be contained in the log file that you would post):

  1. what KSP version are you running (the BG DLC runs on 4 versions, 1.7.0 to 1.7.3)?  Note that, AFAIK, FE isn't officially released for KSP 1.7.3.
  2. what mod version did you install?
  3. how did you install the mod, and have you tried removing and reinstalling it?
  4. did you install the FE default configuration?
  5. what's the minimum mod installation that replicates the problem?
Link to post
Share on other sites

Sorry if its in the thread somewheres already (I did go thru several pages, but its late for me, and I am tired, and prolly shouldnt even be on the forums right nao)..
But does anyone know of a link for instructions on how to make useable FE icons?

I found link for the non-existant wiki :P vOv

 

Link to post
Share on other sites

Ah, nevermind. I've used an incompatible version of the mod and ksp 1.7.1 and now with the latest version of the mod and ksp 1.7.3 it works. Btw how do you post images to the URL to insert them here? This mod is useful and awesome!

Link to post
Share on other sites
Just now, Gleb said:

Btw how do you post images to the URL to insert them here?

Welcome to the forum @Gleb.

The forum itself does not host images so you need to create an account on a hosting service like imgur. This post explains it all:

 

Link to post
Share on other sites
  • 1 month later...

Hey,

I'm getting this Errors in my logs:

Quote

190831T171946.186 [ERROR] [FilterExtensions.Logger.Log] [Filter Extensions 3.2.0.3]: subcategory name duplicated: Ablative Heat Shields
190831T171946.187 [ERROR] [FilterExtensions.Logger.Log] [Filter Extensions 3.2.0.3]: subcategory name duplicated: Air Intake
190831T171946.188 [ERROR] [FilterExtensions.Logger.Log] [Filter Extensions 3.2.0.3]: subcategory name duplicated: Control Surface
190831T171946.189 [ERROR] [FilterExtensions.Logger.Log] [Filter Extensions 3.2.0.3]: subcategory name duplicated: Fairings
190831T171946.190 [ERROR] [FilterExtensions.Logger.Log] [Filter Extensions 3.2.0.3]: subcategory name duplicated: Nose Cones
190831T171946.191 [ERROR] [FilterExtensions.Logger.Log] [Filter Extensions 3.2.0.3]: subcategory name duplicated: Wings
190831T171946.192 [ERROR] [FilterExtensions.Logger.Log] [Filter Extensions 3.2.0.3]: subcategory name duplicated: Prop Engines
190831T171954.198 [ERROR] [FilterExtensions.Logger.Log] [Filter Extensions 3.2.0.3]: BDArmory: No subcategories valid, abandon instantiation of BDArmory
190831T171954.655 [ERROR] [FilterExtensions.Logger.Log] [Filter Extensions 3.2.0.3]: Coatl Aerospace: No subcategories valid, abandon instantiation of Coatl Aerospace
190831T171955.158 [ERROR] [FilterExtensions.Logger.Log] [Filter Extensions 3.2.0.3]: HeatControl: No subcategories valid, abandon instantiation of HeatControl
190831T171955.303 [ERROR] [FilterExtensions.Logger.Log] [Filter Extensions 3.2.0.3]: HGR & HGR_Redux: No subcategories valid, abandon instantiation of HGR & HGR_Redux
190831T171956.378 [ERROR] [FilterExtensions.Logger.Log] [Filter Extensions 3.2.0.3]: Naval Parts: No subcategories valid, abandon instantiation of Naval Parts
190831T172002.286 [ERROR] [FilterExtensions.Logger.Log] [Filter Extensions 3.2.0.3]: Kerbal Foundries: No subcategories valid, abandon instantiation of Kerbal Foundries
190831T172004.871 [ERROR] [FilterExtensions.Logger.Log] [Filter Extensions 3.2.0.3]: 15m: No subcategories valid, abandon instantiation of 15m
190831T172005.118 [ERROR] [FilterExtensions.Logger.Log] [Filter Extensions 3.2.0.3]: 20m: No subcategories valid, abandon instantiation of 20m
190831T172005.380 [ERROR] [FilterExtensions.Logger.Log] [Filter Extensions 3.2.0.3]: 30m: No subcategories valid, abandon instantiation of 30m

Are they a problem?

 

My Logs: https://www.tancredi.nl/downloads/logs.zip

Do you need more information?

Link to post
Share on other sites
  • 1 month later...

Hey there, @linuxgurugamer,

just an idea if you have too much spare time ;) :

For a couple of mods there's no category and no icon defined (e.g. Missing History, or Dr. Jet's Chop Shop), maybe you can look into this it before Christmas 2022? :D 

Thanks again for this mod and the JC, big quality of life mods!

Link to post
Share on other sites
3 hours ago, VoidSquid said:

For a couple of mods there's no category and no icon defined (e.g. Missing History, or Dr. Jet's Chop Shop)

The category config files aren't difficult to make yourself if you use one of the existing ones as a reference. I know @linuxgurugamer likes pull requests for this kind of stuff. Icons require a little bit more work and you might consider reaching out to the mod authors for that.

Link to post
Share on other sites
  • 3 weeks later...

I cannot open an issue on FE Github.

Problem ist, that an "invert = true" does not seem to work on a field when not only the name of the variable is defined but also the value.

Example patch that does not work (added to GameData\000_FilterExtensions_Configs\SubCategories_Electrical.cfg - the block in the middle):

SUBCATEGORY
{
    name = Power Storage
    icon = PowerStorage
    FILTER
    {
        CHECK
        {
            type = resource
            value = ElectricCharge, StoredCharge
        }
        CHECK:NEEDS[WarpPlugin]
        {
            type = field
            value = ElectricCharge, maxAmount, 0.001
            invert = true
        }
        CHECK
        {
            type = moduleName
            value = ModuleCommand, ModuleEngines, ModuleEnginesFX, REGO_ModuleResourceConverter, ModuleGenerator, FNGenerator, ModuleRadioisotopeGenerator
            invert = true
        }
    }
}

 

The problem is that KSP-IE adds a block

	RESOURCE
	{
		name = ElectricCharge
		amount = 0
		maxAmount = 0.001
		isTweakable = false
		hideFlow = false
	}

to every part with ModuleDeployableSolarPanel.

Now does FilterExtensions show all solar panels in the subcategory for "Power Storage".

I just want to filter out all parts from that subcategory which contain a RESOURCE ElectricCharge with a maxAmount of exactly 0.001

But that does not work.

^ and no, I don't want to go the easy way and just add ModuleDeployableSolarPanel to the third block - because there are parts which are solar panels and batteries, like the Bluedog_DB/Parts/ProbeExpansion/bluedog_solarBattery.cfg

Link to post
Share on other sites
  • 3 months later...

New release, 3.2.4.1

  • Thanks to forum user @Gordon-Dry for these:
    • Bluedog_DB fix
    • Update SubCategories_Electrical.cfg (KSP-IE quick fix)
    • Tantares fix
    • Update SubCategories_Electrical.cfg
       
Edited by linuxgurugamer
Link to post
Share on other sites
  • 2 weeks later...

@linuxgurugamer The top post mentions a wiki for documentation, but the link doesn't seem to have any docs there.

I want to try creating configs to look for all parts that can hold science data and support the "collect all" function. (I'm fed up with a stock bug that allows "collect all" to be assigned to an action group despite that function not being supported by the part).

 

Link to post
Share on other sites
22 minutes ago, DeadJohn said:

@linuxgurugamer The top post mentions a wiki for documentation, but the link doesn't seem to have any docs there.

I want to try creating configs to look for all parts that can hold science data and support the "collect all" function. (I'm fed up with a stock bug that allows "collect all" to be assigned to an action group despite that function not being supported by the part).

 

The original mod authors wiki is still here: https://github.com/Crzyrndm/FilterExtension/wiki

Edited by leatherneck6017
Link to post
Share on other sites
  • 1 month later...

New release, 3.2.5

Thanks to user @leatherneck6017 for these:

  • Aero: Filter out ModuleCommand from Wings subcategory
  • Fuel: Add SSTUVolumeConatiner to checks
  • ISRU: Add Radiators subcategory
  • Lights: Filter out landing gear with ModuleWheelBase
  • Solar Panels: Add SSTU solar panels to check. Filter out parts with ModuleCommand and ModuleDockingNode
  • Fix typo in robotics
  • Move antennae out of science and into their ow
Link to post
Share on other sites
  • 1 month later...

I'm trying to get the parts added in the KerbalismConfig addon to show up in a custom filter, but I can't get them to show up for some reason.

My config looks like this:

CATEGORY:NEEDS[KerbalismConfig]
{
	name = Kerbalism
	icon = Kerbal
	colour = #FFF0F0F0
	all = true
	
	FILTER
	{
		CHECK
		{
			type = folder
			value = KerbalismConfig
		}
	}
	
	SUBCATEGORIES
	{
		list = 0,Pods
		list = 1,Fuel Tanks
		list = 2,Engines
		list = 3,Command and Control
		list = 4,Structural
		list = 5,Robotics
		list = 6,Coupling
		list = 7,Payload
		list = 8,Aerodynamics
		list = 9,Ground
		list = 10,Thermal
		list = 11,Electrical
		list = 12,Communications
		list = 13,Science
		list = 14,Cargo
		list = 15,Utility
		list = 16,Undefined
	}
}

And my Player.log is here:

https://drive.google.com/file/d/1dH9YZvFebdSw12LEF1rRgC3oVJaSVvgZ/view?usp=sharing

 

Some of the parts like the Geiger counter show up in the science area, but parts like "kerbalism-container-radial-pressurized-prosemian-small.cfg" don't show up in any of the filter extension categories. 

I would think if it was just a category problem, I would get a filter extension category for kerbalism that had i.e. the science parts in there, but not the others. Instead, I get no Kerbalism category in filter extensions at all.

 

Am I missing something?

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...