Jump to content

[1.3.1] BDArmory Continued - Public BETA of v1.1.0 - Damage and Armor Overhaul


gomker
 Share

Recommended Posts

23 hours ago, gomker said:

Yeah QA should not be done at 2AM - I broke the bullets - fixed here

https://github.com/PapaJoesSoup/BDArmory/releases/download/v1.1.0/BDArmory.1.1.0.23998_12232017.zip

@Acea - Possible that you have the broken bullets build ... Grab yesterdays release linked in the quote above if this is the case :)

Link to comment
Share on other sites

6 minutes ago, DoctorDavinci said:

@Acea - Possible that you have the broken bullets build ... Grab yesterdays release linked in the quote above if this is the case :)

I've grabbed it yesterday, deleted MM cache and tested it over again, and this issue still exists.

Link to comment
Share on other sites

7 minutes ago, Acea said:

I've grabbed it yesterday, deleted MM cache and tested it over again, and this issue still exists.

Couple questions ... Do the BDAc weapons cause damage (this will determine if it is an inherent issue) and did you delete the partdatabase.cfg (this could still be holding old values for your parts)

Link to comment
Share on other sites

5 minutes ago, DoctorDavinci said:

Couple questions ... Do the BDAc weapons cause damage (this will determine if it is an inherent issue) and did you delete the partdatabase.cfg (this could still be holding old values for your parts)

BDAc weapons work all right and I've deleted all old files before installing new version

Link to comment
Share on other sites

12 minutes ago, Acea said:

BDAc weapons work all right and I've deleted all old files before installing new version


What size of round are you shooting in your scenario? ... IIRC a few changes have been made to the bullet defs and this could be the root of your problem

@gomker will have a more in depth understanding of what is going on when he has the chance to take a look (holidays and all :wink:) ... We'll get to the bottom of it as NAS should work like the other weapons in BDAc and in SM's mods

 

Link to comment
Share on other sites

4 minutes ago, DoctorDavinci said:


What size of round are you shooting in your scenario? ... IIRC a few changes have been made to the bullet defs and this could be the root of your problem

@gomker will have a more in depth understanding of what is going on when he has the chance to take a look (holidays and all :wink:) ... We'll get to the bottom of it as NAS should work like the other weapons in BDAc and in SM's mods

See the pre-release discussion and there're more details, the sample is a 5 inch gun but I've gone through most NAS weapons and they showed the same problem.

Link to comment
Share on other sites

4 minutes ago, Acea said:

See the pre-release discussion and there're more details, the sample is a 5 inch gun but I've gone through most NAS weapons and they showed the same problem.

This might help ...

Quote

the behavior being described is only seen when turrets don't load the specified bullets, as to why it's not , when i can pretty much create cfg's on the fly and leave them anywhere, I have no idea, the only thing i can think of is that there's an illegal character in the bullet def, I've seen this in NAS stuff before.

If you are using your own bullet defs then the above is likely the problem ... if you replace the ammo that you are using with BDAc defined ammo does the same thing occur?

Link to comment
Share on other sites

47 minutes ago, DoctorDavinci said:

This might help ...

If you are using your own bullet defs then the above is likely the problem ... if you replace the ammo that you are using with BDAc defined ammo does the same thing occur?

I'd check it really quick and see if it would work.

EDIT: Okay I guess that's it. I'd check my bullet defs and see if there's anything wrong with it, and provide further reports.

EDIT 2: Problem solved. Seems like I shouldn't have edited cfg files with Notepad, copied & pasted all contents into Notepad++ -- save as NTF-8 without BOM -- things work flawlessly. Thanks for the help :wink:

Link to comment
Share on other sites

@Acea Just run the example posted in dev chat  Re your bullet cfg , You are missing 3 lines that even if Zero must be there.

This is the bullet cfg loaded and working

BULLET
{
    name = 5inchHEUS
	caliber = 127
	bulletVelocity = 762
	bulletMass = 20
	//HE Bullet Values
	explosive = true
	tntMass = 3.135
	blastPower = 0 
	blastHeat = 0
	blastRadius = 0
	apBulletMod = 0
	bulletDragTypeName = AnalyticEstimate
	bulletDragArea = 1.209675e-5
}

As compared the to version that refuse to load

BULLET
{
    name = 5inchHEUS
	caliber = 127
	bulletVelocity = 762
	bulletMass = 20
	//HE Bullet Values
	explosive = true
	tntMass = 3.135
	apBulletMod = 0
	bulletDragTypeName = AnalyticEstimate
	bulletDragArea = 1.209675e-5
}

Not tried on the rest but this looks like your issue and the only real difference between yours and the working loading versions

 

Edited by SpannerMonkey(smce)
Link to comment
Share on other sites

5 minutes ago, SpannerMonkey(smce) said:

@Acea Just run the example posted in dev chat  Re your bullet cfg , You are missing 3 lines that even if Zero must be there.

This is the bullet cfg loaded and working

BULLET
{
    name = 5inchHEUS
	caliber = 127
	bulletVelocity = 762
	bulletMass = 20
	//HE Bullet Values
	explosive = true
	tntMass = 3.135
	blastPower = 0 
	blastHeat = 0
	blastRadius = 0
	apBulletMod = 0
	bulletDragTypeName = AnalyticEstimate
	bulletDragArea = 1.209675e-5
}

As compared the to version that refuse to load

BULLET
{
    name = 5inchHEUS
	caliber = 127
	bulletVelocity = 762
	bulletMass = 20
	//HE Bullet Values
	explosive = true
	tntMass = 3.135
	apBulletMod = 0
	bulletDragTypeName = AnalyticEstimate
	bulletDragArea = 1.209675e-5
}

Not tried on the rest but this looks like your issue and the only real difference between yours and the working loading versions

 

Yeah I found it, things work now after added these lines (together with all the copy & paste). Anyway it's all right now and I can concentrate on dealing with all the remaining issues.

Link to comment
Share on other sites

9 hours ago, Murican_Jeb said:

I don't think I've had the muzzle vel problem, but yes, every gun under 11mm seems to do 0.01 damage.

This was due to scaling the values. Value outputs in the formulas were in Mega Joules and we had to scale them down to make sense. Other wise our Hitpoint numbers would be insanely high. Right now they are getting in the 300K range for super large parts like CVX Carrier.

In order to help balance that out on the lower end I did add a buff to anything less than 30mm but we have seen that in testing smaller ones still need more. I left the "bulletDmgMult" property in the weapon config. 

This allows you to increase the damage for that particular weapon if the bullet config is not to your liking.

We added the following to .50cal for reference based on QA testers feedback - bulletDmgMult = 1.3

On 12/23/2017 at 7:21 PM, SuicidalInsanity said:

In the latest build, every single gun has a muzzle velocity of 1030m/s, regardless of ammo type or what speed they've been configured to have in the BD_Bullets.cfg,
Also of note, any round with 'caliber = x.xx' set to something less than 11mm will not do more than 0.01 damage, regardless of muzzle velocity or projectile weight.

Look in the log for "[BDArmory]: Error Loading Bullet Config " if the bullet for that weapon is not found it will load the defaults which are 1030

 

7 hours ago, Acea said:

Error Loading Bullet Config | System.ArgumentNullException: Argument cannot be null. Parameter name: s at System.Double.Parse (System.String s, NumberStyles style, IFormatProvider provider) [0x00000] in <filename unknown>:0 at System.Single.Parse (System.String s) [0x00000] in <filename unknown>:0 at BDArmory.Armor.BulletInfo.Load () [0x00000] in <filename unknown>:0

Send me your bullet config, something is missing and its causing a cascade of errors, I need to handle that better

Edited by gomker
Link to comment
Share on other sites

forgot to refresh the thread before responding

@Acea

Yeah, sorry about that, I did say those fields were deprecated but we didn't remove them just yet to ensure legacy compatibility (JR was working on the tntMass code at the time). Thinking about it we probably should have just went ahead and removed them as we moved them out of weapon config, it was the perfect time to do it.

Link to comment
Share on other sites

1 hour ago, gomker said:

This was due to scaling the values. Value outputs in the formulas were in Mega Joules and we had to scale them down to make sense. Other wise our Hitpoint numbers would be insanely high. Right now they are getting in the 300K range for super large parts like CVX Carrier.

In order to help balance that out on the lower end I did add a buff to anything less than 30mm but we have seen that in testing smaller ones still need more. I left the "bulletDmgMult" property in the weapon config. 

This allows you to increase the damage for that particular weapon if the bullet config is not to your liking.

We added the following to .50cal for reference based on QA testers feedback - bulletDmgMult = 1.3

So what would a realistic dmg multiplier value be for 7mm ranges?

Link to comment
Share on other sites

8 minutes ago, Murican_Jeb said:

So what would a realistic dmg multiplier value be for 7mm ranges?

I would think about this being game play balance, how many hits from a 7mm would destroy X part ?  Say a wing or 1x1 meter panel. Test and adjust to your liking. This is how other damage values were balanced. I would start with 1.3 and go from there.

Link to comment
Share on other sites

2 minutes ago, gomker said:

I would think about this being game play balance, how many hits from a 7mm would destroy X part ?  Say a wing or 1x1 meter panel. Test and adjust to your liking. This is how other damage values were balanced. I would start with 1.3 and go from there.

Alright, except I can't load and reload the game over and over again.

Also, I have an issue with one of my guns, the MG 131 in my (collab) mod. So BDA is at its latest version, bullets are set correctly (And no, I did not delete the 3 lines with "blast____" in them), gun is set correctly with the correct bullet name, basically everything is set correctly and should be fine. However, I do not see the tracer, which usually means its broken. Here is the KSP.log, along with the output.log encase that gives any extra info:

KSP.log

output_log.txt

Random song except this has nothing to do with BDA what is wrong with me

Link to comment
Share on other sites

5 minutes ago, Murican_Jeb said:

Alright, except I can't load and reload the game over and over again.

The life of testing. If you want  to send me the weapon pack you are using I can assist.

The log link you sent me just showed me my dropbox folder

Link to comment
Share on other sites

2 minutes ago, gomker said:

The log link you sent me just showed me my dropbox folder

Yeah, I kinda don't know how to find my own links to my dropbox

This is literally my second time using it :blush:

Does this link to my KSP.log work? Then I'll send you the output log link and the new update to my weapons pack by PM.

Here

Link to comment
Share on other sites

1 minute ago, Murican_Jeb said:

Yeah, I kinda don't know how to find my own links to my dropbox

This is literally my second time using it :blush:

in your File Explorer on your computer, right click , there should be a "copy dropbox link"

Link to comment
Share on other sites

1 hour ago, Murican_Jeb said:

Alright, except I can't load and reload the game over and over again.

Then I guess you won't be able to get much testing done

This is one of the things that the end user doesn't see ... multiple daily builds, running the same scenario over and over again, restarting KSP umpteen million times when tweaking part configs and tweaking code .....

The amount of man hours put into BDAc since the team was formed is staggering (just take a look at the pulse on github :wink:) when you think about it and having to restart KSP a few times while at the tail end of all the previous time put into it is a small price to pay, n'est pas? :)

Edited by DoctorDavinci
Link to comment
Share on other sites

2 minutes ago, DoctorDavinci said:

Sorry, bad forum etiquette ... n'est pas = is that not so :wink:

No no I understand French (since I'm a fellow canadian) was just doing that as a joke That will end up turning into a terrible conversation of me saying random things oh never mind just forget what I even typed i'm just a weird person

Edited by Murican_Jeb
Link to comment
Share on other sites

How to celebrate New Years Eve, featuring BDA physics and vessel mover :wink:

Spoiler

7B3546266B59320194840ADF93091E8955952B61 (1600×1200)

But seriously, so I tried the bullet damage multiplier thing and put it in one of my weapons. The value was 3700 (Yes, it was carefully calculated so it would take away 37 hp) but yet, the bullets still do 0.01 hp. However, in the new years eve picture the reason those bullets are in the air is because of the ricochet, so it might be something to do with armor, although all the bullets actually penetrated the wings and seemed to bounce off the runway, so I don't think it's that.

Spoiler

DCK is awesome for making custom textures :)

7726A53AFC0140CC371639D631EABCF9B322CF54 (1600×1200)

It might be a technical problem that we can find in the log, but I'm pretty sure its part of the physics and stuff in BDA now. Should I give you guys a log or no?

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...