Jump to content
  • 0

Navball icons disappearing?


Rocket In My Pocket
 Share

Question

Little bit of an odd problem. It seems that whenever I'm pointing in a particular direction on the Navball; Ie. Prograde, Anti-normal, or what have you...we'll use Radial out as an example, whenever I face Radial out, the Radial out marker disappears as soon as my nose facing indicator is on top of it, then it comes back as soon as I move away.

I'm quite certain this wasn't happening before and I haven't changed anything recently that I can think of.

Is this perhaps the work of a mod? Or an in-game setting I've missed? Thanks in advance for any ideas or suggestions.

Link to comment
Share on other sites

25 answers to this question

Recommended Posts

  • 1

Ok, so I sorted it out myself...feel a little silly for making this post now lol.

I'll detail the cause and solution though in case this happens to anyone else.

Apparently it was a scaling issue; I'm playing KSP at 4k now, and at 150% scale the icons on the navball start disappearing when you are over them, decreasing the Navball scale to 140% fixed the problem. In a similar fashion the Altitude meter no longer displays numbers at 150% scale but reducing it to 140% fixed that as well. I have no clue why this is personally. However my problem is solved for now and I'm back to playing happily so; all's well that ends well. Lol.

Link to comment
Share on other sites

  • 0

Ah well. Two ways of interpreting the lack of responses in this thread:

1) None of us wanted you to feel utterly stupid, so we didn't say anything.

2) None of us had a clue what the problem might be.

Definitely number 2. Of course! Couldn't have been anything else.

Link to comment
Share on other sites

  • 0
54 minutes ago, Plusck said:

Ah well. Two ways of interpreting the lack of responses in this thread:

1) None of us wanted you to feel utterly stupid, so we didn't say anything.

2) None of us had a clue what the problem might be.

Definitely number 2. Of course! Couldn't have been anything else.

Is there something obvious about max UI scaling at 4k (kind of a requirement to be able to read anything) causing issues with the Navball/Altimeter display that I'm missing here? It certainly seems like a bug?

Not surprised at the lack of responses as I re-posted and marked it as solved 10 minutes after I originally made it.

I'm honestly not sure if this is a joke or a thinly veiled insult. :/

Link to comment
Share on other sites

  • 0
2 minutes ago, Rocket In My Pocket said:

I'm honestly not sure if this is a joke or a thinly veiled insult. :/

I interpreted it as a joke.

2 minutes ago, Rocket In My Pocket said:

Is there something obvious about max UI scaling at 4k

You're probably in a pretty small minority for playing at 4k.  I'm sure that's why you haven't seen it come up much, if it all.

Link to comment
Share on other sites

  • 0
9 minutes ago, Geonovast said:

I interpreted it as a joke.

You're probably in a pretty small minority for playing at 4k.  I'm sure that's why you haven't seen it come up much, if it all.

You're probably right, it's so hard to read the "color" of someones response from the black and white text, y'know what I mean?

Ugh, I know. I hate myself for being "one of those guys" now. Lol. I totally used to roll my eyes at people asking for better 4k support. I've always gamed on potato computers since forever.

My brother got me an awesome new computer/TV on a black Friday sale where he works though so all of a sudden I'm a "#PCMasterRace guy" It's taking some getting used to; believe me. I'm gonna stay humble though, never forget where I came from and all that. Help the little guy sort out his technical issues so he can play KSP too. :rolleyes:

Edited by Rocket In My Pocket
Link to comment
Share on other sites

  • 0
3 minutes ago, Rocket In My Pocket said:

You're probably right, it's so hard to read the "color" of someones response from the black and white text, y'know what I mean?

Ugh, I know. I hate myself for being "one of those guys" now. Lol. I totally used to roll my eyes at people asking for better 4k support. I've always gamed on potato computers since like forever.

My brother got me an awesome new computer/TV on a black Friday sale where he works so all of a sudden I'm a "#PCMasterRace guy" It's taking some getting used to; believe me.

I'm not quite that bad.  I've been a console guy since forever, skating by with average or potato computers.  But KSP made me go out and buy a decent computer for once.  And then I added to it, and added to it.  Today I hooked up the third monitor.

20171218192029.jpg

Link to comment
Share on other sites

  • 0
1 minute ago, Geonovast said:

I'm not quite that bad.  I've been a console guy since forever, skating by with average or potato computers.  But KSP made me go out and buy a decent computer for once.  And then I added to it, and added to it.  Today I hooked up the third monitor.

20171218192029.jpg

That's an awesome setup, I'd love to have multiple monitors so I could play music or watch a show, maybe cruise the forums while I play KSP.

Best part of the picture hands down is the "STAY CALM AND CARRY ON" poster lol.

Also the finished bowl of what I can only assume is Ramen.

Link to comment
Share on other sites

  • 0
13 minutes ago, Rocket In My Pocket said:

That's an awesome setup, I'd love to have multiple monitors so I could play music or watch a show, maybe cruise the forums while I play KSP.

Best part of the picture hands down is the "STAY CALM AND CARRY ON" poster lol.

Also the finished bowl of what I can only assume is Ramen.

I'm assuming if you're running 4K, you've got a pretty decent graphics card that can handle more than one.

Hit up the thrift stores!  The monitor in the middle is an Acer AL2223W, 22 inches, built in speakers.  Not super high res, but it works perfectly.  $9.  I also got an older Dell 20 ish inch monitor at the same store.  It's not widescreen, but it's big enough that that doesn't really matter.  Built in USB hub.  $8 on a store-wide 50% off sale. 

The one on the left is an Acer X191W, got it with a computer off CL for $40.  The one on the right is also an X191W, from eBay.  (I like my stuff to match).  About an hour ago I had to stop myself from buying another AL2223W on eBay for $40.

And the bowl is actually full of tortellini :wink:

Edited by Geonovast
Link to comment
Share on other sites

  • 0
58 minutes ago, Geonovast said:

 

20171218192029.jpg

 

55 minutes ago, Rocket In My Pocket said:

That's an awesome setup, I'd love to have multiple monitors so I could play music or watch a show, maybe cruise the forums while I play KSP.

Best part of the picture hands down is the "STAY CALM AND CARRY ON" poster lol.

Also the finished bowl of what I can only assume is Ramen.

Hmm. The most eye-opening detail here is the revelation that @Geonovast is a spaceplane guy. We'll have to put him on the list. Best to keep track of those guys. :)

Link to comment
Share on other sites

  • 0

This is a bug.  It happened tonight while playing through a VPN.  I shut down the game, rebooted the computer, shutdown the VPN and the icons are currently back. I've restarted my VPN now and the problem doesn't persist.

It appears to be random.  Workaround is restarting the OS (Win7 professional 64 bit) and/or restarting VPN or STEAM.

Link to comment
Share on other sites

  • 0
8 hours ago, tiriss said:

This is a bug.  It happened tonight while playing through a VPN.  I shut down the game, rebooted the computer, shutdown the VPN and the icons are currently back. I've restarted my VPN now and the problem doesn't persist.

It appears to be random.  Workaround is restarting the OS (Win7 professional 64 bit) and/or restarting VPN or STEAM.

Very odd! For me it was a UI scaling issue.

Out of curiosity, what resolution/UI scaling do you play at?

Link to comment
Share on other sites

  • 0
11 hours ago, Rocket In My Pocket said:

Very odd! For me it was a UI scaling issue.

Out of curiosity, what resolution/UI scaling do you play at?

At the risk of having you humblebrag this idiocy into something that needs actual KSP developer resources, no I don't have a 4k monitor and yes I'm just using 1680x1050.  So if you didn't actually experience this bug, please don't tell us about your scary experience when the icons fell.

Link to comment
Share on other sites

  • 0

I apologize.  I didn't mean to come off as rude but reading back I clearly was.  No, it was not a scaling issue, and it was the first time I saw the bug.  I tried switching to the space center, to other multiple ships I had out, to no avail.  The only thing that fixed it was quitting the game completely, and rebooting my system.  As I stated before, I'm not entirely sure which thing fixed the problem.

Link to comment
Share on other sites

  • 0
1 hour ago, tiriss said:

At the risk of having you humblebrag this idiocy into something that needs actual KSP developer resources, no I don't have a 4k monitor and yes I'm just using 1680x1050.  So if you didn't actually experience this bug, please don't tell us about your scary experience when the icons fell.

Huh lol?

I mean I've confirmed the bug and it's repeatable. Ui scaling at 150: icons disappear. Ui scaling at less than 150 they don't. I'm just trying to narrow the underlying cause down further. (And by doing so; help you. As this thread has been solved and dead forever.)

Umm...you did notice this is my thread right? So yeah..pretty sure I've experienced the bug. I see your new here, just FYI; we generally expect a bit more courtesy than that.

Link to comment
Share on other sites

  • 0
23 hours ago, tiriss said:

This is a bug.  It happened tonight while playing through a VPN.  I shut down the game, rebooted the computer, shutdown the VPN and the icons are currently back. I've restarted my VPN now and the problem doesn't persist.

It appears to be random.  Workaround is restarting the OS (Win7 professional 64 bit) and/or restarting VPN or STEAM.

Do you play with mods?

How about providing a log file?

and the VPN is  irrelevent, KSP is not a networked game.

Calling something a bug, especially without any supporting info, is hasty.

Also, since this has no signifigence to the original thread, you would be better off asking for help in a new thread.

Link to comment
Share on other sites

  • 0

Please note that this was actually posted, but was unfortunately not visible until now. Apologies.

2 hours ago, tiriss said:

I apologize.  I didn't mean to come off as rude but reading back I clearly was.  No, it was not a scaling issue, and it was the first time I saw the bug.  I tried switching to the space center, to other multiple ships I had out, to no avail.  The only thing that fixed it was quitting the game completely, and rebooting my system.  As I stated before, I'm not entirely sure which thing fixed the problem.

 

Link to comment
Share on other sites

  • 0
3 hours ago, tiriss said:

I apologize.  I didn't mean to come off as rude but reading back I clearly was.  No, it was not a scaling issue, and it was the first time I saw the bug.  I tried switching to the space center, to other multiple ships I had out, to no avail.  The only thing that fixed it was quitting the game completely, and rebooting my system.  As I stated before, I'm not entirely sure which thing fixed the problem.

This is something I call a GOK, short for God Only Knows.

A one time event usually isn't a bug, but if it's  repeatable, then it might be.

Link to comment
Share on other sites

  • 0
On 12/19/2017 at 3:58 AM, Rocket In My Pocket said:

Is there something obvious about max UI scaling at 4k (kind of a requirement to be able to read anything) causing issues with the Navball/Altimeter display that I'm missing here? It certainly seems like a bug?

Not surprised at the lack of responses as I re-posted and marked it as solved 10 minutes after I originally made it.

I'm honestly not sure if this is a joke or a thinly veiled insult. :/

And I too apologise. Obviously I did intend to make you wonder, for a short while, whether there was a thinly veiled insult in there. However with your track record on the site and clear expertise in the game, I assumed you'd realise very quickly that no insult would make sense.
So yes, I expected you to start by dismissing the fake 1st choice (obvious joke), then wonder whether you were reading it right (that manipulative fourth line), then realise that there was no way it could be serious (the second, sneakier joke).

So again, sorry, it really was in jest. I don't think there is anything obvious at all about your issue, and had absolutely no clue how it could occur.
I should have remembered how easily I can get paranoid about what other people say, rather than encouraging the sentiment.

And, by the laws of unintended consequences, I'm pretty sure that tiriss's first post here was coloured by my own inept jesting, so I bear some responsiblity for that too.

Link to comment
Share on other sites

  • 0

Welp, seems like we're all a bit guilty of jumping to conclusions here, including myself. Lol.

All is well that ends well though, thanks @Plusck for clearing that up, it was only on re reading this thread that I realized you were obviously not being serious, and I was being overly sensitive/defensive.

@tiriss now that we've got that behind us, welcome to the forums friend!

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...