Recommended Posts

1 minute ago, Galileo said:

Is it configurable via MM again?

It should be. I didn't test that explicitly. If not, I'll write a hotfix for that.

Share this post


Link to post
Share on other sites
1 hour ago, The White Guardian said:

Aaand it's live. :D

*And the crowd goes wild!*

Share this post


Link to post
Share on other sites
2 hours ago, The White Guardian said:

Aaand it's live. :D

Yeehaaaa :D

Can't wait to try it.

Thank you very much :)

Share this post


Link to post
Share on other sites

Hey thanks for the update! Tried messing around with it a bit but couldn't figure out how to add new profiles or get Exported profiles to show up. Will test more after documentation is available.

Share this post


Link to post
Share on other sites
49 minutes ago, Cheesecake said:

Does this new version work with DX11 now?

Yes, with lots of thanks to @jrodriguez

As a matter of fact, I tested the in-game GUI with DX11, and only compiled the non-dx11 shaders this morning; so KS3P V6.0 worked with DX11 before I even added support for the normal DirectX version of KSP. :D

Share this post


Link to post
Share on other sites
Posted (edited)

Is there a slightly chance of getting OpenGL shaders to work? For the -force-glcore users out there.

It works. It could be that it's not as beauty as with DX but it works.
The shader postprocessingshaders-linux.unity3d is chosen when -force-glcore is used.

 

Update:

Well, somehow it works, but ...

After a few hours the game started to spam the log with never seen before stuff like

Internal error. Trying to destroy object that is already released to pool.

and the PAW is invisible:
2EKkPk0.jpg

Too much of a hassle, damnit. Removing again. Unfortunately.

But at least I upload the log etc:
https://www.dropbox.com/s/d8m7uc21pxq8ddj/output_log.txt and stuff 2019-07-04-01.zip?dl=1

Edited by Gordon Dry

Share this post


Link to post
Share on other sites
50 minutes ago, DasCostaNix said:

Fricking awesome! Still have to figure out how to get different settings for each scene.
Aaand is this a bug or a feature?

https://youtu.be/1oD9rFqFolA

Whoa that's trippy. Reminds me of those weird '3D' glasses we had in the 90s! And of Escher art xD.

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, DasCostaNix said:

is this a bug or a feature?

https://youtu.be/1oD9rFqFolA

What the actual heck? I'll look into that, but I have no idea what could be causing it.

EDIT: had KSP with KS3P running anyways so I did a quick test. Placed a stock 'Dove' craft in the SPH and placed the front wheel on a marker on the ground, then messed with the gui. Regardless of how much I moved the camera, I cannot replicate your issue. What mods are you using?

That said, I must admit I've found a few mistakes of mine left in the source code that I've since cleaned up. Tomorrow morning I'll release a hotfix to patch a few small bugs.

Edited by The White Guardian

Share this post


Link to post
Share on other sites

I am probably missing something obvious, but how can I assign default profiles for different scenes? I noticed the new profile exports only contain a single batch of settings, instead of all scenes like the old configs. 

On a side note, I'd been away from KSP for a long time until around a month ago, and I've been slowly building a mod list up. I have to say, this is one of my new favorite mods, especially with this update. I don't mind hand-editing config files but being able to tweak it in-game is fantastic. Thank you @The White Guardian and all contributors! :)

Share this post


Link to post
Share on other sites

Wow, being able to edit easily in game is awesome.

Share this post


Link to post
Share on other sites
Posted (edited)

@The White Guardian first all thank you to both yourself an Jrodriguez for the fantastic work in making this update. KS3P is a must have for me and now having the GUI is a real game changer. I had a profile I like before but looking forward to having the ability to easily create multiple profile for different use cases without the tedium.


U9xUJNFh.png

Unfortunately at the moment I am unable to actually use the profiles I've created. I can boot up the game just fine with the default profile and create one of my own and export. However once I try to bring in the created profile, it doesn't appear in the profile selector or editor and neither does the original default. Therefore not only can you not select a profile you cannot now try to create one either. The console shows a ton of NREs when I press the select profile for scene or click the edit profile button.

I tried 3 different ways of bringing in the profile

1. rename the exported .txt to .cfg

2. rename the exported .txt to .cfg and add change the first line to @KS3P
3. keep the exported file as .txt and replace the profile node of the defalt-config.cfg with the contents of the exported one.

As an aside the Ambient Occlusion node remains completely empty when exporting (not even enabled = false) despite being configured during export.

Perhaps these issues are being fixed by the aforementioned code errors but I thought I'd make the report anyway in case its unrelated.

Additional details and link to log in spoiler. I hope this has been helpful and that a solution can be found. I've had a taste of the future and I cant go back :P 

Spoiler

Windows 10, KSP 1.7.1, force DX11

Link to KSP log: https://www.dropbox.com/s/epukwe77y8nq74q/output_log.txt?dl=0

Link to KS3P log: https://www.dropbox.com/s/p4k8otemuoktd36/log.txt?dl=0

Link to config file used (all other profile cfgs were disabled): https://www.dropbox.com/s/4fg5qc64shj2jpb/DefaultConfig.cfg?dl=0

clicking the profile editor leads to a blank screen:

 F5gD4izl.png

 

 

Edited by Zorg

Share this post


Link to post
Share on other sites
14 hours ago, Zorg said:

Unfortunately at the moment I am unable to actually use the profiles I've created.

I have the same problem.
Here's what I tried:

Spoiler

Log: (if it helps)


    ----    KS3P loading report    ----
[Log]: Running MonoBehaviour.Awake()!
[Log]: Loading asset bundle at path C:/Games/Kerbal Space Program/GameData\KS3P\Shaders\postprocessingshaders-windows.unity3d
[Wrn]: Adding shader [Hidden/Post FX/Ambient Occlusion].
[Wrn]: Adding shader [Hidden/Post FX/Blit].
[Wrn]: Adding shader [Hidden/Post FX/Bloom].
[Wrn]: Adding shader [Hidden/Post FX/Builtin Debug Views].
[Wrn]: Adding shader [Hidden/Post FX/Depth Of Field].
[Wrn]: Adding shader [Hidden/Post FX/Eye Adaptation].
[Wrn]: Adding shader [Hidden/Post FX/Fog].
[Wrn]: Adding shader [Hidden/Post FX/FXAA].
[Wrn]: Adding shader [Hidden/Post FX/Grain Generator].
[Wrn]: Adding shader [Hidden/Post FX/Lut Generator].
[Wrn]: Adding shader [Hidden/Post FX/Motion Blur].
[Wrn]: Adding shader [Hidden/Post FX/Screen Space Reflection].
[Wrn]: Adding shader [Hidden/Post FX/Temporal Anti-aliasing].
[Wrn]: Adding shader [Hidden/Post FX/Uber Shader].
[Log]: Adding compute shader [EyeHistogram].

 

 

Share this post


Link to post
Share on other sites

@Zorg @Artemonim I fixed that problem in the hotfix I've just released. Once you're in-game, open the GUI and manually select your custom profile. I've yet to write the code that allows KS3P to memorize these profile preferences. My sincerest apologies for the inconvenience.

Share this post


Link to post
Share on other sites
Posted (edited)
2 minutes ago, The White Guardian said:

I fixed that problem in the hotfix I've just released. Once you're in-game, open the GUI and manually select your custom profile. I've yet to write the code that allows KS3P to memorize these profile preferences. My sincerest apologies for the inconvenience.

No worries, teething problems are always to be expected :) As mentioned earlier all the work you've already done to this point on KS3P has enhanced my game and enjoyment considerably so thank you for that. Will check out the new build immediately!

Edited by Zorg

Share this post


Link to post
Share on other sites
Posted (edited)

Almost forgot: you can technically brute-force KS3P to use a custom config. In Configuration.cfg one may notice the appearance of several new values, each corresponding to a particular game scene.

Here's how they work: when loading a game scene, the appropriate camera operator class asks KS3P to supply the requested profile. KS3P does this automatically: it filters the list of loaded profiles to a list of 'valid' loaded profiles (IE the profiles marked as compatible for this scene).

The ID in the config tells KS3P which profile to take from this list. 0 means first entry, 1 means second entry, etc. Don't worry about selecting a non-existant entry, KS3P automatically checks if the requested ID isn't out of bounds and takes the last found profile if so.

Since the default profiles are likely to be loaded first, one could try manually setting the value to 1 for each of these entries. Clunky, I know, but this is a prototype system that I didn't have time to implement fully. In a future patch, KS3P will instead save the name of the profile requested for each scene, and when supplying the profile to a camera operator, it selects the profile with the requested name IF PRESENT. If it isn't present, it falls back to providing the first element from the list.

Edited by The White Guardian

Share this post


Link to post
Share on other sites
Posted (edited)

Hi @The White Guardian unfortunately I still havent been able to get custom profiles working with v6.1 . I'll try to do some more troubleshooting tomorrow with trying to disable certain nodes and see, but could it be that the exported profiles have some error with certain effects or parameters I am enabling? Everything previews fine during the initial set up with the blank profile though.

For instance with this cfg file (and no others) the KS3P menu GUI does not come up at all for me when I press alt+f3  alt+3 and no effects are visible. The contents of the custom profile in this cfg were exported directly from game.

 

Edited by Zorg

Share this post


Link to post
Share on other sites

Hello! I think Motion Blur is bugged. When enabled the skybox looks very wierd.

Link: https://imgur.com/a/WFpwT4P

First photo: Motion Blur enabled

Second Photo: Motion Blur disabled

Otherwise the mod runs perfectly.

Share this post


Link to post
Share on other sites
1 hour ago, Ovi said:

Hello! I think Motion Blur is bugged. When enabled the skybox looks very wierd.

Link: https://imgur.com/a/WFpwT4P

First photo: Motion Blur enabled

Second Photo: Motion Blur disabled

Otherwise the mod runs perfectly.

Well, everything *is* in motion... maybe not *that* much, tho... :)

Share this post


Link to post
Share on other sites
On 7/5/2019 at 5:46 PM, Zorg said:

the KS3P menu GUI does not come up at all for me when I press alt+f3 and no effects are visible

 

It's Alt+3 (Left Alt + Alpha 3)

Share this post


Link to post
Share on other sites
1 hour ago, Neptuno said:

It's Alt+3 (Left Alt + Alpha 3)

Yeah that was a typo, I was pressing Alt+3. But under the conditions I mentioned the GUI doesnt come up. 

I am able to bring up the GUI and design a custom profile when starting with a blank one, but not after importing the one I attached.

Share this post


Link to post
Share on other sites
Posted (edited)

Hi !

I'm a little bit confuse with the new version of KS3P.

- I download it and put it in my game data

- Launch my game with a ''directX 11'' shortcut

- In game I can pop up the UI with Alt+3 (and alt+2 for be sure)

But nothing happen if I use the default profil or set a new one. The screen always stay the same. And the  log only say : Loading shaders

Did I miss something ?

Thank for your help ! ;)

Edited by Carni35

Share this post


Link to post
Share on other sites

Hi I also recently installed this mod on my ksp 1.7.1 but it dosent seem to work, and yes I have done both manual and automatic installation but there are no changes done to the game visuals, I have tries everything, please help :(

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.