Recommended Posts

For those of y'all having trouble making the mod work, turns out the default config in the latest version has everything disabled. You'll have to manually modify the configuration in the GUI (press Alt+3 in flight), export a config, move it from GameData/KS3P/export into GameData/KS3P, and because TWG has not coded the mod to remember your profile as of yet, switch to your custom profile every time you restart the game. You will also have to setup KS3P to use that config during flight.

tNY5mu1.png

Share this post


Link to post
Share on other sites

Actually, the default config is supposed to show post-processing effects in the main menu to confirm that it is working. A full 'default profile' is still in development.

That said, I've started looking into integration for the post-processing stack V2. Now, this particular edition has a nice little feature that allows for post-processing overrides when coming within range of an override component. I have plans to turn this feature into a custom PQSMod that allows for unique post-processing overrides per planet. Though I'm not sure if KSP is up to the necessary Unity version yet; I may have to wait until it gets upgraded to Unity 2019.

That said, I'm already looking into a custom PQSMod that tweaks the 'temperature' value on the color grading post-processing effect, which basically skews the screen's colors to either warmer (orange) or colder (icy cyan) hues, to further convey the ambient temperature. All that this would need is:

1. A way of finding the active vessel (doable through FlightGlobals)
2. A way of finding the ambient temperature (will have to investigate this)
3. Remapping from the temperature bounds to the color bounds
4. Writing the remapped value to the color grading

All of this shouldn't be too hard to do, the main issue is getting it working properly.

Next, I have several custom effects on the planner, and perhaps a system for loading custom effects from other AssetBundles. Though this is all future music at the moment.

Share this post


Link to post
Share on other sites
2 hours ago, The White Guardian said:

1. A way of finding the active vessel (doable through FlightGlobals)
2. A way of finding the ambient temperature (will have to investigate this)
3. Remapping from the temperature bounds to the color bounds
4. Writing the remapped value to the color grading

 

Heck -- this sounds very cool. Thanks for continuing work on this :)

Share this post


Link to post
Share on other sites

I'm liking this new update, especially the in-game GUI for it, however I'm having no luck with getting it to use anything other than the "KS3P-Default" profile.

I can create, edit and load other profiles into the GUI, but after setting my profile to be used for Flight (Setup > Select Profile for Scene [Flight]), it doesn't actually get used. Changes to my profile have no effect on the scene render, but those made to KS3P-Default do.

Is this the current expected behaviour or might I be missing something?

Share this post


Link to post
Share on other sites

This doesn't seem to be working at all for me. It's like it will not post process period.

Share this post


Link to post
Share on other sites
13 minutes ago, Eskandare said:

This doesn't seem to be working at all for me. It's like it will not post process period.

Just to confirm -- the mod starts in the "off" condition initially.. alt-3, and enable each component by hand to confirm if it's doing anything...

Share this post


Link to post
Share on other sites

Oh there it goes, DOH!

7 minutes ago, Beetlecat said:

Just to confirm -- the mod starts in the "off" condition initially.. alt-3, and enable each component by hand to confirm if it's doing anything...

Oh there it goes, DOH!

 

Share this post


Link to post
Share on other sites
2 minutes ago, Eskandare said:

Oh there it goes, DOH!

hah!
I'm not sure if this is a better default than the "All-on" mode in the previous iteration. :)  The process of creating/exporting our own presets to file (after tweaking in the GUI) is a few posts up/page back or so.

Share this post


Link to post
Share on other sites
Just now, Beetlecat said:

hah!
I'm not sure if this is a better default than the "All-on" mode in the previous iteration. :)  The process of creating/exporting our own presets to file (after tweaking in the GUI) is a few posts up/page back or so.

I left out a few annoying features like grain and vignette. It does make scatterer prettier. 

sJXpuMn.png

Share this post


Link to post
Share on other sites

Can't seem to get the GUI to come up at all. Not sure what I'm missing here. But I've tried rebinding the key itself in the config.cfg and that's still not working. Any advice?

 

Thanks!

Share this post


Link to post
Share on other sites

So I know that the Alt key doesn't work properly on KSP for Linux, so I wouldn't be able to bring up the menu using the normal method. Is there a workaround that I could use to do it? I've tried binding it to other keys and it doesn't help, but then again I don't know the internal names of the keys.

Share this post


Link to post
Share on other sites
1 hour ago, Hex3 said:

So I know that the Alt key doesn't work properly on KSP for Linux, so I wouldn't be able to bring up the menu using the normal method. Is there a workaround that I could use to do it? I've tried binding it to other keys and it doesn't help, but then again I don't know the internal names of the keys.

try right shift + 3

Share this post


Link to post
Share on other sites

This just randomly stopped working right after I tried to get it to work. I've tried uninstalling the mod and re-installing it and Alt+3 does nothing anymore. Has that happened to anyone before?

Share this post


Link to post
Share on other sites
On 8/8/2019 at 11:51 AM, basila said:

try right shift + 3

oddly, it still doesn't work, but the files are definitely in my Gamedata folder. Maybe I'm having the same issue as MaianTrey.

Share this post


Link to post
Share on other sites
2 hours ago, Hex3 said:

oddly, it still doesn't work, but the files are definitely in my Gamedata folder. Maybe I'm having the same issue as MaianTrey.

yes. I've faced the same trouble, but after restart UI works fine. 

KS3P definitely need button in Toolbar. and I still don't understand how to save my setting - now i need to change everything manually after each start the game.

Share this post


Link to post
Share on other sites
3 hours ago, basila said:

yes. I've faced the same trouble, but after restart UI works fine. 

KS3P definitely need button in Toolbar. and I still don't understand how to save my setting - now i need to change everything manually after each start the game.

Try using the "export" function -- it creates a cfg that you can then use as your defaults.

Share this post


Link to post
Share on other sites

Fresh installed the mod, and alt+3 doesn't open anything for me either. I'm forcing glcore on my end though.

Share this post


Link to post
Share on other sites

Same. Fresh install. Unable to open KS3P in flight. Tried Alt 3, LeftShift 3, Rightshift 3.

Is there a way to just make whatever is in the config file just work without having to use the in game GUI?

Nothing opens it.

When I was on 1.7.0 KS3P worked perfectly (as part of Astronomers Visual Pack)

Help please?

Share this post


Link to post
Share on other sites

hey, I tried ks3p in 1.7.3, and it doesn't work. The file is just ignored completely! Could you please give me some advice on that?

Share this post


Link to post
Share on other sites
Posted (edited)

Having a problem over here, using 1.7.3. it loads, the menu opens but enabling anything just blackens the entire screen. Only the UI shows. Any fixes for that?

Edit: Nvm, it was a problem with TAA anti-aliasing. Working great!

Edited by Kradgger

Share this post


Link to post
Share on other sites
23 hours ago, Kradgger said:

Having a problem over here, using 1.7.3. it loads, the menu opens but enabling anything just blackens the entire screen. Only the UI shows. Any fixes for that?

Edit: Nvm, it was a problem with TAA anti-aliasing. Working great!

How do you open the console? Alt + 3 does nothing for me.

Share this post


Link to post
Share on other sites

This update has just ruined KS3P for me. Nothing works and when I click things in the menu nothing activates or changes. I tried making my own config only for KS3P to just stop working as a whole. And now my KSP doesnt even start up either. Was so much easier just to drag and drop someone elses config such as Orbital Phoenix's and have it work instantly. This is just extra hassle

Share this post


Link to post
Share on other sites
3 hours ago, Timanaku said:

This update has just ruined KS3P for me. Nothing works and when I click things in the menu nothing activates or changes. I tried making my own config only for KS3P to just stop working as a whole. And now my KSP doesnt even start up either. Was so much easier just to drag and drop someone elses config such as Orbital Phoenix's and have it work instantly. This is just extra hassle

Perhaps when The White Guardian implements all of his ambitious changes it will all be super duper, but right now its unworkable and broken. I even tried the previous version of KS3P and that doesnt work either.

I have just had to remove KS3P from the gamedata as nothing i do works :( 

@The White Guardian is there anything I can do to just get a Flight config working without being able to open the in game menu as Alt + 3 does not do anything for me.  It looked so so wonderful when your mod was working in the previous update

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.