whale_2

[1.3.1 - 1.7.x] WorldStabilizer - Bugfix for vessels bouncing on scene load

Recommended Posts

On 8/8/2018 at 3:12 PM, linuxgurugamer said:

Does anybody know if this is still needed in 1.4.5?

I am using 1.4.5 and well lots of things seem to want to spawn in at some height above where I parked them lol. But this IS with this mod installed so I cannot say for certain that what I am seeing is not as a result of THIS mod loading them in higher in order to lower them softly to the ground in order to avoid even bigger jumps.

Share this post


Link to post
Share on other sites
4 hours ago, Apaseall said:

I am using 1.4.5 and well lots of things seem to want to spawn in at some height above where I parked them lol. But this IS with this mod installed so I cannot say for certain that what I am seeing is not as a result of THIS mod loading them in higher in order to lower them softly to the ground in order to avoid even bigger jumps.

No, WS has nothing to do with loading, it kicks in after the vessel has been loaded.

6 hours ago, LatiMacciato said:

I haz a kwestion!

since KJR is officially outdated with KSP 1.4.5 is it wise to have is still with WS 0.9.2 or would that summon Kraken-like funny unwanted effects?

They should work quite independently from each other. If you experience any sort of Kraken with WS, please send the logfile and video, I'll look into this.

Besides, @linuxgurugamer's fork of KJR is reported to be working good.

Share this post


Link to post
Share on other sites
5 minutes ago, whale_2 said:

No, WS has nothing to do with loading, it kicks in after the vessel has been loaded.

plus KJR us unnecessary as far I noticed. Great Stuff!!
EDIT: I only use WS.

Edited by LatiMacciato

Share this post


Link to post
Share on other sites
1 hour ago, Autolyzed Yeast Extract said:

1.5 recompile time :D

Please keep in mind that what may seem like enthusiasm from your side can feel like a demand or even harassment from the other side. Asking for updates is fine, but repeating them, phrasing them brusquely, and using unusual fonts and text sizes can be taken the wrong way. 

Share this post


Link to post
Share on other sites

The question is, does it make sense for 1.5? Did Squad actually fix the problem or what? 

(I still play 1.3.1)

Share this post


Link to post
Share on other sites
1 hour ago, whale_2 said:

(I still play 1.3.1)

Me too, (when play at all). Have 1.4.x intalled for teting other mods only, but that one is on hiatus too.

There is info in KSP release notes that theys were fixed/tweaked landing gears and landing legs, to no longer bounce and explode etc.
Have yet to try stock 1.5 game first and then with mods. My "educated" guess would be that this mod is still quite useful even if no longer necessary due to different behaviour or aproach how to fix/workaround of that bug. I think that it is more unity game engine issue than too bad game design issue.

17 minutes ago, vicdoctor said:

For me it makes sense. The bounce is there and your mod solves it.

Does that mean that you tried version 1.4.x in KSP 1.5 ? Or you have recompiled for yourself and then tried it to see if works ?

Share this post


Link to post
Share on other sites

When it was still in version 1.5.0 it was all right, after version 1.5.1 returned to make the famous jumps. I want version 1.5.0 back!

Edited by Catatau_27

Share this post


Link to post
Share on other sites

Note that this plugin still did the trick for 1.4.5 without a recompile and you can adjust the WorldStabilizer.version file if the pop-up annoys you.

It's probably better if the author kicks the tires or whatever but in the meantime if you're still having problems with 1.5 it's worth a shot (I haven't upgraded yet, so no idea if this issue is resolved by the landing wheels fix or what).

Share this post


Link to post
Share on other sites

Just tried a couple different SPH creations, they all eased in nicely and no springiness. Seems to work well. Thanks @whale_2

Share this post


Link to post
Share on other sites

Depois de testar com os mods MNWS (Aero + Ship + Wepon) + trem de pouso ajustável + Worldstabilizer + Kerbalism, tudo vai para a estratosfera, e todo o save é comprometido, sou forçado a abrir um novo save, por sorte esta save usei teste . Todos os navios, edifícios e todo o planeta saem de órbita em algum lugar no vazio, depois disso não é possível retornar, não é possível rastrear uma vez que tudo desaparece no mapa. A visão da base é como se fosse à noite, mas é uma noite infinita. Este é o bug mais bizarro que eu já vi nesta versão do jogo, eu já vi isso antes em outras versões, sempre que eu configuro um porta-aviões para pousar meus aviões no oceano, isso acontece e eu preciso começar mais de 0. Eu uso muitos mods, mas vou enviar o log do que aconteceu. @whale_2

 

Log:  https://drive.google.com/open?id=1ljiK2UdGdr46ndxEV3QA_XD5v6p8f4AL

Edited by Catatau_27

Share this post


Link to post
Share on other sites

Hey @Catatau_27, I've briefly looked through your log file, it doesn't seem like WordStabilizer doing something nasty there, but anyway I suggest trying without WordStabilizer. 

Edited by whale_2

Share this post


Link to post
Share on other sites

Besides, BDArmory folks clearly state that WorldStabilizer is not compatible with BDA (Physics Range Extender in particular), they are doing some their own black magic.

(Written right there on the mod page with big scary letters)

Share this post


Link to post
Share on other sites
28 minutes ago, whale_2 said:

Hey @Catatau_27, I've briefly looked through your log file, it doesn't seem like WordStabilizer doing something nasty there, but anyway I suggest trying without WordStabilizer. 

 

16 minutes ago, whale_2 said:

Besides, BDArmory folks clearly state that WorldStabilizer is not compatible with BDA (Physics Range Extender in particular), they are doing some their own black magic.

(Written right there on the mod page with big scary letters)

If I take the World Stabilizer, everything will jump like the universe is a trampoline. : / In version 1.5.0 I was not using it since it was not necessary, but when it jumped to 1.5.1 it is impossible to stay on the ground without shaking. I would like to have version 1.5.0 back without this update to 1.5.1.

The problem is that I like to shoot the BDA, and everything was working perfectly in version 1.5.0, after the update I had to use the World Stabilizer.

Share this post


Link to post
Share on other sites

Neither 1.5.0 nor 1.5.1 are suggested to be used.
Wait for 1.5.2 and see if this will be a fix or "just another hotfix".

Share this post


Link to post
Share on other sites
7 hours ago, Catatau_27 said:

snip

Please remember to post in English outside of the International subforum. 

Share this post


Link to post
Share on other sites

This mod continuously stops working when I play for any period around the time of 30 minutes +

I've tested with other mods and without, and even a fresh install, i've got no idea why this happens and it is extremely annoying.

does anyone have any suggestions?

I have 16gb of system so this is unlikely to be a memory problem.

Edited by RB101

Share this post


Link to post
Share on other sites
14 hours ago, RB101 said:

This mod continuously stops working when I play for any period around the time of 30 minutes +

I've tested with other mods and without, and even a fresh install, i've got no idea why this happens and it is extremely annoying.

does anyone have any suggestions?

I have 16gb of system so this is unlikely to be a memory problem.

Well, this definitely doesn't happen to me, but I'm still on 1.3.1. Please, send me a logfile where it happens and if you can reproduce it with some minimal environment - not many mods and vessels, then save file as well.

Share this post


Link to post
Share on other sites

Discovered that this mod doesn't play nicely with the KIS/KAS mods. Especially with ground attached items such as ground bases (the surface experiments pack mod is also rendered un-usable, due to this mod) 

Could you put in a method to exclude vessels with surface attached parts from this mods effects completely please?

Thanks :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.