Jump to content

[1.3.1 - 1.8.x] WorldStabilizer - Bugfix for vessels bouncing on scene load


whale_2
 Share

Recommended Posts

On 11/24/2019 at 2:33 PM, OrbitsR4Sissies said:

Hey Whale.

Got a potential bug for you that anyone should be able to replicate. It may be that World Stabilizer works too well when it comes to Deployed Science parts.

...

I think the experiments will work OK now that the lander is gone and I'm out of physics range, but I will check and post what I see for you to consider later.

Yeah, seems like it is. Time to finally buy this DLC and fix it. Hopefully this week. 

On 11/24/2019 at 3:23 PM, Gordon Dry said:

This mod needs an exclusion list, not hardcoded, but as a config file inside a PluginData folder (so that MM does not read it but the mod itself).

Then problematic parts (or modules) can be blacklisted easily.
Best case would be if it's allright to just add an entry to that blacklist and after a scene change it already is read and WS knows about it. No need to reboot KSP then.

There's some sort of blacklist already, but for vessel names. Could be expanded to include PartModules too. Good point.

Link to comment
Share on other sites

@whale_2

Was testing a 1.8.1 install today, and ran into an odd problem.

In a career game, launching a mk1 pod to the initial launch pad would end up being said to be inflight.  The kerbal couldn't eva, I couldn't switch to another scene, etc.

No errors at all, was just unusable.

In another test on the main launchpad (fully upgraded in Sandbox mode), it was ok

 

i would also recommend removing the unBlur mod

Finally, could you install the full KSP-AVC mod and send me the log files after running the game with that?

 

Edited by linuxgurugamer
Link to comment
Share on other sites

On 11/28/2019 at 7:00 PM, linuxgurugamer said:

@whale_2

Was testing a 1.8.1 install today, and ran into an odd problem.

In a career game, launching a mk1 pod to the initial launch pad would end up being said to be inflight.  The kerbal couldn't eva, I couldn't switch to another scene, etc.

No errors at all, was just unusable.

 

Similar problem here.  1.8.1, Mk 1 pod on the runway (level 2), "in flight."  I could EVA (because I'd already upgraded the facilities to allow EVAs)-- what I was doing was planting a flag at both ends of the runway as markers-- and could not recover the spacecraft; status "in flight"/"moving"/"in atmosphere."   I did a temp save, exited the game, removed World Stabilizer, and restarted-- and then the capsule fell through the runway to the "surface" of Kerbin and exploded. (!)  Any part of the log I could provide that would be of assistance?

Edited by MaxwellsDemon
Link to comment
Share on other sites

I *think* this might help...

[LOG 12:27:30.378] [MessageSystem] Save Messages
[LOG 12:27:30.433] Game State Saved as persistent
[LOG 12:27:33.613] Unpacking Thoth Mockup
[LOG 12:27:33.616] WST: onVesselGoOffRails:0: off rails: mk1pod.v2: alt: 69.3725394621724; radar alt: 0.404832810163498; 	 alt: 69.3725394621724
[LOG 12:27:33.616] WST: onVesselGoOffRails:0: mission time: 0
[LOG 12:27:33.616] WST: onVesselGoOffRails:0: checking if we're inside the hangar
[LOG 12:27:33.618] WST: getClosestForeignPart:0: closest part for direction (0.0, 1.0, 0.0): , distance: 1000
[LOG 12:27:33.618] WST: getClosestForeignPart:0: closest part for direction (0.0, -1.0, 0.0): , distance: 1000
[LOG 12:27:33.618] WST: getClosestForeignPart:0: closest part for direction (-1.0, 0.0, 0.0): , distance: 1000
[LOG 12:27:33.618] WST: getClosestForeignPart:0: closest part for direction (1.0, 0.0, 0.0): , distance: 1000
[LOG 12:27:33.618] WST: getClosestForeignPart:0: closest part for direction (0.0, 0.0, -1.0): , distance: 1000
[LOG 12:27:33.618] WST: getClosestForeignPart:0: closest part for direction (0.0, 0.0, 1.0): , distance: 1000
[LOG 12:27:33.618] WST: checkIfInsideHangar:0: doesn't look like we're inside the hangar
[LOG 12:27:33.622] WST: findBoundPoints:0: vessel = mk1pod.v2; furthest downward part = mk1pod.v2; upward part = mk1pod.v2
[LOG 12:27:33.622] WST: findBoundPoints:0: vessel = mk1pod.v2; bottomLength = 0.4844045; bottomPoint = (-0.1, -0.2, -0.2); topLength = 0.6553763; topPoint = (-0.8, 0.0, 0.7)
[LOG 12:27:33.643] WST: stabilize:0: mk1pod.v2: timer = 100
[LOG 12:27:33.643] WST: findAnchoredParts:0: Looking for anchors in mk1pod.v2
[LOG 12:27:33.643] WST: findAnchoredParts:0: Found 0 anchors
[LOG 12:27:33.644] WST: restoreInitialAltitude:0: mk1pod.v2: initial alt: 69.3725394621724; current alt = 69.3725394621724; moving up by: 0
[LOG 12:27:33.645] WST: restoreInitialAltitude:0: mk1pod.v2: downward hit: UnityEngine.RaycastHit; collider = Kerbin Zn1232223233 (UnityEngine.MeshCollider)
[LOG 12:27:33.645] WST: restoreInitialAltitude:0: mk1pod.v2: no upward hit; moving up by 0.2 m just in case
[LOG 12:27:33.646] WST: stabilize:0: Stabilizing; v = mk1pod.v2; radar alt = 0.455048650503159; timer = 100
[LOG 12:27:33.658] WST: stabilize:0: mk1pod.v2: timer = 99
[LOG 12:27:33.658] WST: stabilize:0: mk1pod.v2: timer = 99; moving up
[LOG 12:27:33.659] WST: moveUp:0: mk1pod.v2: alt from top - height = 0.1768489; alt from top: (alt = 1.31663; collider = runway_collider); vessel height = 1.139781; minDownMovement = 0.1
[LOG 12:27:33.659] WST: moveUp:0: mk1pod.v2: minumum downmovement reached; alt from bottom: (alt = 1.31663; collider = runway_collider)
[LOG 12:27:33.659] WST: moveUp:0: mk1pod.v2; new alt = (alt = 0.1768489; collider = runway_collider); alt from top = (alt = 1.315942; collider = runway_collider)
[LOG 12:27:33.666] [UIMasterController]: ShowUI
[LOG 12:27:33.671] [BetterBurnTime] Current celestial body set to Kerbin
[LOG 12:27:33.671] [BetterBurnTime] Geosync altitude: 2863.334 km
[LOG 12:27:33.686] WST: stabilize:0: mk1pod.v2: timer = 98; moving down
[LOG 12:27:33.686] WST: moveDown:0: Recalculating bounds for vessel mk1pod.v2; id=74ed0cf2-e160-424a-bb3e-ef293c44503a
[LOG 12:27:33.687] WST: findBoundPoints:0: vessel = mk1pod.v2; furthest downward part = mk1pod.v2; upward part = mk1pod.v2
[LOG 12:27:33.687] WST: findBoundPoints:0: vessel = mk1pod.v2; bottomLength = 0.478124; bottomPoint = (-0.2, -0.2, -0.1); topLength = 0.6615918; topPoint = (-1.0, -0.1, 0.8)
[LOG 12:27:33.687] WST: moveDown:0: mk1pod.v2: raycast including parts; hit collider: (alt = 0.1763611; collider = runway_collider)
[LOG 12:27:33.687] WST: moveDown:0: Moving down: mk1pod.v2 by 0.07636113; alt = 0.1763611; timer = 98; radar alt = 0.654328882694244; alt from top = 1.315454
[LOG 12:27:33.688] WST: stabilize:0: mk1pod.v2: timer = 97; moving down
[LOG 12:27:33.688] WST: moveDown:0: Recalculating bounds for vessel mk1pod.v2; id=74ed0cf2-e160-424a-bb3e-ef293c44503a
[LOG 12:27:33.688] WST: findBoundPoints:0: vessel = mk1pod.v2; furthest downward part = mk1pod.v2; upward part = mk1pod.v2
[LOG 12:27:33.688] WST: findBoundPoints:0: vessel = mk1pod.v2; bottomLength = 0.4781438; bottomPoint = (-0.2, -0.2, -0.2); topLength = 0.6616023; topPoint = (-1.0, 0.0, 0.7)
[LOG 12:27:33.689] WST: moveDown:0: mk1pod.v2: raycast including parts; hit collider: (alt = 0.09931839; collider = runway_collider)
[LOG 12:27:33.689] WST: moveDown:0: downmovement for mk1pod.v2 is below threshold (0.09931839<0.1); leaving as is: 0.09931839
[LOG 12:27:33.718] WST: stabilize:0: mk1pod.v2: timer = 96; moving down
[LOG 12:27:33.718] WST: moveDown:0: Recalculating bounds for vessel mk1pod.v2; id=74ed0cf2-e160-424a-bb3e-ef293c44503a
[LOG 12:27:33.718] WST: findBoundPoints:0: vessel = mk1pod.v2; furthest downward part = mk1pod.v2; upward part = mk1pod.v2
[LOG 12:27:33.718] WST: findBoundPoints:0: vessel = mk1pod.v2; bottomLength = 0.4781439; bottomPoint = (-0.2, -0.2, -0.1); topLength = 0.661643; topPoint = (-0.9, -0.1, 0.8)
[LOG 12:27:33.718] WST: moveDown:0: mk1pod.v2: raycast including parts; hit collider: (alt = 0.09834274; collider = runway_collider)
[LOG 12:27:33.718] WST: moveDown:0: downmovement for mk1pod.v2 is below threshold (0.09834274<0.1); leaving as is: 0.09834274
[LOG 12:27:33.720] WST: stabilize:0: mk1pod.v2: timer = 95; moving down
[LOG 12:27:33.720] WST: moveDown:0: Recalculating bounds for vessel mk1pod.v2; id=74ed0cf2-e160-424a-bb3e-ef293c44503a
[LOG 12:27:33.720] WST: findBoundPoints:0: vessel = mk1pod.v2; furthest downward part = mk1pod.v2; upward part = mk1pod.v2
[LOG 12:27:33.720] WST: findBoundPoints:0: vessel = mk1pod.v2; bottomLength = 0.4781438; bottomPoint = (-0.2, -0.2, -0.2); topLength = 0.6616429; topPoint = (-0.9, -0.1, 0.8)
[LOG 12:27:33.720] WST: moveDown:0: mk1pod.v2: raycast including parts; hit collider: (alt = 0.09707302; collider = runway_collider)
[LOG 12:27:33.720] WST: moveDown:0: downmovement for mk1pod.v2 is below threshold (0.09707302<0.1); leaving as is: 0.09707302
[LOG 12:27:33.882] WST: stabilize:0: Stabilizing; v = mk1pod.v2; radar alt = 0.565278351306915; timer = 90
[LOG 12:27:34.144] WST: stabilize:0: Stabilizing; v = mk1pod.v2; radar alt = 0.529877901077271; timer = 80
[LOG 12:27:34.414] WST: stabilize:0: Stabilizing; v = mk1pod.v2; radar alt = 0.490906864404678; timer = 70
[LOG 12:27:34.682] WST: stabilize:0: Stabilizing; v = mk1pod.v2; radar alt = 0.451844274997711; timer = 60
[LOG 12:27:34.949] WST: stabilize:0: Stabilizing; v = mk1pod.v2; radar alt = 0.412842750549316; timer = 50
[LOG 12:27:35.217] WST: stabilize:0: Stabilizing; v = mk1pod.v2; radar alt = 0.405396401882172; timer = 40
[LOG 12:27:35.485] WST: stabilize:0: Stabilizing; v = mk1pod.v2; radar alt = 0.405426949262619; timer = 30
[LOG 12:27:35.749] WST: stabilize:0: Stabilizing; v = mk1pod.v2; radar alt = 0.405304878950119; timer = 20
[LOG 12:27:36.014] WST: stabilize:0: Stabilizing; v = mk1pod.v2; radar alt = 0.405304878950119; timer = 10
[LOG 12:27:36.226] WST: FixedUpdate:0: Stopping stabilizing mk1pod.v2
[LOG 12:27:41.005] [11/30/2019 12:27:41 PM [x] Science!]: <Trace> (StatusWindow) - ScienceThisBiome: 0 / 0
[WRN 12:27:42.011] [R&D]: No Experiment definition found with id ROCScience
[WRN 12:27:42.011] [R&D]: No Experiment definition found with id ROCScience
[WRN 12:27:42.011] [R&D]: No Experiment definition found with id ROCScience
[WRN 12:27:42.011] [R&D]: No Experiment definition found with id ROCScience
[WRN 12:27:42.011] [R&D]: No Experiment definition found with id ROCScience
[WRN 12:27:42.011] [R&D]: No Experiment definition found with id ROCScience
[WRN 12:27:42.013] [R&D]: No Experiment definition found with id ROCScience
[WRN 12:27:42.013] [R&D]: No Experiment definition found with id ROCScience
[WRN 12:27:42.013] [R&D]: No Experiment definition found with id ROCScience
[LOG 12:27:46.337] [11/30/2019 12:27:46 PM [x] Science!]: <Trace> (StatusWindow) - Finding Module for Science Report: crewReport
[LOG 12:27:46.337] [11/30/2019 12:27:46 PM [x] Science!]: <Trace> (StatusWindow) - Running Experiment crewReport on part mk1pod.v2
[LOG 12:27:46.339] [Experiments]: Setting FX Modules to 1...
[LOG 12:27:46.339] [Experiments]: FX Modules set: 1
[LOG 12:28:00.366] [SCANsat] Height Map Of [Minmus] Completed...
[LOG 12:28:00.465] [SCANsat] All Height Maps Generated
[LOG 12:28:46.960] Launcher here(in write): True
[LOG 12:29:23.490] [UIMasterController]: ShowUI
[LOG 12:29:23.491] Game Paused!
[LOG 12:29:23.492] [UIMasterController]: ShowUI
[LOG 12:29:23.492] [FlightGlobals]: Active Vessel is in atmosphere. Cannot save.
[LOG 12:29:29.854] 11/30/2019 12:29:29 PM,KerbalAlarmClock,AppLauncher: Destroying Button-Button Count:21
[LOG 12:29:29.855] ScaleModList: listSize 574 maxListSize 383
[LOG 12:29:29.855] ScaleModList: listSize 574 maxListSize 383
[LOG 12:29:29.857] ScaleModList: listSize 574 maxListSize 383
[LOG 12:29:29.858] ScaleModList: listSize 574 maxListSize 383
[LOG 12:29:29.858] ScaleModList: listSize 574 maxListSize 383
[LOG 12:29:29.866] [UIMasterController]: HideUI
[LOG 12:29:29.896] [HighLogic]: =========================== Scene Change : From FLIGHT to SPACECENTER (Async) =====================

 

Link to comment
Share on other sites

Hopefully, all the problems mentioned above have been fixed:

 

"Don't Break the Ground" Bugfix Release

 

Changes:

- Excludes for Parts and PartModules are now configurable (and ground experiments are excluded from stabilization; hope they can survive on their own)

- Minor stabilization logic tweak helped for that strange case with Mk1 capsule and Level 1-2 launchpad 

 

 

Quote

i would also recommend removing the unBlur mod

Finally, could you install the full KSP-AVC mod and send me the log files after running the game with that?

 

TBH, I can't grasp what I have to do with unBlur mod. 

Also, kindly asking to elaborate on that KSP-AVC stuff.

Thanks.

Edited by whale_2
Link to comment
Share on other sites

  • 4 weeks later...
On 12/8/2019 at 6:34 PM, whale_2 said:

.version updated

On 12/14/2019 at 10:03 AM, VoidSquid said:

CKAN still showing 0.9.6 as latest version.

I've downloaded the mod directly, no problem here. But others might rely on what CKAN displays.

Its due to CKAN pulling from Spacedock and at this time, the 0.9.7 version has not been uploaded to Spacedock.

Link to comment
Share on other sites

11 hours ago, archiebald said:

Forgive the ignorance but is there any reason why it can't be uploaded to Spacedock?

I think @whale_2 may have recently changed the way builds are done (looks like no moar batch compiling for backport releases, since 1.8.+ changed the API a lot, and the NET move from 3.5 to 4.+), and they may have just forgotten to upload it there?... vOv
...or perhaps they were waiting for some confirmation from the community that the latest update was fully working, before comitting an "official" update to SpaceDock?... some mod devs do that when they are unsure of whether bugfixes/new features are 100% working... vOv

Edited by Stone Blue
Link to comment
Share on other sites

On 1/9/2020 at 1:43 PM, Stone Blue said:

I think @whale_2 may have recently changed the way builds are done (looks like no moar batch compiling for backport releases, since 1.8.+ changed the API a lot, and the NET move from 3.5 to 4.+), and they may have just forgotten to upload it there?... vOv
...or perhaps they were waiting for some confirmation from the community that the latest update was fully working, before comitting an "official" update to SpaceDock?... some mod devs do that when they are unsure of whether bugfixes/new features are 100% working... vOv

You're totally right, uploaded most recent version to SpaceDock.

Link to comment
Share on other sites

  • 4 weeks later...

Hello

Have heard of converter making mining rover bouncing?

Even with the updated WorldStabilizer on 1.7.3, the rover bounces and stop as soon as I remove the converter...It must be the association of converter with another part or mod that make it bounce...

I do not know what to do...Is it because I hyper edit the rover o Eve to test it?

 

Link to comment
Share on other sites

1 hour ago, gilflo said:

Hello

Have heard of converter making mining rover bouncing?

Even with the updated WorldStabilizer on 1.7.3, the rover bounces and stop as soon as I remove the converter...It must be the association of converter with another part or mod that make it bounce...

I do not know what to do...Is it because I hyper edit the rover o Eve to test it?

 

That looks to me like collision issue, either, between craft parts and/or between craft and ground. Several things might be worth to try:

  1. Avoid cliping craft parts on craft
  2. More distance between wheels and drill
  3. higher clearance between ground and craft parts
  4. Try to test same craft on Kerbin, leave it somewhere, return back to KSC scene and then go back in "flight" to that rover, to see if it will bounce when scene is loaded

You could also discover some specific spot on EVE that might cause kraken forces, maybe to move rover away from that exact spot could help ?
Anyhow, I don't think there is issue with WorldStabilizer mod, rather something else that yet need to be narrowed down.

Link to comment
Share on other sites

@gilflo Indeed, as @kcs123 said - it's unlikely that bounce is related to WS. WS completely stops messing with the craft few seconds after the scene is loaded. 

I suggest trying to adjust spring/damper values or try adding KSPWheel mod - it changes wheel behaviour so can have some positive effect on this. 

Edited by whale_2
Link to comment
Share on other sites

  • 2 weeks later...

Hello and thanks for this mod, I still have this bug in 1.8 when using some other mods so its really helpful. I have a very long ship (100 meters or more) that I want to move around with bon voyage but it clips into the ground on load. I am wondering if I can single out ships to load in higher then normal or change something in the configs that might help.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...