Sign in to follow this  
Bottle Rocketeer 500

[Resolved] Attachment Node Not Working

Recommended Posts

 

This is my CFG, and I need a down-facing node. No matter how much I try, the node doesn't want to face downward:

Spoiler

PART
{
	name = Misc_NoseconeCargoBay
	module = Part
	attachRules = 1,0,1,1,0
	author = BottleRocketeer
	title = Mk.1 Cargo Bay
	description = For those who want to store stuff in their nose. Now in Mk.1!
	mesh = model.mu
	rescaleFactor = 1
	scale = 1
	CrewCapacity = 0
	TechRequired = aerodynamicSystems
	entryCost = 500
	cost = 400
	category = Utility
	subcategory = 0
	manufacturer = C7 Aerospace Division
	mass = 0.15
	maxTemp = 800
	PhysicsSignificance = 1
	bulkheadProfiles = size1
	crashTolerance = 40
	tags = nosecone request  kerbobulus miscellaneous
	node_stack_bottom = 0.0, -0.05, 0.0, -0.75, 0.0, 0.0, 1
	NODE
	{
		name = node_stack_top
		transform = node_top
		size = 0
		method = FIXED_JOINT
	}
	NODE
	{
		name = node_stack_attach
		transform = node_attach
		size = 0
		method = FIXED_JOINT
	}
	MODULE
	{
		name = ModuleAnimateGeneric
		animationName = door
		actionGUIName = Toggle Cargo Doors
		startEventGUIName = Open Cargo Doors
		endEventGUIName = Close Cargo Doors
	}
	MODULE
	{
		name = ModuleCargoBay
    		DeployModuleIndex = 1
    		closedPosition = 0
    		lookupRadius = .3125

    		nodeOuterForeID = top
    		nodeOuterAftID = bottom
		nodeInnerAftID = attach
	}
	
}

 

 

@CobaltWolf @Beale Maybe you could help?

Edited by Bottle Rocketeer 500

Share this post


Link to post
Share on other sites
1 hour ago, Bottle Rocketeer 500 said:

 

This is my CFG, and I need a down-facing node. No matter how much I try, the node doesn't want to face downward:

 

@CobaltWolf @Beale Maybe you could help?

Probably you need to change 

node_stack_bottom = 0.0, -0.05, 0.0, -0.75, 0.0, 0.0, 1

to

node_stack_bottom = 0.0, -0.05, 0.0, 0.0, -1.0, 0.0, 1

but, I don't understand the question fully.

Share this post


Link to post
Share on other sites
13 minutes ago, Beale said:

Probably you need to change 


node_stack_bottom = 0.0, -0.05, 0.0, -0.75, 0.0, 0.0, 1

to


node_stack_bottom = 0.0, -0.05, 0.0, 0.0, -1.0, 0.0, 1

but, I don't understand the question fully.

I'll try that.

EDIT: @Beale THANKS!!! It WORKS!

Edited by Bottle Rocketeer 500
  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this