Jump to content

[1.9.x] B.Dynamics - Retracting/vectoring engines, Critter Crawler


Recommended Posts

Originally by @BahamutoD, original thread is here: 

https://forum.kerbalspaceprogram.com/index.php?/topic/74412-10-bdynamics-retractingvectoring-engines-etc-v120-may-6/

There have been many requests over the years to get the Critter Crawler working again.

Your requests have now been answered.

Together with @Starwaster, the Critter Crawler is crawling out of the woodwork again. 

My thanks to @Starwaster, who responded to a request for a little help with a LOT of help

This includes the following parts:

  • XJ-48k Vector - 1.25m powerful turbojet with thrust vectoring.
  • Critter Crawler - hexapod rover body built to be able to go places that wheeled rovers can not.
  • MJ-88 Mini Vector - 0.625m  turbojet with an advanced thrust vectoring system.
  • R-RCS-B5 Retractable RCS Block (Flat) - Flat retracting RCS block 
  • VTx-202 Retractable Engine - A retractable dual nozzle, liquid fuel and oxidizer powered rocket engine.
  • ILX-40 Retractable Engine - a small Retractable rocket engine
  • ICU-360 Spotlight Turret - A spotlight which follows the mouse
  • TRR-1 Tiny Retractable Radial Engine Cluster

Availability

Dependencies

Featured in StarMod

 

The Critter Crawler needs the KSPWheel mod, the engines need the BDAnimationModules mod

And of course, a picture is worth a thousand words, have a few below:

Spoiler

PoshUnsightlyEquestrian.gif

UnequaledConsiderateAlligatorgar.gif

DefenselessSpectacularAnnelid.gif

 

Spoiler

 

Spoiler

 

 

Edited by linuxgurugamer
Link to post
Share on other sites

critter crawler is cool but I've always loved the retractable engines and RCS, great to have them back (officially - I think they were working before with the updated animation plugin). As always, great work LGG!

Edited by Drew Kerman
Link to post
Share on other sites
4 hours ago, Drew Kerman said:

critter crawler is cool but I've always loved the retractable engines and RCS, great to have them back (officially - I think they were working before with the updated animation plugin). As always, great work LGG!

Yes, they were, but I also did some updating of the cfg, including adding tags

Link to post
Share on other sites

New release, 1.3.1

  • Replaced TGA with DDS files

IMPORTANT - If installing by hand, you MUST delete the old directory before installing this, and then reinstall the BDAnimation mod again

Edited by linuxgurugamer
Link to post
Share on other sites

@linuxgurugamer 

Here you go, I tested it in a minimal install so the logs wouldn't be MASSIVE :P

https://www.dropbox.com/s/v14wni2wpyslnco/KSP.log?dl=0

https://www.dropbox.com/s/yly44t4rfflqkcl/output_log.txt?dl=0

 

Sigh... I reinstalled everything AGAIN... and now it works. But it didn't work for those logs.

KSP is making a liar out of me lately.

I am still curious as to what I had done wrong though, because I can't figure it out.

 

Wrong version of KSPWheel?

Edited by TheKurgan
Link to post
Share on other sites
20 minutes ago, TheKurgan said:

@linuxgurugamer 

Here you go, I tested it in a minimal install so the logs wouldn't be MASSIVE :P

https://www.dropbox.com/s/v14wni2wpyslnco/KSP.log?dl=0

https://www.dropbox.com/s/yly44t4rfflqkcl/output_log.txt?dl=0

 

Sigh... I reinstalled everything AGAIN... and now it works. But it didn't work for those logs.

KSP is making a liar out of me lately.

I am still curious as to what I had done wrong though, because I can't figure it out.

 

Wrong version of KSPWheel?

I'm glad you got it working.  Did you happen to keep the old install around?

Link to post
Share on other sites

Looks like something was off with KSPWheel, see these log entries:

Cannot find a PartModule of typename 'KSPWheelAnimationRemoval'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Cannot find a PartModule of typename 'KSPWheelDeployCollider'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Cannot find a PartModule of typename 'KSPWheelAnimation'
 
(Filename: C:/buildslave/unity/build/artifacts/generated/common/runtime/UnityEngineDebugBindings.gen.cpp Line: 42)

Cannot find a PartModule of typename 'KSPWheelMultiMotorUI

I'm guessing the wrong version of KSPWheel, those partmodules were added for the CritterCrawler

Link to post
Share on other sites

And one more thing.  I'm guessing you may have downloaded a dll only, because there is an AVC .version file which should be with the KSPWheel mod, which would be displayed in the log file, and I don't see it in the log file.

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...