linuxgurugamer

[1.8.x] Toolbar Controller (for modders)

Recommended Posts

A bug has been reported (and I confirmed) that the Toolbar button is not being displayed, but a small black box is.

This makes the toolbar unusable.

I am looking at it, but not sure what's going on yet

Share this post


Link to post
Share on other sites
4 hours ago, linuxgurugamer said:

A bug has been reported (and I confirmed) that the Toolbar button is not being displayed, but a small black box is.

This makes the toolbar unusable.

I am looking at it, but not sure what's going on yet

I don't know if another log would help your diagnostics but here's one anyway.

Log

Share this post


Link to post
Share on other sites

Thanks for the log, but in this case, i didn't need it.

I just released an update for the Blizzy toolbar which fixes the problem

For those interested, it was a result of a change in the way float comparisions were being done, and something which used to work was now broken

Share this post


Link to post
Share on other sites

New release, 0.1.9.3

  • Updated MiniAVC.dll to 1.4.0.2 to fix a nasty CTD
  • Some optimization work on related to the stock toolbar code, reduces the number of calls Unity makes every frame

Share this post


Link to post
Share on other sites

Hi, I'm having a weird issue.

I'm running KSP 1.6.1 for my Realism Overhaul playthrough, and CKAN installed Toolbar Controller 0.1.8.2, even though I notice it was said in a recent post that 0.1.7 is the release that should be for 1.6.1. Although the mod itself seems to be working, I am getting this spammed in console many many times per second that seems to be causing some lag: (pasting URL as for some reason the forums won't allow me to insert it from HTML)

https://imgur.com/2Lox8oS

 

CKAN gave me 1.7.19 version of the toolbar, which seems to be the correct one for 1.6.1

I did try manually replacing the Toolbar Controller version with 0.1.7 as the post said a couple of replies ago, but doing this stopped about half a dozen mods from showing up in the controller, most importantly Kerbal Construction Time, which then wouldn't show up on either toolbar and was spamming its own error in console about not being able to load something about the game state. Forgot to screenshot that one. So I changed back to the 0.1.8.2 version and everything is back to normal, including the error message spam I showed in the image above.

Is there a newer version of Blizzy Toolbar I should update to even though its for a newer version of KSP? I would like to get rid of the console messages :s 

 

Edited by PhilMcgroin
Spelling!

Share this post


Link to post
Share on other sites
1 hour ago, PhilMcgroin said:

Hi, I'm having a weird issue.

I'm running KSP 1.6.1 for my Realism Overhaul playthrough, and CKAN installed Toolbar Controller 0.1.8.2, even though I notice it was said in a recent post that 0.1.7 is the release that should be for 1.6.1. Although the mod itself seems to be working, I am getting this spammed in console many many times per second that seems to be causing some lag: (pasting URL as for some reason the forums won't allow me to insert it from HTML)

https://imgur.com/2Lox8oS

 

CKAN gave me 1.7.19 version of the toolbar, which seems to be the correct one for 1.6.1

I did try manually replacing the Toolbar Controller version with 0.1.7 as the post said a couple of replies ago, but doing this stopped about half a dozen mods from showing up in the controller, most importantly Kerbal Construction Time, which then wouldn't show up on either toolbar and was spamming its own error in console about not being able to load something about the game state. Forgot to screenshot that one. So I changed back to the 0.1.8.2 version and everything is back to normal, including the error message spam I showed in the image above.

Is there a newer version of Blizzy Toolbar I should update to even though its for a newer version of KSP? I would like to get rid of the console messages :s 

 

Log file, please.  I'll have to check to see what's going on with CKAN, and then maybe get out an update for the toolbarcontroller for KSP 1.7.3 and earlier

Share this post


Link to post
Share on other sites

https://drive.google.com/open?id=13pfs51psO1guAycSFO15NMccmYNTehBZ - Output_log.txt

https://drive.google.com/open?id=1WJEW-vGyrvNzIsmJsWp5sTZfJHBSLwAy - KSP.txt

Those are the logs with 0.1.8.2 installed, the one that works except for the console spam. If you want logs from having 0.1.7 installed that breaks everything let me know and I'll switch them back quickly and get those

Share this post


Link to post
Share on other sites
2 hours ago, PhilMcgroin said:

https://drive.google.com/open?id=13pfs51psO1guAycSFO15NMccmYNTehBZ - Output_log.txt

https://drive.google.com/open?id=1WJEW-vGyrvNzIsmJsWp5sTZfJHBSLwAy - KSP.txt

Those are the logs with 0.1.8.2 installed, the one that works except for the console spam. If you want logs from having 0.1.7 installed that breaks everything let me know and I'll switch them back quickly and get those

That Output_log.txt is from KSP 1.3.1:


[KSP Version]: 1.3.1.1891 (WindowsPlayer x64) (x64) en-us ==============================

 

I have an indication that you may have two copies of the ToolbarControl installed:

[LOG 09:04:55.633] ADDON BINDER: Create binding redirect: ToolbarControl, Version=0.1.7.0, Culture=neutral, PublicKeyToken=null => ToolbarControl, Version=0.1.8.2, Culture=neutral, PublicKeyToken=null

[LOG 09:04:55.698] ADDON BINDER: Create binding redirect: ToolbarControl, Version=0.1.6.17, Culture=neutral, PublicKeyToken=null => ToolbarControl, Version=0.1.8.2, Culture=neutral, PublicKeyToken=null

Or something else, I'm not sure.  I really need the correct output_log.txt

 

Edit:  From what I can tell, you have ToolbarController 0.1.8.2 installed, which is the last version for anything prior to 1.8

You have version 1.7.19 installed of the Blizzy toolbar, you need to install 1.7.22.2, you can get it here:

https://spacedock.info/mod/2090/Toolbar/download/1.7.22.2

or here:

https://github.com/linuxgurugamer/ksp_toolbar/releases/tag/1.7.22.2

 

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites
On 12/8/2019 at 12:52 PM, linuxgurugamer said:

That Output_log.txt is from KSP 1.3.1:

Well I'm a dummy. I didn't realize the location had moved to AppData. 

https://drive.google.com/open?id=13pfs51psO1guAycSFO15NMccmYNTehBZ

This is the actual one. However, I think it is now redundant as you managed to spot the issue even with the old log.

On 12/8/2019 at 12:52 PM, linuxgurugamer said:

I have an indication that you may have two copies of the ToolbarControl installed:

Probably also due to the wrong log, because there's definitely only one version in my gamedata folder

On 12/8/2019 at 12:52 PM, linuxgurugamer said:

You have version 1.7.19 installed of the Blizzy toolbar, you need to install 1.7.22.2, you can get it here

This upgrade fixed the problem, no more console spam. Looking for the right version was actually the first thing I tried, but the fact that CKAN had suggested 1.7.19, (and the fact that 1.7.22.2 said in its version file that was for 1.7.1 when I manually checked) threw me off the scent! 

So I guess something needs a slight tweak in whatever CKAN is tweaked by so that it spits out the correct one for 1.6.1

https://gyazo.com/a9e826d3b84e76301d6a0ce10e6945eb

 

Either way, the upgrade fixed it. Thanks so much for the help!

Edited by PhilMcgroin
I'm dumb and realized after I posted that output_log had moved houses!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.