UomoCapra

Kerbal Space Program Enhanced Edition Grand Discussion thread

Recommended Posts

1 hour ago, Arch3rAc3 said:

Devs, is there a way to use Radial preset with D-Pad up and down to fine control throttle (having LB/L1 + D-Pad Up/Down for Max/Minimal throttle instead)?

I've got used to the Radial preset and liked it better over the other two presets, seems easier to use, but not being able to control my throttle while turning the craft is a pain. Wish there was a way to change some key mappings.

Just normal up and down is max and min throttle.

Share this post


Link to post
Share on other sites

Plz need help i dont know how but i seem to have locked the staging. And have no clue how to unlock or weather this is a bug. Im on xbox. Any clues

Panic over found it dont know when i did it but holding LB and pressing A over the staging light locks and unlocks 

Edited by Danone xbox
Up date

Share this post


Link to post
Share on other sites
3 hours ago, AndyChilly said:

I'm hearing word that you can still get achievements using the debug menu...surely not????

Apparently yes and it's a known bug... 

Share this post


Link to post
Share on other sites

Any word on what the patch roll out programme for this is likely to be?

Its obviously been released with a few "known issues", which I assume were unfixable before it had to go for release, and you have to draw a line somewhere - but presumably work continued with a view to patch #1?

Since a few pretty basic control issues were discovered on the day of release can we assume these will also be fixed?

I notice the science tech tree has been adjusted from the previous console version, only seen the first few nodes due to the control failure within R&D in career mode - but from those first nodes it seems a lot more sensible - the ability to gather more basic science earlier is a plus

Share this post


Link to post
Share on other sites

Okay, so I found a huge design oversight. It's making it very difficult to play the game. Is there anyway to disable the trim command? (As in permently. Not LB+Left stick) Trim is hold LB, but you know what else is hold LB? Map and throttle controls. So know what happens evvery time you try to manouver? You set trim, causing your ship to fly wildly out of control. I need a way to disable trim, or set throttle controls and map to not be LB. 

Press LB to adjust your speed while landing, will set trim. You can't change position and throttle at the same time, or ship spirals off because it was just set to max yaw or something. It's quite annoying. Been save scuming for an hour, trying to land a craft on the moon. 

Edited by Omnifarious

Share this post


Link to post
Share on other sites
22 minutes ago, Omnifarious said:

Okay, so I found a huge design oversight. It's making it very difficult to play the game. Is there anyway to disable the trim command? (As in permently. Not LB+Left stick) Trim is hold LB, but you know what else is hold LB? Map and throttle controls. So know what happens evvery time you try to manouver? You set trim, causing your ship to fly wildly out of control. I need a way to disable trim, or set throttle controls and map to not be LB. 

Press LB to adjust your speed while landing, will set trim. You can't change position and throttle at the same time, or ship spirals off because it was just set to max yaw or something. It's quite annoying. Been save scuming for an hour, trying to land a craft on the moon. 

This

 

Trim is very useful, but needs to be separate controls, that nudge it gradually in a desired direction, not something thats easy to set accidentally and essentially impossible to quickly make a fine adjustment to, while flying the craft.

 

Not yet seen a flight sim that uses the primary flying controls (joystick & throttle) for trim adjustments

Share this post


Link to post
Share on other sites
1 hour ago, Omnifarious said:

Okay, so I found a huge design oversight. It's making it very difficult to play the game. Is there anyway to disable the trim command? (As in permently. Not LB+Left stick) Trim is hold LB, but you know what else is hold LB? Map and throttle controls. So know what happens evvery time you try to manouver? You set trim, causing your ship to fly wildly out of control. I need a way to disable trim, or set throttle controls and map to not be LB. 

Press LB to adjust your speed while landing, will set trim. You can't change position and throttle at the same time, or ship spirals off because it was just set to max yaw or something. It's quite annoying. Been save scuming for an hour, trying to land a craft on the moon. 

Thanks for the clear description. Not having the console version, I was trying to understand exactly why trim was coming up as such a frequent problem, and you laid it out nicely. Luckily this sort of thing should be easy to fix, just tweak the control scheme slightly. Nowhere near as complex as an unpredictable save corruption issue, for example.

Share this post


Link to post
Share on other sites

I'll' file a bug report when I have more info on this, but I've encountered the menu locking up, not allowing me to save problem again. I had just finished landing on Kerbin, after heading to the Mun to retrieve Jeb from a previous mission. (fuel tanks destroyed by the trim issue) When I went to recover the vessel, I was unable to. The "A" button didn't do anything. "A" would not work for anything that involved the game saving. Quicksave, quit to menu, recover, space center, tracking station, etc. I was forced to either load a quicksave, or exit to dashboard, potentially loosing data. Well, I mean I did loose progress, but I lost my entire save yesterday when this happened for the first time and I exited to dashboard. No idea what is causing this issue. I tried EVAing, getting to land, floating in water, switching vessels, (As in, go from kerbal to ship, since I couldn't access the tracking station.) etc. I eventually gave up, and am re-getting Jeb again. This time, I have a huge base of like 20m for my lander, to avoid the trim issue, lol.

Also can someone please tell me how to physics warp? I can only find the time warp options, which means no acclerating the game while preforming a manouver. Sitting through 5-20 minute burns in real-time is not fun, lol.

Edited by Omnifarious

Share this post


Link to post
Share on other sites

Also, also, how do I get things to align with the move tool? In the old version of KSP, any items you selected and moved with the move tool, would snap to a set grid. Now, when items are moved in move mode, they still snap, but the grid they snapped to, is based on where you initially placed item, making it all but impossible to allign different items. (I.e. it's very difficult to make a rover, as the seperate wheels are all on varying heights/widths.)

Share this post


Link to post
Share on other sites

Overall, I'm finding I prefered the previous incarnation of KSP for controls. I can't even use the cursor to adjust parts, it can only be done with the thumbsticks. Finding lots of trouble doing basic tasks, like placing parts, and flying the craft, that I had not problem doing in the previous version.

Share this post


Link to post
Share on other sites

In terms of performance, this version is vastly superior, but in terms of controls, well. If a KSP veteran is finding themselves fumbling around not even being able to align parts during the building phase, I can only image how someone new to the series will fair. The game itself is quite fun, but I'm having huge amounts of frustration derive from the controls, or lack thereof. (like previous control methods not present in the new version) Sure, some of it is probably on me, (like not being able to figure out how to physics warp, as I image that has to be in the game, as time warp is) but the rest is purly the controls fighting me at every turn. 

Share this post


Link to post
Share on other sites
21 minutes ago, Omnifarious said:

In terms of performance, this version is vastly superior, but in terms of controls, well. If a KSP veteran is finding themselves fumbling around not even being able to align parts during the building phase, I can only image how someone new to the series will fair. The game itself is quite fun, but I'm having huge amounts of frustration derive from the controls, or lack thereof. (like previous control methods not present in the new version) Sure, some of it is probably on me, (like not being able to figure out how to physics warp, as I image that has to be in the game, as time warp is) but the rest is purly the controls fighting me at every turn. 

Which control scheme are you using?  I use the radial and after a little time adjusting and learning the new layout  I've come to like them a lot.   I haven't tried the curser scheme, but they say it's pretty much the controls from the old version.  Maybe give that shot (unless of course that's the controls you're using).

Edited by OrganizedChaos

Share this post


Link to post
Share on other sites

I've been using the Simplified control scheme, and it took me a bit of time, but after getting used to it I like it for the most part. I have encountered a few issues, which I've logged to the bug tracker:

Controls become unresponsive using Simplified control scheme
Camera resets position/zoom in Simplified control scheme
Inconsistent navigation in Simplified control scheme
"Look around" doesn't always work in Simplified control scheme
Missing controls in Simplified control scheme
Cannot open radial menu when part action window is open in Simplified control scheme

Also, a bit of feedback that is not specific to the Simplified control scheme:

Separate axis-inversion

Share this post


Link to post
Share on other sites

I absolutely love KSP and have been waiting 2 years for this fix/update/whatever and put about 12 hours into my new career sence its re-release and just got this message when i went to load my game (Unable to load save MZRNCYBDSTD7ETLHWYY2ZVEVSG) has this happened to anyone else and or can someone please help!

Edited by GriffKiller

Share this post


Link to post
Share on other sites

I still don't know the cause, but this is the 4th time being unable to save. This time, it happened while inside the tracking station. So my only option is to dashboard, as there is no option to load save in the tracking station.

I'm pretty impressed by the performance, though it takes loading a save to get the best out of it. (What I mean, is that a hundred piece rocket will run at 10FPS, and your game will stay like that, even when only the 40 piece lander is left, but if you load the game, you get back to 25FPS.) I've got a Minmus research base, like 40 parts or so, and I'm getting 25-30FPS. 12 solar panels, 12 landing gear, (It's a huge platform) hitchhikers, processing labs, numerous science devices, mutliple relays/attenae, 7 Kerbals, etc. Running smoothly. The old KSP version could barely handle my basic 3 solar panel research tower with one research item of each time. (1 thermometer, 1 goo canister, etc.) that was like 10 parts. Even ditched the rocket to save on FPS in old Kerbal. This station has 4,000 units of fuel, even. (Mission asked for that. I just wish it had a docking port, lol. I left on the mission before I unlocked docking ports. (They're like 300 science for the standard size, way down the line, and I prefer those over the jr. size you get right away.)

Share this post


Link to post
Share on other sites

Okay, I'm going to file a bug report now, on the 5th time encountering the no save bug, I lost my save data again. I was on year two, day 56, and my only save is now from Year 1, day 97. That was a very long time ago, probably like 10-15 hours.

Share this post


Link to post
Share on other sites
17 hours ago, Shammie said:

Apparently yes and it's a known bug... 

One of many

11 hours ago, Omnifarious said:

Overall, I'm finding I prefered the previous incarnation of KSP for controls. I can't even use the cursor to adjust parts, it can only be done with the thumbsticks. Finding lots of trouble doing basic tasks, like placing parts, and flying the craft, that I had not problem doing in the previous version.

Previous version had bugs, but at least the basics actually worked most of the time

how an 18 month cycle can produce this edition that’s got all the bugs of the previous one and more is beyond me

Share this post


Link to post
Share on other sites
9 hours ago, Omnifarious said:

I still don't know the cause, but this is the 4th time being unable to save. This time, it happened while inside the tracking station. So my only option is to dashboard, as there is no option to load save in the tracking station.

I'm pretty impressed by the performance, though it takes loading a save to get the best out of it. (What I mean, is that a hundred piece rocket will run at 10FPS, and your game will stay like that, even when only the 40 piece lander is left, but if you load the game, you get back to 25FPS.) I've got a Minmus research base, like 40 parts or so, and I'm getting 25-30FPS. 12 solar panels, 12 landing gear, (It's a huge platform) hitchhikers, processing labs, numerous science devices, mutliple relays/attenae, 7 Kerbals, etc. Running smoothly. The old KSP version could barely handle my basic 3 solar panel research tower with one research item of each time. (1 thermometer, 1 goo canister, etc.) that was like 10 parts. Even ditched the rocket to save on FPS in old Kerbal. This station has 4,000 units of fuel, even. (Mission asked for that. I just wish it had a docking port, lol. I left on the mission before I unlocked docking ports. (They're like 300 science for the standard size, way down the line, and I prefer those over the jr. size you get right away.)

So what ur saying is that KSP is still broken? I Cant even load my profile, super aggravating i really dont wanna give up on this game its hands down one of my favorites but idk how many more times i can restart this flipping game before i cant even look at it anymore :(.

Share this post


Link to post
Share on other sites

anyone else finding the crew hatch onthe  mk1 command pod has WAYYYYY to big of a click box?   Im triyng to gather low orbit eva reports, and constantly while my cursor is over my kerbal, it selects the hatch instead, even if im looking away from it with the cursor touching mostly black space.  i have also hit it THROUGH the mk1 command pod, as i was trying to get a crew report, and when i clicked on the back, the crew hatch opened.

 

this is especially frustrating as to close the crew hatch window you have to press O which will also cause you to re enter the ship.   its utterly terrible.

Share this post


Link to post
Share on other sites
56 minutes ago, DD_bwest said:

anyone else finding the crew hatch onthe  mk1 command pod has WAYYYYY to big of a click box?   Im triyng to gather low orbit eva reports, and constantly while my cursor is over my kerbal, it selects the hatch instead, even if im looking away from it with the cursor touching mostly black space.  i have also hit it THROUGH the mk1 command pod, as i was trying to get a crew report, and when i clicked on the back, the crew hatch opened.

 

this is especially frustrating as to close the crew hatch window you have to press O which will also cause you to re enter the ship.   its utterly terrible.

I noticed this same problem. Happens when anything at all is near a place that a Kerbal can enter. Trying to gather temperature readings, or goo data? The crew transfer window pops up...

Share this post


Link to post
Share on other sites
On 17/01/2018 at 2:29 AM, JackFlash81 said:

Anyone else have issues with their ship spinning out of control when you go EVA w/o a probe core that has SAS?  I get that SAS is shut off when the pilot leaves, and that in real life I'm sure we don't really do EVAs with one person on a ship.  My fix is to use the probe core, but was wondering if others had better ideas.

Yeah I had this a few times also. Its because you are accidentally setting trim. Next time before you leave command pod have a look at control indicator (bottom left) and if you see a purple/pink marker there then you just need to reset trim (LB+A, on xbox cursor mode)

Hope this helps i didnt even know trim was a thing until this new port. However now that I do it will come In handy for flying planes.

Share this post


Link to post
Share on other sites

So after people complaining about game breaking bugs and save corruptions, I’m back to holding off my career mode until this is fixed and confirmed to be fixed.

its disheartening to be honest, it really is, im in a ridiculous situation where i now have 2 buggy games in which I don’t trust the programming enough to launch myself into a full career mode for fear of losing progress.

and I know developers are getting annoyed with people like me who are providing problems not solutions, but that’s really not our job. They are paid to test,, test and test again. But we are expected to pay for the game to test test and test again and then provide them with a detailed report including attempts to work around it.

your argument could be that as I owned the game before I should be grateful to have this version for free and not complain but if you go into a tv shop and pay full price for a tv which only shows half the picture, and they say ‘sorry keep that broken one and you can have this one for free’ and you take it home and it also only shows half the picture. You are still gonna feel cheated.

and after 2016’s ‘bug fixing patch’ that really did nothing. I’ve decided not to get my hopes up and will be happy to be called out as a moany git if this does get sorted.

Share this post


Link to post
Share on other sites
10 hours ago, AndyChilly said:

So after people complaining about game breaking bugs and save corruptions, I’m back to holding off my career mode until this is fixed and confirmed to be fixed.

its disheartening to be honest, it really is, im in a ridiculous situation where i now have 2 buggy games in which I don’t trust the programming enough to launch myself into a full career mode for fear of losing progress.

and I know developers are getting annoyed with people like me who are providing problems not solutions, but that’s really not our job. They are paid to test,, test and test again. But we are expected to pay for the game to test test and test again and then provide them with a detailed report including attempts to work around it.

your argument could be that as I owned the game before I should be grateful to have this version for free and not complain but if you go into a tv shop and pay full price for a tv which only shows half the picture, and they say ‘sorry keep that broken one and you can have this one for free’ and you take it home and it also only shows half the picture. You are still gonna feel cheated.

and after 2016’s ‘bug fixing patch’ that really did nothing. I’ve decided not to get my hopes up and will be happy to be called out as a moany git if this does get sorted.

not sure how anyone other than the developers can provide "solutions" to non-functioning game code really, I guess we should be "happy" we have been "allowed" to function as paying beta testers.

You sell a product, you have a basic responsibility to make sure its functional, this mean the various buttons, bells and whistles actually work as the game advertises they work.

Weirdly this even applies to software, if a button doesn't work - make it invisible and disable it in code, then remove references and instructions about it, patch it later when it works.

 

Have now found a whole range of problems, I've only played for a few hours, I now have very little confidence in the QA process that has been followed here, have little faith that there is any point continuing until this is fixed. This is a game that should be wonderful, it should be addictive - instead its just frustrating and broken.

Wondering on just trying to get a refund from microsoft... and not wasting any more of my time on this

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.