• 0
claclawolverine

ksp keeps freezing for 1 second every 5 or 6 seconds

Question

hi, i've tried every solution i've found on forums and posts everywhere i looked, but all of them seem to not work. i tried even to uninstall ksp (latest version, 1.3.1 64 bits) and reinstalling it, i tried to uninstall most of the mods, but the issue stays, it freezes for less time but still freezes, sometimes even every 2 seconds or so, in every part of the game (KSC, VAB, space, thrusting, not thrusting, reentry etc.). memory usage doesn't seem to be the cause of the problem, because with alt+F12 i can see that there are 1700 MB occupied while i have 16 GB RAM. i tried to modify the graphics configuration and it seems to have no effect whatsoever, both modifying the resolution or settings like anti-aliasing or v-sync, i tried even forcing the program to use opengl or setting the graphics from the nvidia panel following the guide provided by the community. i tried also to set the affinity of the processor to the game to prevent it from running on processor 0 but it had no effect. these are the specifics of my computer.

 

Operating System: Windows 10 Home 64-bit (10.0, Build 16299) (16299.rs3_release.170928-1534)

System Manufacturer: Notebook                        
             System Model: P65_P67RGRERA
                     BIOS: 1.05.13
                Processor: Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz (8 CPUs), ~2.6GHz
                   Memory: 16384MB RAM

 DirectX Version: DirectX 12

Card name: NVIDIA GeForce GTX 970M
        Manufacturer: NVIDIA
           Chip type: GeForce GTX 970M
            DAC type: Integrated RAMDAC
             Display Memory: 11141 MB
    Dedicated Memory: 3038 MB
       Shared Memory: 8102 MB

 

 

 

 

this is the list of mods i've installed. i installed them one by one with CKAN and there were no errors in installing or loading them from the module manager. all the mods are up to date today 17/01/2018

 

{
            "name": "TacAtomicClockIrradiated"
        },
        {
            "name": "TACLS"
        },
        {
            "name": "ModuleManager"
        },
        {
            "name": "CommunityResourcePack"
        },
        {
            "name": "BackgroundResources"
        },
        {
            "name": "AtmosphereAutopilot"
        },
        {
            "name": "WaypointManager"
        },
        {
            "name": "AGExt"
        },
        {
            "name": "xScience"
        },
        {
            "name": "ConfigurableContainers-Core"
        },
        {
            "name": "SolarScience"
        },
        {
            "name": "SCANsat"
        },
        {
            "name": "RealChute"
        },
        {
            "name": "RealScaleBoosters"
        },
        {
            "name": "SafeChute"
        },
        {
            "name": "B9PartSwitch"
        },
        {
            "name": "KerbalAtomics-NFECompatibility"
        },
        {
            "name": "NearFutureConstruction"
        },
        {
            "name": "NearFutureElectrical"
        },
        {
            "name": "NearFutureElectrical-Core"
        },
        {
            "name": "NearFutureLaunchVehicles"
        },
        {
            "name": "DeployableEngines"
        },
        {
            "name": "NearFuturePropulsion"
        },
        {
            "name": "NearFutureSolar"
        },
        {
            "name": "NearFutureSolar-Core"
        },
        {
            "name": "CryoTanks"
        },
        {
            "name": "CommunityTechTree"
        },
        {
            "name": "AT-Utils"
        },
        {
            "name": "CommunityCategoryKit"
        },
        {
            "name": "ContractConfigurator"
        },
        {
            "name": "Toolbar"
        },
        {
            "name": "FirespitterCore"
        },
        {
            "name": "GroundConstruction"
        },
        {
            "name": "GroundConstruction-Core"
        },
        {
            "name": "Konstruction"
        },
        {
            "name": "RN-SPP"
        },
        {
            "name": "UKS"
        },
        {
            "name": "USI-ART"
        },
        {
            "name": "USI-Core"
        },
        {
            "name": "USI-EXP"
        },
        {
            "name": "USITools"
        },
        {
            "name": "Hangar"
        },
        {
            "name": "HangerExtenderExtended"
        },
        {
            "name": "Impact"
        },
        {
            "name": "ContractConfigurator-FieldResearch"
        },
        {
            "name": "ContractConfigurator-KerbinSpaceStation"
        },
        {
            "name": "ContractConfigurator-Tourism"
        },
        {
            "name": "Kerbalized-SpaceX"
        },
        {
            "name": "DockSafe"
        },
        {
            "name": "ExtraPlanetaryLaunchpads"
        },
        {
            "name": "FinalFrontier"
        },
        {
            "name": "HideEmptyTechNodes"
        },
        {
            "name": "Karbonite"
        },
        {
            "name": "KAS"
        },
        {
            "name": "KEI"
        },
        {
            "name": "KerbalInventorySystemNoFun"
        },
        {
            "name": "KerbalJointReinforcement"
        },
        {
            "name": "DMagicOrbitalScience"
        },
        {
            "name": "InfernalRobotics"
        },
        {
            "name": "TweakScale"
        },
        {
            "name": "TooManyOrbits"
        },
        {
            "name": "ToughLove"
        },
        {
            "name": "Trajectories"
        },
        {
            "name": "MechJebForAll"
        },
        {
            "name": "NehemiahMultiPurposeParts"
        },
        {
            "name": "NehemiahScienceCommon"
        },
        {
            "name": "OrbitalMaterialScience"
        },
        {
            "name": "NearFutureSpacecraft"
        },
        {
            "name": "NearFutureProps"
        },
        {
            "name": "KerbalAtomics"
        },
        {
            "name": "DynamicBatteryStorage"
        },
        {
            "name": "StateFundingContinued"
        },
        {
            "name": "DeepFreeze"
        },
        {
            "name": "EskandareHeavyIndustries"
        },
        {
            "name": "HeatControl"
        },
        {
            "name": "InterstellarFuelSwitch-Core"
        },
        {
            "name": "KIS"
        },
        {
            "name": "BetterBurnTime"
        },
        {
            "name": "REPOSoftTech-Agencies"
        },
        {
            "name": "RSSeaDragon"
        },
        {
            "name": "SpaceXLegs"
        },
        {
            "name": "SpaceY-Expanded"
        },
        {
            "name": "SpaceY-Lifters"
        },
        {
            "name": "CryoEngines"
        },
        {
            "name": "StationScienceContinued"
        },
        {
            "name": "USI-NuclearRockets"
        },
        {
            "name": "LandingHeight"
        },
        {
            "name": "NavballDockAlignIndCE"
        },
        {
            "name": "KSPInterstellarExtended"
        },
        {
            "name": "AmpYearPowerManager"
        },
        {
            "name": "CactEyeCommunity"
        },
        {
            "name": "ModularFlightIntegrator"
        },
        {
            "name": "KerbalAlarmClock"
        },
        {
            "name": "MemGraph"
        },
        {
            "name": "CameraFocusChanger"
        }

 

 

 

edit: i tried to uninstall the game, reinstall it and every time install a few mods and start the game to see if it would freeze in the ksc screen. to test it i tried to start a new game and move the camera constantly. i reinstalled all the mods without issues, so i loaded my save games again and tried to continue my game, and it started freezing again every few seconds. maybe the issue is the KSC in its most developed form? how can i fix this?

Edited by claclawolverine

Share this post


Link to post
Share on other sites

17 answers to this question

Recommended Posts

  • 0

FYI: Posting this in case someone found a workaround. I'm positive it's not due to mods issue. Though probably because using mods in general.

 

I think it's the CPU man. My PC is waaay lower than yours and I too have the same problem, albeit a bit lesser. Constant 30 fps (part count <100) with occasional freeze between 3-6 sec (everywhere, but mostly VAB/SPH when the part counts >80)

And this is my spec:

OS: Win7 64-bit               
Processor: Intel(R) Core(TM) i5 CPU —650 @ 3.20 GHz (4 CPUs), ~3.2GHz
Memory: 8192 MB

Card name: NVIDIA GeForce GT 710 v2  (MSI)
             Display Memory: 1736 MB
 

This was running on 100% (RAM) and 80% (CPU). Yes, 0 free capacity. Both in KSP 1.3.0. and 1.3.1. with gargantuan amount of mods (OPM, B9, OPT, basically MM patch around 33k). Except visual mods (scatterer, EVE, etc.).

Share this post


Link to post
Share on other sites
  • 0

First, a log file is needed.

Second, it looks like you are running pn a laptop of some kind, along with a large number of mods.

Hiw does the game rin without any mods installed?

Share this post


Link to post
Share on other sites
  • 0

Nope, it's a desktop. Without mods, perfectly fine, constant 100 fps (unless part count >200). As soon as I installed any function heavy mods (FAR, SCANsat, etc), my RAM usage boosted to 100%. Although I'm mostly fine with it. Except probably BDarmory because it has PhysicsRangeExtender dependency, which blows my rig right to 10 FPS.

Like I said, I didn't think it has anything to do with the game, probably because mods in general is eating processes. Which means, I suspect it's my hardware.

Share this post


Link to post
Share on other sites
  • 0

Oh, sorry. I thought you were the original poster.

Given the number of mods you run 8gig isn't enough.

Share this post


Link to post
Share on other sites
  • 0
On 1/17/2018 at 3:12 AM, claclawolverine said:

           Memory: 16384MB RAM

Please just say you have 16GB RAM so it's easier... :wink: 

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, Mrcarrot said:

Please just say you have 16GB RAM so it's easier... :wink: 

sorry XD i copied from dxdiag

 

On 21/1/2018 at 2:47 AM, linuxgurugamer said:

First, a log file is needed.

Second, it looks like you are running pn a laptop of some kind, along with a large number of mods.

Hiw does the game rin without any mods installed?

where do i find the log file? the game doesn't crash, so i don't have the error.log

yes, i run it on a laptop, i tried to expand the allocated memory with memgraph and the situation improved drastically. now it isn't perfectly fluid but it doesn't stop every few seconds anymore.

as i wrote, i tried to reinstall it from scratch, begin the game, move the camera around and see if it stuttered, then if not, install some mods and repeat. it went perfectly even when i finally reinstalled all the mods, but when i loaded my saved game it started stuttering again until the memgraph stuff that i mentioned before. it seemed that the problem was the advanced ksc in some way, i don't know. now i'm playing with the graphic options set to maximum performance through nvidia geforce experience, allocating 8 GB extra RAM via memgraph and it's playable. not perfect but fine.

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, claclawolverine said:

where do i find the log file? the game doesn't crash, so i don't have the error.log

<KSP Root Folder>/KSP.log

Share this post


Link to post
Share on other sites
  • 0
54 minutes ago, claclawolverine said:

where do i find the log file? the game doesn't crash, so i don't have the error.log

Read this BEFORE asking for supporthttp://forum.kerbalspaceprogram.com/index.php?/topic/83212-how-to-get-support-read-first/

Share this post


Link to post
Share on other sites
  • 0

I  had  this  problem  until  I  got  my 1050ti.

Other  than  that  I  have  no  idea, I  have  less  ram  and  a  crappier cpu.

 

Sorry  I'm  not much  help

Share this post


Link to post
Share on other sites
  • 0

I had the same issue, if the game runs for too long (especially if you have a bunch of mods) the game begins to do that.

Share this post


Link to post
Share on other sites
  • 0

Does anyone know what is the root cause? I started getting this after the last update. Prior to that the game was just silky smooth even after the odd extended day of putting together something massive in orbit. I have seen other posts about this being caused by the engine. I am running win10-64,  a i7. 3.6ghz, 24 go ram, a r9-380 4gb video card. I have been going around in circles looking for a fix.

Share this post


Link to post
Share on other sites
  • 0

It sounds like it might be a GC issue. You might check out MemGraph:

Do note that RAM available when you open the task manager is a poor metric: operating systems tend to leave occupied memory occupied, even when no longer strictly needed by the program that allocated it, because it takes CPU time to de-allocate that memory.

Share this post


Link to post
Share on other sites
  • 0
23 hours ago, Starman4308 said:

It sounds like it might be a GC issue. You might check out MemGraph:

Do note that RAM available when you open the task manager is a poor metric: operating systems tend to leave occupied memory occupied, even when no longer strictly needed by the program that allocated it, because it takes CPU time to de-allocate that memory.

i do have memgraph installed, as you can see from my mods list (second from the end) and i allocated 8 GB more to the game, but even so, the longer the game goes on, the more it stutters, even with more memory allocated.

 

p.s. what does GC stand for?

Share this post


Link to post
Share on other sites
  • 0

GC=graphic card

so that may be an overheating condition.. check with gpu-z.. also note northbridge chips get hot too. maybe its a temp thing?

Edited by Jammer-TD

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now