Jump to content
  • 3

All saved ships gone


Question

I'm so incredibly disappointed in this "enhanced" edition. I bought ksp on Xbox when it first came out. The port was terrible but I still put countless hours into it. I waited for 2 years for you all to fix the game but it's obvious this edition was never tested. 

I cannot save any ships.... At all. I hit save craft but they don't show up on the "open craft" screen. 

I'm playing KSP "enhanced" edition on an Xbox one X on the radial preset. 

Please fix this game......

 

 

Link to post
Share on other sites

11 answers to this question

Recommended Posts

  • 0
18 hours ago, TheDonutOfDeath said:

I'm so incredibly disappointed in this "enhanced" edition. I bought ksp on Xbox when it first came out. The port was terrible but I still put countless hours into it. I waited for 2 years for you all to fix the game but it's obvious this edition was never tested. 

I cannot save any ships.... At all. I hit save craft but they don't show up on the "open craft" screen. 

I'm playing KSP "enhanced" edition on an Xbox one X on the radial preset. 

Please fix this game......

 

 

I seriously doubt that it was not tested. Luckily a patch is planned soon.

Link to post
Share on other sites
  • 0

@TheDonutOfDeath We have recently identified an issue where craft files are lost, I would like to ask you a few things to confirm if it's the same issue you are experiencing.

How many craft files had you saved before the issue started manifesting approximately?

Did you shut down the game in a transition screen where the 'Loading' icon is displayed on the lower right?

Link to post
Share on other sites
  • 0
18 hours ago, Samssonart said:

@TheDonutOfDeath We have recently identified an issue where craft files are lost, I would like to ask you a few things to confirm if it's the same issue you are experiencing.

How many craft files had you saved before the issue started manifesting approximately?

Did you shut down the game in a transition screen where the 'Loading' icon is displayed on the lower right?

Surely you tested for that condition?

same as for “power cut” type conditions?

Link to post
Share on other sites
  • 0

@Samssonart

I have also recently encountered this bug unfortunately. After putting in dozens of hours of work into career mode, it's extremely frustrating.

It it helps, I'll describe how it happened.

First, I had about 10 or so saved ships. I didn't and have never turned the game off/quit in the middle of a loading screen (unless the game crashes).

I had just launched a large-ish ship (295 parts) into Orbit, planning on rendezvousing with it. After launch I went back to the Space Center and into the VAB. I launched another, identical ship (295 parts). While loading, the screen froze and the audio messed up (continuously repeating a short sound 20-30 times a second). After 10 or so seconds of this, the game crashed to the Xbox Home screen.

After restarting the game, I noticed all of my quicksaves were gone (with the exception of the Persistent). I then checked the VAB, and noticed that all of my ship saves were gone as well. At this point, the "Return to Space Center, Launch, New Craft, Open Craft, and Save Craft" options weren't greyed out yet. I tried making a small 3 part rocket and clicking Launch. Nothing happened. And now all of the previously mentioned buttons are greyed out. I can't do anything, even exit the VAB.

Restart the game. Load my Career Save. Enter VAB. Return to Space Center. Go back into VAB. All buttons mentioned greyed out. 

Very disappointed. I've encountered tons of other bugs but nothing like this.

*EDIT* : After reading some other reports of this issue (and trying to fix it so I can launch crafts again), I haven't been able to do anything that allows me to launch from the VAB. However, I can launch from the Space Hanger. Thought I would include this as it might help with narrowing the scope of this bug.

Edited by RecursivelyRecursive
Link to post
Share on other sites
  • 0
22 hours ago, RecursivelyRecursive said:

@Samssonart

I have also recently encountered this bug unfortunately. After putting in dozens of hours of work into career mode, it's extremely frustrating.

It it helps, I'll describe how it happened.

First, I had about 10 or so saved ships. I didn't and have never turned the game off/quit in the middle of a loading screen (unless the game crashes).

I had just launched a large-ish ship (295 parts) into Orbit, planning on rendezvousing with it. After launch I went back to the Space Center and into the VAB. I launched another, identical ship (295 parts). While loading, the screen froze and the audio messed up (continuously repeating a short sound 20-30 times a second). After 10 or so seconds of this, the game crashed to the Xbox Home screen.

After restarting the game, I noticed all of my quicksaves were gone (with the exception of the Persistent). I then checked the VAB, and noticed that all of my ship saves were gone as well. At this point, the "Return to Space Center, Launch, New Craft, Open Craft, and Save Craft" options weren't greyed out yet. I tried making a small 3 part rocket and clicking Launch. Nothing happened. And now all of the previously mentioned buttons are greyed out. I can't do anything, even exit the VAB.

Restart the game. Load my Career Save. Enter VAB. Return to Space Center. Go back into VAB. All buttons mentioned greyed out. 

Very disappointed. I've encountered tons of other bugs but nothing like this.

*EDIT* : After reading some other reports of this issue (and trying to fix it so I can launch crafts again), I haven't been able to do anything that allows me to launch from the VAB. However, I can launch from the Space Hanger. Thought I would include this as it might help with narrowing the scope of this bug.

The issue has been identified and fixed in one of the recent development builds. As soon as we finish squashing all the critical bugs we'll have a release candidate and a clearer idea of a patch date. 

Link to post
Share on other sites
  • 0
6 hours ago, Samssonart said:

The issue has been identified and fixed in one of the recent development builds. As soon as we finish squashing all the critical bugs we'll have a release candidate and a clearer idea of a patch date. 

That's great to hear! 

Any idea how the patch will affect my current Career save? As in, after the update will I be able to access my crafts/quicksaves (and Launch them of course) or do I need to start a new Career game? Assuming I'll have to start over again?

Link to post
Share on other sites
  • 0
17 hours ago, RecursivelyRecursive said:

That's great to hear! 

Any idea how the patch will affect my current Career save? As in, after the update will I be able to access my crafts/quicksaves (and Launch them of course) or do I need to start a new Career game? Assuming I'll have to start over again?

I'm not directly involved in the console development team, so take this with a grain of salt, but afaik saves of the current build will still work after the patch.

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...