• 0
JoeKerbalGuy

Game Breaking Bugs/glitches For Xbox One

Question

Hello, recently I have encountered two major bugs/glitches in my time on playing on Xbox One Enhanced Edition. More specifically, I encountered them in career.  The first bug I encountered was my ship spinning in space continuously even with SAS on. This seemed to happen most when I came out of time warp with the SAS on. It also happened near planetary bodies too, when landing. The ship would even spin if time warp wasn’t activated. I have no idea what caused this. The next bug I encountered is much more serious as it involved restarting entire missions. I had accepted multiple contracts in career, which I had finished (not together). When I had finished them however, I could not go back to VAB, Space Center, or Tracking Center. I could open the pause menu but couldn’t click on any of the options that would allow me to leave. This forced me to quit the game, losing some but not all progress for that mission. I believe this glitch in particular to be caused by the switching between vessels or leaving to go to the space center after the rocket was in space.

  • Like 1

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Im not sure if you are experienced player, so just a stupid question regarding the first one - did you have electic charge to rotate the ship, or is it possible you run out of juice and did not know you need it?

Share this post


Link to post
Share on other sites
  • 0
1 hour ago, JoeKerbalGuy said:

Hello, recently I have encountered two major bugs/glitches in my time on playing on Xbox One Enhanced Edition. More specifically, I encountered them in career.  The first bug I encountered was my ship spinning in space continuously even with SAS on. This seemed to happen most when I came out of time warp with the SAS on. It also happened near planetary bodies too, when landing. The ship would even spin if time warp wasn’t activated. I have no idea what caused this. The next bug I encountered is much more serious as it involved restarting entire missions. I had accepted multiple contracts in career, which I had finished (not together). When I had finished them however, I could not go back to VAB, Space Center, or Tracking Center. I could open the pause menu but couldn’t click on any of the options that would allow me to leave. This forced me to quit the game, losing some but not all progress for that mission. I believe this glitch in particular to be caused by the switching between vessels or leaving to go to the space center after the rocket was in space.

The not being able to leave glitch has happened to me as well. I would click on, say the SPH, and couldn't enter it, enter the RnD labs but not exit, and so on. I found that a mod I installed was the cause, but mods aren't available on consoles (yet), so it must have been a glitch. After quitting the game, and re loading it, did you experience the glitch again?

Edited by The_Cat_In_Space

Share this post


Link to post
Share on other sites
  • 0

Yeah the ship spinning when you Eva is most likely trim being set.

I also had this problem at first.

Basically on x box if you press LB and a control input (ie pitch down/up A bit you will see a pink/purple indicator on the control hud bottom left.

It effectively tells the ship /plane to keep pitching/rolling etc in the direction set (trim can be useful for flying  planes) 

So just do a quick check before you go Eva if you see the pink markers. Then press LB+A ( L1 +X, on ps4)to reset trim and it should stop the spinning.

Atleast that's what it is on cursor controls. 

Not sure a bout other controls schemes

But it will tell you on controls panel if  using different  control's.  Looking for set trim and reset trim.

Hope this helps. 

As to the other issue , I've had the same freezing of the game. A restart usually does help.

I would recommend making a save before every  mission and a  couple during the mission. 

Just helps to safeguard against crashes.

And effectively gives you a revert for each mission even if youve  had to turn it off /go to tracking centre etc

Share this post


Link to post
Share on other sites
  • 0

I've never encountered this glitch but I've encountered something similar randomly when playing career mode  it would block me from placing or moving parts in the rocket/plane builders I can still use menu features like launch the rocket or save the game but it won't let me move or place till I quit and start the game and its always random in my experience it happens every 1 to 6 trips to the rocket/plane builders it gets really annoying but its not that bad compared to your problem

Share this post


Link to post
Share on other sites
  • 0
21 hours ago, 99Problems said:

I've never encountered this glitch but I've encountered something similar randomly when playing career mode  it would block me from placing or moving parts in the rocket/plane builders I can still use menu features like launch the rocket or save the game but it won't let me move or place till I quit and start the game and its always random in my experience it happens every 1 to 6 trips to the rocket/plane builders it gets really annoying but its not that bad compared to your problem 

Sometimes I have a glitch where I load a rocket, but when I try to place the parts, it dosen't connect. Have to restart KSP

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now