Jump to content

[1.12] Stockalike Station Parts Redux (January 22, 2022)


Nertea
 Share

Recommended Posts

6 minutes ago, JUSTFoox said:

This mod has problems. How to solve problems?

 vl_qCi8u6XA.jpg?size=668x544&quality=95&

When you download this mod, there is a folder called "Extras" inside the main download. Inside "Extras," there is a folder called "Internals": you must manually put this folder inside "StationPartsExpansionRedux" if you want the IVA views.

It is done this way to save space (the IVA files are large and can decrease performance, many people prefer to play without them for that reason).

Link to comment
Share on other sites

22 minutes ago, lemon cup said:

When you download this mod, there is a folder called "Extras" inside the main download. Inside "Extras," there is a folder called "Internals": you must manually put this folder inside "StationPartsExpansionRedux" if you want the IVA views.

It is done this way to save space (the IVA files are large and can decrease performance, many people prefer to play without them for that reason).

Thanks.

Link to comment
Share on other sites

2 hours ago, BlackDinoShadows said:

I have a problem in the loading screen

it is written "loading part upgrade" please help me i'm stuck

in my gamedata file i deleted station part redux and the game runs normally

Welcome to the forums.

Could we see your log file, please; it might help.  See the topic below for guidance.

Also, how did you install and remove the mod?  Manually, not CKAN, I figure because you said "deleted" but it would be nice to be sure.

Edited by Brigadier
Added welcome
Link to comment
Share on other sites

I am also getting the exact same NRE spam in my logs with any of the 3 science lab parts.

Spoiler

Exception handling event onPartActionUICreate in class ModuleScienceLab:System.NullReferenceException: Object reference not set to an instance of an object
  at ModuleScienceLab.updateModuleUI () [0x00000] in <cd473063d3a2482f8d93d388d0c95035>:0 
  at ModuleScienceLab.onPartActionUI (Part p) [0x00025] in <cd473063d3a2482f8d93d388d0c95035>:0 
  at EventData`1[T].Fire (T data) [0x000b0] in <cd473063d3a2482f8d93d388d0c95035>:0 

NullReferenceException: Object reference not set to an instance of an object
    ModuleScienceLab.updateModuleUI () (at <cd473063d3a2482f8d93d388d0c95035>:0)
    ModuleScienceLab.onPartActionUI (Part p) (at <cd473063d3a2482f8d93d388d0c95035>:0)
    EventData`1[T].Fire (T data) (at <cd473063d3a2482f8d93d388d0c95035>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    UnityEngine.Debug:LogException(Exception)
    EventData`1:Fire(Part)
    UIPartActionWindow:CreatePartList(Boolean)
    UIPartActionWindow:UpdateWindow()
    UIPartActionController:UpdateActiveWindows()
    UIPartActionController:UpdateFlight()
    UIPartActionController:Update()

I believe that the issue is specifically related to the TacGenericConverters that are added to the part in the TAC patches (SSPXR-TACLS-00.cfg & SSPXR-TACLS-01.cfg) included with the mod. Removing the modules fixes the NRE spam.

Here is a super-simple patch to remove the converters that will "fix" the part until it can be diagnosed what about the converters is conflicting with the part.

@PART[sspx-science-1875-1,sspx-lab-375-1,sspx-lab-5-1]:FINAL
{
	!MODULE[TacGenericConverter],* {}
}

This removes the 3 life-support recyclers on those parts. Not critical in my opinion, and so still very playable without them for now.

*This may not fix crafts already in flight.

Link to comment
Share on other sites

Is it on purpose that installing this mod removes the mobile processing lab? its gone and my space station went with it. Even after removing the files (i installed the mod manually) i cannot find the part anymore. I also cant find an equivalent part from this mod to replace it.

Edited by Weegee_Spaghetti
Link to comment
Share on other sites

21 hours ago, BlackDinoShadows said:

I have a problem in the loading screen

it is written "loading part upgrade" please help me i'm stuck

in my gamedata file i deleted station part redux and the game runs normally

can i have some help ?

@Brigadier

This is a problem that occurs when you have two DLLs with the same name. It is a  known KSP and has nothing to do with this mod in particular. To solve it you can install zerominiavc and follow any advice it gives. Also, you can try with communityfixes. The first one in ckan an the other

 

Edited by Tacombel
Link to comment
Share on other sites

Which part(s)? What do you mean 'can't execute?

Pics? Video?

4 hours ago, Weegee_Spaghetti said:

Is it on purpose that installing this mod removes the mobile processing lab? its gone and my space station went with it. Even after removing the files (i installed the mod manually) i cannot find the part anymore. I also cant find an equivalent part from this mod to replace it.

AFAIK the mpl doesn't get removed. Also, there's plenty of other labs in this mod:sticktongue:

Link to comment
Share on other sites

48 minutes ago, modus said:

Which part(s)? What do you mean 'can't execute?

Pics? Video?

AFAIK the mpl doesn't get removed. Also, there's plenty of other labs in this mod:sticktongue:

What's their name? Cuz i looked through the search bar in sandbox aswell as the tech tree and nothing comes up when i search for the mpl or "lab", "science" or any similar phrases.

 

Edit: i maybe fixed it. I have 2 gamedata folders.

But now i am stuck with the "loading part upgrades" thing in the menu. Anyone know a fix maybe? It worked before i downloaded this mod.

 

Edit 2: Fixed it. I had duplicate dll. files. Downloaded ane xtra mod that fixes it.

Edited by Weegee_Spaghetti
Link to comment
Share on other sites

  • 2 weeks later...

Love this mod, just added it again. One question the it used to be two fixed 3.75 meter habitation modules in addition to the storm cellar who seems to be missing. 
They was nice for planetary bases, now its lots of new shiny stuff including 5 meter parts so if they are removed its not an huge deal but curious.

Link to comment
Share on other sites

I'm trying to run a minimal mod game, but am caving in to the need for the "service airlock" part I found very useful in previous games.  Are the "Scatter" service airlocks in this mod?  Sorry if wrong mod forum.  If there is a streamlined way to find what mod a given part is in, without installing said mod, I'd appreciate the education (in a PM is fine)  
I was directed to KerbalX site where a fairly complete search for parts can be done

Edited by darthgently
Link to comment
Share on other sites

5 hours ago, darthgently said:

I'm trying to run a minimal mod game, but am caving in to the need for the "service airlock" part I found very useful in previous games.  Are the "Scatter" service airlocks in this mod?  Sorry if wrong mod forum.  If there is a streamlined way to find what mod a given part is in, without installing said mod, I'd appreciate the education (in a PM is fine)  
I was directed to KerbalX site where a fairly complete search for parts can be done

Should be, yep. The small 1.25m version, and a larger 2.5m version with integrated docking port.

Link to comment
Share on other sites

Hi, I downloaded this mod a couple weeks ago and I love it, but I'm playing career mode and when I try to transmit processed science from the Fate deep space lab, it uploads and everything but doesn't give me the actual science. It shows the progress percentage and gives me a message when it's done but not the message telling me it's added the science. I have two of the stock processing labs on the same station and those work fine, so I've ruled out the issue being the antenna and/or connection. 

Apologies if this is an issue that has already been noted and solved.

Thanks

Link to comment
Share on other sites

19 hours ago, CS30 said:

Hi, I downloaded this mod a couple weeks ago and I love it, but I'm playing career mode and when I try to transmit processed science from the Fate deep space lab, it uploads and everything but doesn't give me the actual science. It shows the progress percentage and gives me a message when it's done but not the message telling me it's added the science. I have two of the stock processing labs on the same station and those work fine, so I've ruled out the issue being the antenna and/or connection. 

Apologies if this is an issue that has already been noted and solved.

Thanks

Are you using TAC Life Support as well? If so, I believe this is related to the NRE spam and I posted a patch that fixes this issue.

Link to comment
Share on other sites

On 12/22/2021 at 6:54 PM, Sandriell said:

Are you using TAC Life Support as well? If so, I believe this is related to the NRE spam and I posted a patch that fixes this issue.

I am using TAC Life Support, that must be the problem then...I took a look at the patch you linked and I'm clueless lol

I'm on Mac, where should I copy and paste that?

Thanks

Link to comment
Share on other sites

On 12/23/2021 at 9:09 PM, Thatsstoguy said:

I was looking for extraplanetary launchpads parts and I saw this. Is the cylinder on this a launchpad? If it is what mod is it from?

That open frame cylinder thingy is a space dock from Mark One Laboratory Extensions.

Link to comment
Share on other sites

On 12/28/2021 at 11:31 PM, Taaaa said:

Again,from a long time ago, the position of the outside airlock of sspx-habitation 375-1 and the position of the IVA airlock are greatly deviated by about 180 °.  Do you have any plans to fix this?

Zero.

On 12/22/2021 at 3:54 PM, Sandriell said:

Are you using TAC Life Support as well? If so, I believe this is related to the NRE spam and I posted a patch that fixes this issue.

Do I have to release something to fix this or is this on TAC?

Link to comment
Share on other sites

On 12/17/2021 at 6:56 AM, magnemoe said:

Love this mod, just added it again. One question the it used to be two fixed 3.75 meter habitation modules in addition to the storm cellar who seems to be missing. 
They was nice for planetary bases, now its lots of new shiny stuff including 5 meter parts so if they are removed its not an huge deal but curious.

Looks like the 3.75 m hab modules depended on KIS for some reason. 
Correction, it was simply that I had not researched them as they was an new node in the tech tree. 

Edited by magnemoe
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...