Jump to content

[1.12] Stockalike Station Parts Redux (June 12, 2022)


Nertea
 Share

Recommended Posts

5 hours ago, Navyjoker2000 said:

It makes sense to me. How would you observe an observation if there was not a body with eyes to do the observation? I put a scientist in the telescope before running the observation as more of an immersion thing. Plus like I said, it makes sense for it to be manned.

I'm not so sure.

Do Hubble,  James Webb and the  Parker Solar Probe come to mind, not to mention all of the Earth-facing weather satellites?   As long as there's an antenna on the telescope, data transmission shouldn't be a problem.

Link to comment
Share on other sites

Any plans to fix the greenhouses and aquaculture module for kerbalism compatiability? The models for the greenhouses in this are amazing and its kinda upsetting they dont give plant comfort or the aquaculture doesnt even do anything for life support in that

Edited by Starslinger999
Link to comment
Share on other sites

54 minutes ago, Starslinger999 said:

Any plans to fix the greenhouses and aquaculture module for kerbalism compatiability? The models for the greenhouses in this are amazing and its kinda upsetting they dont give plant comfort or the aquaculture doesnt even do anything for life support in that

Someone on the Kerbalism end would need to step up and do that. (meaning some volunteer would need to create the configs for it and do a PR to the current Kerbalism maintainer to have it included in that mod. Most of the KSP modding community has moved to that model.

Link to comment
Share on other sites

7 hours ago, panarchist said:

Someone on the Kerbalism end would need to step up and do that. (meaning some volunteer would need to create the configs for it and do a PR to the current Kerbalism maintainer to have it included in that mod. Most of the KSP modding community has moved to that model.

Ah I’ll ask there then

Link to comment
Share on other sites

On 9/29/2021 at 3:52 PM, PurpleOasis said:

Hi @Nertea,

I just updated to the latest version and whenever I run the "Observe Local Space" experiment on the Oculus telescope, I get an error message (see below). This did not happen to me in the previous version.

xrMX68p.png

This seems like a bug. The experiment requires the part to be manned but you can't put a kerbal into the part.

I changed usageReqMaskInternal = 5 to usageReqMaskInternal = 17 in Part//Rigid/station-5/sspx-cupola-telescope-125-1.cfg to fix it. That makes it require a scientist on the vessel.

Link to comment
Share on other sites

On 10/1/2021 at 10:32 AM, lukeduff said:

This seems like a bug. The experiment requires the part to be manned but you can't put a kerbal into the part.

I changed usageReqMaskInternal = 5 to usageReqMaskInternal = 17 in Part//Rigid/station-5/sspx-cupola-telescope-125-1.cfg to fix it. That makes it require a scientist on the vessel.

Thank you, lukeduff. Not sure how you figured it out, but this fixed the issue for me.

Link to comment
Share on other sites

Nevermind, misplaced.  
Getting this trying to update from CKAN (I'll post in that forum also). Not sure where the files are dished up from so not sure if CKAN or other problem

Error downloading StationPartsExpansionRedux 2.0.5: Ssl error:1000007d:SSL routines:OPENSSL_internal:CERTIFICATE_VERIFY_FAILED
  at /build/mono-6.12.0.107/external/boringssl/ssl/handshake_client.c:1132
Edited by darthgently
Link to comment
Share on other sites

12 minutes ago, jefferyharrell said:

Question for you @Nertea: I'm finally getting around to looking at your rotating structures. What's paragravity?

Probably means artificial gravity created by the giant centrifuges. Though, I think paragravity is used to refer to sci-fi artifical gravity.

Link to comment
Share on other sites

22 minutes ago, Luixuis said:

Probably means artificial gravity created by the giant centrifuges. Though, I think paragravity is used to refer to sci-fi artifical gravity.

The part action window makes reference to both rotational gravity and this "paragravity" thing. Which, yeah, as you say, may be sci-fi artificial gravity, since it consumes electric charge.

Link to comment
Share on other sites

Hello, I have tried this mod just now and I love the parts. However, it seems that the IVA is not working for me. I made a clean install of KSP (1.12.2.3167) and the only mods I have are Near Future Spacecraft and Stackalike Station Parts.

When place Kerbals into a habitat and switch to IVA, I only see black all aroud them. When I switch on interior overlay, black boxes appear inside the habitat. Can anybody help me with this or explain what I did wrong? Thank you.

http://fialky.eu/ksp/screenshot17.png

Link to comment
Share on other sites

1 hour ago, ondrafialka said:

Hello, I have tried this mod just now and I love the parts. However, it seems that the IVA is not working for me. I made a clean install of KSP (1.12.2.3167) and the only mods I have are Near Future Spacecraft and Stackalike Station Parts.

When place Kerbals into a habitat and switch to IVA, I only see black all aroud them. When I switch on interior overlay, black boxes appear inside the habitat. Can anybody help me with this or explain what I did wrong? Thank you.

http://fialky.eu/ksp/screenshot17.png

IVAs are a separate CKAN download

Link to comment
Share on other sites

I've been encountering an issue with the science lab parts, where they are unable to transmit their generated science. The transmission occurs as normal, consuming power and indicating the completion percentage, but when it reaches 100% the science remains in the lab. The other functions (science generation, TAC life support recyclers, etc.) seem to be unaffected.

 

These are the two errors that popped up while I interacted with the lab part. I can include the full log if it's helpful.

Quote

SSPX version 2.0.5, KSP version 1.12.2. Other mods are installed, but only stock/Restock/SSPX parts are present where the error occurs. ScienceAlert and [X] Science! were there originally, but the error still occurred when they were removed.
 

On opening part ui. A new error message seems to generate every tick that the ui is open. The log is filled with hundreds of identical error reports.

[ERR 16:24:57.654] Exception handling event onPartActionUICreate in class ModuleScienceLab:System.NullReferenceException: Object reference not set to an instance of an object
  at ModuleScienceLab.updateModuleUI () [0x00000] in <cd473063d3a2482f8d93d388d0c95035>:0
  at ModuleScienceLab.onPartActionUI (Part p) [0x00025] in <cd473063d3a2482f8d93d388d0c95035>:0
  at EventData`1[T].Fire (T data) [0x000b0] in <cd473063d3a2482f8d93d388d0c95035>:0

[EXC 16:24:57.656] NullReferenceException: Object reference not set to an instance of an object
    ModuleScienceLab.updateModuleUI () (at <cd473063d3a2482f8d93d388d0c95035>:0)
    ModuleScienceLab.onPartActionUI (Part p) (at <cd473063d3a2482f8d93d388d0c95035>:0)
    EventData`1[T].Fire (T data) (at <cd473063d3a2482f8d93d388d0c95035>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    UnityEngine.Debug:LogException(Exception)
    EventData`1:Fire(Part)
    UIPartActionWindow:CreatePartList(Boolean)
    UIPartActionWindow:UpdateWindow()
    UIPartActionController:UpdateActiveWindows()
    UIPartActionController:UpdateFlight()
    UIPartActionController:Update()

On completion of transmission.

[ERR 16:27:30.866] Exception handling event OnTriggeredDataTransmission in class ModuleScienceLab:System.NullReferenceException: Object reference not set to an instance of an object
  at ModuleScienceLab.updateModuleUI () [0x00000] in <cd473063d3a2482f8d93d388d0c95035>:0
  at ModuleScienceLab.OnTransmissionComplete (ScienceData data, Vessel origin, System.Boolean xmitAborted) [0x0004e] in <cd473063d3a2482f8d93d388d0c95035>:0
  at EventData`3[T,U,V].Fire (T data0, U data1, V data2) [0x000b0] in <cd473063d3a2482f8d93d388d0c95035>:0

[EXC 16:27:30.866] NullReferenceException: Object reference not set to an instance of an object
    ModuleScienceLab.updateModuleUI () (at <cd473063d3a2482f8d93d388d0c95035>:0)
    ModuleScienceLab.OnTransmissionComplete (ScienceData data, Vessel origin, System.Boolean xmitAborted) (at <cd473063d3a2482f8d93d388d0c95035>:0)
    EventData`3[T,U,V].Fire (T data0, U data1, V data2) (at <cd473063d3a2482f8d93d388d0c95035>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    UnityEngine.Debug:LogException(Exception)
    EventData`3:Fire(ScienceData, Vessel, Boolean)
    <transmitQueuedData>d__42:MoveNext()
    UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)

Edit:

On further testing, this seems to be an interaction between SSPX and TAC life support, discussion is ongoing in tac's release thread.

Edited by Red Dwarf
Link to comment
Share on other sites

  • 2 weeks later...

Hey guys... I installed this mod and I really love it.
I did inflate the centrifuge but I can't transfer any astronauts into it. It always told that I got not enough room for astronauts. 
Again, It's inflated already but astronauts can't move in. And I didn't install MKS at all.
Somebody helps me plz...

Link to comment
Share on other sites

20 hours ago, dan1ell1ma said:

Hello!

Incredible mod! I love it!

 

Please, i really dont know if this is intentional, but inside the dock ports don't have textures.

 

Sem-t-tulo.png

It's a part of the part that you'll only ever see if the docking port is completely detached from any other part on that side, which would mean the part it was attached to is destroyed. The other side of the docking port is where connections to other craft are made. As such, the missing area probably saved some work time for very little downside :P

Link to comment
Share on other sites

26 minutes ago, Tangle said:

It's a part of the part that you'll only ever see if the docking port is completely detached from any other part on that side, which would mean the part it was attached to is destroyed. The other side of the docking port is where connections to other craft are made. As such, the missing area probably saved some work time for very little downside :P

but I remember it having a backside, though yeah it doesn't make a huge difference

Link to comment
Share on other sites

On 10/19/2021 at 2:41 PM, QuQu said:

Hey guys... I installed this mod and I really love it.
I did inflate the centrifuge but I can't transfer any astronauts into it. It always told that I got not enough room for astronauts. 
Again, It's inflated already but astronauts can't move in. And I didn't install MKS at all.
Somebody helps me plz...

Somebody helps!

All the inflatable parts can be inflated by engineers but nobody can move in.

What should I do?

Link to comment
Share on other sites

Recently updated the mod and added the CKAN files like it says for IVA. I can move around and see in the parts but the seats and other props are missing from older versions. Did I download the IVA packs wrong or are the parts just going to be more bare? 

Either way, love the mod. Makes space station building a blast. 

Link to comment
Share on other sites

vasto has no oceans? the water is there but its invisible ash lava and rhode water is fine but no oceans on vasto... is this a kopernicus issue beyond home itself or is it the parralex ? my guess is parralax as ive had some new issues on the newest version of ksp.  the terrain does not match the ground in most places and so anything with a wheel becomes useless and the tyres spin like its floating.  this is a huge issue for me because it makes rovers wheeled bases or anything else wheel related useless. does anyone or the creator have any information about this? do i need to post logs for this?

Link to comment
Share on other sites

22 minutes ago, Aborted Yolk said:

vasto has no oceans? the water is there but its invisible ash lava and rhode water is fine but no oceans on vasto... is this a kopernicus issue beyond home itself or is it the parralex ? my guess is parralax as ive had some new issues on the newest version of ksp.  the terrain does not match the ground in most places and so anything with a wheel becomes useless and the tyres spin like its floating.  this is a huge issue for me because it makes rovers wheeled bases or anything else wheel related useless. does anyone or the creator have any information about this? do i need to post logs for this?

You posted in the wrong thread. This thread is a space station parts mod, not a planet mod.

Link to comment
Share on other sites

On 10/4/2021 at 4:06 PM, jefferyharrell said:

Question for you @Nertea: I'm finally getting around to looking at your rotating structures. What's paragravity?

Not mine. Maybe kerbalism or some other LS mod?

On 10/18/2021 at 11:41 PM, QuQu said:

Hey guys... I installed this mod and I really love it.
I did inflate the centrifuge but I can't transfer any astronauts into it. It always told that I got not enough room for astronauts. 
Again, It's inflated already but astronauts can't move in. And I didn't install MKS at all.
Somebody helps me plz...

Suspect you have KIS. Clear your Kerbals' inventories before moving them in.

On 10/19/2021 at 6:55 PM, dan1ell1ma said:

Hello!

Incredible mod! I love it!

 

Please, i really dont know if this is intentional, but inside the dock ports don't have textures.

 

Sem-t-tulo.png

Hmm. Investigation will happen.

On 10/22/2021 at 12:06 PM, JiffyCraft said:

Recently updated the mod and added the CKAN files like it says for IVA. I can move around and see in the parts but the seats and other props are missing from older versions. Did I download the IVA packs wrong or are the parts just going to be more bare? 

Either way, love the mod. Makes space station building a blast. 

Make sure you have NearFutureProps. It should be part of the dependencies but make sure you have it.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...