Nertea

[1.4.5] Stockalike Station Parts Redux (August 7)

Recommended Posts

Posted (edited)

Is there a way to make this work in 1.3.1 because this is the only mod that has such amazing centrifuges.

Edit: I have now realised that there is a 1.3.1 version on spacedock. :blush:

Edited by TachyonGMZ

Share this post


Link to post
Share on other sites

Any idea why the Mercury won't deploy? I have the MaterialKits right there - 3*3150=9450. Three pilots, one engineer, one technician. Need anything else?

oD1cAz9.png

Share this post


Link to post
Share on other sites

You need more engineers. If I remember correctly it needs 4 or more of them to be deployed. Each part has the number of engineers required to deploy written in the extended description.

Share this post


Link to post
Share on other sites
Posted (edited)
2 hours ago, General Apocalypse said:

You need more engineers. If I remember correctly it needs 4 or more of them to be deployed. Each part has the number of engineers required to deploy written in the extended description.

Nope, was some rounding error, or it requires more (greater than) but not exact (same as).
I sent three fresh engineers (info states "Crew to Deploy: 3" ... CREW, not engineers), didn't work.
Then I disassembled some RCS on the ship I sent the engineers in and IT WORKED! 75 extra MaterialKits did the trick.

And then I loaded the save, just when I docked, before deploying. Undocked, thus having the original cew with just one engineer, one technician and three pilots,
but with those 75 extra MK and IT DID DEPLOY. Well, the three extra engineers were still within 150m, but not docked. I think I did deploy something earlier with just regular cew, no engineer.

Looks awesome, btw, nice mod!

 

EDIT: Loaded again, landed the engineers and then deployed (engineers not needed, the extra MaterialKits were).
The Hotel is now officially open:

2Ziw8oX.png
...damn that thing is power hungry :D

Edited by firda
  • Like 2

Share this post


Link to post
Share on other sites
Posted (edited)

Version of the mod for 1.2.2

 

I am trying to make a multiplayer ksp interstellar warfare server with lots of mods. I have tried to install the older version of this mod  (stockalike station parts expansion), but it wasn't nearly as good as this version in 1.4. I would just download 1.4 but some of the mods I have are only for 1.2 and if I try to reinstall all of the mods it would take quite a long time and some of them wouldn't even make it to 1.4. So is there a possibility that you could release this update for 1.2.2. If you don't want to that is completely fine.:D

 

Edited by Will Bales
I wanted to give a clear description to the dev

Share this post


Link to post
Share on other sites

I've just noticed that the 1.25m station multi-hub (PTD-MULT) is in a higher tech node than the 2.5m one (PPD-MULT) — the former is in Meta-Materials (550 science) and the latter is in Advanced MetalWorks (300 science).  Is that intentional, or were they meant to be the other way around?

Also, on an unrelated note, in the Hexa-Girder M1 and L1 "Support" subtype, the batteries and monopropellant tanks are slightly off-center in the model.  Just a minor cosmetic thing, doesn't hurt anything, but since I noticed I figured I'd mention it.

Share this post


Link to post
Share on other sites
On 6/11/2018 at 1:46 PM, firda said:

Nope, was some rounding error, or it requires more (greater than) but not exact (same as).

https://github.com/ChrisAdderley/StationPartsExpansionRedux/blob/d38160bd6382b798183780a64021e486c58db303/Source/HabUtils/ModuleDeployableHabitat.cs#L455

part.GetConnectedResourceTotals(defn.id, out res, out outRes, true);
if (res < DeployResourceAmount)

Really looks like rounding error, something like 1/3+1/3+1/3=0.333+0.333+0.333=0.999 < 1.
It should probably use Math.Round, but you seem to have it configurable, so it would need another parameter, something like

if (Math.Round(res * DeployResourceRound) < Math.Round(DeployResourceAmount * DeployResourceRound))

to mitigate the problem. (Default DeployResourceRound = 100)
...and it could create problem when you try to remove the resource, needing similar check/fix (make everything empty if the difference is < 0.01).

Share this post


Link to post
Share on other sites
Posted (edited)

A late congrats on release!

I don't update my KSP or mods often, so I am only just now seeing this lol.

Off the top of your head does anyone know if the current version will work on KSP 1.3.1?  EDIT: I'm an idiot! I'm still running 1.2.2 so none of them work. Wasn't kidding in the last paragraph lol.  I probably won't update until at least 1.5 - major updates are a PITA with a continuous save.

I hope it's a while before a KSP update breaks the old mod. I also hope I don't use the old mod as extensively as I think I do.

Edited by saxyomega90125
answered my own question
  • Like 1

Share this post


Link to post
Share on other sites
On 6/24/2018 at 2:56 AM, saxyomega90125 said:

A late congrats on release!

I don't update my KSP or mods often, so I am only just now seeing this lol.

Off the top of your head does anyone know if the current version will work on KSP 1.3.1?  EDIT: I'm an idiot! I'm still running 1.2.2 so none of them work. Wasn't kidding in the last paragraph lol.  I probably won't update until at least 1.5 - major updates are a PITA with a continuous save.

I hope it's a while before a KSP update breaks the old mod. I also hope I don't use the old mod as extensively as I think I do.

Dude I have that same problem. I'm trying to ask Nertea about a possible compatibility with the newer version of this mod to 1.2.2..

Share this post


Link to post
Share on other sites
2 hours ago, Will Bales said:

Dude I have that same problem. I'm trying to ask Nertea about a possible compatibility with the newer version of this mod to 1.2.2..

Two things are likely to be a problem there.  First off, this mod is localized, and 1.2.2 didn't have localization, so all the text will be gibberish.  Secondly, there's some animated parts that rely on an DLL, and typically those need to be recompiled for each major version.  So I'd expect most of the parts to work back to 1.3.x, but at least the text to break on anything older than that.

Share this post


Link to post
Share on other sites
Posted (edited)
3 hours ago, DStaal said:

Two things are likely to be a problem there.  First off, this mod is localized, and 1.2.2 didn't have localization, so all the text will be gibberish.  Secondly, there's some animated parts that rely on an DLL, and typically those need to be recompiled for each major version.  So I'd expect most of the parts to work back to 1.3.x, but at least the text to break on anything older than that.

Thanks for the analysis!:D

By any chance do you know what dll i would have to manipulate in order for the files to work correctly together??

Edited by Will Bales
need help

Share this post


Link to post
Share on other sites

Is there an easy way to turn this mod from 1.4.2 to 1.2.2?? :/

Share this post


Link to post
Share on other sites
Posted (edited)
4 hours ago, StarStreak2109 said:

Have you actually read two posts up?!?

Considering that he actually quoted the post, probably he didn't understand.

@Will Bales

You would need to edit the source code and replace all the Localization calls with the actual text, then recompile it against 1.2.2.  The DLLs won't work in 1.2.2 because they are calling methods and classes which don't exist in 1.2.2

Short answer, no, there is no easy way to backport it to 1.2.2

Edited by linuxgurugamer

Share this post


Link to post
Share on other sites
On 6/16/2018 at 8:11 PM, Wyzard said:

I've just noticed that the 1.25m station multi-hub (PTD-MULT) is in a higher tech node than the 2.5m one (PPD-MULT) — the former is in Meta-Materials (550 science) and the latter is in Advanced MetalWorks (300 science).  Is that intentional, or were they meant to be the other way around?

Also, on an unrelated note, in the Hexa-Girder M1 and L1 "Support" subtype, the batteries and monopropellant tanks are slightly off-center in the model.  Just a minor cosmetic thing, doesn't hurt anything, but since I noticed I figured I'd mention it.

What's a Hexa-Girder? I don't see anything like that... am I missing an update?

Share this post


Link to post
Share on other sites
19 minutes ago, Starwaster said:

What's a Hexa-Girder? I don't see anything like that... am I missing an update?

It's from Near Future Construction - Different mod, same mod author.  (And honestly, they set the standard for structural girders in KSP.)

  • Like 2

Share this post


Link to post
Share on other sites

Oops, I guess I asked about it in the wrong thread, then.  My mistake — I have all Nertea's stuff installed so sometimes I forget which parts are from which pack.  :)

Share this post


Link to post
Share on other sites
Posted (edited)

@Nertea, I have been a user of your part packs for a long while now, I want to thank you for your beautiful work, your designs are gorgeous and your part packs are most useful.

Speaking of utility, one of the bits I love the most is the self-adjusting support legs. Is there a way to incorporate this technology to stock or other landing legs part packs?

Reason for the ask is that I have several vessels already in flight that would hugely benefit from this technology - thing is I don't want to put them down and re-launch.

Looking forward to your response! Thanks again!

Edited by hypervelocity

Share this post


Link to post
Share on other sites

Thanks for this amazing parts pack! I'm enjoying using it immensely.

I use the USI levelling legs over yours though, even though I prefer your styling, because the USI ones have a ground anchor mode which is invaluable for stopping the sliding. I hope you can consider such a feature in your mod in the future!

Share this post


Link to post
Share on other sites
On 6/17/2018 at 2:11 AM, Wyzard said:

I've just noticed that the 1.25m station multi-hub (PTD-MULT) is in a higher tech node than the 2.5m one (PPD-MULT) — the former is in Meta-Materials (550 science) and the latter is in Advanced MetalWorks (300 science).  Is that intentional, or were they meant to be the other way around?

Also, on an unrelated note, in the Hexa-Girder M1 and L1 "Support" subtype, the batteries and monopropellant tanks are slightly off-center in the model.  Just a minor cosmetic thing, doesn't hurt anything, but since I noticed I figured I'd mention it.

As Wyzard said, is the multi-hub progression intentional or a mistake?

In my carrer I just modified configs, switching 1.25 and 2.5 node positions.

Share this post


Link to post
Share on other sites

Any chance an update is coming for this plug-in? The warning message displayed on startup saying Station Parts Expansion Redux isn't compatible with KSP v1.4.4 is becoming bothersome.

Share this post


Link to post
Share on other sites
3 hours ago, CMagnuson said:

Any chance an update is coming for this plug-in? The warning message displayed on startup saying Station Parts Expansion Redux isn't compatible with KSP v1.4.4 is becoming bothersome.

Most mod are waiting for the 1.4.5 patch to be updated.

  • Like 1

Share this post


Link to post
Share on other sites
20 hours ago, CMagnuson said:

Any chance an update is coming for this plug-in? The warning message displayed on startup saying Station Parts Expansion Redux isn't compatible with KSP v1.4.4 is becoming bothersome.

I play on KSP 1.4.4 and with SSPExR v1.04.  I don't believe I've run into any game-breaking problems in my career save with this install.  Give it a try (backup your game first).

Your kilometerage may vary.:cool:

Share this post


Link to post
Share on other sites
Posted (edited)

Hi, I've just got a question regarding crew slots on the centrifuges. I've had an issue midway through career where crew slots are no longer visible in the SPH and VAB on centrifuges. I don't know if this is a case of problem created or solved, could anyone confirm whether or not they're supposed to have crew slots in-editor? Just so I can establish a baseline.

EDIT: Just checked, and it's anything inflatable, not just centrifuges. However, the phenomenon is limited only to the SSPX mod.

Edited by KarmaLarma

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now