Nertea

[1.7.x] Stockalike Station Parts Redux (May 21st)

Recommended Posts

22 hours ago, Nightwindale said:

I think i've tried that, but i will check it again to be 100% sure, a bit later.

Tried installing both mods downloaded from CKAN (SSPX 0.5.2 and SSPXr 1.0.2), with latest NearFutureProps (0.3.1) and ModuleManager (3.0.6). Still have the same thing, two those parts are missing, preventing few crafts to load: "crewtube-125-25-2" and "crewtube-docking-25".

Share this post


Link to post
Share on other sites

Would a log file ending like this indicate that your mod was at fault? I can appreciate that 'Food' isn't a resource that I have any mods for, but I have seen many mods added resources (like Ore) that show up only when the mod was installed.
 

[LOG 23:56:38.248] PartLoader: Compiling Part 'StationPartsExpansionRedux/Parts/Containers/sspx-cargo-container-25-1/sspx-cargo-container-25-1'
[WRN 23:56:38.303] DontDestroyOnLoad only work for root GameObjects or components on root GameObjects.
[ERR 23:56:38.304] Module ModuleB9PartSwitch threw during OnLoad: B9PartSwitch.HandledFatalException: Fatal exception while attempting to load fields for B9PartSwitch.PartSubtype ---> System.Collections.Generic.KeyNotFoundException: No tank type named 'Food' exists
  at B9PartSwitch.B9TankSettings.GetTankType (System.String name) [0x00000] in <filename unknown>:0 
  at B9PartSwitch.TankTypeValueParser.Parse (System.String value) [0x00000] in <filename unknown>:0 
  at B9PartSwitch.Fishbones.NodeDataMappers.ValueScalarMapper.Load (System.Object& fieldValue, .ConfigNode node, B9PartSwitch.Fishbones.Context.OperationContext context) [0x00000] in <filename unknown>:0 
  at B9PartSwitch.Fishbones.NodeDataField.Load (.ConfigNode node, B9PartSwitch.Fishbones.Context.OperationContext context) [0x00000] in <filename unknown>:0 
  at B9PartSwitch.Fishbones.NodeDataList.Load (.ConfigNode node, B9PartSwitch.Fishbones.Context.OperationContext context) [0x00000] in <filename unknown>:0 
  --- End of inner exception stack trace ---
  at B9PartSwitch.FatalErrorHandler.HandleFatalError (B9PartSwitch.FatalException exception) [0x00000] in <filename unknown>:0 
  at B9PartSwitch.Fishbones.NodeDataList.Load (.ConfigNode node, B9PartSwitch.Fishbones.Context.OperationContext context) [0x00000] in <filename unknown>:0 
  at B9PartSwitch.Fishbones.NodeDataObjectExtensions.LoadFields (System.Object obj, .ConfigNode node, B9PartSwitch.Fishbones.Context.OperationContext context) [0x00000] in <filename unknown>:0 
  at B9PartSwitch.PartSubtype.Load (.ConfigNode node, B9PartSwitch.Fishbones.Context.OperationContext context) [0x00000] in <filename unknown>:0 
  at B9PartSwitch.Fishbones.Parsers.NodeObjectWrapper.Load (System.Object obj, .ConfigNode node, B9PartSwitch.Fishbones.Context.OperationContext context) [0x00000] in <filename unknown>:0 
  at B9PartSwitch.Fishbones.NodeDataMappers.NodeListMapper.Load (System.Object& fieldValue, .ConfigNode node, B9PartSwitch.Fishbones.Context.OperationContext context) [0x00000] in <filename unknown>:0 
  at B9PartSwitch.Fishbones.NodeDataField.Load (.ConfigNode node, B9PartSwitch.Fishbones.Context.OperationContext context) [0x00000] in <filename unknown>:0 
  at B9PartSwitch.Fishbones.NodeDataList.Load (.ConfigNode node, B9PartSwitch.Fishbones.Context.OperationContext context) [0x00000] in <filename unknown>:0 

[LOG 23:56:38.380] PartLoader: Part 'StationPartsExpansionRedux/Parts/Containers/sspx-cargo-container-25-1/sspx-cargo-container-25-1' has no database record. Creating.
[LOG 23:56:38.425] DragCubeSystem: Creating drag cubes for part 'sspx-cargo-container-25-1'
[EXC 23:56:38.487] InvalidOperationException: Cannot get volume before parent has been linked!
    B9PartSwitch.PartSubtype.get_TotalVolume ()
    B9PartSwitch.ModuleB9PartSwitch.GetInfo ()
    PartLoader.CompilePartInfo (.AvailablePart newPartInfo, .Part part)
    PartLoader+<CompileParts>c__Iterator1.MoveNext ()
    UnityEngine.SetupCoroutine.InvokeMoveNext (IEnumerator enumerator, IntPtr returnValueAddress)

 

Share this post


Link to post
Share on other sites
7 hours ago, Ben0 said:

Would a log file ending like this indicate that your mod was at fault? I can appreciate that 'Food' isn't a resource that I have any mods for, but I have seen many mods added resources (like Ore) that show up only when the mod was installed.

I'm on 1.4.1 and get the same error about the "food" tank. Do you have Kerbalism installed?

I do and in my case it seems like some sort of conflict between B9, Kerbalism and SSPXr. Not saying this mod is at fault, just these three together result in the error for me. Eventually I had all three working together by going back to an older versions of Kerbalism (1.3.0.2) and the non-upgraded version of B9 that is included with this mod. That worked for me. At this point though, I've uninstalled Kerbalism since my box keeps locking up after a successful app launch and I'm trying to isolate the cause of the problem - maybe too many mods...

Share this post


Link to post
Share on other sites
On 25.3.2018 at 1:25 AM, Gurki said:

About texture replacement issue (like the big drills from MKS mod), it look like this is between the model and the texture replacement implementation using MODEL/texture attribute. Overwriting the stock texture with one from MKS package work well ... I think that's exclude the texture to be broken.

@Gurki @Stone Blue

Indeed, I also digged into that once more, and while these issues share the same workaround (remove the texture line) it seem to be two different causes. Here it doesn't seem to load some textures while on the MKS drills it doesn't seem to replace them with correctly loaded textures... So again sorry to @Stone Blue, in this point you were right. Same workaround, but different issues.
Not to self: Don't dig into into a forum topic when not in the correct mood.

BTW, this could be a unity Issue, that it doesn't load some SSPX textures:
https://forum.unity.com/threads/texture2d-loadrawtexturedata-does-not-work-properly-with-dxt1-and-mipmaps.494627/
https://issuetracker.unity3d.com/issues/texture2d-dot-loadrawtexturedata-fails-to-load-dxt1-texture-with-mipmaps-data-and-throws-a-unityexception

Edited by Jebs_SY

Share this post


Link to post
Share on other sites

I'm not able to see where this food TankType is coming from @Ben0 would you mind posting your GameData/ModuleManager.ConfigCache ?

Share this post


Link to post
Share on other sites
37 minutes ago, Cookkiiezzz said:

Does it work on 1.4.1 now?

Please learn to read the last few pages of a thread before asking a question especially whether a mod works in the newly released version of KSP. It may have been answered. A lot of people don't read and so the repeat question liquides modders off.

It works fine except for the problems discussed within the last 2 maybe 3 pages of this thread.

Share this post


Link to post
Share on other sites
On 3/26/2018 at 4:05 AM, Donster said:

I'm on 1.4.1 and get the same error about the "food" tank. Do you have Kerbalism installed?

I do and in my case it seems like some sort of conflict between B9, Kerbalism and SSPXr. 

 

On 3/25/2018 at 8:13 PM, Ben0 said:

Would a log file ending like this indicate that your mod was at fault? I can appreciate that 'Food' isn't a resource that I have any mods for, but I have seen many mods added resources (like Ore) that show up only when the mod was installed.

I assume both of you are using Kerbalism for KSP 1.4.

The problem is that the tank types (definitions) are missing. The subtypes (installed into the parts) are present but they are blank and null without the tank types.

Share this post


Link to post
Share on other sites

Heya @Nertea

I figured I’d drop in and give you something else to read than “great mod but have problem X”.

Thank you a million times over for all the work and time you’ve put into this!

Share this post


Link to post
Share on other sites

I would like to contribute a part I menaged to successfully implent into KSP 1.4.1. since i found it hard to move the large aquacultural parts around Kerbin via plane i thaught why not making a small fish tank?

.. long story short, I borrowed the MysteryGoo mesh and wrote a config file to make a small science collector (alternately I could use the MysteryGoo tank for the second science experiment but I thaught it's better not to mix the goo with any fish).

so here's the PXL-SAST Small Aquaculture Study Tank (aka sspx-aquatank):

  • unlocks at basic science (with the stock materials bay)

YdZtRCB.png
source - license: MIT

I would love some feedback and hope for integration, thanks!

Edited by LatiMacciato

Share this post


Link to post
Share on other sites

I would love a 1.25m version of the Clamp Senior ... hate the look of joining parts with two regular clamp o trons

Share this post


Link to post
Share on other sites
1 minute ago, Mordrehl said:

I would love a 1.25m version of the Clamp Senior ... hate the look of joining parts with two regular clamp o trons

I remember the old SSPX had new versions of all the stock ports, and they had mono tanks. wishes they would reappear here

Share this post


Link to post
Share on other sites

I cannot fathom how awesome and detailed these models and IVA's are, many thanks for this great mod. Out of curiosity, in the next few months is there a plan to add some 1.875m parts? I think they'd really compliment your 1.25m parts for small stations or outposts, you'd have to provide some adapters though, Squad really didn't give enough structural elements with Making History. 

Share this post


Link to post
Share on other sites
10 hours ago, DeltaDizzy said:

Just install it as usual, they work fine if installed at the same time.

@HaydenTheKing

If I delete the original will it mess up my save?  Won’t having both cause duplicates of some parts?

Share this post


Link to post
Share on other sites
On 2018-03-26 at 9:05 AM, Donster said:

I'm on 1.4.1 and get the same error about the "food" tank. Do you have Kerbalism installed?

I do and in my case it seems like some sort of conflict between B9, Kerbalism and SSPXr. Not saying this mod is at fault, just these three together result in the error for me. Eventually I had all three working together by going back to an older versions of Kerbalism (1.3.0.2) and the non-upgraded version of B9 that is included with this mod. That worked for me. At this point though, I've uninstalled Kerbalism since my box keeps locking up after a successful app launch and I'm trying to isolate the cause of the problem - maybe too many mods...

Not so much a "conflict" as SSPXr and Kerbalism not being supported by each other. This would happen with other resource packs such as TAC, Snack or USI, but they have support patches.

This can be added from either Kerbalism or from SSPXr side, but would be quite a bit of work, as definitions would need to be set up for both all resources and the converters they use in Kerbalism.

For now, if you want to use the mods together, you can do so by removing the "Containers" folder under SSPXr Parts. As far as I can tell, these are the only thing's that are incompatible, and everything else seems to be working fine together.

Edited by nosscire

Share this post


Link to post
Share on other sites
17 hours ago, Mordrehl said:

I would love a 1.25m version of the Clamp Senior ... hate the look of joining parts with two regular clamp o trons

 

Wait ... wasn't it @Nertea previous iteration of this mod that had a docking port that matched the end of the 1.25m parts?

 

https://imgur.com/a/k6qrA

Ooh there was ... 2nd part there, the Docking Module ... any chance we can get that part in this version of the mod?

 

Also the extensible port module included in Redux ... you can attach it to a part but it does not have an attachment on it's other end

Edited by Mordrehl
More Info

Share this post


Link to post
Share on other sites
7 hours ago, HaydenTheKing said:

If I delete the original will it mess up my save?  Won’t having both cause duplicates of some parts?

Not really. In name only. Add the new mod, retire your ships, then delete the old mod. Or keep it around, they don't hurt each other. 

7 minutes ago, Mordrehl said:

 

Wait ... wasn't it @Nertea previous iteration of this mod that had a docking port that matched the end of the 1.25m parts?

You'll get this in the next update, but I won't be bringing back the docking modules of ugly hideousness.

Screen_Shot_2018-03-11_at_1.32.03_PM.png

Share this post


Link to post
Share on other sites
2 minutes ago, Nertea said:

Not really. In name only. Add the new mod, retire your ships, then delete the old mod. Or keep it around, they don't hurt each other. 

You'll get this in the next update, but I won't be bringing back the docking modules of ugly hideousness.

Screen_Shot_2018-03-11_at_1.32.03_PM.png

 

Awesome, just want something with a slim form factor ... the stock senior 2.5m dock is very nice that they fit almost flush together

 

EDIT :   The extensible currently supplied can't dock with anything nor does it have an attachment point

Edited by Mordrehl

Share this post


Link to post
Share on other sites

Heyyyy  found the right thread!

Soon as i get done with this current mission Ill look at the parts that i think are slightly broke and let you know =)

Share this post


Link to post
Share on other sites
1 minute ago, Mordrehl said:

EDIT :   The extensible currently supplied can't dock with anything nor does it have an attachment point

It can only dock in extended mode. Game limitation.

Share this post


Link to post
Share on other sites
10 minutes ago, Nertea said:

It can only dock in extended mode. Game limitation.

 

Hmmm ok but I'm talking about in the VAB itself  ... I tend build modular

For example :

Station section going up

<DOCK> - <TUBE> - <DOCK>

To deliver that in orbit, I put a dock on the end of a command module, and stick that station section on top

<DOCK> - <TUBE> -< DOCK> to <DOCK> - <COMMAND>

Once in orbit I then control from the exposed/free dock and connect to anything already in orbit .... then undock the command module

When I extend the part in the VAB there's still no part attachment showing ... you can attach it to a part, but you can't attach the ends of the docking port to each other in the VAB

 

I did love the 1.25m docking module you had in the original mod ... it essentially sat on the end of 1.25 sections as a cap

Edited by Mordrehl

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.