• 1
Eterna1Soldier

Save bug FIX after capturing asteroid

Question

Whenever you captured an asteroid, a bug immediately occurs where you can no longer save the game, switch vessels, or go to the KSC. It turns out that this is caused by a contract bug. If you have a contract open to capture a specific class of asteroid and you fulfill that requirement, the save glitch will occur 100% of the time. However, if you cancel the contract (or simply don't take one at all), you can now save the game and progress after capturing an asteroid.

I've learned that;

-This bug only occurs if you have an active contract to capture an asteroid.

-The asteroid you capture MUST fulfill the contract classification requirement for the bug to trigger.

For example, if you have a contract to capture a 'B' class asteroid, but you capture an 'A' class instead, then the save bug will not trigger.

So basically, don't bother accepting asteroid contracts, because they'll break your game the moment you fulfill them. (At least for the Xbox version. I would like someone to test this out for the PS4).

Share this post


Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 1

Thank you for the insightful report. We are currently investigating this on both platforms. We can confirm that this does not occur in a sandbox game or a randomly selected asteroid, and that it does appear to be restricted to contracts only which is an important detail.

Share this post


Link to post
Share on other sites
  • 1

Can confirm exactly as eterna1 saw on x box is same on ps4 have to decline mission to save or switch after asteroid intercept 

Share this post


Link to post
Share on other sites
  • 0
On 1/30/2018 at 9:25 AM, Squelch said:

We can confirm that this does not occur in a sandbox game or a randomly selected asteroid, and that it does appear to be restricted to contracts only which is an important detail.

I just posted a response to a similar glitch. It was a satellite contract. This glitch is so bad it nullifies almost any good that came from the "Enhanced" re-release. 

Share this post


Link to post
Share on other sites
  • 0

I can confirm that this exact bug existed in the "Failing Tiger Edition". This seems to imply that the bug has nothing to do with either port and is part of the original code from version 1.2. Can anyone confirm that this also happened on the PC version?

Share this post


Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.