peteletroll

[1.7.*, 1.6.*, 1.5.*, 1.4.*] DockRotate - lightweight robotics - rotational control on docking ports (plus NodeRotate, make any part rotate)

Recommended Posts

3 hours ago, peteletroll said:

Testing DockRotate/Klaw interactions with a recovery mission to the Mun:

K4gwZ0S.jpg

Nice!

But how the kraken did someone get an LES to the Mun? :sticktongue:

Share this post


Link to post
Share on other sites
On 1/18/2019 at 7:59 PM, peteletroll said:

New release!

Robotic arms with Advanced Grabbing Units work much better now.

@G_Creature, this should solve the problem you had with your gantry.

Thank you, I'll test it as soon as I am able.

Share this post


Link to post
Share on other sites

I'm adding a new feature: it's called "Flip Flop Reverse" now, but I'm open to suggestions for better names.

When activated on a rotating part, it will toggle the "Reverse Rotation" flag after every rotation command. It can be used for deployable/retractable vessel parts: if you configure an action group for deploy and set the flip flop flag, using the same action group a second time will perform the same motion in reverse.

As an example, if you configure action group 1 on a VTOL to rotate engine nacelles from takeoff to flight configuration, and enable the flip flop mode on the rotating joints, hitting 1 again will put the nacelles back to takeoff configuration, ready to repeat the cycle.

Share this post


Link to post
Share on other sites

New release!

I added flip-flop mode, as described in previous post.

The internals changed a lot: now the code is hopefully more robust and mantainable. Nothing should change from the user point of view.

Share this post


Link to post
Share on other sites

Is this mod in any way useful to electric aircraft? for example: does the part rotate enough to create enough force to accelerate it above 200 m/s?

Share this post


Link to post
Share on other sites
2 hours ago, Dash8466 said:

does the part rotate enough to create enough force to accelerate it above 200 m/s?

Top speed is 8 revolutions per second. 200 m/s is going to be hard to reach.

Share this post


Link to post
Share on other sites
58 minutes ago, peteletroll said:

Top speed is 8 revolutions per second. 200 m/s is going to be hard to reach.

Is there any way you could speed this up? 

Share this post


Link to post
Share on other sites
3 minutes ago, Dash8466 said:

Is there any way you could speed this up? 

By daisy chaining. But I never tried.

Share this post


Link to post
Share on other sites
1 minute ago, peteletroll said:

By daisy chaining. But I never tried.

ohh that is a good one, should I just try 3 then?

Share this post


Link to post
Share on other sites
1 minute ago, peteletroll said:

A good start! I'd recommend two counter rotating propellers with some sort of variable pitch.

Oh im already doing that with normal stock props, about 10-15 small reaction wheels each. But if you wanna have as much force as that with this mod you should chain 2 or 3 together 

Share this post


Link to post
Share on other sites

Having an issue on a reinstall, put in latest DR, after docking my science lab to my station, I enable rotation, for this example it shows a -150 degree angle on my clamp o tron.

Hitting rotate to snap the numbers change, and the module is rotating, but after the "movement" is complete it reverts back to the -150 angle shown.

Share this post


Link to post
Share on other sites

@RW-1, I definitely need more information. Does the previous version of DockRotate have the same bug? Could you share your savefile?

Share this post


Link to post
Share on other sites
22 hours ago, peteletroll said:

@RW-1, I definitely need more information. Does the previous version of DockRotate have the same bug? Could you share your savefile?

Hi, sorry for the delay ...

Yes, I believe the previous version had it, though unfortunately I couldn't tell  you what it was, I hadn't updates the mod in a while, may have been in the 1.3 or 14. range.

 

Here is my persistent file (was that correct?)

https://drive.google.com/open?id=1_QwnHJGbxHhHMmBe2rsrF2MP9bC422RH

Share this post


Link to post
Share on other sites

@RW-1, you have some ports with Smart Autostruts disabled. It's usually enabled by default. I was able to reproduce your problem on your Mun station (most of your career didn't load because of missing parts), and I fixed it by enabling Smart Autostruts on both sides of the rotating joint. Let me know if this works for you too.

Share this post


Link to post
Share on other sites
On 2/16/2019 at 11:38 AM, peteletroll said:

@RW-1, you have some ports with Smart Autostruts disabled. It's usually enabled by default. I was able to reproduce your problem on your Mun station (most of your career didn't load because of missing parts), and I fixed it by enabling Smart Autostruts on both sides of the rotating joint. Let me know if this works for you too.

Hi,

First off, thanks! This mod is indispensable, if JSP were like google, they would bake it in (but maybe pay you to do so ... :)  )

To my knowledge I didnt know I had smart autostruts on for anything. I knew though that you would figure out what was going on though.

Will install the new release, but also check your fix by enabling on both sides in my current loadout. (loading as I type)

PS, most of that career didn't load, because earlier in the week I removed missing history mod or upgraded and it broke a few things, I had to rebuild my Station II which I felt would be easier to do that troubleshooting that issue down, it was when I was trying to align modules I ran into the reported issue. It was sad, I had that loadout since 1.5.1, but a fresh start isn't all bad ...

Yes, I could reproduce, now testing with the new release...

Ahh, so sweet to have it back! you're the best ... Many thanks!

Edited by RW-1

Share this post


Link to post
Share on other sites

I made a thing. (sorry about the music... please mute it)

 

 

Edited by Rich T

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.