Jump to content

[1.9.x, 1.10.x] Click Through Blocker - NEW DEPENDENCY


Recommended Posts

3 minutes ago, Stone Blue said:

Do you want them tested for 1.9.1, or 1.10.0? ... or?... both vOv
Also, the question about the best way to get notified of your beta releases?

 

If you have the time, both, otherwise do 1.9.1 first.  I was able to replicate the bug and the fix on my system for both.  I'm confused by what @Jesusthebird wrote, so need to know the results for each of the betas.

Thanks

I'll have to think about notification, it's not something I have done before.  And I do understand the need

Link to post
Share on other sites
5 hours ago, linuxgurugamer said:

If you have the time, both, otherwise do 1.9.1 first.  I was able to replicate the bug and the fix on my system for both.  I'm confused by what @Jesusthebird wrote, so need to know the results for each of the betas.

Thanks

I'll have to think about notification, it's not something I have done before.  And I do understand the need

sorry, lets see..basically, the two test builds you linked fixes the bug from happening when you click an option for CTB FIRST, but if you close the toolbarwindow after that, the bug still happens. Im doing fresh save testing, so when the scene loads, both windows pop up, CTB seems fine now in terms if IT causing the bug, in all of my testing so far, closing the toolbar window after selecting an option for CTB causes the bug to appear still. closing toolbar first before selecting an option for CTB seems to work fine tho.

Link to post
Share on other sites
11 minutes ago, Jesusthebird said:

but if you close the toolbarwindow after that,

You are referring to the ToolbarController???

This wasn't clear.  Ok, that means I need to do a small update to the Toolbarcontroller for this bug as well.

You need to be specific when reporting bugs.  Just aying toe "toolbarwindow" isn't clear, because it may be from different things.  Just for info, it would have been much clearer if you said something like this:

"Click the yellow wrench to open the Toolbar Controller window.  Then, clicking the Close on that window, the bug appears"

Now that I know what I'm looking for, I was able to easily replicate it

Edited by linuxgurugamer
Link to post
Share on other sites
2 hours ago, linuxgurugamer said:

You are referring to the ToolbarController???

This wasn't clear.  Ok, that means I need to do a small update to the Toolbarcontroller for this bug as well.

You need to be specific when reporting bugs.  Just aying toe "toolbarwindow" isn't clear, because it may be from different things.  Just for info, it would have been much clearer if you said something like this:

"Click the yellow wrench to open the Toolbar Controller window.  Then, clicking the Close on that window, the bug appears"

Now that I know what I'm looking for, I was able to easily replicate it

ahh I see what you meen. I actually was referring to the information window that automatically appears on the first time you install and run the mod for the first time, I didn't even think about the wrench icon. The hide window on start button I thought was a good clue but I guess you could think that im referring to clicking the wrench icon again to toggle the window off
1.10.9 seems to do the trick tho on both ksp 1.9.1 and 1.10

Edited by Jesusthebird
Link to post
Share on other sites
8 hours ago, Jesusthebird said:

ahh I see what you meen. I actually was referring to the information window that automatically appears on the first time you install and run the mod for the first time, I didn't even think about the wrench icon. The hide window on start button I thought was a good clue but I guess you could think that im referring to clicking the wrench icon again to toggle the window off
1.10.9 seems to do the trick tho on both ksp 1.9.1 and 1.10

Thank you. Sometimes a picture is worth a thousand words.

Once I realized it was in multiple mods, it became obvious to me what was going on

Edited by linuxgurugamer
Link to post
Share on other sites

New release, 0.1.10.9

  • Fixed Popupshown.cfg from having endless repeats of the popupshown = true appended
  • Fixed error which caused buildings to be non-clickable if clicking on a control in the window closed it (such as an X or a Close button)
  • Made all members of Log class to be internal, to avoid conflicts with KSP_Log
Link to post
Share on other sites

Some people think I worry over minor issues, such as this small update.  I do it to eliminate all nullrefs in the log file, which makes it easier for everybody in the long run to actually find real errors:

New release 0.1.10.10

  • Fix nullrefs upong returning to mainmenu by adding check for no game loaded (ie:  returning to main menu) in CBTMonitor.Update & CBTMonitor.LateUpdate
     
Link to post
Share on other sites

Firstly, Hi linuxgurugamer, thanks for the mods you've created!

I may have found a conflict with your latest CTB update, however given the time it takes my slow ass laptop to load KSP, it could take me forever to narrow it down but hopefully this bug report will help you a bit... it is my first so be gentle :sticktongue:

Extra note... I do not have either DLC installed on this install... if you need any further info to help you, let me know.

I couldn't locate the Player.log file when I created this report but I have now and updated CTB again and reloaded so I could see if the issue is replicated and I get the appropriate log file. The problem does indeed persist, fixed by rolling back to v0.1.10.6.

As the previous version seems to work, an easy fix might be to update the version compatibility to exclude 1.8.x? That is... if this issue doesn't happen in 1.9.x+. As I'm using RSS/RO/RP-1, I can't update KSP to attempt a replication of the bug with later versions.

Edited by Kerbalnaut #55487
player.log and bug replication/comfirmation
Link to post
Share on other sites
22 hours ago, Kerbalnaut #55487 said:

I may have found a conflict with your latest CTB update, however given the time it takes my slow ass laptop to load KSP, it could take me forever to narrow it down but hopefully this bug report will help you a bit... it is my first so be gentle :sticktongue:

I was able to replicate the problem, it's not specific to 1.8.1

Can you please try this:

https://www.dropbox.com/s/g6ksnzy58nu4w6b/000_ClickThroughBlocker-0.1.10.11.zip?dl=0

and let me know if it fixes it

Link to post
Share on other sites
  • 5 weeks later...

Hi linuxgurugamer, 

there seems to be a bug in CTB since 1.10 at least. If you launch a pod without any crew, no locks are applied and you control such a vessel. In case of crew leaving a pod, locks get applied and the pod becomes uncontrollable. Not a game breaking bug but triggers my OCD. Cheers. 

Link to post
Share on other sites
  • 2 weeks later...

Hi @linuxgurugamer

I seem to have an issue with CTB in that it doesn't seem to be working.

I am running KSP V1.10.1.2939 with mods Kebal alarm clock, Kerbal joint reinforcement - next, Precise Node, Toolbar controller, Zero MiniAVC and Click Through Blocker.

If I have Precise Node open with a target selected, left mouse clicking say to increase prograde ect, if I click too fast the target is un-selected.

Link to the player.log - https://drive.google.com/drive/folders/1Wpm2DZ94sp-MfiNZldG6AAGYgluLnPQ7?usp=sharing

Thanks,

Glenn.

Link to post
Share on other sites
  • 2 weeks later...
36 minutes ago, Drew Kerman said:

@linuxgurugamer can you install

and see if it still functions with the latest CTB? When I dropped the latest CTB into my 1.9.1 install with AMP all the stock buttons that it hid were showing. reverting back to CTB 0.1.9.5 fixed it

Which mode were you using, FocusFollowsClick or FocusFollowsMouse?

Link to post
Share on other sites

Happy Friday everyone!

So, Module Manager posts a message on the KSP load screen that "click through blocker DLLL 0.1.10.11 is not compatible with this version (1.10.1) of KSP" and then the game stops loading. 

The game loads normally without CTB installed but there are still errors in the log caused by a couple of other mods - namely ScanSat and MechJeb.

Loggy mc log face

Is this my fault or something Linuxgurugamer should look at?

x

Link to post
Share on other sites
1 hour ago, rextable said:

Happy Friday everyone!

So, Module Manager posts a message on the KSP load screen that "click through blocker DLLL 0.1.10.11 is not compatible with this version (1.10.1) of KSP" and then the game stops loading. 

The game loads normally without CTB installed but there are still errors in the log caused by a couple of other mods - namely ScanSat and MechJeb.

Loggy mc log face

Is this my fault or something Linuxgurugamer should look at?

x

Please post the Player.log 

Link to post
Share on other sites
6 hours ago, rextable said:

So, Module Manager posts a message on the KSP load screen that "click through blocker DLLL 0.1.10.11 is not compatible with this version (1.10.1) of KSP"

That's a warning, can be ignored.

6 hours ago, rextable said:

and then the game stops loading

 

First, you have a number of MiniAVC.dll files, they are broken.

You can fix that by installing ZeroMiniAVC, which will remove them.

If it's still an issue, try removing MagicSmokeIndustries aka Infernal Robotics

 

Link to post
Share on other sites
4 hours ago, linuxgurugamer said:

That's a warning, can be ignored.

 

First, you have a number of MiniAVC.dll files, they are broken.

You can fix that by installing ZeroMiniAVC, which will remove them.

If it's still an issue, try removing MagicSmokeIndustries aka Infernal Robotics

 

Okay, I'll give that a try.

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...